Autor Tema: ¿Como puedo crear un script para apagar los leds y otro para autoiniciar pyload?  (Leído 9927 veces)

0 Usuarios y 1 Visitante están viendo este tema.

machiminax

  • Visitante
¿Y si pruebas a poner la ruta completa de python?

Código: [Seleccionar]
#!/bin/sh /etc/rc.common
# Copyright (C) 2008-2010 OpenWrt.org

START=90


start(){
        /usr/bin/python /usr/share/python/pyload/pyLoadCore.py --daemon
}

stop(){
          /usr/bin/python /usr/share/python/pyload/pyLoadCore.py --quit
}



también con un start más tardío, ahí puse 90

edito, o también en lugar de  /usr/bin/python, prueba con /usr/bin/python2.7 ya que el otro es un enlace simbólico


Voy a poner los pasos que he seguido por si cometi algun error.

1. Desde winspc descargo el archivo pyload que tengo en init.d
2. Lo edito siguiendo tus instrucciones con start 90 y python2.7
3. Lo renombro como autopyload
4. Lo subo a la carpeta init.d con winspc
5. Desde putty
    cd ..
    cd etc
    cd init.d
    chmod +x autopyload
    reboot
6. Luci
    system -- startup -- initscripts
    busco autopyload y marco enabled
    reboot


Pero nada sigue sin autoarrancar.Eso si al igual que ocurria con el anterior script que tenia,si que es posible iniciarlo manualmente desde Luci haciendo click en start.
El script aparece como enable en Luci pero no arranca pyload.Es lo mismo que me pasaba con el que ya tengo,solo se inicia si yo pulso start en Luci.

Os agradezco mucho la ayuda.
Yo no se muy bien que mas se puede hacer.
Ya lo he comentado mas arriba que Transmissions si que se autoinicia si lo marco como enable pero pyload se resiste...
Gracias de nuevo por intentar resolver mi lio.



    


« Última modificación: 13-03-2014, 01:53 (Jueves) por machiminax »

machiminax

  • Visitante
Hola a todos de nuevo.Por fin he conseguido que se autoinicie pyload.
Explico un poco como ha sido porque lo consegui de manera "indirecta".
Me copre una raspberry y le instale xbmc con pyload y transmission.
Entonces para autoiniciar pyload modifique crontab con contrab-e y funciono perfectamente.
Con lo cual mi primer pensamiento fue hacer lo mismo en openwrt.
Pero chascazo que me lleve pues no funciono.
Entonces ya totalmente desesperado y sin encontrar explicacion modifique la configuracion de pyload en openwrt (python pyLoadCore.py -s) y cambie la ruta donde se guarda la configuracion del programa.
Por defecto estaba en root/pyload.
La pase para usr/share/python/pyload/config.
Entonces los siguientes pasos:
export EDITOR=nano (esto es opcional yo odio VI por eso lo hice)
sh /etc/init.d/cron start
sh /etc/init.d/cron enable
crontab -e
y pegamos "@reboot python /usr/share/python/pyload/pyLoadCore.py --daemon"
Ctl+x para salvar los cambios.
Y ya esta.

Bueno publico esto por si le sirve a alguien que este con mi mismo problema.
Gracias a todos.

« Última modificación: 09-05-2014, 20:16 (Viernes) por machiminax »

//FINAL Y MÁS DOS RESPUESTAS