Autor Tema: Problemas con router tp-link y openwrt  (Leído 3520 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Albertron

  • Visitante
Problemas con router tp-link y openwrt
« en: 01-09-2014, 22:32 (Lunes) »
Hola. Ante todo decir que soy novato en este mundillo, intentare explicarme lo mejor posible. Tengo un router tp-link mr3220 v2.3 que lo uso conectando un módem USB para repartir conexión con todos los aparatos de casa. Ayer le instale el firmware rooter, concretamente la versión funnelweb. Y toqueteando la ip del router,se quedo el navegador colgado y ahora no tengo conexión a Internet ni puedo entrar en la configuración del router. Me da una ip rara (169.254.188.24) máscara subred 255.255.0.0 y no me da ninguna puerta de enlace. He probado entrar desde varias direcciones y ninguna me consigue entrar, también poniendo ip manualmente. También he probado a resetear el router. Me dijeron que dejará el botón de reset pulsado unos cuantos segundos y no vi que cambiará ninguna luz, probé en el pc y aun no me dejaba entrar en la configuración del router. Ya no se que más hacer para poder solucionarlo, así que si se os ocurre algo os estaré eternamente agradecidos. Esto me pasa por tocar sin saber.



Albertron

  • Visitante
Re: Problemas con router tp-link y openwrt
« Respuesta #1 en: 02-09-2014, 00:51 (Martes) »
Os comento, porque he estado buscando informacion y algo mas he sacado en claro, aunque no soy capaz aun de entrar al router.

HE conseguido poner el router en falisafe mode (o eso creo). Es Poner en ON el router y en cuanto se enciende la primera luz pulsar constantemente el boton reset, hasta que la luz de sistema se queda parpadeando. Luego he configurado el adaptador de red asi: ip 192.168.1.2 mascara subred 255.255.255.0 puerta de enlace 192.168.1.1

He hecho ping y me sale esto: Respuesta desde 192.168.1.1: bytes=32 tiempo<1m TTL=64

Pero me sigue sin dejar entrar al router desde el navegador o desde telnet. Todo esto lo he hecho en base a pruebas de gente con el mismo problema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: Problemas con router tp-link y openwrt
« Respuesta #2 en: 02-09-2014, 08:34 (Martes) »
Seguro que no puedes entrar por telnet ?
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Albertron

  • Visitante
Re: Problemas con router tp-link y openwrt
« Respuesta #3 en: 02-09-2014, 09:06 (Martes) »
Es la primera vez que uso telnet. No se si lo habre echo bien. He seguido un tutorial al pie de la letra.

Albertron

  • Visitante
Re: Problemas con router tp-link y openwrt
« Respuesta #4 en: 02-09-2014, 16:06 (Martes) »
Yepa. Ya me lo han solucionado en otro foro. Dejo por aqui los pasos que he seguido por si acaso le pasa a alguien mas:

Basicamente lo que tienes que hacer es:
1) Configurar una IP fija 192.168.1.2 / 255.255.255.0 en tu PC (no necesitas puerta de enlace y dns para esto).
2) Conecta tu PC al router por cable de red.
2) Apaga el router (desconecta el alimentador o usa el interruptor ON/OFF si lo tiene)
3) Enciende el router y tan pronto como veas que las luces se encienden, hay que pulsar el boton reset continuamente hasta que la luz de sistema parpadea rapidamente. Esto quiere decir que has entrado en el modo de recuperacion correctamente, si no, vuelve a intentarlo (apagandolo etc).
4) Conectate por telnet al router mediante el programa putty (solo cambia la IP por 192.168.1.1 y una vez seleccionado puerto 23 y Telnet, le das a Open abajo).
5) Si conectas bien te deberia salir una linea de comandos donde debes teclear y pulsar enter despues de cada comando:
5.1) mount_root
5.2) Luego uno de estos: firstboot o mtd -r erase rootfs_data o rm -r /overlay/*
5.3) Si el router no se reinicia automaticamente tras los comandos anteriores teclea: reboot -f
6) El router deberia reiniciarse, ya puedes configurar tu PC para que coja una IP automaticamente y ya deberias poder entrar en el equipo otra vez.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re:
« Respuesta #5 en: 02-09-2014, 17:19 (Martes) »
Vamos, el modo failsafe que está explicado en las FAQ.
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

//FINAL Y MÁS DOS RESPUESTAS