Autor Tema: Bajar la velocidad de los puertos lan del router?  (Leído 2364 veces)

0 Usuarios y 1 Visitante están viendo este tema.

zapple

  • Visitante
Bajar la velocidad de los puertos lan del router?
« en: 12-11-2014, 14:17 (Miércoles) »
Hola compañeros. Os cuento la pelicula...

Mi hermano tiene un receptor de satelite con puerto ethernet que despues de una tormenta electrica el puerto ethernet del receptor dejó de funcionar correctamente.
Parece ser que el puerto no se quedó "frito" del todo porque al menos mostraba 2 leds encendidos a ambos lados del puerto, pero no funciona como debiera. Al conectar el receptor al router (ZTE H108N de Movistar) con DHCP el receptor no recibe una IP valida. Poniendo una IP a mano tampoco se comunica con el router.
Despues de muchas pruebas sin exito me decidi a sustituir el transformador de Lan (H1601CG) del receptor pensando que estaba cascado


... pero despues de la sustitución del componente la cosa no mejoró.

Un amiguete me sugirió que buscara algun cachirulo que permitiera bajar la velocidad de comunicación entre el puerto ethernet del receptor y el del router adsl. Encontré un viejo router 3Com a 10mbps de los que ponia telefonica en el principio de los tiempos y lo puse como switch entre el router adsl de movistar y el receptor de satelite. Con esta combinacion todo funciona correctamente, el receptor recibe una IP buena y se comunica perfectamente.

He estado leyendo sobre Autonegotiation http://en.wikipedia.org/wiki/Autonegotiation y he encontrado este post
https://forum.openwrt.org/viewtopic.php?id=35858 pero se me hace dificil de entender. Tengo por aqui un Comtrend CT5361 blanco de telefonica con el que me gustaria cacharrear un poco para intentar conseguirlo, pero necesito de vuestra ayuda porque no logro entender bien como hacerlo.
Si alguien me pudiera echar un cable, se agradece.

edito para modificar link


« Última modificación: 13-11-2014, 09:18 (Jueves) por zapple »

zapple

  • Visitante
Re: Bajar la velocidad de los puertos lan del router?
« Respuesta #1 en: 16-11-2014, 11:38 (Domingo) »
Conseguido!!  ;)

Comtrend CT5361 (el blanco de timofonica)
http://wiki.openwrt.org/toh/comtrend/ct5361
Ethernet:    Broadcom BCM5325

Firm: OpenWRT Backfire 10.03.01 openwrt-CT536_CT5621-squashfs-cfe.bin
https://downloads.openwrt.org/backfire/10.03.1/brcm63xx/openwrt-CT536_CT5621-squashfs-cfe.bin




- instalar robocfg
 
Citar
robocfg    0.01-1    This package contains an utility for configuring the Broadcom BCM5325E/536x
https://downloads.openwrt.org/backfire/10.03.1/brcm63xx/packages/robocfg_0.01-1_brcm63xx.ipk

Código: [Seleccionar]
root@OpenWrt:~# robocfg show
probing eth1
Switch: enabled
Port 0(W):  DOWN enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
Port 1(4):  DOWN enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
Port 2(3): 100FD enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
Port 3(2):  DOWN enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
Port 4(1):  DOWN enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
Port 5(C): 100FD enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
VLANs: BCM5325/535x disabled mac_check mac_hash
root@OpenWrt:~#

Port 2(3): Dice que tengo conectado el cable ethernet al puerto LAN 2 del CT5361. 100FD: Dice que ese puerto esta funcionando a 100mbps Full Duplex.

- Quiero bajar la velocidad solamente en ese puerto LAN 2 a 10mbps Half Duplex.
Código: [Seleccionar]
root@OpenWrt:~# robocfg port 2 media 10HD
probing eth1
root@OpenWrt:~#

Código: [Seleccionar]
root@OpenWrt:~# robocfg show
probing eth1
Switch: enabled
Port 0(W):  DOWN enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
Port 1(4):  DOWN enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
Port 2(3):  10HD enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
Port 3(2):  DOWN enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
Port 4(1):  DOWN enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
Port 5(C): 100FD enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
VLANs: BCM5325/535x disabled mac_check mac_hash
root@OpenWrt:~#



Argumentos para "media":
Citar
media auto|10HD|10FD|100HD|100FD|1000HD|1000FD

Los cambios no se mantienen cuando se reinicia el router, por lo que habria que crear un init script o añadir el comando en el System>Startup de LuCI.
...por ejemplo
Código: [Seleccionar]
sleep 2
robocfg port 2 media 10HD
exit 0

saludos