Autor Tema: Ayuda  (Leído 1733 veces)

0 Usuarios y 1 Visitante están viendo este tema.

recman

  • Visitante
Ayuda
« en: 04-02-2018, 11:23 (Domingo) »
Hola a todos
Os explico mi problema tengo un TL-WR1043ND V2
que ayer me puse a instalar openwrt todo iba bien hasta cuando tenia que poner el comando opkg update que me di cuenta que no tenia la wan conectada,entonces desenchufe el router de la corriente y ya no me deja entrar con putty.
no se si ya es para tirar o tengo alguna solucion.

muchismas gracias



recman

  • Visitante
Re: Ayuda
« Respuesta #1 en: 04-02-2018, 14:54 (Domingo) »
He conseguido entrar con putty en modo ssh pero no se como puedo restaurar a fabrica
muchas gracias

cimbor

  • Visitante
Re: Ayuda
« Respuesta #2 en: 04-02-2018, 15:51 (Domingo) »
Lo mas fácil para dejarlo con openwrt instalado con las opciones por defecto nuevamente es encender el router y pulsar el botón wps/reset unos 20 segundos y soltarlo. En otros modelos de tplink que tengo me funciona listo para configurar todo de nuevo.

Enviado desde mi LG-D802 mediante Tapatalk


recman

  • Visitante
Re: Ayuda
« Respuesta #3 en: 04-02-2018, 15:57 (Domingo) »
El problema es que no se llego a intalar el openwrt

cimbor

  • Visitante
Re: Ayuda
« Respuesta #4 en: 04-02-2018, 16:16 (Domingo) »
¿Y que deja hacer ahora por ssh?

Enviado desde mi LG-D802 mediante Tapatalk

recman

  • Visitante
Re: Ayuda
« Respuesta #5 en: 04-02-2018, 16:43 (Domingo) »
Ese es el problema que entra pero cuando le pongo opkg update me da error y no se ni instaler openwrt ni poner el sofware original

cimbor

  • Visitante
Re: Ayuda
« Respuesta #6 en: 04-02-2018, 16:45 (Domingo) »
Intenta entrar con el navegador por si tiene luci instalado, de todos modos pon aqui lo que salga al ejecutar ifconfig.

Enviado desde mi LG-D802 mediante Tapatalk


Ficht

  • Visitante
Re: Ayuda
« Respuesta #7 en: 04-02-2018, 19:46 (Domingo) »
Ese es el problema que entra pero cuando le pongo opkg update me da error y no se ni instaler openwrt ni poner el sofware original

Hola, si entras por ssh, entonces si que tienes openwrt instalado, lo que no has configurado las redes, por eso opkg te da un error, no tiene salida a internet.

Tienes que editar  /etc/config/network  poner una ip local apropiada, el gateway y dns...

saludos.

Garcad

  • Visitante
Re: Ayuda
« Respuesta #8 en: 05-02-2018, 03:40 (Lunes) »
Como te han comentado antes...  edita el archivo /etc/config/network

Si el router que te da Internet, tiene el rango de red 192.168.0.1

config interface 'lan'
   option ifname 'eth0.1'
   option type 'bridge'
   option proto 'static'
   option netmask '255.255.255.0'
   option ipaddr '192.168.0.155'
   option gateway '192.168.0.1'
   option dns '192.168.0.1'

Si el router que te da Internet, tiene el rango de red 192.168.1.1

config interface 'lan'
   option ifname 'eth0.1'
   option type 'bridge'
   option proto 'static'
   option netmask '255.255.255.0'
   option ipaddr '192.168.1.155'
   option gateway '192.168.1.1'
   option dns '192.168.1.1'

Y edita el archivo /etc/config/dhcp

config dhcp 'lan'
   option interface 'lan'
   option ignore '1'

config dhcp 'wan'
   option interface 'wan'
   option ignore '1'

Que desactiva el protocolo dhcp en la conexión lan, ya que debemos dejar que sea el router principal quien asigne las direcciones ip.

Guarda los cambios, reinicia el router Openwrt y en este momento debería de tener Internet.

Recuerda bien que ip le has puesto, en 192.168.x.155, y que este bien puesto, para poder tener acceso al router, si los pones mal los datos, no tendrás acceso al router y te veras obligado a instalar de nuevo Openwrt.

Luego para poder acceder al router tendrás que usar la dirección ip """" option ipaddr  """"

Salu2
« Última modificación: 05-02-2018, 03:50 (Lunes) por Garcad »

peperfus

  • Visitante
Re: Ayuda
« Respuesta #9 en: 05-02-2018, 14:34 (Lunes) »
Hola. Me alegro de que lo hayas conseguido.

Como consejo, te sugiero que no empieces en los foros un post con título "Ayuda". Es demasiado genérico y la gente no sabe a qué se refiere.
Sería más adecuado, por ejemplo, poner: "No puedo conectar a Internet" o algo por el estilo.  ;)

recman

  • Visitante
Re: Ayuda
« Respuesta #10 en: 05-02-2018, 18:20 (Lunes) »
Hola. Me alegro de que lo hayas conseguido.

Como consejo, te sugiero que no empieces en los foros un post con título "Ayuda". Es demasiado genérico y la gente no sabe a qué se refiere.
Sería más adecuado, por ejemplo, poner: "No puedo conectar a Internet" o algo por el estilo.  ;)

Tienes razon lo siento
es que soy bastante novato en estos temas

recman

  • Visitante
Re: Ayuda
« Respuesta #11 en: 05-02-2018, 18:29 (Lunes) »
Como te han comentado antes...  edita el archivo /etc/config/network

Si el router que te da Internet, tiene el rango de red 192.168.0.1

config interface 'lan'
   option ifname 'eth0.1'
   option type 'bridge'
   option proto 'static'
   option netmask '255.255.255.0'
   option ipaddr '192.168.0.155'
   option gateway '192.168.0.1'
   option dns '192.168.0.1'

Si el router que te da Internet, tiene el rango de red 192.168.1.1

config interface 'lan'
   option ifname 'eth0.1'
   option type 'bridge'
   option proto 'static'
   option netmask '255.255.255.0'
   option ipaddr '192.168.1.155'
   option gateway '192.168.1.1'
   option dns '192.168.1.1'

Y edita el archivo /etc/config/dhcp

config dhcp 'lan'
   option interface 'lan'
   option ignore '1'

config dhcp 'wan'
   option interface 'wan'
   option ignore '1'

Que desactiva el protocolo dhcp en la conexión lan, ya que debemos dejar que sea el router principal quien asigne las direcciones ip.

Guarda los cambios, reinicia el router Openwrt y en este momento debería de tener Internet.

Recuerda bien que ip le has puesto, en 192.168.x.155, y que este bien puesto, para poder tener acceso al router, si los pones mal los datos, no tendrás acceso al router y te veras obligado a instalar de nuevo Openwrt.

Luego para poder acceder al router tendrás que usar la dirección ip """" option ipaddr  """"

Salu2

Hola antes de nada muchas gracias por toda tu explicacion.
He puesto edita el archivo /etc/config/network y mira lo que me dice



  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 DESIGNATED DRIVER (Bleeding Edge, 12009)
 -----------------------------------------------------
  * 2 oz. Orange Juice         Combine all juices in a
  * 2 oz. Pineapple Juice      tall glass filled with
  * 2 oz. Grapefruit Juice     ice, stir well.
  * 2 oz. Cranberry Juice
 -----------------------------------------------------
root@OpenWrt:~# /etc/config/network
-ash: /etc/config/network: Permission denied
root@OpenWrt:~#

Garcad

  • Visitante
Re: Ayuda
« Respuesta #12 en: 06-02-2018, 00:53 (Martes) »
Tienes que usar un editor de texto.