Autor Tema: ayuda vlans wr1043nd  (Leído 4131 veces)

0 Usuarios y 1 Visitante están viendo este tema.

eq7mavala

  • Visitante
ayuda vlans wr1043nd
« en: 03-12-2012, 19:38 (Lunes) »
buenas tardes, me he comprado un wr1043nd y necesito deshabilitar las vlan, necesito que los 5 puertos esten junto con la wifi en el mismo vlan, pierdo siempre algo, necesito que solo sea switch, gracias



Noltari

  • Visitante
Re: ayuda vlans wr1043nd
« Respuesta #1 en: 03-12-2012, 20:25 (Lunes) »
buenas tardes, me he comprado un wr1043nd y necesito deshabilitar las vlan, necesito que los 5 puertos esten junto con la wifi en el mismo vlan, pierdo siempre algo, necesito que solo sea switch, gracias
Pon esto en el fichero /etc/config/network y reinicia el router:
Código: [Seleccionar]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'

Saludos!

eq7mavala

  • Visitante
Re: ayuda vlans wr1043nd
« Respuesta #2 en: 03-12-2012, 23:44 (Lunes) »
Nada, lo dejo por imposible, no chuta ni a la de tres, poniendo solo eso, cambiando la ip por la 192.168.1.2 (la 1.1 es el router ADSL), no funciona ni aun conectandolo a una boca normal no WAN, desconozco que le pasa, pero me tiene hasta los raviolli, lo he comprado hoy como la solución a mis problemas y nada mas lejos de la realidad, estoy arto!!!! Nada funciona bien, ni el 5813n, ni este, ni mi ubitiqui!!!!!!

Todo son problema!  :-[

eq7mavala

  • Visitante
Re: ayuda vlans wr1043nd
« Respuesta #3 en: 04-12-2012, 00:14 (Martes) »
Genial, he mirado por ahi, que ponía que había que meter la versión alemana del firmware, la he metido y ahora solo se encienden por milésimas de segundo las luces y se apaga y se repite, cíclico, pues nada, me ha durado menos de 5 horas el aparato, cojonudo, si os interesa a alguno...

Noltari

  • Visitante
Re: ayuda vlans wr1043nd
« Respuesta #4 en: 04-12-2012, 00:48 (Martes) »
Genial, he mirado por ahi, que ponía que había que meter la versión alemana del firmware, la he metido y ahora solo se encienden por milésimas de segundo las luces y se apaga y se repite, cíclico, pues nada, me ha durado menos de 5 horas el aparato, cojonudo, si os interesa a alguno...
Suena a que vas a tener que reuperarlo con un cable serial. ¿Por qué has metido otro firmware?
A veces os ponéis nerviosos y no sabéis por qué hacéis las cosas ni vosotros mismos.
Abres un hilo en el foro para que te ayudemos y acabas liándola...
Mi intento siguiente iba a haber sido definir la VLAN 1 con todos los puertos...

Por cierto, no era en este router en el que el bootloader deshabilitaba el puerto WAN sólo en las últimas versiones del Hardware. Creo que era eso lo que te ha pasado :$...

eq7mavala

  • Visitante
Re: ayuda vlans wr1043nd
« Respuesta #5 en: 04-12-2012, 08:11 (Martes) »
Buenos dias, si es la ultima version la 1.8, pero en la pagina de openwrt ponia algo asi, pero ma acabo de sar cuenta que habia que haber hecho mas cosas...

http://wiki.openwrt.org/toh/tp-link/tl-wr1043nd#back.to.original.firmware

De serial y eso NPI, pero he visto esto, que presupongo que tambien valdra, correcto?

Creo que por fin le voy a dar uso al arduino aparte de para jugar con las lucecitas  ;D

http://blackhold.nusepas.com/2012/01/recuperando-un-tp-link-wr1043nd/

Muchas gracias

Ayer antes de abrir este post borre la vlan 2 y asigne todo en la vlan 1, no funciono... :(

Noltari

  • Visitante
Re: ayuda vlans wr1043nd
« Respuesta #6 en: 04-12-2012, 11:49 (Martes) »
Buenos dias, si es la ultima version la 1.8, pero en la pagina de openwrt ponia algo asi, pero ma acabo de sar cuenta que habia que haber hecho mas cosas...

http://wiki.openwrt.org/toh/tp-link/tl-wr1043nd#back.to.original.firmware

De serial y eso NPI, pero he visto esto, que presupongo que tambien valdra, correcto?

Creo que por fin le voy a dar uso al arduino aparte de para jugar con las lucecitas  ;D

http://blackhold.nusepas.com/2012/01/recuperando-un-tp-link-wr1043nd/

Muchas gracias

Ayer antes de abrir este post borre la vlan 2 y asigne todo en la vlan 1, no funciono... :(

Lo de volver al firmware original sólo funciona si tienes acceso a un firmware funcional para flashear el oficial.

Si no tienes acceso a un firmware funcional tienes que acceder por UART (usando un conversor USB a UART, como el arduino o algo parecido), para poder acceder al bootloader y cargar desde ahí el firmware.

Saludos!

eq7mavala

  • Visitante
Re: ayuda vlans wr1043nd
« Respuesta #7 en: 06-12-2012, 20:02 (Jueves) »
Ale, 1043 resucitado!

Ademas he conseguido poner todo en la misma subred:


root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.254'
        option gateway '192.168.1.1'
        option broadcast '192.168.1.255'
        option dns '80.58.61.250'
        option _orig_ifname 'wlan0'
        option _orig_bridge 'true'
        option ifname 'eth0.1'

config switch
        option name 'rtl8366rb'
        option reset '1'
        option enable_vlan '1'
        option enable_vlan4k '1'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '1'
        option ports '0 1 2 3 4 5t'


Cualquier otra cosa inviable, gracias

//FINAL Y MÁS DOS RESPUESTAS