Autor Tema: Convertir TDT en centro multimedia wifi con router hg556a  (Leído 7790 veces)

0 Usuarios y 1 Visitante están viendo este tema.

peterpunk

  • Visitante
Convertir TDT en centro multimedia wifi con router hg556a
« en: 27-09-2012, 14:16 (Jueves) »
Hola a todos,
La verdad no se si se me ha ido la pinza con lo que pretendo hacer, pero mi hija y mi mujer me han secuestrado la tele y he pensado un sistema para poder seguir viendo las cosas que grabo por la noche sin discutir con ellas.
Tengo un TDT grabador con conexión Ethernet, este le quiero conectar a un router hg556a con disco duro. El hg556a debe estar conectado al wifi de casa. De forma que quien tenga la tele pueda ver lo grabado directamente en el TDT ( puede acceder a un disco duro remoto) y yo pueda acceder al disco duro (y TDT) para ver el contenido grabado desde un portátil.

Lo que hecho de momento es conectar el hg556a como cliente a la red wifi. Me conecto con el portátil por Ethernet al router, pero lo que necesito es conectarme por wifi al hg556a directamente para poder acceder al disco. Si accedo al hg556a o al router wifi puedo ver la dir IP asignada por el DHCP y hacer conexión pero es una dir variable, por lo que debe ser una IP fija.

¿Cómo conecto el hg556a con una ip fija al wifi de casa?
¿Cómo accedería directamente al TDT? La IP del TDT estaría oculta tras el hg556a, yo me conecto al router principal.
No soy capaz de montar el disco, de momento estoy probando con un usb. Según otros post es fácil, pero me da error.

root@OpenWrt:/dev# clear
root@OpenWrt:/dev# mount -t vfat /dev/sda1 /mnt/sda1
mount: mounting /dev/sda1 on /mnt/sda1 failed: Invalid argument
root@OpenWrt:/dev# mount -t vfat /dev/sda /mnt/sda1
mount: mounting /dev/sda on /mnt/sda1 failed: Invalid argument
root@OpenWrt:/dev# ls -ltr /dev/s*
brw-r--r--    1 root     root        8,   1 Sep 26 19:23 /dev/sda1
brw-r--r--    1 root     root        8,   0 Sep 26 19:23 /dev/sda
root@OpenWrt:/dev# ls -ld /mnt/sda1
drwxrwxrwx    2 root     root             0 Sep 26 16:42 /mnt/sda1
root@OpenWrt:/dev#

El Firmwares del hg556 es la r33275 del post https://foro.seguridadwireless.net/openwrt/openwrt-en-huaweig-hg556a/

Por si no queda claro, tenia hechos dos dibujos, pero no soy capaz de subir imágenes.

¿Alguna idea?
Saludos y gracias.



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: Convertir TDT en centro multimedia wifi con router hg556a
« Respuesta #1 en: 27-09-2012, 14:26 (Jueves) »
Lo he intentado eh ?
He leído 3 veces tu mensaje y la verdad no he conseguido entender el 'tinglado' que quieres montar  ;D

Con respecto al montaje del disco duro ... seguro que el formato es fat32 ?
Pon la salida del dmesg a ver si da alguna pista ...  ^-^
« Última modificación: 27-09-2012, 14:32 (Jueves) por jar229 »
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8384
Re: Convertir TDT en centro multimedia wifi con router hg556a
« Respuesta #2 en: 27-09-2012, 14:36 (Jueves) »
hola

Citar
Por si no queda claro, tenia hechos dos dibujos, pero no soy capaz de subir imágenes.

sube las imagenes a un servidor gratuito por ej.  http://imageshack.us/

copia la ruta de esa imagen en el servidor y pegala entre este codigo

Código: [Seleccionar]
[img][/img]
saludos

peterpunk

  • Visitante
Re: Convertir TDT en centro multimedia wifi con router hg556a
« Respuesta #3 en: 27-09-2012, 23:07 (Jueves) »
Iremos por partes... salida de dmesg
El Windows cuando pulso sobre el usb boton derecho-propiedades dice:

Sistemas de archivos FAT32. Por lo que supongo tengo que creer es vfat

root@OpenWrt:~# ls -ld /mnt/sda1
drwxrwxrwx    2 root     root             0 Sep 26 16:42 /mnt/sda1
root@OpenWrt:~# ls -ltr /dev/sd*
brw-r--r--    1 root     root        8,   0 Sep 27 20:42 /dev/sda
brw-r--r--    1 root     root        8,   1 Sep 27 20:42 /dev/sda1
root@OpenWrt:~# mount -t vfat /dev/sda1 /mnt/sda1
mount: mounting /dev/sda1 on /mnt/sda1 failed: Invalid argument
root@OpenWrt:~# dmesg
[spoiler][    0.000000] Linux version 3.3.8 (noltari@skynet) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #1 Sun Aug 26 16:48:15 CEST 2012
[    0.000000] Detected Broadcom 0x6358 CPU revision a1
[    0.000000] CPU frequency is 300 MHz
[    0.000000] 64MB of RAM installed
[    0.000000] registering 40 GPIOs
[    0.000000] gpiochip_add: registered GPIOs 0 to 39 on device: bcm63xx-gpio
[    0.000000] board_bcm963xx: Boot address 0xbe000000
[    0.000000] board_bcm963xx: CFE version: 100.48.56-49.46
[    0.000000] HW556: ath9k caldata offset 0xf7e000
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0002a010 (Broadcom BMIPS4350)
[    0.000000] board_bcm963xx: board name: HW556
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone PFN ranges:
[    0.000000]   Normal   0x00000000 -> 0x00004000
[    0.000000] Movable zone start PFN for each node
[    0.000000] Early memory PFN ranges
[    0.000000]     0: 0x00000000 -> 0x00004000
[    0.000000] On node 0 totalpages: 16384
[    0.000000] free_area_init_node: node 0, pgdat 802a3d70, node_mem_map 81000000
[    0.000000]   Normal zone: 128 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 16256 pages, LIFO batch:3
[    0.000000] Reserving 0MB of memory at 0MB for crashkernel
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc:
  • 0

[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line:  root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Primary instruction cache 16kB, VIPT, 2-way, linesize 16 bytes.
[    0.000000] Primary data cache 16kB, 2-way, VIPT, cache aliases, linesize 16 bytes
[    0.000000] Memory: 61848k/65536k available (2237k kernel code, 3688k reserved, 403k data, 200k init, 0k highmem)
[    0.000000] NR_IRQS:128
[    0.000000] Calibrating delay loop... 299.26 BogoMIPS (lpj=598528)
[    0.036000] pid_max: default: 32768 minimum: 301
[    0.040000] Mount-cache hash table entries: 512
[    0.052000] NET: Registered protocol family 16
[    0.068000] registering PCI controller with io_map_base unset
[    0.088000] bio: create slab <bio-0> at 0
[    0.096000] PCI host bridge to bus 0000:00
[    0.100000] pci_bus 0000:00: root bus resource [mem 0x30000000-0x37ffffff]
[    0.104000] pci_bus 0000:00: root bus resource [io  0x8000000-0x800ffff]
[    0.108000] pci 0000:00:01.0: [168c:ff1d] type 0 class 0x000200
[    0.108000] pci 0000:00:01.0: reg 10: [mem 0x00000000-0x0000ffff]
[    0.120000] pci 0000:00:01.0: BAR 0: assigned [mem 0x30000000-0x3000ffff]
[    0.124000] Switching to clocksource MIPS
[    0.136000] NET: Registered protocol family 2
[    0.140000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.148000] TCP established hash table entries: 2048 (order: 2, 16384 bytes)
[    0.156000] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
[    0.164000] TCP: Hash tables configured (established 2048 bind 2048)
[    0.172000] TCP reno registered
[    0.172000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.180000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.188000] NET: Registered protocol family 1
[    0.192000] pci 0000:00:01.0: fixup device configuration
[    0.200000] PCI: CLS 0 bytes, default 16
[    0.204000] audit: initializing netlink socket (disabled)
[    0.212000] type=2000 audit(0.212:1): initialized
[    0.216000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.224000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.232000] msgmni has been set to 120
[    0.240000] io scheduler noop registered
[    0.244000] io scheduler deadline registered (default)
[    0.252000] bcm63xx_uart.0: ttyS0 at MMIO 0xfffe0100 (irq = 10) is a bcm63xx_uart
[    0.260000] console [ttyS0] enabled, bootconsole disabled
[    0.276000] physmap platform flash device: 02000000 at 1e000000
[    0.284000] physmap-flash.0: Found 1 x16 devices at 0x0 in 16-bit bank. Manufacturer ID 0x0000c2 Chip ID 0x00227a
[    0.292000] physmap-flash.0: Found an alias at 0x1000000 for the chip at 0x0
[    0.292000] Amd/Fujitsu Extended Query Table at 0x0040
[    0.300000]   Amd/Fujitsu Extended Query version 1.3.
[    0.304000] number of CFI chips: 1
[    0.308000] bcm63xxpart: CFE boot tag found with version 8 and board type HW556
[    0.316000] bcm63xxpart: Partition 0 is CFE offset 0 and length 20000
[    0.320000] bcm63xxpart: Partition 1 is kernel offset 20100 and length fff00
[    0.328000] bcm63xxpart: Partition 2 is rootfs offset 120000 and length ce0000
[    0.336000] bcm63xxpart: Partition 3 is cal_data offset e00000 and length 1f0000
[    0.344000] bcm63xxpart: Partition 4 is nvram offset ff0000 and length 10000
[    0.352000] bcm63xxpart: Partition 5 is linux offset 20000 and length de0000
[    0.360000] bcm63xxpart: Spare partition is offset 360004 and length a9fffc
[    0.364000] 6 bcm63xxpart partitions found on MTD device physmap-flash.0
[    0.372000] Creating 6 MTD partitions on "physmap-flash.0":
[    0.380000] 0x000000000000-0x000000020000 : "CFE"
[    0.388000] 0x000000020100-0x000000120000 : "kernel"
[    0.392000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.408000] 0x000000120000-0x000000e00000 : "rootfs"
[    0.420000] mtd: partition "rootfs" set to be root filesystem
[    0.424000] mtd: partition "rootfs_data" created automatically, ofs=360000, len=AA0000
[    0.432000] 0x000000360000-0x000000e00000 : "rootfs_data"
[    0.444000] 0x000000e00000-0x000000ff0000 : "cal_data"
[    0.452000] 0x000000ff0000-0x000001000000 : "nvram"
[    0.460000] 0x000000020000-0x000000e00000 : "linux"
[    0.480000] bcm63xx-wdt bcm63xx-wdt:  started, timer margin: 30 sec
[    0.488000] Registered led device: HW556:red:message
[    0.488000] Registered led device: HW556:red:hspa
[    0.492000] Registered led device: HW556:red:dsl
[    0.492000] Registered led device: HW556:red:power
[    0.492000] Registered led device: HW556:red:all
[    0.492000] TCP cubic registered
[    0.496000] NET: Registered protocol family 17
[    0.500000] 8021q: 802.1Q VLAN Support v1.8
[    0.516000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    0.524000] Freeing unused kernel memory: 200k freed
[    3.292000] eth0: link forced UP - 100/full - flow control off/off
[    3.516000] roboswitch: Probing device eth0: found a 5325! It's a 5350.
[    4.580000] There is already a switch registered on the device 'eth0'
[    6.108000] Button Hotplug driver version 0.4.1
[   10.108000] JFFS2 notice: (348) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 9 of xref (0 dead, 3 orphan) found.
[   13.104000] Compat-wireless backport release: compat-wireless-2012-07-13
[   13.108000] Backport based on wireless-testing.git master-2012-07-16
[   13.116000] compat.git: wireless-testing.git
[   13.184000] cfg80211: Calling CRDA to update world regulatory domain
[   13.188000] cfg80211: World regulatory domain updated:
[   13.196000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   13.204000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   13.212000] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   13.220000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   13.228000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   13.236000] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   13.688000] NET: Registered protocol family 10
[   14.176000] SCSI subsystem initialized
[   14.272000] There is already a switch registered on the device 'eth0'
[   14.636000] usbcore: registered new interface driver usbfs
[   14.640000] usbcore: registered new interface driver hub
[   14.648000] usbcore: registered new device driver usb
[   15.816000] PCI: Enabling device 0000:00:01.0 (0000 -> 0002)
[   15.832000] ath: phy0: eeprom contains invalid mac address: ff:ff:ff:ff:ff:ff
[   15.840000] ath: phy0: random mac address will be used: 8e:53:b5:fa:11:26
[   15.848000] ath: EEPROM regdomain: 0x0
[   15.848000] ath: EEPROM indicates default country code should be used
[   15.848000] ath: doing EEPROM country->regdmn map search
[   15.848000] ath: country maps to regdmn code: 0x3a
[   15.848000] ath: Country alpha2 being used: US
[   15.848000] ath: Regpair used: 0x3a
[   15.860000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   15.864000] Registered led device: ath9k-phy0
[   15.864000] ieee80211 phy0: Atheros AR9280 Rev:2 mem=0xc0320000, irq=39
[   15.872000] cfg80211: Calling CRDA for country: US
[   15.876000] cfg80211: Regulatory domain changed to country: US
[   15.880000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   15.892000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[   15.900000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[   15.908000] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   15.916000] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   15.924000] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   15.932000] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[   16.820000] NTFS driver 2.1.30 [Flags: R/O MODULE].
[   17.520000] PPP generic driver version 2.4.2
[   17.800000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   18.508000] NET: Registered protocol family 24
[   18.856000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[   18.968000] bcm63xx_ehci bcm63xx_ehci.0: BCM63XX integrated EHCI controller
[   18.972000] bcm63xx_ehci bcm63xx_ehci.0: new USB bus registered, assigned bus number 1
[   19.008000] bcm63xx_ehci bcm63xx_ehci.0: irq 18, io mem 0xfffe1300
[   19.024000] bcm63xx_ehci bcm63xx_ehci.0: USB 2.0 started, EHCI 1.00, overcurrent ignored
[   19.032000] hub 1-0:1.0: USB hub found
[   19.036000] hub 1-0:1.0: 2 ports detected
[   19.208000] nf_conntrack version 0.5.0 (969 buckets, 3876 max)
[   19.564000] usb 1-1: new high-speed USB device number 2 using bcm63xx_ehci
[   20.012000] hub 1-1:1.0: USB hub found
[   20.024000] hub 1-1:1.0: 2 ports detected
[   20.348000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   20.808000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[   20.920000] bcm63xx_ohci bcm63xx_ohci.0: BCM63XX integrated OHCI controller
[   20.924000] bcm63xx_ohci bcm63xx_ohci.0: new USB bus registered, assigned bus number 2
[   20.932000] bcm63xx_ohci bcm63xx_ohci.0: irq 13, io mem 0xfffe1400
[   21.000000] hub 2-0:1.0: USB hub found
[   21.004000] hub 2-0:1.0: 2 ports detected
[   21.180000] Initializing USB Mass Storage driver...
[   21.184000] usbcore: registered new interface driver usb-storage
[   21.192000] USB Mass Storage support registered.
[   21.228000] usbcore: registered new interface driver ums-alauda
[   21.268000] usbcore: registered new interface driver ums-cypress
[   21.308000] usbcore: registered new interface driver ums-datafab
[   21.344000] usbcore: registered new interface driver ums-freecom
[   21.384000] usbcore: registered new interface driver ums-isd200
[   21.424000] usbcore: registered new interface driver ums-jumpshot
[   21.460000] usbcore: registered new interface driver ums-karma
[   21.500000] usbcore: registered new interface driver ums-sddr09
[   21.540000] usbcore: registered new interface driver ums-sddr55
[   21.580000] usbcore: registered new interface driver ums-usbat
[   21.620000] input: gpio-keys-polled as /devices/platform/gpio-keys-polled.0/input/input0
[   26.628000] eth0: link forced UP - 100/full - flow control off/off
[   26.644000] device eth0 entered promiscuous mode
[   26.660000] br-lan: port 1(eth0) entered forwarding state
[   26.664000] br-lan: port 1(eth0) entered forwarding state
[   28.668000] br-lan: port 1(eth0) entered forwarding state
[   29.856000] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   32.484000] wlan0: authenticate with 88:25:2c:8b:27:34
[   32.500000] wlan0: send auth to 88:25:2c:8b:27:34 (try 1/3)
[   32.508000] wlan0: authenticated
[   32.528000] ath9k 0000:00:01.0: wlan0: disabling HT due to WEP/TKIP use
[   32.548000] wlan0: associate with 88:25:2c:8b:27:34 (try 1/3)
[   32.568000] wlan0: RX AssocResp from 88:25:2c:8b:27:34 (capab=0x11 status=0 aid=3)
[   32.580000] wlan0: associated
[   32.584000] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  270.640000] usb 1-1.1: new high-speed USB device number 3 using bcm63xx_ehci
[  270.760000] scsi0 : usb-storage 1-1.1:1.0
[  271.768000] scsi 0:0:0:0: Direct-Access     TDK LoR  Trans-It Drive   PMAP PQ: 0 ANSI: 0 CCS
[  272.056000] sd 0:0:0:0: [sda] 8028160 512-byte logical blocks: (4.11 GB/3.82 GiB)
[  272.068000] sd 0:0:0:0: [sda] Write Protect is off
[  272.076000] sd 0:0:0:0: [sda] Mode Sense: 23 00 00 00
[  272.076000] sd 0:0:0:0: [sda] No Caching mode page present
[  272.080000] sd 0:0:0:0: [sda] Assuming drive cache: write through
[  272.096000] sd 0:0:0:0: [sda] No Caching mode page present
[  272.104000] sd 0:0:0:0: [sda] Assuming drive cache: write through
[  272.112000]  sda: sda1
[  272.124000] sd 0:0:0:0: [sda] No Caching mode page present
[  272.132000] sd 0:0:0:0: [sda] Assuming drive cache: write through
[  272.136000] sd 0:0:0:0: [sda] Attached SCSI removable disk
[  316.820000] FAT-fs (sda1): codepage cp437 not found
[  499.872000] FAT-fs (sda1): codepage cp437 not found
[/spoiler]
« Última modificación: 27-09-2012, 23:15 (Jueves) por peterpunk »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: Convertir TDT en centro multimedia wifi con router hg556a
« Respuesta #4 en: 28-09-2012, 07:57 (Viernes) »
Citar
[  316.820000] FAT-fs (sda1): codepage cp437 not found
[  499.872000] FAT-fs (sda1): codepage cp437 not found

Ya ves que se queja.

Código: [Seleccionar]
opkg update
opkg install --force-depend kmod-nls-cp437

Después de instalar el paquete, vuelve a probar el montaje  ;)
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

peterpunk

  • Visitante
Re: Convertir TDT en centro multimedia wifi con router hg556a
« Respuesta #5 en: 28-09-2012, 18:24 (Viernes) »
Pues vale, he instalado el paquete, y tampoco montaba el disco...

El dmesg  indicaba algo de iso8859-1 pues he instalado el paquete.

opkg update
opkg install --force-depend kmod-nls-iso8859-1

Despues de reiniciar, ya se podia montar el disco.

MUCHAS GRACIAS. Paso 1 conseguido...

El problema es que como he tomado el Firmwares del hg556 es la r33275 del post https://foro.seguridadwireless.net/openwrt/openwrt-en-huaweig-hg556a/   

y indicaba usb ... no entiendo porque necesita paquetes adicionales.

He intentado instalar el firm de nuevo mediante LuCI y al instalar indica:
Código: [Seleccionar]
The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

¿Porqué? Pero si es el mismo que instalé sobre el firm del fabricante.....

Esto me esta superando.

         
« Última modificación: 28-09-2012, 18:26 (Viernes) por peterpunk »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: Re: Convertir TDT en centro multimedia wifi con router hg556a
« Respuesta #6 en: 28-09-2012, 19:27 (Viernes) »
Esos paquetes son necesarios para el soporte de discos en fat32, y noltari no se ha dado cuenta de ello.
Lo que no entiendo es porqué quieres volverlo a instalar.
Si quieres, puedes probar la compilación que yo puse hace poco. En teoría, en esa ya están incluidos esos paquetes.

Para istalar, hazlo como la primera vez que pusiste OpenWrt.

Enviado desde mi U8500 usando Tapatalk 2

EDITO: mi compilación tampoco incluye kmod-nls-iso8859-1  :'(
« Última modificación: 02-10-2012, 13:57 (Martes) por jar229 »
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

peterpunk

  • Visitante
Re: Convertir TDT en centro multimedia wifi con router hg556a
« Respuesta #7 en: 02-10-2012, 11:55 (Martes) »
Hola de nuevo.
El instalar de nuevo es para empezar todo de nuevo.  El firm que indicas supongo que será el del  post:
https://foro.seguridadwireless.net/openwrt/instalacion-%28facil%29-de-openwrt-en-huawei-553/ que es de fecha 08-06-2011, yo he tomado el firm del otro post porque era mas actual, pero en este tiene un firm mas reciente aunque el inicio sea antiguo.


De momento esto es lo que tengo montado.
Desde wifi NO se puede acceder al LUcI, ni al ssh del router de manera directa. Tengo que conectarme por ethernet al router y desde ahí puedo acceder a LUcI o al ssh.
¿Cómo configuro el router, para poder llegar por wifi a a LUcI o al ssh?
¿Cómo configuro el router, para poder llegar al servidor web del TDT?

Mas cosas. Quiero montar el disco usb al arrancar el disco. De lo que sabia de Linux era configurar el fstab, pero el fichero no existe (ver código)
[spoiler]root@OpenWrt:/etc# cat fstab
cat: can't open 'fstab': No such file or directory
root@OpenWrt:/etc# pwd
/etc
root@OpenWrt:/etc# ls -l  fstab
lrwxrwxrwx    1 root     root            10 Aug 26 14:44 fstab -> /tmp/fstab
root@OpenWrt:/etc# cat fstab
cat: can't open 'fstab': No such file or directory
root@OpenWrt:/etc#
[/spoiler]
Leyendo en otro post indica instalar  block-mount
He instalado el paquete. Ya tengo el fichero fstab.
Añado la línea para que monte el usb.
Con mount –a  lo monta sin problema.
/etc/init.d/fstab stop
/etc/init.d/fstab disable

/etc/init.d/fstab start
/etc/init.d/fstab enable
Reboot
Cuando arranca he perdido todo lo que estaba en el fstab.
¿Por qué?
« Última modificación: 04-10-2012, 22:50 (Jueves) por peterpunk »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: Convertir TDT en centro multimedia wifi con router hg556a
« Respuesta #8 en: 02-10-2012, 14:17 (Martes) »
Hola de nuevo.
El instalar de nuevo es para empezar todo de nuevo.  El firm que indicas supongo que será el del  post:
https://foro.seguridadwireless.net/openwrt/instalacion-%28facil%29-de-openwrt-en-huawei-553/ que es de fecha 08-06-2011, yo he tomado el firm del otro post porque era mas actual, pero en este tiene un firm mas reciente aunque el inicio sea antiguo.

Los firmwares que encuentres en ese hilo son para el hg553.
Tu router es un hg556a, no ? Entonces los firmwares no te valen.

De momento esto es lo que tengo montado.
Desde wifi NO se puede acceder al LUcI, ni al ssh del router de manera directa. Tengo que conectarme por ethernet al router y desde ahí puedo acceder a LUcI o al ssh.
¿Cómo configuro el router, para poder llegar por wifi a a LUcI o al ssh?
¿Cómo configuro el router, para poder llegar al servidor web del TDT?

La configuración del wifi y de la red, la tienes en el hilo (apartado wifi) al que hacías referencia.
Tómalo como ejemplo y adáptalo a tu red: https://foro.seguridadwireless.net/openwrt/instalacion-%28facil%29-de-openwrt-en-huawei-553/

Mas cosas. Quiero montar el disco usb al arrancar el disco. De lo que sabia de Linux era configurar el fstab, pero el fichero no existe (ver código)
[spoiler]root@OpenWrt:/etc# cat fstab
cat: can't open 'fstab': No such file or directory
root@OpenWrt:/etc# pwd
/etc
root@OpenWrt:/etc# ls -l  fstab
lrwxrwxrwx    1 root     root            10 Aug 26 14:44 fstab -> /tmp/fstab
root@OpenWrt:/etc# cat fstab
cat: can't open 'fstab': No such file or directory
root@OpenWrt:/etc#
[/spoiler]
Leyendo en otro post indica instalar  block-mount
He instalado el paquete. Ya tengo el fichero fstab.
Añado la línea para que monte el usb.
Con mount –a  lo monta sin problema.
/etc/init.d/fstab stop
/etc/init.d/fstab disable
Reboot
Cuando arranca he perdido todo lo que estaba en el fstab.
¿Por qué?


El fichero que tienes que editar está en /etc/config/fstab
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

peterpunk

  • Visitante
Re: Convertir TDT en centro multimedia wifi con router hg556a
« Respuesta #9 en: 04-10-2012, 22:31 (Jueves) »
Hola de nuevo.
El usb ya esta montado y configurado el fstab.
MUCHAS GRACIAS.

Los firmwares que encuentres en ese hilo son para el hg553.
Tu router es un hg556a, no ? Entonces los firmwares no te valen.
Ni caso, se me ha ido la pinza, era el post que estaba leyendo para el tema de la red.

Cita de: jar229
Para istalar, hazlo como la primera vez que pusiste OpenWrt.
Pues negativo, porque lo instale sobre el firm original.
El modo de recuperacion del otro post tampoco funciona.
¿Como se reinstala? , pa la proxima vez.

Seguimos con los muchos problemas de red....
Me leido entero el post
https://foro.seguridadwireless.net/openwrt/instalacion-%28facil%29-de-openwrt-en-huawei-553/
en busca la solucion a mis problemas pero no hay manera...

El interfaz STABRIDGE me indica: Asignar interfaces, por lo que creo que hay algo mal.



He repasado el proceso dos veces con el mismo resultado.
Desde el router funciona el ping, traceroute, etc a internet, pero el portatil conectado por cable al router no puede salir a internet.
Con el movil tampoco puedo acceder al portatil detras del router.

¿Porque?

El portatil esta simulando el TDT, que no puedo desconectar de la tele para hacer pruebas.

aqui pongo los ficheros de configuración por si alguien me dice que los pasa.

[spoiler]root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.20'
        option netmask '255.255.255.0'
        option gateway '192.168.2.1'
        option dns '62.36.225.150'

config interface 'wwan'
        option proto 'dhcp'

config interface 'stabridge'
        option proto 'relay'
        option network 'lan wwan'
        option ipaddr '192.168.2.20'

root@OpenWrt:/etc/config# cat wireles
cat: can't open 'wireles': No such file or directory
root@OpenWrt:/etc/config# cat wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option macaddr 'mac hg665'
        option hwmode '11ng'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '0'
        option country 'ES'
        option distance '12'
        option txpower '20'

config wifi-iface
        option network 'wwan'
        option bssid 'mac router ppal'
        option ssid 'mi red'
        option encryption 'wep-open'
        option device 'radio0'
        option mode 'sta'
        option key1 'mi clave'
        option key '1'

root@OpenWrt:/etc/config# cat dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config dhcp
        option interface 'wwan'
        option ignore '1'

root@OpenWrt:/etc/config#[/spoiler]
« Última modificación: 05-10-2012, 09:18 (Viernes) por peterpunk »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: Convertir TDT en centro multimedia wifi con router hg556a
« Respuesta #10 en: 05-10-2012, 08:14 (Viernes) »
Hola de nuevo.
El usb ya esta montado y configurado el fstab.
MUCHAS GRACIAS.

 ;)

Pues negativo, porque lo instale sobre el firm original.
El modo de recuperacion del otro post tampoco funciona.
¿Como se reinstala? , pa la proxima vez.

Del primer mensaje del hilo

Modo de instalación recomendado:

    Con el router apagado pulsar botón de RESTART y mantenerlo pulsado.
    Encender el router y seguir con el botón apretado durante 20 segundos.
    Soltar el botón.
    Configurar la IP del ordenador como 192.168.1.2 y máscara de subred 255.255.255.0
    Abrir el navegador y acceder a http://192.168.1.1



Citar
El interfaz STABRIDGE me indica: Asignar interfaces, por lo que creo que hay algo mal.

Eso es normal.



Citar
aqui pongo los ficheros de configuración por si alguien me dice que los pasa.

Déjalos así:

/etc/config/network
Código: [Seleccionar]
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.3.20'
        option netmask '255.255.255.0'
        option gateway '192.168.2.1'
        option dns '8.8.8.8'

config interface 'wwan'
        option proto 'dhcp'

config interface 'stabridge'
        option proto 'relay'
        option network 'lan wwan'
        option ipaddr '192.168.2.20'

/etc/config/wireless

Código: [Seleccionar]
config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option macaddr 'mac hg665'
        option hwmode '11ng'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '0'
        option country 'ES'
        option txpower '20'

config wifi-iface
        option network 'wwan'
        option bssid 'mac router ppal'
        option ssid 'mi red'
        option encryption 'wep-open'
        option device 'radio0'
        option mode 'sta'
        option key1 'mi clave'
        option key '1'

/etc/config/dhcp: Este está correcto.

No has puesto /etc/config/firewall. Asegúrate que el apartado LAN quede así:

Código: [Seleccionar]
config zone
option name 'lan'
option network 'lan wwan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'

Es posible, que debas reservar la ip para el hg556a en el router principal.
En la mayoría de routers se puede hacer sin problema, y se hace asignado una IP para una determinada MAC. Tu deberías reservar la 192.168.2.20

Te pongo una captura de mi router para que te sirva de ejemplo



Y yo de tí, cambiaría pero yo la encriptación de la red. WEP 'malo'. WEP 'caca'  ;D ;D
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

peterpunk

  • Visitante
Re: Convertir TDT en centro multimedia wifi con router hg556a
« Respuesta #11 en: 08-10-2012, 12:08 (Lunes) »
Por fin me funciona el modo puente transparente.

Modo de instalación recomendado:
    No has puesto /etc/config/firewall. Asegúrate que el apartado LAN quede así:
Creo que este era el problema. Los ficheros que has puesto son casi identicos a los mios, solo cambiar la red.  No entiendo en funcionamiento de firewall. Tanto en esta configuración como en modo cliente normal.
En modo cliente (para no liar las cosas), cuando esta activo el firewall desde la lan se puede acceder a intertnet. Con firewall parado (firewall stop;firewall disable). Ya no es posible acceder.
Yo tenia entendido que el wirewall servia para cortar trafico, si el firewall esta apagado, ¿No deberia dejar pasar todo el trafico? ¿o lo he apagado mal?

Modo de instalación recomendado:
    Con el router apagado pulsar botón de RESTART y mantenerlo pulsado.
Mil disculpas. No hay mas ciego que el que no quiere ver. Por mucho que me tiré una hora pulsando el boton de RESET (como en el hg553) normal que no entrara en modo recuperación.

Modo de instalación recomendado:
Es posible, que debas reservar la ip para el hg556a en el router principal.
En la mayoría de routers se puede hacer sin problema, y se hace asignado una IP para una determinada MAC. Tu deberías reservar la 192.168.2.20
Y yo de tí, cambiaría pero yo la encriptación de la red. WEP 'malo'. WEP 'caca'

Mi router no puede hacer eso, (Astoria de ya.com) o al menos despues de repasar varias veces la configuración no encuentro que se pueda hacer.
Respecto a WEP tienes razon, pero mi portatil es muy viejo y no admite wpa. Tendria que comprame un adaptador wif-USB, pero paso porque sólo lo uso para navegar. Los problemas de seguridad se pueden cerrar fijando las mac permitidas, al menos que se compliquen un poco en entrar.

Creo que el manual wifi del 553 tiene varias erratas o se ha quedado desactualizado, cito a continuación:

-El tema de firewall ya comentado que no esta detallado en el manual y sin el al menos a mi no me funciona.

-Cuando se indica /etc/init.d/dhcp restart
Este comando no existe creo que te refieres al dnsmasq

-Las actualizaciones han dejado de funcionar.
Hay que cambiar la primera linea del fichero /etc/opkg.conf por esta:
src/gz attitude_adjustment http://downloads.openwrt.org/attitude_adjustment/12.09-beta/brcm63xx/generic/packages

Saludos y muchas gracias.

//FINAL Y MÁS DOS RESPUESTAS