Autor Tema: BT HomeHub 2.0B IMPOSIBLE de ACCEDER  (Leído 3352 veces)

0 Usuarios y 1 Visitante están viendo este tema.

ATAGA

  • Visitante
BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« en: 14-02-2016, 19:41 (Domingo) »
Hola a todos, os queria pedir ayuda para recuperar este router porque ya no se que hacer.

Cometi un grabe error al intentar volver al firmware Barrier Breaker v14.07 despues de ver lo mal que iba el firmware Chaos Calmer v15.05 . En vez de utilizar el sysupgrade utilice el archivo "openwrt-Lantiq-xway-BTHOMEHUBV2B-squashfs-ubinized.bin" del tutorial de instalacion que no entiendo por que no publican compilaciones en formato bin para este router y hay que andar con archivos con extension sysupgrade (no me dan mucha confianza). El problema es que despues de eso Windows no es capaz de asignarle una IP y no puedo acceder a el a menos que lo haga por el puerto TTL que sorprendentemente carga sin problemas aunque a partir de aqui no se que hacer ya que no es posible parar el inicio del kernel para poder trabajar en el (no responde el teclado hasta que se carga el firmware por completo)

¿Alguien me podria ayudar a volver a reinstalar el Barrier Breaker v14.07? se lo agradeceria anormemente.



Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2175
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #1 en: 14-02-2016, 20:37 (Domingo) »
Hola a todos, os queria pedir ayuda para recuperar este router porque ya no se que hacer.

Cometi un grabe error al intentar volver al firmware Barrier Breaker v14.07 despues de ver lo mal que iba el firmware Chaos Calmer v15.05 . En vez de utilizar el sysupgrade utilice el archivo "openwrt-Lantiq-xway-BTHOMEHUBV2B-squashfs-ubinized.bin" del tutorial de instalacion que no entiendo por que no publican compilaciones en formato bin para este router y hay que andar con archivos con extension sysupgrade (no me dan mucha confianza). El problema es que despues de eso Windows no es capaz de asignarle una IP y no puedo acceder a el a menos que lo haga por el puerto TTL que sorprendentemente carga sin problemas aunque a partir de aqui no se que hacer ya que no es posible parar el inicio del kernel para poder trabajar en el (no responde el teclado hasta que se carga el firmware por completo)

¿Alguien me podria ayudar a volver a reinstalar el Barrier Breaker v14.07? se lo agradeceria anormemente.

Si has utilizado una imagen sin guardar los parámetros anteriores, el router tiene los datos por defecto. Accede a él en la IP 192.168.1.1 y configúralo. La extensión no tiene nada que ver en esto, son unas simples letras que tiene el fichero en el nombre...
Recuerda que tienes que poner el PC en la misma subred que el router, pero con distinta IP.

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

ATAGA

  • Visitante
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #2 en: 15-02-2016, 11:14 (Lunes) »
Insisto que no puedo hacer nada con el router. NO funcionan los botones, el router esta sin IP y sin eso yo no puedo hacer nada...porque no puedo comunicarme con el a menos que lo haga por puerto TTL, es decir, soldando cables que ya lo he hecho.

¿Como se reinstala en la Flash el firmware?, es decir, instalar el firmware como si fuera la primera vez, pero a traves del puerto TTL..,no por cable de red, que no tengo IP en el router.

El problema es que el firmware que he instalado no esta COMPLETO, si no, no tiene sentido que en el tutotial de instalacion se instalen tres firmwares:

"Openwrt-Lantiq-xway-BTHOMEHUBV2B-squashfs-ubinized.bin"
openwrt-Lantiq-xway-BTHOMEHUBV2B-uImage
openwrt-Lantiq-xway-BTHOMEHUBV2B-uImage-initramfs

Yo he instalado la primera, y supuestamente hace falta instalar las otras dos para que el router funcione correctamente y que ya no puedo hacer a traves del cable de red.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2175
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #3 en: 15-02-2016, 13:55 (Lunes) »
Insisto que no puedo hacer nada con el router. NO funcionan los botones, el router esta sin IP y sin eso yo no puedo hacer nada...porque no puedo comunicarme con el a menos que lo haga por puerto TTL, es decir, soldando cables que ya lo he hecho.

¿Como se reinstala en la Flash el firmware?, es decir, instalar el firmware como si fuera la primera vez, pero a traves del puerto TTL..,no por cable de red, que no tengo IP en el router.

El problema es que el firmware que he instalado no esta COMPLETO, si no, no tiene sentido que en el tutotial de instalacion se instalen tres firmwares:

"Openwrt-Lantiq-xway-BTHOMEHUBV2B-squashfs-ubinized.bin"
openwrt-Lantiq-xway-BTHOMEHUBV2B-uImage
openwrt-Lantiq-xway-BTHOMEHUBV2B-uImage-initramfs

Yo he instalado la primera, y supuestamente hace falta instalar las otras dos para que el router funcione correctamente y que ya no puedo hacer a traves del cable de red.

Las otras dos imágenes son totalmente distintas y NO SON PARA QUEMAR EN LA FLASH.
Cuando te metes por consola, ¿qué sale? ¿Arranca openwrt o no? ¿Qué hiciste para quemar la imagen?
Si arranca openwrt, ¿podrías pegar lo que te sale al poner ifconfig?
Explica algo más  :P
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

ATAGA

  • Visitante
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #4 en: 15-02-2016, 23:12 (Lunes) »
Si, te cuento.

Despues de estar unos dias probando el Barrier Breaker v14.07 que instalé siguiendo el tutorial de instalacion que hay en este foro lo que hice es pasar a la actualizacion Chaos Calmer v15.05 utlizando el archivo "openwrt-lantiq-xway-BTHOMEHUBV2B-UBIFS-sysupgrade.tar" despues de pensarme si merecia la pena utlizar el formato squashfs en lugar de UBIFS por recomendacion del foro openwrt.ebilan.co.uk (que si es mas moderno, que si es mas avanzado, patatin patatero,...). Pues bien, lo lo recomiendo en ABSOLUTO ya que despues de actializar a traves de la interfaz LUCI me iba muy lento, sobre todo al guardar cambios y agarre un cabreo que ni pa que.... El firmware oficial contiene muchas cosas que sobresatura el funcionamiento del router, vamos que no esta optimizado para este router (si alguien lo tiene compilado de manera INTELIGENTE le estaria muy agradecido si lo publicara en este foro o por lo menos como lo ha logrado).

Visto el panorama que tenia y encima que el overlay era imposible de llevarlo a cabo de ninguna manera... decidi volver a Barrier Breaker v14.07 sin guardar nada de la configuracion. Aqui es cuando utilice el archivo "openwrt-lantiq-xway-BTHOMEHUBV2B-squashfs-ubinized.bin" y lo cargue desde la interfaz LUCI. La instalacion se completo sin problemas, pero al reiniciar el router se quedo mas sordo que una tapia...y en cuando a los leds solo funciona el de power.

Por mas que intentes aceder al router es imposible porque no tiene ninguna IP a la cual conectar por telnet, SSH, WinSCP,...

La sorpresa fue cuando utilce un adaptador USB to UART-RS232 y tres cables soldados al router para ver si podia acceder al terminal y desblinkear el router, sin embargo, no puedo hacer nada de lo siguiente

1) Como la IP del router está en blanco no puedo utilizar tftpd32 para cargar el firmware.

2) Es imposible parar el booteo para evitar la carga del kernel y poder asignarle manualmente una IP con el comando "setenv ipaddr 192.168.1.101" (al final del todo te pongo todo lo que escupe la consola durante el inicio del kernel, a ver si tu puedes ver alguna solucion a mi problema).

3) Tampoco puedo editar el archivo network (vi /etc/config/network). Sale en blanco y cuando le escribo la configuracion luego no se puede guardar porque dice que es un archivo de solo lectura.

4) Si utilizo los comandos "uci set network.lan.ipaddr=192.168.1.101"  y "uci set network.lan.netmask=255.255.255.0" me dice que nanai de la china... porque no encunetra la entrada y si la añades (uci add network.lan.ipaddr=192.168.1.101"  y "uci add network.lan.netmask=255.255.255.0)  pasa olimpicamente de la orden y te salta un listado de los posibles comandos que se pueden utlizar con uci y lo mas gracioso ¡es que aparece listado el comando add!, pero no existe...

5) El pulsado todos los botones del reset, power, los dos a la vez, por separado, tres veces, pulsando durante mas tiempo,...no hace ni puñetero caso.

6) El comando "reboot" funciona a pesar de no estar dentro de las instrucciones de ayuda.

7) el comando "ifconfig" (desde SSH) no hace absolutamente nada, ni da error ni tampoco sale nada.

Conclusion: ¿Existe alguna forma de instalar el firnware sin saber la IP?, supongo que si , porque digo yo que en el caso hipotetico de que saliera este router de la fabrica ¿como introducen el firmware cuando no hay absolutamente nada programado en el y mucho menos con una IP?


""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""

root@OpenWrt:/# reboot
procd: - shutdown -
root@OpenWrt:/# [   38.936000] UBIFS: un-mount UBI device 0, volume 1
[   38.940000] UBIFS: background thread "ubifs_bgt0_1" stops
procd: - reboot -[   38.956000] reboot: Res

U-Boot 1.3.1a (Jan  1 2012 - 10:38:10)

Board: DANUBE (0x50129083)
Chip V1.5
CPU Speed 333 MHz
DR Speed 166 MHz
FPI Speed 83 MHz

Setting up clock generators...
DRAM:  64 MB
Flash: 512 kB
In:    serial
Out:   serial
Err:   serial
danube Switch
NAND:  32 MiB
Hit any key to stop autoboot:  0 (no es posible pararlo ni pulsando todas las teclas, no responde al teclado)

NAND read: device 0 offset 0x4000, size 0xe50000
 15007744 bytes read: OK
## Booting image at 81000000 ...
   Image Name:   MIPS OpenWrt Linux-3.18.20
   Created:      2015-09-11  17:02:56 UTC
   Image Type:   MIPS Linux Kernel Image (unknown compression)
   Data Size:    1445140 Bytes =  1.4 MB
   Load Address: 80002000
   Entry Point:  80002000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK

Starting kernel ...

[    0.000000] Linux version 3.18.20 (buildbot@builder1) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r46450) ) #1 Fri Sep 4 17:16:20 CEST 2015
[    0.000000] SoC: Danube rev 1.5
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019641 (MIPS 24KEc)
[    0.000000] MIPS: machine is BTHOMEHUBV2B - BT Home Hub 2B
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x03ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x03ffffff]
[    0.000000] Initmem setup node 0 [mem 0x00000000-0x03ffffff]
[    0.000000] Primary instruction cache 16kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line: console=ttyLTQ0,115200 init=/etc/preinit
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Writing ErrCtl register=0005b5b3
[    0.000000] Readback ErrCtl register=0005b5b3
[    0.000000] Memory: 60336K/65536K available (3475K kernel code, 154K rwdata, 556K rodata, 148K init, 195K bss, 5200K reserved)
[    0.000000] NR_IRQS:256
[    0.000000] CPU Clock: 333MHz
[    0.000000] Calibrating delay loop... 221.18 BogoMIPS (lpj=442368)
[    0.040000] pid_max: default: 32768 minimum: 301
[    0.044000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.048000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.056000] pinctrl core: initialized pinctrl subsystem
[    0.064000] NET: Registered protocol family 16
[    0.076000] pinctrl-xway 1e100b10.pinmux: Init done
[    0.080000] dma-xway 1e104100.dma: Init done - hw rev: 3, ports: 5, channels: 20
[    0.088000] PCI host bridge /fpi@10000000/pci@E105400 ranges:
[    0.092000]  MEM 0x0000000018000000..0x0000000019ffffff
[    0.096000]   IO 0x000000001ae00000..0x000000001affffff
[    0.100000] ath9k,eeprom 10000000.fpi:localbus@0:ath9k_eep: failed to load eeprom address
[    0.112000] gpio-stp-xway 1e100bb0.stp: Init done
[    0.116000] usbcore: registered new interface driver usbfs
[    0.120000] usbcore: registered new interface driver hub
[    0.124000] usbcore: registered new device driver usb
[    0.128000] PCI host bridge to bus 0000:00
[    0.132000] pci_bus 0000:00: root bus resource [mem 0x18000000-0x19ffffff]
[    0.136000] pci_bus 0000:00: root bus resource [io  0xffffffff]
[    0.140000] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.144000] pci 0000:00:0e.0: BAR 0: assigned [mem 0x18000000-0x1800ffff]
[    0.148000] Switched to clocksource MIPS
[    0.152000] NET: Registered protocol family 2
[    0.160000] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.168000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.172000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.180000] TCP: reno registered
[    0.184000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.188000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.196000] NET: Registered protocol family 1
[    0.200000] gptu: totally 6 16-bit timers/counters
[    0.204000] gptu: misc_register on minor 63
[    0.208000] gptu: succeeded to request irq 126
[    0.212000] gptu: succeeded to request irq 127
[    0.220000] gptu: succeeded to request irq 128
[    0.224000] gptu: succeeded to request irq 129
[    0.228000] gptu: succeeded to request irq 130
[    0.232000] gptu: succeeded to request irq 131
[    0.244000] lantiq,vmmc 1f103000.vmmc: requested GPIO 511
[    0.248000] lantiq,vmmc 1f103000.vmmc: reserved 1MB at 0x03a00000
[    0.256000] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.264000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.272000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.296000] msgmni has been set to 117
[    0.304000] io scheduler noop registered
[    0.308000] io scheduler deadline registered (default)
[    0.316000] 1e100c00.serial: ttyLTQ0 at MMIO 0x1e100c00 (irq = 112, base_baud = 0) is a lantiq,asc
[    0.324000] console [ttyLTQ0] enabled
[    0.324000] console [ttyLTQ0] enabled
[    0.332000] bootconsole [early0] disabled
[    0.332000] bootconsole [early0] disabled
[    0.340000] lantiq nor flash device: 00080000 at 10000000
[    0.344000] Found: AMD AM29LV400BB
[    0.348000] ltq_nor: Found 1 x16 devices at 0x0 in 16-bit bank
[    0.352000] number of JEDEC chips: 1
[    0.356000] 5 ofpart partitions found on MTD device ltq_nor
[    0.364000] Creating 5 MTD partitions on "ltq_nor":
[    0.368000] 0x000000000000-0x000000040000 : "uboot"
[    0.376000] 0x000000040000-0x000000050000 : "uboot_env"
[    0.380000] 0x000000050000-0x000000060000 : "rg_conf_1"
[    0.384000] 0x000000060000-0x000000070000 : "rg_conf_2"
[    0.392000] 0x000000070000-0x000000080000 : "rg_conf_factory"
[    0.424000] nand: device found, Manufacturer ID: 0xec, Chip ID: 0x75
[    0.424000] nand: Samsung NAND 32MiB 3,3V 8-bit
[    0.424000] nand: 32MiB, SLC, page size: 512, OOB size: 16
[    0.436000] Scanning device for bad blocks
[    0.540000] 3 ofpart partitions found on MTD device 14000000.nand-parts
[    0.544000] Creating 3 MTD partitions on "14000000.nand-parts":
[    0.552000] 0x000000000000-0x000000004000 : "art"
[    0.556000] 0x000000004000-0x000000204000 : "kernel"
[    0.560000] 0x000000204000-0x000002000000 : "ubi"
[    0.572000] etop: invalid MAC, using random
[    0.652000] libphy: ltq_mii: probed
[    1.324000] eth0 (uninitialized): Could not attach to PHY
[    1.332000] etop: mdio probe failed
[    1.336000] wdt 1f8803f0.watchdog: Init done
[    1.340000] TCP: cubic registered
[    1.344000] NET: Registered protocol family 17
[    1.348000] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[    1.360000] Bridge firewalling registered
[    1.364000] 8021q: 802.1Q VLAN Support v1.8
[    1.368000] ath9k,eeprom 10000000.fpi:localbus@0:ath9k_eep: endian check enabled.
[    1.376000] ath9k,eeprom 10000000.fpi:localbus@0:ath9k_eep: using random mac
[    1.384000] ath9k,eeprom 10000000.fpi:localbus@0:ath9k_eep: pci slot: 14
[    1.388000] pci 0000:00:0e.0: fixup device configuration
[    1.396000] pci 0000:00:0e.0: fixup info: [168c:0027] revision 01 class 0x028000
[    1.400000] ath9k,eeprom 10000000.fpi:localbus@0:ath9k_eep: loaded ath9k eeprom
[    1.412000] UBI: auto-attach mtd7
[    1.416000] UBI: attaching mtd7 to ubi0
[    1.896000] UBI: scanning is finished
[    1.920000] UBI: attached mtd7 (name "ubi", size 29 MiB) to ubi0
[    1.928000] UBI: PEB size: 16384 bytes (16 KiB), LEB size: 15872 bytes
[    1.932000] UBI: min./max. I/O unit sizes: 512/512, sub-page size 256
[    1.940000] UBI: VID header offset: 256 (aligned 256), data offset: 512
[    1.944000] UBI: good PEBs: 1919, bad PEBs: 0, corrupted PEBs: 0
[    1.952000] UBI: user volume: 2, internal volumes: 1, max. volumes count: 92
[    1.956000] UBI: max/mean erase counter: 8/6, WL threshold: 4096, image sequence number: 1773235501
[    1.968000] UBI: available PEBs: 0, total reserved PEBs: 1919, PEBs reserved for bad PEB handling: 40
[    1.976000] UBI: ubiblock0_0 created from ubi0:0(rootfs)
[    1.980000] ubiblock: device ubiblock0_0 (rootfs) set to be root filesystem
[    1.988000] UBI: background thread "ubi_bgt0d" start[    2.004000] VFS: Mounted root (squashfs filesystem) readonly on device 254:0.
[    2.008000] Freeing unused kernel memory: 148K (8041b000 - 80440000)
procd: Console is alive
procd: - watchdog -
procd: - preinit -
[    4.588000] random: mktemp urandom read with 76 bits of entropy available
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level (¿aqui podria hacer algo?)
[    8.168000] UBIFS: background thread "ubifs_bgt0_1" started, PID 401
[    8.180000] UBIFS: mounted UBI device 0, volume 1, name "rootfs_data"
[    8.184000] UBIFS: LEB size: 15872 bytes (15 KiB), min./max. I/O unit sizes: 512 bytes/512 bytes
[    8.192000] UBIFS: FS size: 26887168 bytes (25 MiB, 1694 LEBs), journal size 1349120 bytes (1 MiB, 85 LEBs)
[    8.204000] UBIFS: reserved for root: 1269947 bytes (1240 KiB)
[    8.208000] UBIFS: media format: w4/r0 (latest is w4/r0), UUID A38DA8C6-9F88-4959-A9A2-7D9BDC3929FC, small LPT model
switching to overlay
mount failed: No such device
switching to jffs2 failed - fallback to ramoverlay
mount failed: No such device
procd: - early -
procd: - watchdog -
procd: - ubus -
procd: - init -
Please press Enter to activate this console.


BusyBox v1.22.1 (2014-09-21 06:13:27 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 BARRIER BREAKER (14.07, r42625)
 -----------------------------------------------------
  * 1/2 oz Galliano         Pour all ingredients into
  * 4 oz cold Coffee        an irish coffee mug filled
  * 1 1/2 oz Dark Rum       with crushed ice. Stir.
  * 2 tsp. Creme de Cacao
 -----------------------------------------------------
root@OpenWrt:/# [   14.996000] random: nonblocking pool is initialized

root@OpenWrt:/# procd: - init complete -

root@OpenWrt:/# procd: Instance odhcpd::instance1 s in a crash loop 6 crashes, 0 seconds since last crash (a saber...)

root@OpenWrt:/#

""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""




danitool

  • Visitante
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #5 en: 16-02-2016, 00:00 (Martes) »
Sin IP se puede transferir el firmware via XMODEM a través de puerto serie. Ni idea de si el bootloader u Openwrt soportan esta característica.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2175
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #6 en: 16-02-2016, 08:39 (Martes) »
Ummm.
Siento que no voy a poder ser de mucha ayuda. Parece que el método de flasheo de este router es distinto al "normal", y no tengo este modelo de router.
A ver si alguien con más experiencia en estos temas te puede decir algo.
Si el bootloader no te deja parar el arranque, y openwrt no inicializa la red, no veo cómo hacerlo.

[    1.324000] eth0 (uninitialized): Could not attach to PHY

https://dev.openwrt.org/ticket/20147
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

Ficht

  • Visitante
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #7 en: 17-02-2016, 19:56 (Miércoles) »
Si, te cuento.
2) Es imposible parar el booteo para evitar la carga del kernel y poder asignarle manualmente una IP con el comando "setenv ipaddr 192.168.1.101" (al final del todo te pongo todo lo que escupe la consola durante el inicio del kernel, a ver si tu puedes ver alguna solucion a mi problema).

Hola ATAGA:
Has probado encender el router (o conectarle el cable) pero ya con algunas teclas del teclado pulsadas? es decir, pensando que hay un retraso en lo que ves en pantalla y lo que ya pasó en el router... (en algunos me ha pasado y he tenido que repetirlo varias veces).
Por xmodem yo lo intentaría si no termina de ir el bootloader, pero tarda bastante. (y claro, de usb nada de nada verdad?)

ATAGA

  • Visitante
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #8 en: 19-02-2016, 13:07 (Viernes) »
Lo de mantener pulsado el boton mientras arranca el router y otras muchas mas cosas...ya lo he intentado, pero no deja pararlo. Tan solo responde el teclado cuando aparecen las lineas:

Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level (¿aqui podria hacer algo?)

Lo del USB olvidate que no hay acceso.

El problema es bastante chungo por haber instalado el firmware con el formato UBIFS y eso que me lo recomendaron en openwrt.ebilan.co.uk (me parece que nadie tiene ni idea del tema, no se como en la pagina oficial no advierten de las consecuencias)

Este formato UBIFS graba los datos de tal manera que son INALTERABLES (como si grabarasas un CD y si te equivocas, pues para la basura) quedando el router totalmente LOBOTOMIZADO y sin ningun dato de configuracion.

Como comprenderas en esta situacion es imposible acceder al USB

Lo de XMODEM creo que seria la solucion ya que no es necesario conocer la IP, ¿no?, te agradeceria que me explicaras con mas detalle como se hace el proceso (no tengo mucha idea en temas de OPENWRT). En openwrt.ebilan.co.uk me han contestado lo siguiente para realizar el proceso de instalacion a traves del puerto TTL, pero no puedo hacer nada ya que es imposible asignarle una IP al router si no puedo parar el bootloder que es necesario para utilizar el tftpd32 y meter las instrucciones de flasheo:

http://openwrt.ebilan.co.uk/viewtopic.php?f=4&t=123

danitool

  • Visitante
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #9 en: 19-02-2016, 14:17 (Viernes) »
Entonces tu principal problema es que no puedes parar el bootloader para entrar en su línea de comandos no?

En algunos bootloaders cuando no encuentran una imagen arrancable del firmware se paran automáticamente.

No sé si este es el caso, pero tal vez borrando el firmware Openwrt, se quedaría parado en línea de comandos, esperando que le envies un firmware.

Las consecuencias de borrar el firmware pueden ser que te quedes aún con menos opciones, así que yo lo probaría como último recurso. Eso en caso de que deje borrar la partición del firmware, o kernel, que en este router no sé como funciona la cosa.

Ficht

  • Visitante
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #10 en: 19-02-2016, 15:38 (Viernes) »
Lo de mantener pulsado el boton mientras arranca el router y otras muchas mas cosas...ya lo he intentado, pero no deja pararlo. Tan solo responde el teclado cuando aparecen las lineas:

Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level (¿aqui podria hacer algo?)

Lo del USB olvidate que no hay acceso.

El problema es bastante chungo por haber instalado el firmware con el formato UBIFS y eso que me lo recomendaron en openwrt.ebilan.co.uk (me parece que nadie tiene ni idea del tema, no se como en la pagina oficial no advierten de las consecuencias)

Este formato UBIFS graba los datos de tal manera que son INALTERABLES (como si grabarasas un CD y si te equivocas, pues para la basura) quedando el router totalmente LOBOTOMIZADO y sin ningun dato de configuracion.

Como comprenderas en esta situacion es imposible acceder al USB

Lo de XMODEM creo que seria la solucion ya que no es necesario conocer la IP, ¿no?, te agradeceria que me explicaras con mas detalle como se hace el proceso (no tengo mucha idea en temas de OPENWRT). En openwrt.ebilan.co.uk me han contestado lo siguiente para realizar el proceso de instalacion a traves del puerto TTL, pero no puedo hacer nada ya que es imposible asignarle una IP al router si no puedo parar el bootloder que es necesario para utilizar el tftpd32 y meter las instrucciones de flasheo:

http://openwrt.ebilan.co.uk/viewtopic.php?f=4&t=123


Ten "Muy" en cuenta lo que dice danitool, respecto a las opciones que puedes perder.... (si eliminas lo que está instalado)

xmodem, busca instrucciones de cómo se usa en putty, creo que es muy fácil, que hay una opción para activarlo (yo tengo linux y si lo he usado, pero es diferente)

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2175
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #11 en: 19-02-2016, 17:19 (Viernes) »
Lo de mantener pulsado el boton mientras arranca el router y otras muchas mas cosas...ya lo he intentado, pero no deja pararlo. Tan solo responde el teclado cuando aparecen las lineas:

Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level (¿aqui podria hacer algo?)

Lo del USB olvidate que no hay acceso.

El problema es bastante chungo por haber instalado el firmware con el formato UBIFS y eso que me lo recomendaron en openwrt.ebilan.co.uk (me parece que nadie tiene ni idea del tema, no se como en la pagina oficial no advierten de las consecuencias)

Este formato UBIFS graba los datos de tal manera que son INALTERABLES (como si grabarasas un CD y si te equivocas, pues para la basura) quedando el router totalmente LOBOTOMIZADO y sin ningun dato de configuracion.

Como comprenderas en esta situacion es imposible acceder al USB

Lo de XMODEM creo que seria la solucion ya que no es necesario conocer la IP, ¿no?, te agradeceria que me explicaras con mas detalle como se hace el proceso (no tengo mucha idea en temas de OPENWRT). En openwrt.ebilan.co.uk me han contestado lo siguiente para realizar el proceso de instalacion a traves del puerto TTL, pero no puedo hacer nada ya que es imposible asignarle una IP al router si no puedo parar el bootloder que es necesario para utilizar el tftpd32 y meter las instrucciones de flasheo:

http://openwrt.ebilan.co.uk/viewtopic.php?f=4&t=123


En ebilan te dicen que para parar el bootloader tienes que pulsar Control+J ¿has probado esa combinación de teclas para pararlo?
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

ATAGA

  • Visitante
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #12 en: 19-02-2016, 19:31 (Viernes) »
Si, vuelvo a repetir que el teclado NO FUNCIONA en ese paso y mira que he probado conectando el router por el puerto TTL, por cable ethernet y con ambos conectados...

danitool

  • Visitante
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #13 en: 19-02-2016, 20:44 (Viernes) »
Si, vuelvo a repetir que el teclado NO FUNCIONA en ese paso y mira que he probado conectando el router por el puerto TTL, por cable ethernet y con ambos conectados...
puedes probar otro adaptador TTL

En Openwrt sí que puedes teclear?

O bien a las bravas, sin adaptador, conectas TX con RX y que se realimente a sí mismo, de esa forma se tragaria su propia salida interpretando pulsaciones de teclado.

Luego conectas tu adaptador y miras si se paró en la línea de comandos.

ATAGA

  • Visitante
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #14 en: 20-02-2016, 12:44 (Sábado) »
Ni haciendo cortocircuito responde... es por "c0j0n0s" la carga. Tan solo puedo operar (teclear) con estos comandos despues de la carga y encima algunos comandos se los pasa por el forro :


. : [ [[ alias bg break cd chdir command continue echo eval exec
        exit export false fg getopts hash help history jobs kill let
        local printf pwd read readonly return set shift source test times
        trap true type ulimit umask unalias unset wait

ATAGA

  • Visitante
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #15 en: 27-02-2016, 11:09 (Sábado) »
YA LO HE RECUPERADO. Gracias al usuario icewrt del foro openwrt.ebilan.co.uk. Os digo como lo he SOLUCIONADO.

Pues resulta que el simbolo del sistema del U-BOOT (Porta-Danube #) se puede forzar a que salga haciendo lo siguiente:

1. Conectar el router al PC por cable de red (no me creia que fuera posible comunicarse con el router sin ninguna IP) y ENCENDERLO.

2. Se ha de abrir la consola del simbolo del sistema de windows y escribir el comando "nc -n -u -p 6666 -v 192.168.1.11 6666 ". No pulsar ninguna tecla ni cerrar la consola en ningun momento.

3. Se desenchufa el router de la pared y se vuelve a enchufar. En este paso hay que darse prisa y estar al loro de que vuelva a detectarse la conexion LAN establecida entre el router y el PC.

4. Nada mas aparecer la conexion LAN router-PC hay que ir inmediatamente a  la consola del simbolo del sistema de windows, pulsar la tecla intro, esperar al menos dos segundos, volver a pulsar la tecla intro y finalmente escribir el siguiente codigo: setenv stdout nc (tela el truquito).

5. Milagrosamente la consola te responde mostrando el simbolo del sistema del U-BOOT (Porta-Danube #)

6. A partir de aqui es seguir las instrucciones de la instalacion, es decir, a partir de:

tftpboot 81000000 openwrt-lantiq-xway-BTHOMEHUBV2B-uImage (importante escribirlo rápido)
nand erase 0x004000 0x1ffC000
nand write 81000000 0x004000 0x200000
tftpboot 81000000 openwrt-lantiq-xway-BTHOMEHUBV2B-uImage-initramfs
bootm 81000000

TODAVIA NO ME LO CREO. Ya lo daba por perdido y casi he estado a punto de comprar otro por ebay....pufff

danitool

  • Visitante
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #16 en: 27-02-2016, 12:21 (Sábado) »
 >:(

Me alegro de que lo hayas recuperado.

Una cosa, el comando
Código: [Seleccionar]
nc -n -u -p 6666 -v 192.168.1.11 6666lo ejecutas en windows?, pero eso es un comando de netcat. Windows viene con netcat instalado por defecto?

Por otra parte a pesar de todo U-boot parece que tenía una IP asignada (192.168.1.11), con un server escuchando en el puerto UDP 6666.

ATAGA

  • Visitante
Re: BT HomeHub 2.0B IMPOSIBLE de ACCEDER
« Respuesta #17 en: 28-02-2016, 17:19 (Domingo) »
Ese comando lo ejecuto desde el simbolo del sistema (administrador) en el propio Windows, pero he de acceder al directorio donde se encuentra netcat, es decir, el archivo "nc.exe" lo tengo que copiar en una carpeta y luego acceder a ella antes de meter el comando.