Autor Tema: ¿instalar una versión anterior de un paquete ?  (Leído 1534 veces)

0 Usuarios y 1 Visitante están viendo este tema.

peperfus

  • Visitante
¿instalar una versión anterior de un paquete ?
« en: 18-02-2018, 19:17 (Domingo) »
Hola

Lo que pretendo es instalar python < 2.7.9, ya que a partir de esa versión, se ve que cambiaron la verificación de sertificados de conexión y no me va lo que estoy intentando instalar (yowsup-cli). Y como no tengo ni idea de python (y no me apetece ponerme, ya estoy bastante ocupado), pues se me había ocurrido instalar una versión anterior.

Mi open es lede(17), y he visto que en barrier breaker hay una anterior que podría probar, supongo.

El caso es que no sé cómo (si se puede) tengo que hacer para añadir ese repositorio y hacer que el opkg me lo instale.
He intentado añadir esta linea a custom_feeds de la config de opkg:
src/gz python_viejo https://archive.openwrt.org/barrier_breaker/14.07/brcm63xx/generic/packages/oldpackages/

pero al hacer opkg update me dice signature file download failed...

¿puedo hacerlo de alguna manera? Gracias.



Ficht

  • Visitante
Re: ¿instalar una versión anterior de un paquete ?
« Respuesta #1 en: 18-02-2018, 22:35 (Domingo) »
Hola

Lo que pretendo es instalar python < 2.7.9, ya que a partir de esa versión, se ve que cambiaron la verificación de sertificados de conexión y no me va lo que estoy intentando instalar (yowsup-cli). Y como no tengo ni idea de python (y no me apetece ponerme, ya estoy bastante ocupado), pues se me había ocurrido instalar una versión anterior.

Mi open es lede(17), y he visto que en barrier breaker hay una anterior que podría probar, supongo.

El caso es que no sé cómo (si se puede) tengo que hacer para añadir ese repositorio y hacer que el opkg me lo instale.
He intentado añadir esta linea a custom_feeds de la config de opkg:
src/gz python_viejo https://archive.openwrt.org/barrier_breaker/14.07/brcm63xx/generic/packages/oldpackages/

pero al hacer opkg update me dice signature file download failed...

¿puedo hacerlo de alguna manera? Gracias.

Hola peperfus:
En principio creo que será difícil de esa manera, pues las cosas cambian bastante entre BB y LEDE, lo que si puedes es intentar compilarlo en lede y ver si se deja.
cambiando el makefile de Python7 y sus paquetes de configuración por los de la versión que había en BB. (en el directorio ./feeds/packages/lang/etc.... )
Si tuvieses espacio en disco descargas los dos repos y combinas los feeds de lo que buscas y ver que sale. (hacerlo antes de compilar nada, con todo limpio)

Yo he solucionado de esta manera los problemas que he tenido con libffmpeg-full desde lede en adelante, usando la versión anterior que había en CC, así me compila perfecto.

Saludos.

peperfus

  • Visitante
Re: ¿instalar una versión anterior de un paquete ?
« Respuesta #2 en: 18-02-2018, 23:16 (Domingo) »
¿Y si bajo de LEDE a CC?

O mejor  :P, voy a probar directamente en BB.
« Última modificación: 18-02-2018, 23:56 (Domingo) por peperfus »