Seguridad Wireless - Wifi

Equipos y materiales => Puntos de acceso, routers, switchs y bridges => Openwrt & LEDE => Mensaje iniciado por: emeryth en 26-10-2012, 18:14 (Viernes)

Título: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: emeryth en 26-10-2012, 18:14 (Viernes)
[Manual] Multiwan con HG-556a


En definicion un multiwan es util cuando tenemos 2 o más entradas wan (internet o enrutado a otras redes) y queremos que una unica red utilice las 2 o más salidas wan, de una manera determinada.  Podemas configurarlo para que al caer una de las wan la otra empiese a trabajar. O podemos configurarlo para que se repartan el trabajo entre ellas.

OJO esto no aumentara el anchuo de banda. Si tenemos una entrada de internet de 10 Mbps y otra de 6 Mbps no tendremops un ancho de banda de de 16 Mbps. Me esplico, sí quieres bajar un archivo ISO de una distribucion linux por descarga directa (unica fuente). Solo podras bajarlo por una sola wan, ya sea por la de 10 o por la de 6 depende de cómo lo configures. Pero si quieres bajar el mismo archivo por un enlace torrents (muchas fuentes) podras utilizar las 2 wan al tiempo porque se reparten las fuentes. Dando como resultado una descarga que se acerca mucho a los 16 Mbps (esto tiene muchas variables)

La manera de realizar el multiwan es dividiendo en lan virtuales el router, el router HG-556 nombra a su switch como “eth0”, el contred 5361 los nombra “eth1”, algunos router no se les puede dividir el switch en lan virtuale (vlan).

En nuestro ejemplo tendremos 1 puerto lan (conector Lan1), 3 puertos wan (los otros 3 conectores del router, lan2 al lan 4), y la wifi configurada como cliente para ser una cuarta entrada wan (wwan)

Código: [Seleccionar]
eth0 (switch)
Vlan 0               Vlan 1                      Vlan 2                         Vlan 3
(puerto)0                 1                                 2                           3
eth0.0              eth0.1                     eth0.2                         eth0.3
Lan1 (fisico)       Lan2                              Lan3                          Lan4
Lan                      Wan2                             Wan3                         Wan4
             XX:XX:XX:XX:18:XX XX:XX:XX:XX:28:XX       XX:XX:XX:XX:38:XX


Para ejecutar multiwan debes tener instalado los siguientes paquetes: Iptables, ip, iptables-mod-conntrack, iptables-mod-conntrack-extra, iptables-mod-ipopt, kmod-ipt-ipopt
Multiwan, luci-app-multiwan, nano. Esta compilacion los tiene instalado.

https://docs.google.com/open?id=0ByLHkumzyj7idm1mdlViR1k0dms (https://docs.google.com/open?id=0ByLHkumzyj7idm1mdlViR1k0dms)

Nota la mayoria de comando  estan basados en uci, por lo tanto deben ejecutarse desde Putty (ventana de comandos del SSH).

Configuracion del archivo etc/config/network

[spoiler]config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config switch 'eth0'
   option enable '1'
   option reset '1'
   option enable_vlan '1'

config switch_vlan
   option device 'eth0'
   option vlan '0'
   option ports '0 5t'

config switch_vlan
   option device 'eth0'
   option vlan '1'
   option ports '1 5t'

config switch_vlan
   option device 'eth0'
   option vlan '2'
   option ports '2 5t'

config switch_vlan
   option device 'eth0'
   option vlan '3'
   option ports '3 5t'

config interface 'lan'
   option type 'bridge'
   option proto 'static'
   option netmask '255.255.255.0'
   option ifname 'eth0.0'
   option ipaddr '192.168.30.1'
   option nat '1'

config interface 'wan2'
   option ifname 'eth0.1'
   option proto 'dhcp'
   option macaddr 'XX:XX:XX:XX:18:XX '

config interface 'wan3'
   option ifname 'eth0.2'
   option proto 'dhcp'
   option macaddr 'XX:XX:XX:XX:28:XX '

config interface 'wan4'
   option ifname 'eth0.3'
   option proto 'dhcp'
   option macaddr 'XX:XX:XX:XX:38:XX '

config interface 'wwan'
   option proto 'dhcp'
[/spoiler]


Las subredes entre la las wan y la lan no se pueden repetir. Por eso la interface lan tiene una subred algo dificil de encontrar en el entorno. Se puede fijar una ip a cada wan pero es más flexible nombralas por una mac cualquiera, pero dirente entre ellas.  

Nota: hg556a no permite la conexión ADSL por lo que este tipo de wan no es posible hasta el momento.

Comandos uci para el archivo network, debes poner los numero de la MAC que te apetesca, y una subred en la lan. Todo lo demas puede ser igual para el router hg556a

[spoiler]uci set network.eth0=switch
uci set network.eth0.enable=1
uci set network.eth0.reset=1
uci set network.eth0.enable_vlan=1

uci add network switch_vlan
uci set network.@switch_vlan[-1].device=eth0
uci set network.@switch_vlan[-1].vlan=0
uci set network.@switch_vlan[-1].ports="0 5t"

uci add network switch_vlan
uci set network.@switch_vlan[-1].device=eth0
uci set network.@switch_vlan[-1].vlan=1
uci set network.@switch_vlan[-1].ports="1 5t"

uci add network switch_vlan
uci set network.@switch_vlan[-1].device=eth0
uci set network.@switch_vlan[-1].vlan=2
uci set network.@switch_vlan[-1].ports="2 5t"

uci add network switch_vlan
uci set network.@switch_vlan[-1].device=eth0
uci set network.@switch_vlan[-1].vlan=3
uci set network.@switch_vlan[-1].ports="3 5t"

uci set network.lan=interface
uci set network.lan.ifname=eth0.0
uci set network.lan.type=bridge
uci set network.lan.proto=static
uci set network.lan.netmask=255.255.255.0
uci set network.lan.ipaddr=192.168.30.1
uci set network.lan.nat=1

uci set network.wan2=interface
uci set network.wan2.ifname=eth0.1
uci set network.wan2.proto=dhcp
uci set network.wan2.macaddr=XX:XX:XX:XX:18:XX

uci set network.wan3=interface
uci set network.wan3.ifname=eth0.2
uci set network.wan3.proto=dhcp
uci set network.wan3.macaddr=XX:XX:XX:XX:28:XX

uci set network.wan4=interface
uci set network.wan4.ifname=eth0.3
uci set network.wan4.proto=dhcp
uci set network.wan4.macaddr=XX:XX:XX:XX:38:XX

uci set network.wwan=interface
uci set network.wwan.proto=dhcp
uci commit
[/spoiler]

configuracion de /etc/config/wireless

El wireless apunta a una red que nos brinda internet (nos sirve de wan) la configuracion es la misma que para poner el router como cliente. Esta configuracion es mas facil realizarla desde luci, despues de un escaneo con la wifi.

[spoiler]config wifi-device 'radio0'
   option type 'mac80211'
   option macaddr´XX:XX:XX:XX:XX:XX´
   option hwmode '11ng'
   option htmode 'HT20'
   list ht_capab 'SHORT-GI-40'
   list ht_capab 'TX-STBC'
   list ht_capab 'RX-STBC1'
   list ht_capab 'DSSS_CCK-40'
   option channel '11'
   option disabled '0'

config wifi-iface
   option device 'radio0'
   option bssid ‘XX:XX:XX:XX:XX:XX’
   option mode 'sta'
   option network 'wwan'
   option ssid 'nombre de la red’
   option encryption 'tipo de encriptacion”
   option key 'clave'
[/spoiler]

comandos uci para el wireless

[spoiler]uci set wireless.radio0.channel=11
uci set wireless.radio0.hwmode=11ng
uci set wireless.radio0.disabled=0
uci set wireless.@wifi-iface[0].mode=sta
uci set wireless.@wifi-iface[0].network=wwan
uci set wireless.@wifi-iface[0].ssid=nombre de la red
uci set wireless.@wifi-iface[0].encryption=tipo de encriptacion
uci set wireless.@wifi-iface[0].key=clave
uci commit
[/spoiler]

Configuracion de archivo /etc/config/firewall

Las cosas a configurar en este archivo son muy pocas, se basan en agrupar las interfaces es 2 grupos o zonas. Una zona lan donde se refiere a la interfac lan, y una zona wan donde se refieren a las interfaces wwan, wan2, wan3, wan4 que hemos creado en el archivo network.

[spoiler]config defaults
   option syn_flood '1'
   option input 'ACCEPT'
   option output 'ACCEPT'
   option forward 'REJECT'

config zone
   option name 'lan'
   option network 'lan'
   option input 'ACCEPT'
   option output 'ACCEPT'
   option forward 'REJECT'

config zone
   option name 'wan'
   option input 'REJECT'
   option output 'ACCEPT'
   option forward 'REJECT'
   option masq '1'
   option mtu_fix '1'
   option network 'wan wwan wan2 wan3 wan4'

config forwarding
   option src 'lan'
   option dest 'wan'
[/spoiler]

en los comandos uci solo se tiene que alterar 2 parametros todos los demas pueden quedar como bienen.

Código: [Seleccionar]
uci set firewall.@zone[0].network=lan
uci set firewall.@zone[1].network="wan wwan wan2 wan3 wan4"
uci commit

Configuracion del archivo /etc/config/multiwan

[spoiler]config multiwan 'config'
   option enabled '1'
   option default_route 'fastbalancer'

config interface 'wwan'
   option weight '10'
   option health_interval '10'
   option icmp_hosts 'dns'
   option timeout '3'
   option health_fail_retries '3'
   option health_recovery_retries '5'
   option failover_to 'fastbalancer'
   option dns 'auto'

config interface 'wan2'
   option weight '10'
   option health_interval '10'
   option icmp_hosts 'dns'
   option timeout '3'
   option health_fail_retries '3'
   option health_recovery_retries '5'
   option failover_to 'fastbalancer'
   option dns 'auto'

config interface 'wan3'
   option weight '10'
   option health_interval '10'
   option icmp_hosts 'dns'
   option timeout '3'
   option health_fail_retries '3'
   option health_recovery_retries '5'
   option failover_to 'fastbalancer'
   option dns 'auto'

config interface 'wan4'
   option weight '10'
   option health_interval '10'
   option icmp_hosts 'dns'
   option timeout '3'
   option health_fail_retries '3'
   option health_recovery_retries '5'
   option failover_to 'fastbalancer'
   option dns 'auto'
[/spoiler]

La primera parte activa el multiwan, y configura la forma de controlar los paquetes. Si al probar la red es inestable, puedes cambiar el metodo en que multiwan controla los paquetes cambiando el valor de failover_to que puede ser fastbalancer (Balanceado con netfilter) o balancer (Balanceado con iproute2)

Las otras partes definen los nombres de las interface wan, deben ser los mismos nombres que los referidos en el archivo network. Solo es importante el nombre de la interface los demas datos de cada columna pueden quedarse como estan.

Comandos uci para multiwan

[spoiler]uci set multiwan.config.enabled=1
uci set multiwan.config.default_route=fastbalancer

uci delete multiwan.wan
uci delete multiwan.wan2

uci set multiwan.wwan=interface
uci set multiwan.wwan.weight=10
uci set multiwan.wwan.health_interval=10
uci set multiwan.wwan.icmp_hosts=dns
uci set multiwan.wwan.timeout=3
uci set multiwan.wwan.health_fail_retries=3
uci set multiwan.wwan.health_recovery_retries=5
uci set multiwan.wwan.failover_to=fastbalancer
uci set multiwan.wwan.dns=auto

uci set multiwan.wan2=interface
uci set multiwan.wan2.weight=10
uci set multiwan.wan2.health_interval=10
uci set multiwan.wan2.icmp_hosts=dns
uci set multiwan.wan2.timeout=3
uci set multiwan.wan2.health_fail_retries=3
uci set multiwan.wan2.health_recovery_retries=5
uci set multiwan.wan2.failover_to=fastbalancer
uci set multiwan.wan2.dns=auto

uci set multiwan.wan3=interface
uci set multiwan.wan3.weight=10
uci set multiwan.wan3.health_interval=10
uci set multiwan.wan3.icmp_hosts=dns
uci set multiwan.wan3.timeout=3
uci set multiwan.wan3.health_fail_retries=3
uci set multiwan.wan3.health_recovery_retries=5
uci set multiwan.wan3.failover_to=fastbalancer
uci set multiwan.wan3.dns=auto

uci set multiwan.wan4=interface
uci set multiwan.wan4.weight=10
uci set multiwan.wan4.health_interval=10
uci set multiwan.wan4.icmp_hosts=dns
uci set multiwan.wan4.timeout=3
uci set multiwan.wan4.health_fail_retries=3
uci set multiwan.wan4.health_recovery_retries=5
uci set multiwan.wan4.failover_to=fastbalancer
uci set multiwan.wan4.dns=auto
uci commit
[/spoiler]

otros comandos uci para configurar la zona horaria y el idioma de luci

[spoiler]uci set system.@system[0].hostname=openwrt
uci set system.@system[0].zonename=Europe/Madrid
uci set system.@system[0].timezone=CET-1CEST,M3.5.0,M10.5.0/3
uci set system.@system[0].conloglevel=8
uci set system.@system[0].Cronloglevel=8
uci set luci.main.lang=es
uci commit
[/spoiler]

Esta parte debe copiarse de un solo tirón y pegarse en la ventana de comandos para que rellene el archivo firewall, esto configura los iptables para accesos a servicios y detección de ataques o escaneos

[spoiler]cat >> /etc/firewall.user << EOF      
iptables -I INPUT 1 -p tcp --tcp-flags ALL NONE -m limit --limit 3/m --limit-burst 5 -j LOG --log-prefix "Firewall> Null scan "
iptables -I INPUT 2 -p tcp --tcp-flags ALL NONE -m recent --name blacklist_60 --set -m comment --comment "Drop/Blacklist Null scan" -j DROP
iptables -I INPUT 3 -p tcp --tcp-flags ALL FIN,PSH,URG -m limit --limit 3/m --limit-burst 5 -j LOG --log-prefix "Firewall> XMAS scan "
iptables -I INPUT 4 -p tcp --tcp-flags ALL SYN,RST,ACK,FIN,URG -m limit --limit 3/m --limit-burst 5 -j LOG --log-prefix "Firewall> XMAS-PSH scan "
iptables -I INPUT 5 -p tcp --tcp-flags ALL ALL -m limit --limit 3/m --limit-burst 5 -j LOG --log-prefix "Firewall> XMAS-ALL scan "
iptables -I INPUT 6 -p tcp --tcp-flags ALL SYN,RST,ACK,FIN,URG -m recent --name blacklist_60 --set  -m comment --comment "Drop/Blacklist Xmas/PSH scan" -j DROP
iptables -I INPUT 7 -p tcp --tcp-flags ALL FIN,PSH,URG -m recent --name blacklist_60 --set  -m comment --comment "Drop/Blacklist Xmas scan" -j DROP
iptables -I INPUT 8 -p tcp --tcp-flags ALL ALL -m recent --name blacklist_60 --set  -m comment --comment "Drop/Blacklist Xmas/All scan" -j DROP
iptables -I INPUT 9 -p tcp --tcp-flags ALL FIN -m limit --limit 3/m --limit-burst 5 -j LOG --log-prefix "Firewall> FIN scan "
iptables -I INPUT 10 -p tcp --tcp-flags ALL FIN -m recent --name blacklist_60 --set  -m comment --comment "Drop/Blacklist FIN scan" -j DROP
iptables -I INPUT 11 -p tcp  -m multiport --dports 23,79 --tcp-flags ALL SYN -m limit --limit 3/m --limit-burst 5 -j LOG --log-prefix "Firewall>SYN scan trap:"
iptables -I INPUT 12 -p tcp  -m multiport --dports 23,79 --tcp-flags ALL SYN -m recent --name blacklist_180 --set -j DROP
iptables -I INPUT 13 -p udp  -m limit --limit 6/h --limit-burst 1 -m length --length 0:28 -j LOG --log-prefix "Firewall>0 length udp "
iptables -I INPUT 14 -p udp -m length --length 0:28 -m comment --comment "Drop UDP packet with no content" -j DROP
EOF
[/spoiler]

se aconseja un reboot.
Título: Re: [Manual] Multiwan con HG-556a
Publicado por: emeryth en 29-10-2012, 09:47 (Lunes)
hola chicos,

Al parecer este tema no despierta mucho interés, porque es poco útil o porque esta mal explicado si es el ultimo caso se espera feedback para mejorarlo.  :-\
Título: Re: Re: [Manual] Multiwan con HG-556a
Publicado por: jar229 en 29-10-2012, 11:16 (Lunes)
Yo creo que poca gente tiene 2 o más conexiones para poder sacar partido al multiwan.
Pero no te preocupes, que está perfectamente explicado ;) 

Enviado desde mi Cube U30GT ( Infected v. 1.3) usando Tapatalk 2
Título: Re: [Manual] Multiwan con HG-556a
Publicado por: eq7mavala en 29-10-2012, 11:42 (Lunes)
A mi me podria interesar, si fuera en plan cuando internet que lo recibo por LAN se pierda que conecte por 3G, pero no es lo mas habitual
Título: Re: [Manual] Multiwan con HG-556a
Publicado por: Noltari en 29-10-2012, 11:58 (Lunes)
Opino lo mismo que jar229.
Está bien explicado, pero no hay mucha gente que utilice multiwan.

Aunque está muy bien tenerlo como tuto "educativo" :D.

Saludos!
Título: Re: [Manual] Multiwan con HG-556a
Publicado por: Elnef en 29-10-2012, 13:05 (Lunes)
Yo también creo que tiene más interés teórico que práctico porque pocas personas tienen dos redes disponibles.
Título: Re: Re: [Manual] Multiwan con HG-556a
Publicado por: elduendeverde en 02-11-2012, 17:06 (Viernes)
Y se podría utilizar un puerto LAN como WAN, para aprovechar un router adsl como neutro?


Enviado desde mi GT-S5830 usando Tapatalk 2
Título: Re: [Manual] Multiwan con HG-556a
Publicado por: emeryth en 02-11-2012, 17:24 (Viernes)
En principio si, pero no se si te entendi bien.

Openwrt en su instalación default, ya deja el router como neutro, ahora si tu objetivo es tener las zonas de firewall bien definidas y organizadas, pues solo tienes que configurar etc/config/network

Código: [Seleccionar]
config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config switch 'eth0'
   option enable '1'
   option reset '1'
   option enable_vlan '1'

config switch_vlan
   option device 'eth0'
   option vlan '0'
   option ports '0 1 2  5t'

config switch_vlan
   option device 'eth0'
   option vlan '1'
   option ports '3 5t'

config interface 'lan'
   option type 'bridge'
   option proto 'static'
   option netmask '255.255.255.0'
   option ifname 'eth0.0'
   option ipaddr '192.168.x.1'
   option nat '1'

config interface 'wan'
   option ifname 'eth0.1'
   option proto 'dhcp'
   option macaddr 'XX:XX:XX:XX:18:XX '

config interface 'wwan'
   option proto 'dhcp'

Ademas de configurar las zonas del firewall con estos comando uci, tendrás el puerto LAN4 del hg556 trabajando como wan exclusivamente y tras el firewall

Código: [Seleccionar]
uci set firewall.@zone[0].network=lan
uci set firewall.@zone[1].network="wan wwan"
uci commit
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: longyny en 23-02-2013, 01:05 (Sábado)
Buenas,

Yo he seguido las instrucciones al pie de la letra, adaptando la numeracion de los puertos del switch a los de mi router, un Comtrend AR-5387un con Openwrt r35318, la compilación que hay aquí en el foro.

La cosa es que veo que todas las wan se conectan correctamente mediante dhcp a sus respectivos routers, ( 3 wan en 3 vlans y 1 wan via wireless en modo cliente )
pero a la hora de la verdad tan solo utilizo una de ellas, que cambia segun le da al router.

Cual puede ser el fallo para que ocurra eso? Yo lo que quiero es poder utilizarlas de forma combinada.

Saludos, y gracias de antemano.
Título: Re: Re: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: jar229 en 23-02-2013, 10:04 (Sábado)


Cual puede ser el fallo para que ocurra eso? Yo lo que quiero es poder utilizarlas de forma combinada.

Saludos, y gracias de antemano.

Lee bien el primer mensaje ...:-\

Enviado desde mi U30GT-H usando Tapatalk 2
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: longyny en 23-02-2013, 10:08 (Sábado)
Si, ya se que se que puede configurar en failover o en balanceo de carga, pero es que supuestamente lo tengo todo bien configurado para balanceo de carga, de ahi que no sepa a que se debe.
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: raphik en 23-02-2013, 10:54 (Sábado)
Si, ya se que se que puede configurar en failover o en balanceo de carga, pero es que supuestamente lo tengo todo bien configurado para balanceo de carga, de ahi que no sepa a que se debe.
A lo que se refiere jar229 es que a pesar de que esté todo bien configurado para el  balanceo de carga:
Citar
OJO esto no aumentará el ancho de banda. Si tenemos una entrada de Internet de 10 Mbps y otra de 6 Mbps no tendremos un ancho de banda de de 16 Mbps. Me explico, si quieres bajar un archivo ISO de una distribucion linux por descarga directa (única fuente) solo podrás bajarlo por una sola wan, ya sea por la de 10 o por la de 6, depende de cómo lo configures. Pero si quieres bajar el mismo archivo por un enlace torrents (muchas fuentes) podrás utilizar las 2 wan al tiempo porque se reparten las fuentes, dando como resultado una descarga que se acerca mucho a los 16 Mbps.
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: longyny en 23-02-2013, 13:24 (Sábado)
De eso tambien soy consciente, pero como tambien dice, bajando un torrent con multiples fuentes si deberia aprovechar todas las interfaces wan, y no lo hace, tan solo utiliza una, es a eso a lo que me refiero.
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: jotaeme76 en 11-07-2013, 08:30 (Jueves)
Muchas gracias por el tutorial chicos. Espero probarlo en breve. LLevaba buscando algo asi hace bastante tiempo y resulta que lo tenemos para nuestro HG556a >:(. He estado a punto de instalar pfsense, pero eso de tener un pc mas en la habitacion encendido  permanentemente........
Espero si alguien lo ha probado pueda aportar algun comentario mas sobre si funciona bien el balanceo.
Saludos
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: jotaeme76 en 15-07-2013, 09:02 (Lunes)
Hola de nuevo amigos, me dispongo a probar el multiwan, pero resulta que la compilacion que uso(breaker r36114) no me deja instalar alguno de los paquetes necesarios.
He visto que en el post habeis colgado una compilacion que ya los trae, pero el enlace esta caido.
Agradeceria lo resubieseis.
Saludos
Título: Re: Re: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: jar229 en 15-07-2013, 10:15 (Lunes)
Hola de nuevo amigos, me dispongo a probar el multiwan, pero resulta que la compilacion que uso(breaker r36114) no me deja instalar alguno de los paquetes necesarios.
He visto que en el post habeis colgado una compilacion que ya los trae, pero el enlace esta caido.
Agradeceria lo resubieseis.
Saludos

A qué compilación y de que hilo te refieres ?

Y ... porqué no usas el backport a Attitude Adjustment que seguro que no te da problemas para instalar lo que quieras ?

Enviado desde mi Cube U30GT
Título: Re: Re: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: jotaeme76 en 15-07-2013, 11:16 (Lunes)
Hola de nuevo amigos, me dispongo a probar el multiwan, pero resulta que la compilacion que uso(breaker r36114) no me deja instalar alguno de los paquetes necesarios.
He visto que en el post habeis colgado una compilacion que ya los trae, pero el enlace esta caido.
Agradeceria lo resubieseis.
Saludos

A qué compilación y de que hilo te refieres ?

Y ... porqué no usas el backport a Attitude Adjustment que seguro que no te da problemas para instalar lo que quieras ?

Enviado desde mi Cube U30GT

Me refiero a la compilacion que esta al principio en este mismo hilo.
De todas formas probare la que me dices a ver si puedo instalarle todos los paquetes necesarios.
Gracias
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: jotaeme76 en 15-07-2013, 13:56 (Lunes)
Hola de nuevo, deciros que acabo de instalar la version attitude adjustment. Despues de instalarle todos los paquetes necesarios, le hago un reinicio al router y se me queda el led rojo de encendido parpadeando y no me deja acceder a este ni por web ni por ssh.
Agradeceria resubieseis la compilacion que ya trae los paquetes instalados.
Gracias de nuevo

Edito el mensaje para deciros que he tambien he probado con la version Backport de danitool a la versión backfire que hay colgada en el foro y tampoco la he podido hacer funcionar, pues cuando activo la pestaña de multiwan, al reiniciar el router ya no puedo acceder a el y entra en un bucle de constantes reinicios.
Es por eso que me gustaria probar la compilacion que en su dia estaba colgada mas arriba en este post.
Saludos
Título: Re: Re: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: jar229 en 15-07-2013, 22:12 (Lunes)

Me refiero a la compilacion que esta al principio en este mismo hilo.
De todas formas probare la que me dices a ver si puedo instalarle todos los paquetes necesarios.
Gracias

Acabo de bajarla sin ningún problema ...  ^-^
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: jotaeme76 en 16-07-2013, 09:17 (Martes)
Buenas, ya he podido descargar la compilación (despiste total por mi parte).
Probada y funcionando perfectamente, sin reinicios ni nada raro.
Ahora toca probar configuraciones del apartado multiwan, a ver si consigo darle prioridad a una wan sobre la otra.
Tambien me gustaria saber si se puede poner un rango de ips para que utilizen una sola wan.
Saludos y gracias por subir estos estupendos tutos.
Edito el mensaje a ver si me ayudais a despejar varias dudas:
He configurado el HG556 tal como viene en el post.Se me queda de la siguiente forma:
puerto 1 :LAN ip estatica 192.168.30.1 Gateway 192.168.30.1 servidor dhcp activado
puerto 2:WAN2 ip dhcp tipo 192.168.1.x
puerto 3 :WAN ip dhcp tipo 192.168.3.x
el pc que se conecta a la boca LAN tiene asignacion automatica de ip.
A)Funciona bien, pero he observado que cuando reinicio manualmente el HG556a(desde la pestaña system/reboot)pierdo toda conexion con el router y con internet. Entonces miro la ip que tienen asignada automaticamente y resulta que es del rango del WAN 1 en vez del rango de la LAN.
Si le asigno a la tarjeta del pc una ip manualmente ya me da acceso.
B)La otra duda es que en la pestaña del Multiwan hay un apartado de reglas en la parte inferior. Me gustaria saber como configurar cada uno de los apartados para que una direccion ip siempre salga por el mismo WAN, ya que uso Noip, por lo que me gustaria solo usase una de las lineas adsl.
Espero me podais echar una mano.
Saludos y gracias
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: emeryth en 21-07-2013, 10:31 (Domingo)
Hola jotaeme76, había dejado tirado el hilo, por falta de tiempo y porque funciona bien, pero ya es hora que actualice la compilación, subiré lo antes posible una nueva compilación al día.
Con respecto a tus preguntas:

1.Si se puede dirigir la salida de determinadas ip por una determinada wan, esto lo haces en  “Reglas de tráfico Multi-WAN”

2.Con respecto al cambio de ip del puerto 1 no estoy seguro que puede ser pero algo que no debieras de colocar es Gateway a la misma ip del router. Porque el router multiwan no gestiona las dns, esto lo realiza cada entrada wan por lo que este parámetro mejor lo dejas vacio.

Espero que te sea de ayuda,

Saludos.
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: jotaeme76 en 21-07-2013, 18:50 (Domingo)
Muchas gracias Emerith por responder. Continuo haciendo pruebas. Ya he conseguido tambien lo de redirigir ciertas ip por una sola wan.
Lo cierto es que es una maravilla. Ahora solo queda meterle todos los pcs de mi red y a ver que tal se porta con el balanceo.
Un saludo y espero si hay novedades las pongas por aqui.
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: jotaeme76 en 02-09-2013, 08:41 (Lunes)
Hola de nuevo amigos, ya llevo una temporada usando este router como multiwan y todo perfecto. Ahora me gustaria me echaseis una mano a poder bloquear un rango de puertos (por ejemplo desde el 10000 hasta el 65000) pero solamente para una determinada ip. Esto es para evitar que me saturen el hg556a con exceso de conexiones tcp y udp(p2p).
Un saludo a todos y cualquier pista sera bienvenida.
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: Noltari en 02-09-2013, 13:06 (Lunes)
Hola de nuevo amigos, ya llevo una temporada usando este router como multiwan y todo perfecto. Ahora me gustaria me echaseis una mano a poder bloquear un rango de puertos (por ejemplo desde el 10000 hasta el 65000) pero solamente para una determinada ip. Esto es para evitar que me saturen el hg556a con exceso de conexiones tcp y udp(p2p).
Un saludo a todos y cualquier pista sera bienvenida.

Buenas, eso lo puedes hacer desde Network->Firewall->Traffic Rules.

Bloqueo de conexiones de entrada:
(https://dl.dropboxusercontent.com/u/4708147/seguridadwireless/firewall_block_ports/block.png) (https://dl.dropboxusercontent.com/u/4708147/seguridadwireless/firewall_block_ports/block.png)
Bloqueo de conexiones de salida:
(https://dl.dropboxusercontent.com/u/4708147/seguridadwireless/firewall_block_ports/block2.png) (https://dl.dropboxusercontent.com/u/4708147/seguridadwireless/firewall_block_ports/block2.png)

Saludos!
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: jotaeme76 en 02-09-2013, 19:29 (Lunes)
Muchas gracias por tu ayuda, y encima con ejemplos graficos. En cuanto tenga un hueco me pongo a ello y ya comento que tal.
Saludos
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: sezarmorante en 19-09-2013, 19:19 (Jueves)
Hola, tengo un HG553 y tengo pensado implementarle multiwan. Tengo que investigar si funciona de la misma manera que con vuestro router. La idea que tengo es usar un pincho 3g para web y correo y el resto a través del wifi (wan que tengo configurada ahora). Había pensado dirigir el tráfico a3g o wifi según los puertos, ¿esto se puede hacer?
Gracias y un saludo
Título: Re: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: emeryth en 22-09-2013, 15:58 (Domingo)
Hola cezarmorente, el router hg556 y el hg553 son casi identificos, la unica diferencia es el tipo de WiFi, por lo q puedes usar este Manual. Además si es posible redirigir el flujo segunda su Puerto.

Saludos
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: VTCop en 10-11-2013, 18:25 (Domingo)
Impresionante tutorial. Me ha venido de perlas. Muchísisisisimas gracias por compartirlo !!!!

Una cosilla sobre el paquete luci-app-multiwan. Si flasheo mi HG556a con el firmware que hay enlazado desde tu post (OpenWRT 12.09-beta2) todo me funciona correctamente, pero si me instalo la ultima versión de OpenWRT y a continuación le instalo del paquete luci-app-multiwan el router no se enciende, entra un boot infinito de reinicios, ¿un poco raro no?

En cualquier caso con el firmware que tú has colgado me va perfecto. Muchas gracias
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: tiagorl en 26-11-2013, 16:29 (Martes)
Podemos hacer bonding de esas interfaces?
Título: Re: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: emeryth en 28-11-2013, 12:24 (Jueves)
Si esto permite balance de carga.
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: aventurer en 28-11-2013, 21:02 (Jueves)
Debe funcionar, mirad,  aquí indica que sí se puede hacer channel bonding.

http://wiki.openwrt.org/doc/networking/network.interfaces

Y aqui viene algun "detallito" sobre el asunto

http://lxr.free-electrons.com/source/Documentation/networking/bonding.txt



Saludos
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: Cristof_Romuard en 31-07-2014, 20:15 (Jueves)
Pues la verdad es que después de mucho leer, de estar mas de 8 horas dándole al tema, me rindo, esto no hay quien lo ponga en marcha, así que dejare mi conexión de casa para casa y la del trabajo para el trabajo.... que le vamos a hacer...

Desde luego no se puede decir que no lo intentara, pero es que no hay forma, cuando instalo lici-app-multiwan en modo fuerza bruta y copio los paquetes en lib/modules el router se vuelve loco y deja de funcionar, con la consiguiente resubida del firm... y así hasta el infinito y mas allá.

Nada, que lo dejo por imposible.
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: Tki2000 en 31-07-2014, 21:13 (Jueves)
Pues la verdad es que después de mucho leer, de estar mas de 8 horas dándole al tema, me rindo, esto no hay quien lo ponga en marcha, así que dejare mi conexión de casa para casa y la del trabajo para el trabajo.... que le vamos a hacer...

Desde luego no se puede decir que no lo intentara, pero es que no hay forma, cuando instalo lici-app-multiwan en modo fuerza bruta y copio los paquetes en lib/modules el router se vuelve loco y deja de funcionar, con la consiguiente resubida del firm... y así hasta el infinito y mas allá.

Nada, que lo dejo por imposible.

¿Y por qué instalas los paquetes forzándolos? ¿No puedes instalar una imagen del trunk y actualizar los paquetes directamente sin forzar? Ya que dices que tienes que resubir la imagen podrías aprovechar para grabar un trunk directamente y sus respectivos paquetes (recuerda que la imagen del trunk no viene con luci y si lo quieres es lo primero que deberías actualizar)
Título: Re:
Publicado por: jar229 en 02-08-2014, 02:03 (Sábado)
Además ahora no tiene porqué usar la rama trunk. Puede instalar la rc2 de Barrier Braker, no?
Título: Re:
Publicado por: Tki2000 en 02-08-2014, 11:14 (Sábado)
Además ahora no tiene porqué usar la rama trunk. Puede instalar la rc2 de Barrier Braker, no?


Xácticamente  ;D
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: aventurer en 31-08-2014, 20:42 (Domingo)
Buenas.

Una preguntita. ¿Este hilo hace referencia al multiwan de este post?

https://forum.openwrt.org/viewtopic.php?id=39052 (https://forum.openwrt.org/viewtopic.php?id=39052)

O es otro desarrollo diferente.

Gracias

Título: Re: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: emeryth en 31-08-2014, 21:09 (Domingo)
No, es otro proyecto mucho más actualizado. Estoy preparando un nuevo manual para este paquete que funciona mucho mejor al conseguir el multiwan, esta semana lo publicaré.

Saludos
Título: Re:
Publicado por: Cristof_Romuard en 25-09-2014, 19:55 (Jueves)
Pues yo ya lo e intentado de todas las formas y no tengo witos de hacerlo... A ver si con ese tuto nuevo me lío menos...
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: emeryth en 25-09-2014, 20:02 (Jueves)
Hola  Cristof_Romuard y aventurer,

El manual es este: https://foro.seguridadwireless.net/openwrt/(manual)-mwan3-proyecto-alternativo-a-multiwan-(hg556a)/

espero que te sirva.

Saludos.  ;D
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: juandingas en 01-10-2014, 12:18 (Miércoles)
Hola

¿Se podría usar multiwan para repetir 2 señales wifi?

Es decir, dos routers A y B y un tercer router C con openwrt. Se crea un enlace como repetidor desde C (master 1 con su propia red wifi) hasta A (que sería el cliente). Esto es lo típico. Pero ¿Se podría al mismo tiempo añadir otro repetidor desde C (con su propio wifi master 2) hasta B (como cliente) y que las dos (C-A y C-B) coexistan?

Gracias
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: emeryth en 01-10-2014, 13:58 (Miércoles)
hola juandingas,

No estoy muy seguro que es lo que planteas, creo que no tienes muchos conceptos claros, deberías leer los hilos relevantes de openwrt, porque no te das a entender lo suficiente.

Ademas, he visto que as hecho esta pregunta en otros hilos y algunas preguntas tuyas me dan a entender, que tu nivel es muy básico, no deberías empezar a construir una casa desde el tejado y menos si no sabes para que es un martillo (dirección ip). No quiero desmotivarte solo curratelo más, lee los hilos relevantes de openwrt de punta a punta y verás que tus preguntas ya tienen respuestas, también usa la wikipedia. Ánimo

Saludos.  ;)
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: juandingas en 01-10-2014, 14:27 (Miércoles)
Hola

Si, en ello estoy, informándome todo lo que puedo.

Lo que planteo es, a ver si me sé explicar.

En el modo repetidor aparecen radio0 y radio1 en el caso de tener antena usb externa.

En radio0 se crea el wifimaster para repetir un cliente, ya sea en el mismo router radio0 o con la antena externa usb radio1.

Mi duda es si es posible crear dos o más wifimaster diferentes en radio0 y repetir la señal de diferentes clientes, bien desde el scan radio0 o desde radio1 y que puedan convivir juntas. De ese modo si cae una se puede acceder a la otra.

gracias
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: emeryth en 01-10-2014, 18:05 (Miércoles)
Hola juandingas,

Según yo se, por definición el modo repetidor debe ser transparente a la red, no tener firewall, tener la misma subred del router AP, no tener configurada ninguna wan, y por si fuera poco no todas las tarjetas wifi lo soportan. Un multiwan exige que tengas subredes diferentes en cada zona, por supuesto una firewall activa, y en definitiva el router no es transparente.

Lo que en teoría si es capas de gestionar multiwan (o mwan3) es que; un router  con su tarjeta wifi interna, mas 2 wifi usb. Configurando las 2 tarjetas wifi usb en modo cliente a un AP que les da Internet, las dos deberían estar en la zona wan, y la wifi interna ponerla como AP y en la zona LAN. Sí se cae una de las AP queda la otra.

Si que es posible colocar 2 AP wifi en un solo router, por medio de las redes virtuales (vlan) pero además de tener poco sentido, mas de 3 wifis juntas se estorbaran unas a otras por el ancho de banda en que trabajan. Bueno por probar que no quede, ya dirás si te resulta algo interesante.

Espero te aclare algo,

Saludos.
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: freelhx en 01-07-2016, 19:03 (Viernes)
No puedo instalar multiwan.  Sabeis que puede ser?



Installing luci-app-multiwan (git-15.248.30277-3836b45-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05/brcm63xx/generic/packages/luci/luci-app-multiwan_git-15.248.30277-3836b45-1_all.ipk.

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-multiwan:
 *    multiwan *
 * opkg_install_cmd: Cannot install package luci-app-multiwan.

Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: raphik en 02-07-2016, 11:05 (Sábado)
Ese error está reportado en las FAQ: dependencias de paquetes con el kernel.
https://foro.seguridadwireless.net/openwrt/(faq)-preguntas-mas-comunes-sobre-openwrt/#post_FAQ_Kernel_Deps

Saludos.
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: emeryth en 02-07-2016, 12:04 (Sábado)
hola,  freelhx

raphik tiene razón, multiwan tiene problemas desde hace mucho tiempo con las ultimas compilaciones. te recomiendo que le eches un ojo a esto.

https://foro.seguridadwireless.net/openwrt/(manual)-mwan3-proyecto-alternativo-a-multiwan-(hg556a)/

saludos
Título: Re: [Tutorial] Multiwan con HG556a (VLANs)
Publicado por: freelhx en 02-07-2016, 13:04 (Sábado)
Gracias a los dos ;)

He estado echando un vistazo al otro post, y me parece bastante mas complicado, por eso me decidi en probar esta manera.

Intentare configurar MWAN3, haber si puedo. Gracias nuevamente.