Autor Tema: [Tutorial] Movistar ftth en TP-LINK 1043 v2 con Openwrt  (Leído 3835 veces)

0 Usuarios y 1 Visitante están viendo este tema.

dodger

  • Visitante
[Tutorial] Movistar ftth en TP-LINK 1043 v2 con Openwrt
« en: 21-10-2014, 10:37 (Martes) »
Buenas,
Abro este hilo por que hay varias personas que me han preguntado como configurar este router de tplink para la fibra de Movistar.
El problema de este router es el "puerto 6" del switch que tiene la v2 del hardware
Y que hace inútil el script de Noltari (Muchas gracias Noltari!)

La configuración que yo hice es 50% Luci 50% cli, no me he puesto a scriptarlo, no tengo tiempo sorry :-(

Yo no tengo IPTV contratada, asi que voy a poner mis pasos hasta la VOIP, imagino que alguien colaborará con la IPTV.

Hacer un factory reset y déjarlo de 0.
Configurar lo básico que queráis configurar :-P

Mediante Luci (via web):
  • network->switch
AÑADIR las vlan's 3 y 6 SIN TOCAR las otras, solo añadirlas. Y tageas los puertos 5 y 6 de esas 2 vlans, SOLO DE ESAS 2 VLANS.
Es muy importante hacerlo así, sino se perderá la conexión con el "router" (esto me llevó un buen rato a mí, hasta que ví un mensaje en openwrt.org sobre el switch).
Guardar en este punto :-)

  • network->interfaces:
Añadir el nuevo wan, es de tipo "pppoe" con los datos habituales (adslppp@telefonicanetpa/adslppp).
En physical settings asignar el interfaz eth0.6 (la vlan6); en el firewall, ponerlo en zona WAN.
Añadir la voip: de tipo DHCP, le asignas el interfaz eth0.3 (vlan3) y le crer una zona nueva en el firewall (voip por ejemplo).

  • network->firewall:
La nueva zona "voip" tiene que tener un "any-any" a/desde lan, es decir marcar como permitido desde lan -> voip y lo contrario.
Por lo demás, poner a voip input->accept, output->accept, forward->reject, Masquerading ok y MSS clamping KO.

Guardar ;-)


Mediante CLI (ssh)
Cambiar la configuración del vlan3, dejarlo como sigue:
Fichero:
Código: [Seleccionar]
/etc/config/network
Código: [Seleccionar]
config interface 'voip'
        option proto 'dhcp'
        option ifname 'eth0.3'
        option accept_ra '0'
        option defaultroute '0'
        option peerdns '0'

La cuestión fue el "accept_ra"... no sé por qué, pero todo funcionó después de poner este parámetro.
El bird4, YO (personalmente, no como el resto), lo tengo así:
Fichero:
Código: [Seleccionar]
/etc/bird4.conf
Código: [Seleccionar]
log syslog all;
router id 192.168.0.1;
debug protocols all;
filter voip_timo {
        if net ~ 10.0.0.0/8 then accept;
        else reject;
}
protocol kernel {
        persist;                # Don't remove routes on bird shutdown
        scan time 20;           # Scan kernel routing table every 20 seconds
        import none;            # Default is import all
        export all;             # Default is export none
}
protocol device {
        scan time 10;           # Scan interfaces every 10 seconds
}
protocol static {
        export none;
}
protocol rip {
        import all;
        export all;
        export filter voip_timo;
        interface "eth0.3";
}
Se puede comentar la línea "debug protocols all;", es simplemente para debug.

Arrancar el bird4 y habilitarlo para que arranque siempre.
Debería insertar rutas sobre eth0.3 como las siguientes:

Código: [Seleccionar]
root@gigarouter01:/etc/config# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         80.58.67.xxx    0.0.0.0         UG    0      0        0 pppoe-wan6_inet
10.22.128.0     0.0.0.0         255.255.224.0   U     0      0        0 eth0.3
10.31.255.128   10.22.128.1     255.255.255.224 UG    0      0        0 eth0.3
80.58.67.xxx    0.0.0.0         255.255.255.255 UH    0      0        0 pppoe-wan6_inet
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan

Hasta aquí, tendríais internet y voip lista, falta IPTV... alguien se anima?



rocalondon

  • Visitante
Re: [Tutorial] Movistar ftth en TP-LINK 1043 v2 con Openwrt
« Respuesta #1 en: 04-11-2014, 06:47 (Martes) »
dodger muchas gracias,

Ya me funciona Internet, Wifi y voip. Ahora nos falta iptv (Imagenio).

De acuerdo al primer post de Noltari de este hilo para iptv se necesitan y recomiendan los  siguientes paquetes: swconfig, bird4, mcproxy, kmod-bridge, udpxy.

¿Tiene alguien información de como configurar manualmente, mcproxy, kmod-bridge, udpxy?. Para estos paquetes no encuentro dicha información en el hilo ni en Internet.

gracias por vuestra ayuda

dodger

  • Visitante
Re: [Tutorial] Movistar ftth en TP-LINK 1043 v2 con Openwrt
« Respuesta #2 en: 04-11-2014, 10:31 (Martes) »
Mirate el script de Noltari para el resto de configuraciones, te pego las fáciles :
Código: [Seleccionar]
cat >/etc/config/igmpproxy<<EOF
config igmpproxy
option quickleave 1

config phyint
option network eth0.2
option direction upstream
list altnet 172.26.0.0/16
list altnet 192.168.1.0/24

config phyint
option network br-lan
option direction downstream
EOF

cat >/etc/mcproxy.conf<<EOF
######################################
##-- mcproxy configuration script --##
######################################

# Protocol: IGMPv1|IGMPv2|IGMPv3 (IPv4) - MLDv1|MLDv2 (IPv6)
protocol IGMPv2;

# Proxy Instance: upstream ==> downstream
pinstance iptv: "eth0.2" ==> "br-lan";
EOF

Revisalas y adaptalas a los nombres de los interfaces principalmente, pero estas no romperan nada.
Después se hace una nueva zona del firewall para IPTV:

Código: [Seleccionar]
uci add firewall zone                     
uci set firewall.@zone[-1].name="iptv"
uci set firewall.@zone[-1].input="ACCEPT"
uci set firewall.@zone[-1].output="ACCEPT"
uci set firewall.@zone[-1].forward="REJECT"
uci set firewall.@zone[-1].network="iptv"
Y por lo que veo, si la ip del iptv es 10.* hay que añadir:
Código: [Seleccionar]
uci set firewall.@zone[-1].masq="1"
La zona de forwarding:
Código: [Seleccionar]
uci add firewall forwarding
uci set firewall.@forwarding[-1].src="lan"
uci set firewall.@forwarding[-1].dest="iptv"

uci add firewall forwarding
uci set firewall.@forwarding[-1].src="iptv"
uci set firewall.@forwarding[-1].dest="lan"

De nuevo, si la ip del iptv es 10.* Y quieres habilitar el "Video On Demand" (que Noltari dice que da problemas), se añade esta regla adicional al firewall de usuario:
Código: [Seleccionar]
    echo -e "iptables -t nat -A PREROUTING -s 172.26.0.0/16 -p udp -d $iptv_ipaddr -j DNAT --to-destination $deco_ipaddr" >> "/etc/firewall.user"

No tengo tiempo para mirar más, lo siento  :(
« Última modificación: 04-11-2014, 10:43 (Martes) por dodger »

warren.deleon

  • Visitante
Re: [Tutorial] Movistar ftth en TP-LINK 1043 v2 con Openwrt
« Respuesta #3 en: 05-11-2014, 07:47 (Miércoles) »
Buenas,
Abro este hilo por que hay varias personas que me han preguntado como configurar este router de tplink para la fibra de Movistar.
El problema de este router es el "puerto 6" del switch que tiene la v2 del hardware
Y que hace inútil el script de Noltari (Muchas gracias Noltari!)

La configuración que yo hice es 50% Luci 50% cli, no me he puesto a scriptarlo, no tengo tiempo sorry :-(

Yo no tengo IPTV contratada, asi que voy a poner mis pasos hasta la VOIP, imagino que alguien colaborará con la IPTV.

Hacer un factory reset y déjarlo de 0.
Configurar lo básico que queráis configurar :-P

Mediante Luci (via web):
  • network->switch
AÑADIR las vlan's 3 y 6 SIN TOCAR las otras, solo añadirlas. Y tageas los puertos 5 y 6 de esas 2 vlans, SOLO DE ESAS 2 VLANS.
Es muy importante hacerlo así, sino se perderá la conexión con el "router" (esto me llevó un buen rato a mí, hasta que ví un mensaje en openwrt.org sobre el switch).
Guardar en este punto :-)

  • network->interfaces:
Añadir el nuevo wan, es de tipo "pppoe" con los datos habituales (adslppp@telefonicanetpa/adslppp).
En physical settings asignar el interfaz eth0.6 (la vlan6); en el firewall, ponerlo en zona WAN.
Añadir la voip: de tipo DHCP, le asignas el interfaz eth0.3 (vlan3) y le crer una zona nueva en el firewall (voip por ejemplo).

  • network->firewall:
La nueva zona "voip" tiene que tener un "any-any" a/desde lan, es decir marcar como permitido desde lan -> voip y lo contrario.
Por lo demás, poner a voip input->accept, output->accept, forward->reject, Masquerading ok y MSS clamping KO.

Guardar ;-)


Mediante CLI (ssh)
Cambiar la configuración del vlan3, dejarlo como sigue:
Fichero:
Código: [Seleccionar]
/etc/config/network
Código: [Seleccionar]
config interface 'voip'
        option proto 'dhcp'
        option ifname 'eth0.3'
        option accept_ra '0'
        option defaultroute '0'
        option peerdns '0'

La cuestión fue el "accept_ra"... no sé por qué, pero todo funcionó después de poner este parámetro.
El bird4, YO (personalmente, no como el resto), lo tengo así:
Fichero:
Código: [Seleccionar]
/etc/bird4.conf
Código: [Seleccionar]
log syslog all;
router id 192.168.0.1;
debug protocols all;
filter voip_timo {
        if net ~ 10.0.0.0/8 then accept;
        else reject;
}
protocol kernel {
        persist;                # Don't remove routes on bird shutdown
        scan time 20;           # Scan kernel routing table every 20 seconds
        import none;            # Default is import all
        export all;             # Default is export none
}
protocol device {
        scan time 10;           # Scan interfaces every 10 seconds
}
protocol static {
        export none;
}
protocol rip {
        import all;
        export all;
        export filter voip_timo;
        interface "eth0.3";
}
Se puede comentar la línea "debug protocols all;", es simplemente para debug.

Arrancar el bird4 y habilitarlo para que arranque siempre.
Debería insertar rutas sobre eth0.3 como las siguientes:

Código: [Seleccionar]
root@gigarouter01:/etc/config# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         80.58.67.xxx    0.0.0.0         UG    0      0        0 pppoe-wan6_inet
10.22.128.0     0.0.0.0         255.255.224.0   U     0      0        0 eth0.3
10.31.255.128   10.22.128.1     255.255.255.224 UG    0      0        0 eth0.3
80.58.67.xxx    0.0.0.0         255.255.255.255 UH    0      0        0 pppoe-wan6_inet
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan

Hasta aquí, tendríais internet y voip lista, falta IPTV... alguien se anima?

Una vez hecho hecho esto, cuales son los pasos a seguir para conseguir que funcione el Movistar TV?

Noltari

  • Visitante
Re: [Tutorial] Movistar ftth en TP-LINK 1043 v2 con Openwrt
« Respuesta #4 en: 05-11-2014, 23:21 (Miércoles) »
Muchas gracias a la información facilitada en este post por dodger, warren.deleon y otros.

El TL-WR1043ND v2 ya es compatible con mi script de configuración:
https://foro.seguridadwireless.net/openwrt/(tutorial)-movistar-ftth-con-openwrt/

Saludos!

//FINAL Y MÁS DOS RESPUESTAS