?>/script>'; } ?> [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio) Widgets Magazine

Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 857003 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Colerax

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1100 en: 22-03-2016, 19:09 (Martes) »
Hola Noltari.

En referencia al parche que te han aceptado:

Hace dos días aceptaron unos parches que mandé para habilitar el IGMP Snooping en los switches AR8327/AR8337:
https://dev.openwrt.org/changeset/48268
Estos switches están presentes en routers como el TL-WDR4300 y el Archer C7 (entre otros).

Investigando un poco sobre los problemas con el tráfico multicast me di cuenta de que aunque dichos switches soportan IGMP/MLD Snooping, el driver de OpenWrt no activaba dicho soporte, por lo que el tráfico multicast era redirigido a todos los dispositivos conectados.
De momento no he tenido tiempo para probarlo en un router configurado como principal, ya que ahora mismo tengo el ASUS RT-AC87U como router principal, pero sí he podido comprobar que actuando como router secundario (dumb AP), ya no hay multicast flooding.

Para habilitarlo tenéis que editar el fichero /etc/config/network y añadir la opción "option igmp_snooping '1'" a la sección del switch.
De esta forma el cambio será persistente aunque reiniciéis el router.
Si por el contrario queréis hacer pruebas para ver su funcionamiento, lo podéis activar/desactivar con los siguientes comandos:
Código: [Seleccionar]
swconfig dev switch0 set igmp_snooping 1
swconfig dev switch0 set igmp_snooping 0

El hecho de que haya que activarlo manualmente ha sido una de las condiciones impuestas para aceptar el parche. Una vez que se confirme que todo funciona correctamente probablemente será activado por defecto.


Si se genera una build con la nueva versión de OpenWRT 15.05.1 que han liberado hace unos días con el ImageBuilder, ¿Estarían incluidos tus cambios?




« Última modificación: 22-03-2016, 19:10 (Martes) por Colerax »

Colerax

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1101 en: 22-03-2016, 21:02 (Martes) »
Hola Noltari.

En referencia al parche que te han aceptado:

Hace dos días aceptaron unos parches que mandé para habilitar el IGMP Snooping en los switches AR8327/AR8337:
https://dev.openwrt.org/changeset/48268
Estos switches están presentes en routers como el TL-WDR4300 y el Archer C7 (entre otros).

Investigando un poco sobre los problemas con el tráfico multicast me di cuenta de que aunque dichos switches soportan IGMP/MLD Snooping, el driver de OpenWrt no activaba dicho soporte, por lo que el tráfico multicast era redirigido a todos los dispositivos conectados.
De momento no he tenido tiempo para probarlo en un router configurado como principal, ya que ahora mismo tengo el ASUS RT-AC87U como router principal, pero sí he podido comprobar que actuando como router secundario (dumb AP), ya no hay multicast flooding.

Para habilitarlo tenéis que editar el fichero /etc/config/network y añadir la opción "option igmp_snooping '1'" a la sección del switch.
De esta forma el cambio será persistente aunque reiniciéis el router.
Si por el contrario queréis hacer pruebas para ver su funcionamiento, lo podéis activar/desactivar con los siguientes comandos:
Código: [Seleccionar]
swconfig dev switch0 set igmp_snooping 1
swconfig dev switch0 set igmp_snooping 0

El hecho de que haya que activarlo manualmente ha sido una de las condiciones impuestas para aceptar el parche. Una vez que se confirme que todo funciona correctamente probablemente será activado por defecto.


Si se genera una build con la nueva versión de OpenWRT 15.05.1 que han liberado hace unos días con el ImageBuilder, ¿Estarían incluidos tus cambios?


Me respondo, los cambios no están incluidos en el repositorio para empaquetar con Imagebuilder.

He compilado 15.05.1 aplicando el patch del igmp snooping para el switch AR8327/AR8337 de Noltari y efectivamente los paquetes UDP de Imagenio dejan de inundar la red lan, pero..., mientras que por VLC puedo ver los canales perfectamente, el deco de movistar se queda tostado y dejo de ver los canales.

He probado a activar selectivamente el igmp snooping por puerto del router en lugar de activarlo en el switch entero, ej:

Código: [Seleccionar]
# Boca del switch conectada al Desco
swconfig dev switch0 port 5 set igmp_snooping 0
# Resto de bocas del switch
swconfig dev switch0 port 4 set igmp_snooping 1
swconfig dev switch0 port 3 set igmp_snooping 1
swconfig dev switch0 port 2 set igmp_snooping 1

y esto parece que funciona correctamente, el deco funciona correctamente y el resto de bocas no tienen inundación de paquetes.

PD: Tengo como proxy, el programa igmpproxy en lugar de mcproxy, quizás con mcproxy funcione perfectamente activando igmp snooping en el switch entero.



« Última modificación: 23-03-2016, 10:40 (Miércoles) por Colerax »

darKknight

  • Visitante
Re: Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1102 en: 24-03-2016, 08:53 (Jueves) »


¿Alguien ha probado a usar más de un decodificador o conjunto decodificador + VLC/Kodi?

Me ocurre que si se está viendo el mismo canal desde dos dispositivos (decodificador + Kodi con el plugin de Movistar TV), si se cambia de canal o se apaga uno de ellos se corta en el otro. Entiendo que por la interfaz downstream llega un leave para abandonar ese grupo multicast (canal) desde uno de los clientes y lo reenvía por la interfaz de upstream cortando la recepción inmediatamente. He probado con igmpproxy y mcproxy (mucho más estable éste, por cierto). Si se desactiva quick leave no ocurre, pero no me parece una solución válida, mucho menos para hacer zapping o tener Movistar TV por ADSL como en mi caso. El IGMP proxy de los routers de Movistar tienen quick leave activado, y no se corta la recepción cuando se ve el mismo canal en varios dispositivos y se cambia en uno de ellos. También es verdad que tiene más parámetros que el de OpenWRT.

¿Habéis notado esto? No se si tendrá solución, no veo que haya nada que configurar para ello.

Es cierto, yo también tengo dos decos (arris concretamente) conectados por DHCP, y ocurre lo que dices. No se si habrá alguna forma de arreglarlo porque mis conocimientos no dan para tanto  :-\. Supongo que habría que parchearlo de forma que compruebe que no hay más clientes en ese grupo multicast antes de hacer el leave.

¿Nadie sabe nada? Lo unico que he encontrado es este parche https://dev.openwrt.org/browser/trunk/package/network/services/igmpproxy/patches/250-fix_multiple_downlink_interfaces.patch?rev=44859

Basicamente es para que al tener varias interfaces download y abandonar el grupo multicast en alguna de ellas, compruebe si hay algun miembro en la otra antes de enviar el leave por la interfaz upstream. Algo asi necesitamos, pero que compruebe si queda algun miembro en la misma interfaz. A ver si algun experto en materia es capaz de modificarlo para solucionarlo.

Con ese parche se me ocurre poner una interfaz download diferente mediante VLAN para cada decodificador, a ver si realmente funciona y no envia el leave si hay otro suscriptor en la otra interfaz al cambiar de canal en una de ellas.

Me gustaria probarlo, pero no se como aplicar el parche. Supongo que tendria que bajar las fuentes de OpenWRT y compilar el firmware entero con el paquete igmpproxy y el parche aplicado. Ya he compilado antes, pero no se como va el tema de los parches. Seria con 15.05 o 15.05.1 oficial.

Muchas gracias y enhorabuena a noltari por su gran trabajo.


warren.deleon

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1103 en: 28-03-2016, 10:00 (Lunes) »
Hola a todos,

He recibido un email de Movistar diciendo lo siguiente:

Citar
Buenos días:
Hemos detectado que hay configurado en su router un mapeo de puertos, de manera que, a través de uno de dichos puertos (TCP 4022)
 
se puede visualizar desde internet su paquete Movistar TV sin que usted sea consciente de ello. Esto, además de la intrusión en su equipamiento, puede provocar que su conexión vaya más lenta de lo habitual.
Por tanto, para solucionar el problema, es necesario deshacer esa configuración.
 
La acción concreta que tiene que efectuar es deshacer el mapeo del puerto TCP 4022 y eliminar la conversión de RTP a HTTP, para lo cual dispone de dos opciones:
 
1.- Acceder a la configuración de su router a través del portal Alejandra y deshacer el mapeo al puerto 4022:
http://www.movistar.es/particulares/internet/adsl-fibra-optica/clientes/configuracion-routers-portal-alejandra/
 
 
2.- Desinstalar en su PC la aplicación udpxy para eliminar la conversión de RTP a HTTP.
 
 
Si tiene cualquier problema y necesita ayuda técnica para solucionar este tema, comuníquenoslo y nos pondremos en contacto con usted.
Un saludo

Tengo un TP-Link TL-WR1043N/ND v2 con OpenWrt Chaos Calmer 15.05-rc3 y usé el script de Noltari. ¿Alguno podría decirme qué debo hacer? Según Movistar debo desactivar eso, y no se cómo hacerlo.


Ficht

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1104 en: 28-03-2016, 10:16 (Lunes) »
Hola a todos,

He recibido un email de Movistar diciendo lo siguiente:

Citar
Buenos días:
Hemos detectado que hay configurado en su router un mapeo de puertos, de manera que, a través de uno de dichos puertos (TCP 4022)
 
se puede visualizar desde internet su paquete Movistar TV sin que usted sea consciente de ello. Esto, además de la intrusión en su equipamiento, puede provocar que su conexión vaya más lenta de lo habitual.
Por tanto, para solucionar el problema, es necesario deshacer esa configuración.
 
La acción concreta que tiene que efectuar es deshacer el mapeo del puerto TCP 4022 y eliminar la conversión de RTP a HTTP, para lo cual dispone de dos opciones:
 
1.- Acceder a la configuración de su router a través del portal Alejandra y deshacer el mapeo al puerto 4022:
http://www.movistar.es/particulares/internet/adsl-fibra-optica/clientes/configuracion-routers-portal-alejandra/
 
 
2.- Desinstalar en su PC la aplicación udpxy para eliminar la conversión de RTP a HTTP.
 
 
Si tiene cualquier problema y necesita ayuda técnica para solucionar este tema, comuníquenoslo y nos pondremos en contacto con usted.
Un saludo

Tengo un TP-Link TL-WR1043N/ND v2 con OpenWrt Chaos Calmer 15.05-rc3 y usé el script de Noltari. ¿Alguno podría decirme qué debo hacer? Según Movistar debo desactivar eso, y no se cómo hacerlo.

Hombre, entiendo yo, que basta con entrar al router y bloquear el trafico del puerto 4022 hacia el exterior, tal vez antes de bloquear nada, podrías hacer un escaneo de puertos a tu ip de casa, por ejemplo desde el móvil conectado a 3g (y no en tu wifi), y ver qué puertos o servicios tienes abiertos, y a partir de ahí, ir bloqueando o cerrando lo que no deba estar abierto...

« Última modificación: 28-03-2016, 10:42 (Lunes) por Ficht »

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1105 en: 28-03-2016, 12:29 (Lunes) »
Hola a todos,

He recibido un email de Movistar diciendo lo siguiente:

Citar
Buenos días:
Hemos detectado que hay configurado en su router un mapeo de puertos, de manera que, a través de uno de dichos puertos (TCP 4022)
 
se puede visualizar desde internet su paquete Movistar TV sin que usted sea consciente de ello. Esto, además de la intrusión en su equipamiento, puede provocar que su conexión vaya más lenta de lo habitual.
Por tanto, para solucionar el problema, es necesario deshacer esa configuración.
 
La acción concreta que tiene que efectuar es deshacer el mapeo del puerto TCP 4022 y eliminar la conversión de RTP a HTTP, para lo cual dispone de dos opciones:
 
1.- Acceder a la configuración de su router a través del portal Alejandra y deshacer el mapeo al puerto 4022:
http://www.movistar.es/particulares/internet/adsl-fibra-optica/clientes/configuracion-routers-portal-alejandra/
 
 
2.- Desinstalar en su PC la aplicación udpxy para eliminar la conversión de RTP a HTTP.
 
 
Si tiene cualquier problema y necesita ayuda técnica para solucionar este tema, comuníquenoslo y nos pondremos en contacto con usted.
Un saludo

Tengo un TP-Link TL-WR1043N/ND v2 con OpenWrt Chaos Calmer 15.05-rc3 y usé el script de Noltari. ¿Alguno podría decirme qué debo hacer? Según Movistar debo desactivar eso, y no se cómo hacerlo.
Prueba a ejecutar estos comandos:
Código: [Seleccionar]
uci delete firewall.udpxy
uci commit firewall
/etc/init.d/firewall reload

Saludos.


Roberto_MCF

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1106 en: 29-03-2016, 13:22 (Martes) »
Yo con un WRT1900ACS con Jazztell 200/200 y OpenWRT me funciona perfectamente sin limitarme nada, bajo a machete y sirvo a machete, pero claro es caro jejeje

buenas, tengo el mismo router y fibra de jazztel, quiero ponerle openwrt me puedes pasar la configuración de las vlan? o si me haces una captura de tu etc/config/network me vale. Gracias


jostor4713

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1107 en: 01-04-2016, 22:00 (Viernes) »
Hola a todos.
Soy totalmente novato en este tema, pero me gusta trastear y me he quitado de enmedio el movistar vg 8050 para poner un tp link wdr4900 v1.
El caso es que siguiendo el tutorial todo me va perfecto, internet FTTH a 300 megas, voip y televisión. Pero tengo dos decodificadores de imagenio y normalmente funcionan bien los dos por DHCP sin ningún problema, pero de vez en cuando al estar utilizando uno sólo, la imagen se empieza a pixelar y tengo que apagarlo todo y reiniciar. Me gustaría saber si esto puede ser síntoma de la saturación de trafico multicast. Si me lo confirma alguien supongo que aplicando el parche de IGMP slooping de Noltari se solucionará.
Muchas gracias.


sincrack

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1108 en: 05-04-2016, 14:56 (Martes) »
Yo con un WRT1900ACS con Jazztell 200/200 y OpenWRT me funciona perfectamente sin limitarme nada, bajo a machete y sirvo a machete, pero claro es caro jejeje

buenas, tengo el mismo router y fibra de jazztel, quiero ponerle openwrt me puedes pasar la configuración de las vlan? o si me haces una captura de tu etc/config/network me vale. Gracias

Claro sin problema, es muy sencillo, yo tengo la ip 192.168.20.1 tu debes poner la que quieras ponerle jejeje:

Código: [Seleccionar]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdd4:4a4a:4e3b::/48'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 5t 6'
option vid '1'

config switch_vlan
option device 'switch0'
option vlan '6'
option ports '4t 5t'
option vid '1074'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ip6assign '60'
option ipaddr '192.168.20.1'
option netmask '255.255.255.0'

config interface 'wan'
option _orig_ifname 'eth0.6'
option _orig_bridge 'false'
option proto 'dhcp'
option ifname 'eth0.1074'

config interface 'wan6'
option ifname 'eth0'
option proto 'dhcpv6'

« Última modificación: 05-04-2016, 14:58 (Martes) por sincrack »

el acido

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1109 en: 13-04-2016, 18:00 (Miércoles) »
Hola, he instalado el firmware de Noltari en un archer c7 y cuando intento activar el igmp sooping con el comando:

swconfig dev switch0 set igmp_snooping 1

me responde con lo siguiente:

Unknown attribute "igmp_snooping"

¿Que hago mal? ¿el parche de Noltari no está implementado en su firmware?

Gracias.


tagotis

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1110 en: 18-04-2016, 10:10 (Lunes) »
Hola tengo un router tp-link tl-wr1043ND version 1.2 y quisiera saber si una vez puesto el  openwrt se puede volver al firmware de fabrica sino me convence el cambio, gracias


eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1111 en: 18-04-2016, 10:57 (Lunes) »
Hola tengo un router tp-link tl-wr1043ND version 1.2 y quisiera saber si una vez puesto el  openwrt se puede volver al firmware de fabrica sino me convence el cambio, gracias

Tienes la información aquí:
https://wiki.openwrt.org/toh/tp-link/tl-wr1043nd#back_to_original_firmware


jdgszorro

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1112 en: 18-04-2016, 11:55 (Lunes) »
Buenas,

  no se si os habrá pasado ya a alguno, pero la semana pasada me llego un sms de movistar para que dejara el deco encendido para una actualización y nada lo que me temía.

Al día siguiente voy al Movistar TV y me da el mensaje de Not network.

Tengo un TP-LINK con Openwrt (Lucy).

Alguna idea de que puede ser o que tengo que modificar ?

Muchas gracias.


madmalkav

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1113 en: 18-04-2016, 20:07 (Lunes) »
Buenas, acabao de pedir la portabilidad a Movistar después de un año desastroso con Oceans. Actualmente ya uso OpenWRT en mi router pero quería aprovechar la ocasión para actualizarlo y añadir las modificaciones de este hilo. El router es un Netogear WNR3500L. ¿Algún consejo a tener en cuenta o compilo con los paquetes que se mencionan en el primer post y listo?


jdgszorro

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1114 en: 19-04-2016, 17:39 (Martes) »
Socccccccccccooooooooooorrro !!!  :'(


Nadie sabe porque ha dejado de funcionar Movistar TV con la última actualización.

 ¿ Han cambiado algo ? ¿ Puertas de enlace ? o alguna otra cosa.

Mucha gracias por adelantado.


inforytel

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1115 en: 21-04-2016, 01:11 (Jueves) »
¿Has conseguido configurar la voip con el nuevo router?, yo quiero configurarlo con un servidor asterisk, pero no doy con la clave con la configuracion de las vlans en este router Askey


tagotis

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1116 en: 22-04-2016, 20:51 (Viernes) »
Hola tengo un router tp-link tl-wr1043ND version 1.2 y quisiera saber si una vez puesto el  openwrt se puede volver al firmware de fabrica sino me convence el cambio, gracias

Tienes la información aquí:
https://wiki.openwrt.org/toh/tp-link/tl-wr1043nd#back_to_original_firmware

Gracias, de momento bien, el unico inconveniente es la bajada de velocidad con el original tenia 300mb de bajada y ahora no paso de 120mb


tagotis

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1117 en: 23-04-2016, 13:20 (Sábado) »
Muy buenas!

En primer lugar, quisiera agradecer a Noltari el estupendo trabajo realizado. Compré un TP-Link TD4300 hace unos meses, después de leer este hilo, y me costó cinco minutos tener la conexión lista. Enhorabuena.

Y en segundo lugar, quisiera aportar mis modestas experiencias al hilo:

* IPv6
 - A pesar de que el script está preparado para usar IPv6, Movistar aún no ha configurado toda su red; depurando la conexión he visto que el servidor de PPPoE explícitamente rechaza usar IPv6.
- Si a alguien le interesa el tema, Hurricane Electric (https://www.tunnelbroker.net/) ofrece túneles IPv6 gratuitos, que con OpenWrt se configuran en minutos.

* VOIP:
 - Conseguí instalar y hacer funcionar Asterisk en el router; ahora lo uso como servidor de VOIP, puedo conectar varios terminales, hacer y recibir llamadas (suenan todos los terminales, puesto que para el servidor de VOIP de Movistar sólo hay un dispositivo conectado), y obviamente también hablar entre terminales.
 - Además, con esta configuración no es necesario permitir tráfico entre la LAN y la red VOIP de Movistar.
 - Para poder usar la VOIP desde fuera tengo un servidor de VPN en el propio router; así puedo conectarme desde el móvil y hacer / recibir llamadas con la línea del fijo, aunque esté fuera de casa.

Si a alguien le interesa algo de lo que comento más arriba y necesita ayuda, que lo comente.

Hola podrías hacer un pequeño tutorial para configurar el asterisk, estoy intentado configurarlo y por mas que leo no consigo enterarme de nada, gracias


eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1118 en: 25-04-2016, 13:12 (Lunes) »
Muy buenas!

En primer lugar, quisiera agradecer a Noltari el estupendo trabajo realizado. Compré un TP-Link TD4300 hace unos meses, después de leer este hilo, y me costó cinco minutos tener la conexión lista. Enhorabuena.

Y en segundo lugar, quisiera aportar mis modestas experiencias al hilo:

* IPv6
 - A pesar de que el script está preparado para usar IPv6, Movistar aún no ha configurado toda su red; depurando la conexión he visto que el servidor de PPPoE explícitamente rechaza usar IPv6.
- Si a alguien le interesa el tema, Hurricane Electric (https://www.tunnelbroker.net/) ofrece túneles IPv6 gratuitos, que con OpenWrt se configuran en minutos.

* VOIP:
 - Conseguí instalar y hacer funcionar Asterisk en el router; ahora lo uso como servidor de VOIP, puedo conectar varios terminales, hacer y recibir llamadas (suenan todos los terminales, puesto que para el servidor de VOIP de Movistar sólo hay un dispositivo conectado), y obviamente también hablar entre terminales.
 - Además, con esta configuración no es necesario permitir tráfico entre la LAN y la red VOIP de Movistar.
 - Para poder usar la VOIP desde fuera tengo un servidor de VPN en el propio router; así puedo conectarme desde el móvil y hacer / recibir llamadas con la línea del fijo, aunque esté fuera de casa.

Si a alguien le interesa algo de lo que comento más arriba y necesita ayuda, que lo comente.

Hola podrías hacer un pequeño tutorial para configurar el asterisk, estoy intentado configurarlo y por mas que leo no consigo enterarme de nada, gracias

Hace mucho tiempo que lo instalé, no me veo capaz de hacer un tutorial después de tanto tiempo; lo que sí te puedo pasar son mis ficheros de configuración, a ver si te ayudan. Éstos son los ficheros que creo que modifiqué, los ficheros que no están aquí es porque no recuerdo haberlos tocado respecto a los que venían de ejemplo con Asterisk; la información privada o confidencial la he enmascarado, añadiendo "_" al principio y al final (es decir, donde pone _9xxxxxxxx_ debes poner tu número de teléfono 912345678).

# sip.conf
Código: [Seleccionar]
[general]
context=unauthenticated         ; default context for incoming calls
allowguest=no                   ; disable unauthenticated calls
srvlookup=yes                   ; enabled DNS SRV record lookup on outbound calls
udpbindaddr=0.0.0.0             ; listen for UDP requests on all interfaces
tcpenable=no                    ; disable TCP support
directmedia=outgoing

register => _9xxxxxxxx_@telefonica.net:_9xxxxxxxx_@10.31.255.134:5070

[dispositivo](!)     ; create a template for our devices
type=friend          ; the channel driver will match on username first, IP second
context=dispositivos ; this is where calls from the device will enter the dialplan
host=dynamic         ; the device will register with asterisk
dtmfmode=auto        ; accept touch-tones from the devices, negotiated automatically
disallow=all         ; reset which voice codecs this device will accept or offer
allow=gsm,ulaw,alaw  ; which audio codecs to accept from, and request to, the device
mailbox=555@default  ; all devices share a common mailbox
sendrpid=yes         ; send Remote-Party-Id to devices
deny=0.0.0.0/0.0.0.0
permit=192.168.0.0/255.255.0.0

[_device1_](dispositivo)
secret=_password1_

[_device2_](dispositivo)
secret=_password2_

[Movistar](!)
type=peer
secret=_9xxxxxxxxx_
insecure=port,invite
dtmfmode=auto
disallow=all
allow=gsm,ulaw,alaw
outboundproxy=10.31.255.134:5070
qualify=no

[MovistarOut](Movistar)
host=telefonica.net
fromuser=_9xxxxxxxxx_
fromdomain=telefonica.net

[MovistarIn](Movistar)
context=incoming
defaultuser=_9xxxxxxxxx_
host=10.31.255.134
port=5060
trustrpid=yes

#extensions.conf
Código: [Seleccionar]
[globals]
trunk  = SIP/MovistarOut
ext501 = SIP/_device1_
ext502 = SIP/_device2_

[dispositivos]
include = noplus
include = internos
include = moviles
include = gratuitos
include = nacionales
include = emergencias

[noplus]
exten => _+34.,1,Goto(dispositivos,${EXTEN:3},1)

[internos]
exten => 501,1,Dial(${ext501})
exten => 502,1,Dial(${ext502})

[moviles]
exten => _[67]XXXXXXXX,1,Dial(${trunk}/${EXTEN})

[gratuitos]
exten => _[89]00XXXXXX,1,Dial(${trunk}/${EXTEN})

[nacionales]
exten => _[89]ZXXXXXXX,1,Dial(${trunk}/${EXTEN})
exten => _[89]01XXXXXX,1,Dial(${trunk}/${EXTEN})
exten => _[89]02XXXXXX,1,Dial(${trunk}/${EXTEN})

[emergencias]
exten => 061,1,Dial(${trunk}/${EXTEN})
exten => 091,1,Dial(${trunk}/${EXTEN})
exten => 092,1,Dial(${trunk}/${EXTEN})
exten => 112,1,Dial(${trunk}/${EXTEN})

[incoming]
exten => s,1,Dial(${ext501}&${ext502},15)

Lo mejor es que le eches un vistazo, los adaptes, y si no te funcionan lo comentamos.


tagotis

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1119 en: 26-04-2016, 09:26 (Martes) »
Muy buenas!

En primer lugar, quisiera agradecer a Noltari el estupendo trabajo realizado. Compré un TP-Link TD4300 hace unos meses, después de leer este hilo, y me costó cinco minutos tener la conexión lista. Enhorabuena.

Y en segundo lugar, quisiera aportar mis modestas experiencias al hilo:

* IPv6
 - A pesar de que el script está preparado para usar IPv6, Movistar aún no ha configurado toda su red; depurando la conexión he visto que el servidor de PPPoE explícitamente rechaza usar IPv6.
- Si a alguien le interesa el tema, Hurricane Electric (https://www.tunnelbroker.net/) ofrece túneles IPv6 gratuitos, que con OpenWrt se configuran en minutos.

* VOIP:
 - Conseguí instalar y hacer funcionar Asterisk en el router; ahora lo uso como servidor de VOIP, puedo conectar varios terminales, hacer y recibir llamadas (suenan todos los terminales, puesto que para el servidor de VOIP de Movistar sólo hay un dispositivo conectado), y obviamente también hablar entre terminales.
 - Además, con esta configuración no es necesario permitir tráfico entre la LAN y la red VOIP de Movistar.
 - Para poder usar la VOIP desde fuera tengo un servidor de VPN en el propio router; así puedo conectarme desde el móvil y hacer / recibir llamadas con la línea del fijo, aunque esté fuera de casa.

Si a alguien le interesa algo de lo que comento más arriba y necesita ayuda, que lo comente.

Hola podrías hacer un pequeño tutorial para configurar el asterisk, estoy intentado configurarlo y por mas que leo no consigo enterarme de nada, gracias

Hace mucho tiempo que lo instalé, no me veo capaz de hacer un tutorial después de tanto tiempo; lo que sí te puedo pasar son mis ficheros de configuración, a ver si te ayudan. Éstos son los ficheros que creo que modifiqué, los ficheros que no están aquí es porque no recuerdo haberlos tocado respecto a los que venían de ejemplo con Asterisk; la información privada o confidencial la he enmascarado, añadiendo "_" al principio y al final (es decir, donde pone _9xxxxxxxx_ debes poner tu número de teléfono 912345678).

# sip.conf
Código: [Seleccionar]
[general]
context=unauthenticated         ; default context for incoming calls
allowguest=no                   ; disable unauthenticated calls
srvlookup=yes                   ; enabled DNS SRV record lookup on outbound calls
udpbindaddr=0.0.0.0             ; listen for UDP requests on all interfaces
tcpenable=no                    ; disable TCP support
directmedia=outgoing

register => _9xxxxxxxx_@telefonica.net:_9xxxxxxxx_@10.31.255.134:5070

[dispositivo](!)     ; create a template for our devices
type=friend          ; the channel driver will match on username first, IP second
context=dispositivos ; this is where calls from the device will enter the dialplan
host=dynamic         ; the device will register with asterisk
dtmfmode=auto        ; accept touch-tones from the devices, negotiated automatically
disallow=all         ; reset which voice codecs this device will accept or offer
allow=gsm,ulaw,alaw  ; which audio codecs to accept from, and request to, the device
mailbox=555@default  ; all devices share a common mailbox
sendrpid=yes         ; send Remote-Party-Id to devices
deny=0.0.0.0/0.0.0.0
permit=192.168.0.0/255.255.0.0

[_device1_](dispositivo)
secret=_password1_

[_device2_](dispositivo)
secret=_password2_

[Movistar](!)
type=peer
secret=_9xxxxxxxxx_
insecure=port,invite
dtmfmode=auto
disallow=all
allow=gsm,ulaw,alaw
outboundproxy=10.31.255.134:5070
qualify=no

[MovistarOut](Movistar)
host=telefonica.net
fromuser=_9xxxxxxxxx_
fromdomain=telefonica.net

[MovistarIn](Movistar)
context=incoming
defaultuser=_9xxxxxxxxx_
host=10.31.255.134
port=5060
trustrpid=yes

#extensions.conf
Código: [Seleccionar]
[globals]
trunk  = SIP/MovistarOut
ext501 = SIP/_device1_
ext502 = SIP/_device2_

[dispositivos]
include = noplus
include = internos
include = moviles
include = gratuitos
include = nacionales
include = emergencias

[noplus]
exten => _+34.,1,Goto(dispositivos,${EXTEN:3},1)

[internos]
exten => 501,1,Dial(${ext501})
exten => 502,1,Dial(${ext502})

[moviles]
exten => _[67]XXXXXXXX,1,Dial(${trunk}/${EXTEN})

[gratuitos]
exten => _[89]00XXXXXX,1,Dial(${trunk}/${EXTEN})

[nacionales]
exten => _[89]ZXXXXXXX,1,Dial(${trunk}/${EXTEN})
exten => _[89]01XXXXXX,1,Dial(${trunk}/${EXTEN})
exten => _[89]02XXXXXX,1,Dial(${trunk}/${EXTEN})

[emergencias]
exten => 061,1,Dial(${trunk}/${EXTEN})
exten => 091,1,Dial(${trunk}/${EXTEN})
exten => 092,1,Dial(${trunk}/${EXTEN})
exten => 112,1,Dial(${trunk}/${EXTEN})

[incoming]
exten => s,1,Dial(${ext501}&${ext502},15)

Lo mejor es que le eches un vistazo, los adaptes, y si no te funcionan lo comentamos.

Gracias por los archivos, el problema que tengo es cuando intento conectar desde el movil usando  CSipSimple, creo la cuenta con los datos puestos en asterisk pero siempre me dice "Error al registrar - Request Timeout."

mirando en el la consola de asterisk sale " NOTICE[21720]: chan_sip.c:28332 handle_resquest_register: Registration from '<sip:951xxxxxx@192.168.1.100>' failed for '192.168.1.34:59350' - Wrong password" (951xxxxx es mi numero de telefono y 192.168.1.34 es la ip del movil)