Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 595130 veces)

0 Usuarios y 3 Visitantes están viendo este tema.

sanuro10

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #40 en: 12-10-2013, 16:01 (Sábado) »
Ya que estamos..
Otro asunto es que con los medidores de velocidad habituales..los 100Mb..se quedan en una birria de menos de 20 o 10 Mb. No le he prestado a eso de momento mucha atención porque la percepción al navegar y demás es que va casi como antes con el Comtrend.
Sí he leído algún forero aquejado del mismo problema.
Alguna recomendación al respecto?
Gracias y saludos



Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #41 en: 12-10-2013, 16:37 (Sábado) »
Muchas gracias por tu rápida respuesta, Noltari.
Podrian ir los tiros por crear una vlan solo para la wifi? no se...
Bueno, te espero pues como agua de mayo...o del mes que sea
Muchas gracias de nuevo.
Saludos
Una primera posible solución en la que no confío demasiado consiste en cambiar la configuración de igmpproxy para redirigir las transmisiones multicast directamente al eth0.1, en lugar de al bridge LAN.

Para ello, hay que cambiar la configuración de igmpproxy por la siguiente:
Código: [Seleccionar]
config igmpproxy
option quickleave 1
 
config phyint
option network iptv
option direction upstream
list altnet 192.168.1.0/24
list altnet 172.0.0.0/8
 
config phyint
option network eth0.1
option direction downstream

Después, reinicia el router y haz la prueba.

Ya que estamos..
Otro asunto es que con los medidores de velocidad habituales..los 100Mb..se quedan en una birria de menos de 20 o 10 Mb. No le he prestado a eso de momento mucha atención porque la percepción al navegar y demás es que va casi como antes con el Comtrend.
Sí he leído algún forero aquejado del mismo problema.
Alguna recomendación al respecto?
Gracias y saludos
No he conseguido reproducir este problema de velocidad que bastantes usuarios habéis reportado, pero en tu caso puede ser debido a una saturación en la red, basándonos en el mismo problema del WiFi.

Saludos.

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #42 en: 12-10-2013, 16:46 (Sábado) »
Buenas de nuevo,

Prueba primero la solución anterior y si no funciona prueba la descrita en este post.

Esta solución consiste en crear una nueva área local dedicada únicamente al decodificador. Para ello, creamos una nueva área local que tenga como interfaz física una nueva VLAN en la que aislamos el puerto LAN del router en el que está conectado el decodificador.
De esta forma, redigirimos únicamente las transmisiones multicast a dicha área local aislada, evitando así retransmitirlo al resto de dispositivos de la LAN.
No obstante, si udpxy se encuentra funcionando, podremos acceder a las transmisiones multicast por http sin ningún problema tal y como aparece detallado en el manual.

Primero hay que añadir una nueva interfaz llamada tvlan, que va a ser la red de área local utilizada únicamente por el decodificador:
Esta interfaz sustituye al alias de la LAN que aparece en el tutorial (hay que borrar el alias o modificarlo con la siguiente configuración).
vi /etc/config/network
Código: [Seleccionar]
config interface 'tvlan'
option ifname 'eth0.4'
option proto 'static'
option ipaddr '10.X.Y.Z'
option netmask '255.255.255.248'
Y añadimos una nueva VLAN en el switch aislando un puerto:
Código: [Seleccionar]
config switch_vlan
option device 'switch0'
option vlan '5'
option ports '0t 2'
option vid '4'

Con el fin de no perder demasiado tiempo configurando el firewall para esta nueva red, añadimos la interfaz tvlan a la misma zona del firewall de la LAN.
vi /etc/config/firewall
Código: [Seleccionar]
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan tvlan'

Por último hay que editar la configuración de igmpproxy para que redirija los multicast a la red tvlan.
vi /etc/config/igmpproxy
Código: [Seleccionar]
config igmpproxy
option quickleave 1
 
config phyint
option network iptv
option direction upstream
list altnet 192.168.1.0/24
list altnet 172.0.0.0/8
 
config phyint
option network tvlan
option direction downstream

Esta solución es un poco más radical, pero es lo más estable en cuanto a limitar las transmisiones multicasting al único dispositivo para el cual son estrictamente necesarias.

Saludos!
« Última modificación: 12-10-2013, 16:46 (Sábado) por Noltari »

sanuro10

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #43 en: 12-10-2013, 19:14 (Sábado) »
Muchas gracias, Pteridium y Noltari por vuestras rápidas respuestas.
Noltari, pruebo y jugueteo con tus indicaciones y te cuento.
Saludos

sanuro10

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #44 en: 13-10-2013, 12:28 (Domingo) »
Hola, Noltari
Probadas las modificaciones que referias y nasti de plasti...
Algo se me sigue escapando
Esperamos a tu deco??  ;)
Gracias y saludos

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #45 en: 13-10-2013, 12:39 (Domingo) »
Hola, Noltari
Probadas las modificaciones que referias y nasti de plasti...
Algo se me sigue escapando
Esperamos a tu deco??  ;)
Gracias y saludos
Buenas,

Pues sabiendo que llega mañana casi mejor esperamos, porque tengo alguna idea, pero es ir a ciegas ;D.

Saludos!

sanuro10

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #46 en: 13-10-2013, 12:46 (Domingo) »
OK, Noltari....
Porque trompazos me he pegao algunos y se resite el jodio..lo que es la ignorancia... :-\
No se que deco te llegara, el mio es un adb-TLF5810Twx, pero entiendo no ha de haber diferencias en la configuración de red, etc.
Espero tu alumbramiento  ;D
Gracias y saludos


Pd
Que si no te llega...me lo dices y ya buscamos un apaño..
igual te mando el mio mientras...
 ;D ;D ;D

sanuro10

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #47 en: 26-10-2013, 14:01 (Sábado) »
Hola, Noltari
Finalmente y tras bastantes cabezazos buscando el problema, reinstale "TODO" el router entero...firmware, paquetes, etc.
No ha hecho falta la solución que me apuntabas con nueva Interface, nueva VLAN aislando puerto, etc.
Adaptando la configuración de tu tutorial al TP1043ND, lleva funcionando establemente ya unos días, tanto Internet, como Imagenio ( incluso en los pc´s), la wifi..
De todas formas, le guardo la configuración a menudo por si los duendes se llevan algún 0 o algún 1...

Muchas gracias por tus indicaciones una vez más. >:( >:(

Con lo que empiezo a maniobrar ahora es con la VoIP..y he instalado softphone en pc (phonerlite) y en android. EL caso es que no va fina la cosa...tengo que seguir dando cabezazos.. ??? ??? ???.y eso que ya tengo el melón mas deformado que el hombre elefante...
La idea final sera una vez resuelto el tema voip poder configurar una vpn para acceder a My Home..desde el mundo exterior, incluso para poder hacer llamadas de voz.
En este sentido puedes hacer algún comentario o recomendación para seguir?

Gracias y saludos

mgnx

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #48 en: 27-10-2013, 19:04 (Domingo) »
Buenas.

Ante todo muchas gracias a Noltari y a otros por los consejos vertidos en posts anteriores, que me han permitido tener mi WR1043ND funcionando, al menos los datos. No he probado la VoIP, pero asumo que si a otros os va, también me irá cuando lo necesite.

En cambio, no me funciona Imagenio. Con toda seguridad porque ahora Movistar está desplegando los Comtrend con otra configuración... Ver http://www.adslzone.net/postx350338-0-0.html

¿Alguien sabe cómo hacer funcionar un router openwrt con dos zonas DHCP, una para los ordenadores habituales con sus DNS típicos y otra para el deco con otros DNSs?

Saludos

Jorge

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #49 en: 29-10-2013, 20:59 (Martes) »
En este tutorial se explica cómo configurar OpenWrt para Movistar FTTH.

Hay varios tutoriales sobre el tema, pero ninguno explica cómo hacer para que funcione la conexión VOIP que proporciona Movistar con la fibra óptica, ni ninguno que explique cómo hacer para que funcione Imagenio.
Si me llevó tiempo dar con la configuración para tener VOIP con OpenWrt, no os imagináis lo que me ha costado averiguar la configuración adecuada para Imagenio xD (básicamente porque personalmente no lo tengo contratado).

Tutoriales para configuración por LuCI
Movistar FTTH

Tutoriales para configuración por Shell
Movistar FTTH
Movistar FTTH + VOIP
Movistar FTTH + VOIP + Imagenio (IPTV)

Espero que el tutorial os sirva de ayuda, porque hay mucha gente interesada en conseguir VOIP con Openwrt en la fibra óptica de Movistar, y también en conseguir Imagenio.

Agradecimientos al usuario bonedark por prestarse a hacer las pruebas necesarias para averiguar la configuración necesaria para Imagenio.

Saludos!

Estimado Noltari
Hace tiempo compre dos tp-link, el 3600 y el 4300
Y me funcionan de maravilla con fibra de movistar

El problema vino hace una semana... mi mujer ha contratado imagenio y no hay manera de hacer que se vea desde hace una semana....he utilizado Putty pero.... ni siguiendo el tuttorial...no hay manera...

Solución posible: he recordado y leído que tenias el mismo router que yo y me preguntaba si podrías enviarme una compilacion un una copia de tu firm para flashearla..cambio las ipadtv...y ha funcionar...

He llamado a Movistar y estos son los datos que me han dado, pero no me cuadran por ningún lado con el tutorial...

Gateway: 10.240.148.nn
Decodificador: 10.240.148.xx

Netmask 255.255.255.248
DNS 172.26.24.3

ip dpch 239.0.2.30:22222

Muchas gracias por tu atención

Copio y pego en el Foro para que quede registrado

Jorge

psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #50 en: 02-11-2013, 22:38 (Sábado) »
Buenas noches, perdonar un poco mi ignorancia, cuando decis que los cambios son por LuCI os referis desde la propia interfaz de OpenWrt, y por Shell a que os referis? a conectar mediante adaptador RS-232 directamente a la placa base del router y enviarle comandos usando por ejemplo Putty? Si, es así, teneis a mano alguna imagen para ver donde se conecta este adaptador a un router TP-Link TL-WDR4300. Sabeís si el firmware que habeis puesto más arriba para actualizar desde la imagen de fábrica a OpenWrt tiene alguna limitación? por ejemplo, que no sea compatible con alguna determinada version de los 4300?

Muchas gracias, y perdonar por mis dudas de novato.

Saludos a todos!!
« Última modificación: 02-11-2013, 22:39 (Sábado) por psdos »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4579
Re: Re: Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #51 en: 02-11-2013, 22:54 (Sábado) »
Buenas noches, perdonar un poco mi ignorancia, cuando decis que los cambios son por LuCI os referis desde la propia interfaz de OpenWrt, y por Shell a que os referis? a conectar mediante adaptador RS-232 directamente a la placa base del router y enviarle comandos usando por ejemplo Putty? Si, es así, teneis a mano alguna imagen para ver donde se conecta este adaptador a un router TP-Link TL-WDR4300. Sabeís si el firmware que habeis puesto más arriba para actualizar desde la imagen de fábrica a OpenWrt tiene alguna limitación? por ejemplo, que no sea compatible con alguna determinada version de los 4300?

Muchas gracias, y perdonar por mis dudas de novato.

Saludos a todos!!

LuCi: interfaz web de OpenWrt.
Shell: conexión usando el protocolo SSH (mediante putty por ejemplo).

Olvídate del RS-232 ;D

Enviado desde mi CUBE U30GT usando Tapatalk
Valoraciones positivas en compra/venta:
114 en Htcmania
104 en Har2mano
16 en elchapuzasinformatico
7 en gsmspain
4 en foro2mano
 .... :)
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #52 en: 02-11-2013, 23:25 (Sábado) »
Muchas gracias jar229, voy a intentar si puedo configurar mi nuevo TP-Link 4300 para Movistar Fibra e Imagenio con el tutorial del compañero.

Unas dudas más. Según el manual de este hilo hay que cambiar unos valores por los propios de nuestro deco de Imagenio

config interface 'iptv'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '172.26.X.Y'
option netmask '255.255.240.0'
option gateway '172.26.X.Z'
config 'alias'
option 'interface' 'lan'
option 'proto' 'static'
option ipaddr '10.X.Y.Z'
option netmask '255.255.255.248'
Atención: hay que cambiar las direcciones IP de IPTV y del alias del Bridge LAN por las únicas de cada cliente (marcadas en verde).

Yo lo he visto apagando totalmente el deco y pulsando la tecla menú miestras arrancaba, y me dice lo siguiente, es por que me digais a que corresponde con cada opcion, y si lo de X, Y y Z se corresponden...

Dirección IP: 10.180.xxx.xxx
Máscara de Subred: 255.255.255.248
Pasarela: 10.180.xxx.xxx
Direccion IP del OPCH: 239.0.xxx.xxx:22222
DNS Primario: 172.26.xxx.xxx

Por cierto, mi version de 4300 es la 1.6 y no me acepta el firmware que puso aqui Noltari, alguna idea please??

Me autorespondo, en lo que atañe al firmware OpenWrt para el TL-WDR4300 v1.6, y os dejo aquí el firmware por si a alguien le hace falta

https://dl.dropboxusercontent.com/u/13133686/openwrt-ar71xx-generic-tl-wdr4300-v1-squashfs-factory.bin

Ya he hecho funcionar Internet con el, pero me falta VOIP y sobre todo Imagenio.

Por favor echadme un cable...
« Última modificación: 03-11-2013, 20:54 (Domingo) por psdos »

Hemin

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #53 en: 06-11-2013, 21:07 (Miércoles) »
Hola a todos,

primero de todo agradeceros el tutorial, y por ahora todo OK, hasta antes de ayer que me trajeron el receptor de imagenio, que aquí es donde creo que mi caso difiere bastante del manual que nos puesto nuestro compañero Noltari, y os cuento porque.

Para empezar, el decodificador coge IPs dentro del rango de la LAN, debido a que el mismo router tiene habilitadas las opciones 60 y 240, con las cuales cuando detecta el decodificador "vendor" le asigna un rango superior de IPs diferente del de los pcs, 192.168.200-.220, ademas les pone el DNS 172.26.x.x. Con la opción 240 asigna el multicast (239.x.x.x) al deco.

Luego el eth0.2 tiene una ip del rango 10.246.x.x/9, y por ningún lado aparece la IP del rango 172.26.x.x, a parte de eso tiene habilitado el NAT

Teniendo en cuenta esto, entiendo que en las reglas del firewall tengo que activar "masquerading" para el NAT.
No tengo que crear ningún alias, ya que no tengo ninguna ip secundaria...

Ni red lan tiene el rango 172.16.0.0/24 entiendo que esto no tiene por que afectar, no?

Las rutas de Rip en el eth0.2 me detectan redes 172.26.x.x

psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #54 en: 06-11-2013, 22:54 (Miércoles) »
Hemin, y tú que router tienes? a ver si me puedes echar una mano y hacemos funcionar almenos Imagenio. Yo tengo un TP-Link TL-WDR4300 v1.6.

De firmware le puse el que comenté más arriba.

https://dl.dropbox.com/u/4708147/openwrt/tpl_wdr4300/openwrt-ar71xx-generic-tl-wdr4300-v1-squashfs-sysupgrade_r34892.bin

Saludos!!!
« Última modificación: 06-11-2013, 22:55 (Miércoles) por psdos »

Hemin

  • Visitante
Re: Re: Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #55 en: 06-11-2013, 23:28 (Miércoles) »
Hemin, y tú que router tienes? a ver si me puedes echar una mano y hacemos funcionar almenos Imagenio. Yo tengo un TP-Link TL-WDR4300 v1.6.

De firmware le puse el que comenté más arriba.

https://dl.dropbox.com/u/4708147/openwrt/tpl_wdr4300/openwrt-ar71xx-generic-tl-wdr4300-v1-squashfs-sysupgrade_r34892.bin

Saludos!!!

Tengo el mismo que tu pero versión 1.3 y el firmware el del 3 de noviembre de la página oficial.

A mi la puerta de enlace de la eth0.2 la saca del protocolo rip una 10. algo. Parece como si la infraestructura fuera diferente y ahora la ip 10 de movistar haga de puerta de enlace  con la 172.26

Sent from my GT-I9300 using Tapatalk

Goyete

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #56 en: 06-11-2013, 23:58 (Miércoles) »
Pues desde aquí mis más sinceros agradecimientos a Noltari por los tutoriales, están muy currados y seguro que con bastante esfuerzo y tiempo detrás. Yo ya he quitado el Comtrend y he colocado un TP-Link N900 (WRD4900) directamente a la ONT. Funcionando sin problemas la parte de Internet. Ahora vamos con las dudas:

- Me instalaron el Movistar TV Mini que incluyen ahora. ¿De donde saco esas IP fijas de cada usuario que aparecen en verde en el manual como X.Y.Z? La TV Mini también las tiene?
- Para instalar Luci tras flashear el router entré por Telnet y ahora no me deja. Me sale un texto que dice SSH-2.0 dropbear y un monton de caracteres. ¿Alguna idea por favor?

Saludos!

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4579
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #57 en: 07-11-2013, 08:12 (Jueves) »

- Para instalar Luci tras flashear el router entré por Telnet y ahora no me deja. Me sale un texto que dice SSH-2.0 dropbear y un monton de caracteres. ¿Alguna idea por favor?

Saludos!

Usa putty y configura una conexión SSH (olvídate de telnet).
Valoraciones positivas en compra/venta:
114 en Htcmania
104 en Har2mano
16 en elchapuzasinformatico
7 en gsmspain
4 en foro2mano
 .... :)
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #58 en: 07-11-2013, 12:53 (Jueves) »
Buenos días,

En primer lugar siento no haber podido contestar antes, pero el Máster me está quitando más tiempo del que me gustaría, junto con ciertos problemas con Apple que me han hecho quedarme sin portátil desde hace casi un mes (http://www.mbp2011.com/), y para colmo me han robado el iPad Mini (mala racha, supongo xD). Menos mal que tengo un sobremesa nuevo :/...

Voy a dar una serie de consejos generales sobre cómo obtener las IPs necesarias y cuál se utiliza para cada cosa y alguna otra explicación general. Si alguien tiene dudas después, que vuelva a postear e intentaré solucionarlas cuanto antes.

Para obtener las direcciones IPs necesarias para Imagenio lo mejor es hacer un backup de la configuración del router de Movistar.

Una vez que tenemos dicho backup (backupsettings.conf), lo abrimos con un editor de texto y buscamos lo siguiente:
Código: [Seleccionar]
br0:0De esta forma, encontraremos la sección relacionada con el alias de la LAN:
Código: [Seleccionar]
<IPInterface instance="2">
<Enable>TRUE</Enable>
<IPInterfaceIPAddress>10.217.47.233</IPInterfaceIPAddress>
<IPInterfaceSubnetMask>255.255.255.248</IPInterfaceSubnetMask>
<X_BROADCOM_COM_IfName>br0:0</X_BROADCOM_COM_IfName>
</IPInterface>
Esa es la IP y máscara de subred del alias de la LAN.
Código: [Seleccionar]

config 'alias'
option 'interface' 'lan'
option 'proto' 'static'
option ipaddr '10.217.47.233'
option netmask '255.255.255.248'

Por otro lado, si queremos saber la dirección IP de la interfaz IPTV buscamos lo siguiente:
Código: [Seleccionar]
eth0.2Y nos encontramos con la sección:
Código: [Seleccionar]
<WANIPConnection instance="2">
<Enable>TRUE</Enable>
<ConnectionType>IP_Routed</ConnectionType>
<Name>2</Name>
<AddressingType>Static</AddressingType>
<ExternalIPAddress>172.26.208.63</ExternalIPAddress>
<SubnetMask>255.255.240.0</SubnetMask>
<DefaultGateway>172.26.208.1</DefaultGateway>
<X_BROADCOM_COM_IGMPEnabled>TRUE</X_BROADCOM_COM_IGMPEnabled>
<X_TELEFONICA-ES_IGMPEnabled>TRUE</X_TELEFONICA-ES_IGMPEnabled>
<RouteProtocolRx>RIPv2</RouteProtocolRx>
<X_BROADCOM_COM_IfName>eth0.2</X_BROADCOM_COM_IfName>
<X_BROADCOM_COM_VlanMux8021p>4</X_BROADCOM_COM_VlanMux8021p>
<X_BROADCOM_COM_VlanMuxID>2</X_BROADCOM_COM_VlanMuxID>
<PortMappingNumberOfEntries>0</PortMappingNumberOfEntries>
</WANIPConnection>
Esa es la IP, máscara de subred y gateway de la IPTV:
Código: [Seleccionar]
config interface 'iptv'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '172.26.208.63'
option netmask '255.255.240.0'
option gateway '172.26.208.1'

En cuanto a la VOIP no debería haber ninguna duda, dado que la configuración se realiza por DHCP, y si está bird4 bien configurado como aparece en el tutorial y la interfaz VOIP también, debería funcionar sí o sí xD.

Saludos!

psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #59 en: 07-11-2013, 16:26 (Jueves) »
Noltari te lo curras que da gusto tio. Muchas gracias, si a ti te quita tiempo el Master, a mí, entre el trabajo, programar y un muchachito de 6 meses, no tengo tiempo de nada. Te agradezco enormemente tú esfuerzo para que los más nuevos entendamos todo este entramado, da gusto ver gente que ayuda tan desinteresadamente.

Un 10 para tí compi. En cuanto tenga una ratillo empiezo a hacer pruebas.

Una vez más muchas gracias compañero. >:(

PD: Yo tengo una MacBook Pro 15" Retina display que compré el año pasado y un MAC Pro con 4 años ya y de momento tocaré madera pero ni un fallo en ninguno de los dos. Has probado ya Mavericks?
« Última modificación: 07-11-2013, 16:53 (Jueves) por psdos »