Autor Tema: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)  (Leído 38493 veces)

0 Usuarios y 1 Visitante están viendo este tema.

emeryth

  • Visitante
[Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« en: 02-09-2014, 20:48 (Martes) »
[Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)


  • Introducción
  • Idea básica sobre un sistema de múltiples wan
  • Preparación del material que brinda las WAN
  • Requisitos para mwan3
  • Configuración del switch del router
  • Configuración de las interfaces
  • Configuración del firewall
  • Comprobar que todo está bien
  • Instalar el MWAN3
  • Configurar el MWAN3
  •      INTERFACES
  •      MIEMBROS
  •      POLÍTICAS
  •      REGLAS
  • Pruebas de funcionamiento
  • Configuración de led´s del router hg556a



Introducción

El primero punto a aclarar, el proyecto MWAN3 no es el mismo proyecto multiwan (paquete) ni está basado en él, pero logra los mismos resultados y algunos más, se tiene más control sobre el proceso pero es más complejo de manejar.

El proyecto multiwan al parecer está en sus últimos estertores, pues su creador no responde a las consultas por el foro ni actualiza el paquete desde hace 2 años, por lo que se explica los problemas que causa el programa cuando se ejecuta en compilaciones actuales de openwrt. En compilaciones antiguas aún funcionan bien, pero con los peligros de no tener actualizaciones que corrijan los problemas de seguridad, y en especial el bug Heartbleed.

Buscando alternativas encontré el proyecto MWAN3 con su wiki (http://wiki.openwrt.org/doc/howto/mwan3) y su foro de desarrollo (https://forum.openwrt.org/viewtopic.php?id=39052). El paquete debe ser instalado durante la configuración del router, por lo tanto no debe estar compilado en la imagen openwrt.


Idea básica sobre un sistema de múltiples wan

En definición, un multiwan es útil cuando tenemos 2 o más entradas wan (internet o enrutado a otras redes) y queremos que una única red utilice las 2 o más salidas wan de una manera determinada.  Podemos configurarlo para que al caer una de las wan la otra empiece a trabajar. O podemos configurarlo para que se repartan el trabajo entre ellas.

OJO esto no aumentará el ancho de banda. Si tenemos una entrada de Internet de 10 Mbps y otra de 6 Mbps NO tendremos un ancho de banda de 16 Mbps. Me explico, sí quieres bajar un archivo ISO de una distribución Linux por descarga directa (única fuente) solo podrás bajarlo por una sola wan, ya sea por la de 10 o por la de 6, depende de como lo tengas configurado. Pero si quieres bajar el mismo archivo por un enlace torrents (muchas fuentes) podrás utilizar las 2 wan al tiempo porque se reparten las fuentes, dando como resultado una descarga que se acerca mucho a los 16 Mbps (esto tiene muchas variables).


Preparación del material que brinda las WAN

Una wan puede ser cualquier interfaz del router, como alguno de los puertos Lan, las entradas PPPoE, dispositivos 3G (por usb) o el mismo wifi trabajando como cliente.

 

Los nombres que tienen las interfaces pueden ser cualquiera mientras que no sean muy grandes, ni tengan espacios o caracteres especiales, deberían ser descriptivos de su uso.
Cualquier interfaz puede ser wan o lan, todo depende de en que zona del fireware sea argumentado.

Requisitos para mwan3

El hardware debe tener apoyo VLAN (que soporte conmutación de puertos) y por lo menos 3 interfaces activas (2 para wan y un lan).

Se necesita OpenWrt 12.09 o posterior, y los siguientes paquetes instalados, que si no están en la compilación se instalaran automáticamente como dependencias.

  • ip
  • iptables
  • iptables-mod-conntrack
  • iptables-mod-conntrack-extra
  • iptables-mod-ipopt

Configuración del switch del router

Desde luci podemos dividir cada entrada lanX (puerto) del router individualmente, para manejarla como una lan virtual.
 
En nuestro ejemplo tendremos un puerto lan (conector Lan1 o puerto 0), tres puertos wan (los otros 3 conectores del router, lan2, lan3 y lan4). Antes de guardar la configuración en el router, no te equivoques, tu pc debe estar conectado al puerto 0 del router, porque los demás puertos serán wan y no te darán acceso al router.


Date cuenta, el cuadro de cpu debe estar en “marcado” para todas las VLAN, y solo un puerto debe estar seleccionado para cada interfaz vlan. El penúltimo puerto, mejor déjalo “parado” en todos los vlan (éste puede variar según el router, porque es un puerto interno del router).

Ejemplo parte del archivo /etc/config/network
Código: [Seleccionar]
config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0 5t'

config switch_vlan
option device 'eth0'
option vlan '2'
option ports '1 5t'

config switch_vlan
option device 'eth0'
option vlan '3'
option ports '2 5t'

config switch_vlan
option device 'eth0'
option vlan '4'
option ports '3 5t'
 

Configuración de las interfaces

Red>Interface>añadir nueva interfaz…

Debes colocar un nombre que describa la wan y ponerlo como cliente DHCP, esto es solo  al principio, después si quieres puedes cambiarlo a ip fija, identificación por mac, o dejarlo así. Por último, elegir la interfaz física que le toque. En este caso una interfaz vlan, pero podría ser una wifi, el 3G o pppoe (este router no lo soporta).


En configuración avanzada, debe estar seleccionado la opción “usar pasarela por defecto” y coloque una métrica diferente en cada interfaz WAN, puede ir ascendiendo de 10 en 10. Wan = métrica 10, wan2 = métrica 20, wan3 = métrica 30….


En la pestaña “configuración de cortafuegos” deja todas las interfaces wan en una misma zona del firewall, en este caso la zona wan.

Ejemplo de una parte del archivo /etc/config/network
Código: [Seleccionar]
config interface 'lan'
option ifname 'eth0.1'
option force_link '1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.30.1'

config interface 'wan'
option proto 'dhcp'
option ifname 'eth0.2'
option metric '10'

config interface 'wan2'
option proto 'dhcp'
option ifname 'eth0.3'
option metric '20'

config interface 'wan3'
option proto 'dhcp'
option ifname 'eth0.4'
option metric '30'

 

Observa que la interfaz lan no tienga asociado ningún servidor DNS, ni puerta de entrada. Además, debes quitar estas líneas de la configuración lan que se crean algunas veces y pueden dar problemas con el mwan3:

Código: [Seleccionar]
   option _orig_ifname 'eth0.x'
    option _orig_bridge 'false'

Por otro lado, es conveniente utilizar diferentes subredes en cada interfaz wan y lan.
Aunque en mis pruebas a funcionado con subredes repetidas en las wan, es mejor no arriesgarse a colisiones innecesarias.

Configuración del firewall

Los apartados a configurar en este archivo son muy pocos, se basan en agrupar las interfaces en dos grupos o zonas. Una zona lan donde se refiere a la interfaz lan, y una zona wan donde se gestionan las interfaces wwan, wan, wan2, wan3, que hemos creado en el archivo network. Es posible colocar cada interfaz wan en una zona diferente, pero solo conseguiremos un aumento de gasto en la CPU.


Un detalle importante que debemos colocar en el archivo firewall es: tener en cada zona del firewall la opción “opción conntrack '1'” para activar el nat entre las zonas. Esta opción no tiene un modo grafico en luci para seleccionarla (por lo menos yo no la he encontrado).  Por lo tanto, no queda otra que utilizar los comandos uci o editar el archivo de firewall directamente:

Modo uci:
Código: [Seleccionar]
uci set firewall.@zone[0].conntrack=1
uci set firewall.@zone[1].conntrack=1
uci commit

Configuración de archivo /etc/config/firewall
Código: [Seleccionar]
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'
option conntrack '1'

config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
option network 'wan wan6 wan2 wan3'
option conntrack '1'

config forwarding
option src 'lan'
option dest 'wan'
 

Comprobar que todo está bien

Cuando tienes listas todas las interfaces, ya sean wan por Switch, la o las wifi, el 3G o PPPoE (no soportado por este router), conectamos las interfaces a Internet e intentamos conseguir ping de google, para comprobar el funcionamiento de cada interfaz. Si existe algún problema antes de instalar mwan3, este no lo arreglará y posiblemente tendrás que empezar de nuevo.

Ejemplo de comandos para realizar la prueba de ping a google, no debería perderse ningún paquete.

Código: [Seleccionar]
ping -c 1 -I eth0.2 www.google.com
ping -c 1 -I eth0.3 www.google.com
ping -c 1 -I eth0.4 www.google.com
ping -c 1 -I wwan www.google.com

Resultado esperado para cada interfaz:
Código: [Seleccionar]
root@OpenWrt:/etc/config# ping -c 1 -I eth0.2 www.google.com
PING www.google.com (173.194.41.242): 56 data bytes
64 bytes from 173.194.41.242: seq=0 ttl=54 time=57.888 ms

--- www.google.com ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 57.888/57.888/57.888 ms

Instalar el MWAN3

Antes de instalar el paquete, deben  asegurarse de que todas sus interfaces WAN están configuradas y funcionan correctamente, según lo explicado anteriormente. Y reinicia el router antes de la instalación.

Dejo aquí mis compilaciones, no tienen instaladas el paquete MWAN3, pero las he compilado con él, y está listo para instalarlas. Son para la versión A y B del hg556a, debes instalarlo con Internet, porque tiene dependencias. Instala primero el paquete mwan3 y luego el de luci.

compilación Chaos Calmer r42261 versión A
compilación Chaos Calmer r42261 versión B

Si utilizas otro tipo de router también puedes instalarlo desde la instalación de programas de luci. Cuando te dispongas a instalarlo solo deja una interfaz con Internet porque sino te dará errores de instalación.

También puedes descargar primero el paquete y después instalarlo con la ayuda de los siguientes comandos:

Código: [Seleccionar]
cd /tmp
wget http://213.136.13.52/mwan3_1.5-4_all.ipk
wget http://213.136.13.52/luci-app-mwan3_1.3-1_all.ipk
opkg update
opkg install mwan3_*.ipk
opkg install luci-app-mwan3_*.ipk

NOTA: Es muy importante reiniciar el router después de la instalación de MWAN3.

Configurar el MWAN3

Mwan3 no es un demonio que se ejecuta en segundo plano, por tanto cualquier alteración que hagamos en la configuración no tendrá efecto, hasta que ocurra un reinicio del router o una desconexión y/o conexión en caliente de una interfaz (hotplug).

La configuración de mwan3 se divide en 4 partes, con las que se puede entrelazar opciones más complejas que con el proyecto multiwan.

INTERFACES: En esta parte del archivo de configuración MWAN3 declaramos las wan que existen y que queremos tener activas, para el sistema de múltiples wan.

Mwan3 realiza ping cíclicos a un servidor (list track ip). En este caso a un servidor dns de google, pero podría ser cualquier dns para saber si tenemos salida a Internet. O podría hacer ping a la puerta de entrada del siguiente router a que esté conectado, si solo queremos saber si se conectó físicamente el cable. No hay cantidad límite de direcciones para hacer ping, todas se realizan al mismo tiempo y pueden estar repetidas en diferentes interfaces wan. Sí no se declara una dirección para hacer ping, la interfaz aparece siempre como conectada.

La opción “count” es el número de ping enviado a cada dirección; “timeout” es el tiempo de espera para recibir la respuesta del servidor, que no debería ser menor a 2 seg; “reliability” es la cantidad mínima de direcciones que deben responder al ping, para que se considere una prueba exitosa; “interval” es el tiempo en segundos que se espera entre las pruebas de ping; “down y up” es la cantidad de pruebas exitosas o fracasadas para considerar la interfaz conectada o desconectada.


Código: [Seleccionar]
# Interfaz
config interface 'wan'
option enabled '1'
list track_ip '8.8.4.4'
list track_ip '8.8.8.8'
option reliability '1'
option count '1'
option timeout '3'
option interval '5'
option down '5'
option up '5'

config interface 'wan2'
option enabled '1'
list track_ip '8.8.4.4'
list track_ip '8.8.8.8'
option reliability '1'
option count '1'
option timeout '3'
option interval '5'
option down '5'
option up '5'

config interface 'wan3'
option enabled '1'
list track_ip '8.8.4.4'
list track_ip '8.8.8.8'
option reliability '1'
option count '1'
option timeout '3'
option interval '5'
option down '5'
option up '5'
 


MIEMBROS: Cada interfaz se divide en varios miembros, cada uno con una prioridad (métrica) y un peso (weight), la prioridad es mayor entre más bajo el número, el peso puede tener cualquier valor. Solo se tiene en cuenta el peso cuando las métricas son iguales.


Código: [Seleccionar]
# Miembros

config member 'wan_m1_w3'
option interface 'wan'
option metric '1'
option weight '3'

config member 'wan_m2_w3'
option interface 'wan'
option metric '2'
option weight '3'

config member 'wan_m3_w3'
option interface 'wan'
option metric '3'
option weight '3'

config member 'wan2_m1_w3'
option interface 'wan2'
option metric '1'
option weight '3'

config member 'wan2_m2_w3'
option interface 'wan2'
option metric '2'
option weight '3'

config member 'wan2_m3_w3'
option interface 'wan2'
option metric '3'
option weight '3'

config member 'wan3_m1_w3'
option interface 'wan3'
option metric '1'
option weight '3'

config member 'wan3_m2_w3'
option interface 'wan3'
option metric '2'
option weight '3'

config member 'wan3_m3_w3'
option interface 'wan3'
option metric '3'
option weight '3'
 


POLÍTICAS: En ellas se agrupan los miembros para establecer el comportamiento de estos en el mwan3. Cuando hay miembros con diferente métrica, solo se tendrá en cuenta al de menor número que esté activo, no se tiene en cuenta el peso del miembro.

Pero si tenemos 3 miembros con la misma métrica, se realizará un balance de la carga entre los miembros. Este balance se realiza dependiendo del peso de cada uno, si todos tienen el mismo número estará equilibrada la carga (33% para cada uno).

Se tiene que sumar todos los pesos de la política, y con éste dividir el peso de cada miembro para saber la proporción que le tocará en el balance de la carga. Por ejemplo, en el caso de tener dos miembros de peso 3 y uno de peso 2, el balance de carga es: 37.5% +37.5%+25%.

En el ejemplo hay una política llamada conmutador, cada uno de sus miembros tiene diferente métrica. Por lo tanto, cuando se use esta política, se utilizará la interfaz wan al 100%.  Pero, sí se desconecta la interfaz wan, esta utilizará a wan2 al 100%, lo mismo para la wan3, cuando vuelva a aparecer la interfaz wan ella tendrá la prioridad. Esta es una configuración en conmutador de error.

En el caso de la política llamada balance, todos los miembros tienen la misma métrica, por lo tanto, se dividen la carga al 33% para cada miembro. Cuando se desconecta un miembro la carga se divide en los miembros que quedan, y cuando este regrese se vuelve a repartir.

Se pueden crear políticas muy complejas a partir de entrelazar miembros, jugando con el balance y la conmutación. Tanto las políticas como los miembros pueden estar en la configuración sin que realicen una tarea concreta en las reglas, las que sobren no es necesario borrarlas.


Código: [Seleccionar]
# Políticas

config policy 'conmutador'
list use_member 'wan_m1_w3'
list use_member 'wan2_m2_w3'
list use_member 'wan3_m3_w3'

config policy 'balance'
list use_member 'wan_m1_w3'
list use_member 'wan2_m1_w3'
list use_member 'wan3_m1_w3'

config policy 'wan_only'
list use_member 'wan_m1_w3'

config policy 'wan2_only'
list use_member 'wan2_m1_w3'

config policy 'wan3_only'
list use_member 'wan3_m1_w3'
 

REGLAS: En ellas se describe cuando se seguirá una política dada. En las reglas, es importante el orden en que se encuentran. Por lo que, deben colocarse las reglas más especificas al comienzo de la lista y las más generales al final. Debería existir por lo menos una regla configurada.

En el ejemplo existe una regla llamada voip que utiliza la política de conmutador para el servicio de llamadas voip, que van hacia la dirección ip 77.72.169.x por cualquier puerto UDP.

Si esto no se cumple para la conexión, la siguiente regla dice que todas las conexiones a cualquier destino utilizarán la política balance, que en este caso balancea la carga entre sus wan.


Código: [Seleccionar]
# Reglas

config rule 'voip'
        option dest_port '1024:65535'
        option proto 'udp'
        option dest_ip '77.72.169.0/24'
        option use_policy 'conmutador'

config rule 'default_rule'
option dest_ip '0.0.0.0/0'
option use_policy 'balance'
 

Pruebas de funcionamiento

La interfaz de luci nos entrega muchísima información sobre el funcionamiento del entorno de múltiples wan. Además, podemos editar el archivo de configuración de MWAN3 y el de red (network). En el apartado avanzado > troubleshooting encontramos los resultados de todas las pruebas necesarias para evaluar la salud de nuestro sistema de múltiples wan.


Configuración de led´s del router hg556a

Dejo la configuración de los led´s que tengo, para que sea más vistoso el flujo en cada interfaz: led rojo trasmisión y led verde recepción.

Código: [Seleccionar]
/etc/config/system

config led 'led_lan'
option name 'LAN'
option sysfs 'HW556:red:dsl'
option trigger 'netdev'
option mode 'link tx rx'
option default '0'
option dev 'eth0'

config led 'led_usb'
option name 'USB'
option sysfs 'HW556:red:hspa'
option trigger 'usbdev'
option dev '1-2'
option interval '50'
option default '0'

config led
option default '0'
option sysfs 'HW556:red:lan4'
option trigger 'netdev'
option dev 'eth0.4'
option name 'wan3-t'
option mode 'tx'

config led
option default '0'
option name 'wan3-r'
option sysfs 'HW556:green:lan4'
option trigger 'netdev'
option dev 'eth0.4'
option mode 'rx'

config led
option default '0'
option name 'wan2-t'
option sysfs 'HW556:red:lan3'
option trigger 'netdev'
option dev 'eth0.3'
option mode 'tx'

config led
option default '0'
option name 'wan2-r'
option sysfs 'HW556:green:lan3'
option trigger 'netdev'
option dev 'eth0.3'
option mode 'rx'

config led
option default '0'
option name 'wan-t'
option sysfs 'HW556:red:lan2'
option trigger 'netdev'
option dev 'eth0.2'
option mode 'tx'

config led
option default '0'
option name 'wan-r'
option sysfs 'HW556:green:lan2'
option trigger 'netdev'
option dev 'eth0.2'
option mode 'rx'

config led
option default '0'
option name 'lan-t'
option sysfs 'HW556:red:lan1'
option trigger 'netdev'
option dev 'eth0.1'
option mode 'tx'

config led
option default '0'
option name 'lan-r'
option sysfs 'HW556:green:lan1'
option trigger 'netdev'
option dev 'eth0.1'
option mode 'rx'




« Última modificación: 05-11-2014, 18:22 (Miércoles) por Noltari »

vk496

  • Visitante
Re: Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #1 en: 02-09-2014, 22:44 (Martes) »
Dejo comentario para tenerlo a mano en el Tapatalk y leermelo con calma... :D

Salu2

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #2 en: 03-09-2014, 09:08 (Miércoles) »
Le pongo 'chincheta' unas semanas y lo añado al [Índice] Hilos relevantes de OpenWrt   >:(
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

emeryth

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #3 en: 03-09-2014, 10:30 (Miércoles) »
Gracias por añadirlo a los hilos relevantes de openwrt y la chincheta.  ;D

saludos

anatulfo

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #4 en: 04-09-2014, 02:19 (Jueves) »
Magnifico trabajo. Gracias por el aporte.

raphik

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #5 en: 09-09-2014, 02:11 (Martes) »
Excelente aporte. Funciona correctamente en el AR-5387un con la Chaos Calmer r42435 (paquetes mwan3 y luci-app-mwan3 incluídos en la compilación).

Lo único que me ha fallado es la configuración de la lan, a la que he tenido que añadir servidores dns:
Código: [Seleccionar]
config interface 'lan'
option ifname 'eth0.1'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option dns '8.8.8.8 8.8.4.4'

Gracias por el tuto.

emeryth

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #6 en: 09-09-2014, 15:06 (Martes) »
Hola raphik,

Bueno, no muestras como están los test de salud de mwan3 (en avanzado > troubleshooting). Pero es posible que en las puertas de entrada de cada wan no tengan configuradas sus dns, me refiero al dispositivo individual que te da Internet por cada wan. Por otro lado, observo que utilizas una subred muy común, seguro qué no se repite en alguna wan?

El dns en la Lan solo debería ser necesario antes de la instalación del paquete mwan3, pero cuando éste ya esté funcionando el dns debería entregarlo la puerta de entrada de cada wan. Todas las wan pueden hacer uso de la misma dns de google, pero lo ideal es utilizar la dns de su respectiva ISP. Bueno, esto es solo si tenemos en cuenta el ejemplo porque si te das cuenta cada una de las wan son cliente DHCP (para que nos entregué la dns), pero también lo podemos colocar como ip fija y anotar el dns para cada wan.

Código: [Seleccionar]
config interface 'wan'
option proto 'dhcp'
option ifname 'eth0.2'
option metric '10'



Saludos,   :D
« Última modificación: 09-09-2014, 15:13 (Martes) por emeryth »

raphik

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #7 en: 10-09-2014, 09:02 (Miércoles) »
... es posible que en las puertas de entrada de cada wan no tengan configuradas sus dns, me refiero al dispositivo individual que te da Internet por cada wan. Por otro lado, observo que utilizas una subred muy común, seguro qué no se repite en alguna wan?

Efectivamente, no había declarado ni la puerta de enlace ni el servidor DNS en las WAN. Es curioso, porque esto no es necesario cuando conectas el PC directamente al router WAN.

Como sólo dispongo de un único ISP, he montado una red algo pintoresca para probar MWAN3. Tres routers HG553 con OpenWRT se conectan como clientes, via wifi, al router ISP. Cada uno de ellos proporciona WAN por cable a un AR-5387un.
En realidad este montaje no tiene ningún sentido, excepto el de posibilitar la realización de pruebas cuando sólo hay un único ISP.



Saludos.

raphik

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #8 en: 10-09-2014, 09:12 (Miércoles) »
Como curiosidad, la cantidad de puertos interno que tiene el AR-5387un.


emeryth

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #9 en: 10-09-2014, 09:55 (Miércoles) »
Hola raphik,

Pues si que es pintoresca tu red, no tenia ni idea que mwan3 soportara ese tipo de configuración tan redundante. Bueno lo ideal es que cada router wan tengo una subred y su servicio dhcp activado, y que además la wifi de dicho wan, que en tu caso esta como cliente, este separado de la subred del router (por las zonas de firewall), por cuestiones de seguridad. Además la subred de tu router mwan3 debería ser diferente a la de cualquier wan. Bueno me alegra que funcione de la manera en que lo probaste y gracias por el feedback.  

Saludos  ;D
« Última modificación: 10-09-2014, 10:03 (Miércoles) por emeryth »

raphik

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #10 en: 10-09-2014, 14:19 (Miércoles) »
Para mí es muy útil poder configurar los routers WAN desde el PC mediante LuCI sin tener que andar recableando. El problemas es que MWAN3 encamina el tráfico aleatoriamente por cualquiera de las WAN. Para evitar que el tráfico tome el camino equivocado, lo primero que he hecho ha sido poner cada router WAN en una subred distinta.

Router WAN1 en la subred 192.168.2.0/30 con la IP 192.168.2.1
Router WAN2 en la subred 192.168.2.4/30 con la IP 192.168.2.5
Router WAN3 en la subred 192.168.2.8/30 con la IP 192.168.2.9

Lo siguiente ha sido establecer reglas para encaminar el tráfico adecuadamente. Lo he probado y funciona.
(EDITO: Estas reglas no son necesarias.)



Saludos.
« Última modificación: 12-09-2014, 10:53 (Viernes) por raphik »

emeryth

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #11 en: 10-09-2014, 22:02 (Miércoles) »
Hola raphik,

Bueno desde mi configuración de ejemplo, sí que tengo acceso con luci a cualquier router de los que están conectados al wan. Puede ser que las reglas del firewall de los router wan puedan estar bloqueándose unos a otros.

Esa es una regla muy elegante para la disposición de tus subredes, pero de esta manera enlazarías cada puerto lan con una determinada subred y no podrías intercambiar los cables entre ellos. Una alternativa es colocar cada interfaz wan como ip fija y no como cliente DHCP.

No tengo en disposición ningún pincho 3g ahora mismo, y me gustaría saber si alguien lo ha probado con éxito. Para mí queda claro la elasticidad que tiene el MWAN3 en comparación con el paquete MULTIWAN.

 Saludos,   ;D

raphik

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #12 en: 11-09-2014, 00:03 (Jueves) »
Sí, una regla muy elegante pero 100% prescindible. Tal como sugieres, he asignado una IP fija a cada puerto WAN del router MWAN3 para que enlacen con cada una de las subredes. He borrado la regla y funciona.
Lo que no creo que vaya a funcionar es el intercambio de cables, porque cada interfaz lógica WANx está ligada a una interfaz física eth0.x.



Saludos.

emeryth

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #13 en: 12-09-2014, 09:43 (Viernes) »
Hola raphik,

No he dicho, que con la IP fija se pudiera intercambiar los puertos, solo que ya que enlazabas interfaces con IP en las reglas de MWAN3, podrías hacerlo con una IP fija desde la interfaces de red. Para no estar pendiente de que cable corresponde a que subred y que subred a que puerto, lo mejor es colocar la interfaz como cliente DHCP. En el ejemplo que doy todo esto funciona bien.

Saludos, 

raphik

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #14 en: 12-09-2014, 10:02 (Viernes) »
Gracias por la aclaración. Lo había entendido mal.

En realidad, tal como he definido las subredes, no hay margen para las IP de las interfaces lógicas WAN. Tanto si les pongo una IP fija como si dejo que se las asigne el DHCP, siempre van a ser las mismas: 192.168.2.2. 192.168.2.6 y 192.168.2.10 para WAN1, WAN2 y WAN3, respectivamente.

He vuelto a ponerles el protocolo DHCP y a quitar las reglas. Los resultados son:
1. Puedo acceder a las interfaces LuCI de los tres routers WAN desde el PC.
2. Los cables WAN se pueden intercambiar. Si se intercambian después de arrancar el router hay que resetear las interfaces WAN para que tomen las nuevas direcciones IP.

Saludos.
« Última modificación: 12-09-2014, 10:49 (Viernes) por raphik »

emeryth

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #15 en: 12-09-2014, 11:49 (Viernes) »
Me alegro que tengas acceso al luci de cada los wan sin ninguna regla.

2. Los cables WAN se pueden intercambiar. Si se intercambian después de arrancar el router hay que resetear las interfaces WAN para que tomen las nuevas direcciones IP.

Saludos.

Bueno no es necesario entrar a luci y resetear la interfaz wan para que tome la nueva ip, si esperas unos segundos el MWAN3 lo resetea automáticamente, según la cantidad de pruebas fracasadas (option down '5') que tengas configuradas. En este caso son unos 40 segundos.

Citar
config interface 'wan2'
   option enabled '1'
   list track_ip '8.8.4.4'
   list track_ip '8.8.8.8'
   option reliability '1'
   option count '1'
   option timeout '3'
   option interval '5'
   option down '5'
   option up '5'

Saludos.
« Última modificación: 13-09-2014, 09:02 (Sábado) por emeryth »

raphik

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #16 en: 20-09-2014, 10:11 (Sábado) »
Nuevo escenario.


Pretendo montar MWAN3 en un HG553 dotado de dos radios: el radio interno del propio router y un segundo radio externo proporcionado por un pincho wifi. Los dos radios se conectarán al único ISP de que dispongo.

El hg553 detecta los dos radios y permite definir sus interfaces:

/etc/config/wireless
Código: [Seleccionar]
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11g'
option path 'pci0000:00/0000:00:01.0/ssb0:0'
option txpower '20'
option country '00'
option disabled '0'
option channel 'auto'

config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11g'
option path 'platform/ohci-platform/usb2/2-1/2-1:1.0'
option htmode 'HT20'
option disabled '0'
option txpower '20'
option country '00'
option channel 'auto'

config wifi-iface
option network 'wwan1'
option ssid 'miSSID'
option encryption 'psk2'
option device 'radio0'
option mode 'sta'
option bssid 'xx:xx:xx:xx:xx:xx'
option key 'miClaveSecreta'

config wifi-iface
option network 'wwan2'
option ssid 'miSSID'
option encryption 'psk2'
option device 'radio1'
option mode 'sta'
option bssid 'xx:xx:xx:xx:xx:xx'
option key 'miClaveSecreta'

/etc/config/network
Código: [Seleccionar]
config interface 'wwan1'
option proto 'dhcp'

config interface 'wwan2'
option proto 'dhcp'

El problema es que no consigo hacerlas funcionar las dos a la vez. Me explico: monto la interfaz sobre uno de los dos radios (da igual por cual empiece). Realizo la prueba de ping a Google y compruebo que funciona.

Código: [Seleccionar]
root@OpenWrt:~# ping -c 1 -I wlan0 www.google.com
PING www.google.com (74.125.230.50): 56 data bytes
64 bytes from 74.125.230.50: seq=0 ttl=54 time=42.425 ms

--- www.google.com ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 42.425/42.425/42.425 ms

Seguidamente monto la interfaz sobre el otro radio y también pasa la prueba del ping a Google, sólo que deja de funcionar el radio que se montó en primer lugar.

Código: [Seleccionar]
root@OpenWrt:~# ping -c 1 -I wlan1 www.google.com
PING www.google.com (74.125.230.49): 56 data bytes
64 bytes from 74.125.230.49: seq=0 ttl=55 time=64.105 ms

--- www.google.com ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 64.105/64.105/64.105 ms


root@OpenWrt:~# ping -c 1 -I wlan0 www.google.com
PING www.google.com (74.125.230.51): 56 data bytes

--- www.google.com ping statistics ---
1 packets transmitted, 0 packets received, 100% packet loss

Si reconecto desde LuCI la interfaz que no funciona, consigo que funcione, pero la otra deja de hacerlo inmediatamente.

Hay algo que se me escapa, pero no sé qué es. ¿Será que OpenWRT no soporta dos radios distintas en modo cliente? ¿Alguna pista?

emeryth

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #17 en: 20-09-2014, 10:48 (Sábado) »
Hola raphik,

Así por encima, solo veo que te falta ponerle la métrica a las interfaces wwan0 y wwan1 en /etc/config/network, haré una prueba y te cuento.

PD: Tienes las dos interfaces del mismo lado del firewall?

Saludos   ;D
« Última modificación: 21-09-2014, 21:54 (Domingo) por emeryth »

raphik

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #18 en: 21-09-2014, 12:51 (Domingo) »
Hola, emeryth.

Efectivamente, las dos interfaces wwan están en la misma zona del cortafuegos. La métrica ya la he corregido, pero el problema no tenía nada que ver con eso, ni siquiera con MWAN3.

Con el HG556a no he podido conectar dos radios al mismo AP. Sin embargo, las pruebas con el HG553 son favorables. Tres radios conectadas al mismo ISP: dos pinchos wifi + el radio interno. La conexión al PC, por cable. Ha pasado la prueba del ping a Google y MWAN3 funciona bien.



Seguiré haciendo pruebas con el HG556a ver.A

Saludos.
« Última modificación: 23-09-2014, 19:53 (Martes) por raphik »

Cristof_Romuard

  • Visitante
Re: [Manual] MWAN3 proyecto alternativo a MULTIWAN (HG556a)
« Respuesta #19 en: 27-09-2014, 21:21 (Sábado) »
Mira que esta todo bien explicado... pues no consigo que esto funcione.

Mira el log a ver si encuentras algún fallo...

Código: [Seleccionar]
Troubleshooting Data
Software versions :

OpenWrt - OpenWrt Barrier Breaker r39304
LuCI - svn-r9948

mwan3 - 1.5-4
luci-app-mwan3 - 1.3-1

Output of "cat /etc/config/mwan3" :

config rule 'default_rule'
option dest_ip '0.0.0.0/0'
option use_policy 'balanced'

config rule 'sticky_odd'
option src_ip '0.0.0.1/0.0.0.1'
option dest_port '443'
option proto 'tcp'
option use_policy 'wan2_wan'

config rule 'sticky_even'
option src_ip '0.0.0.0/0.0.0.1'
option dest_port '443'
option proto 'tcp'
option use_policy 'wan_wan2'

config interface 'wan2'
list track_ip '8.8.8.8'
list track_ip '208.67.220.220'
option reliability '1'
option count '1'
option timeout '2'
option interval '5'
option down '3'
option up '8'
option enabled '1'

config interface 'wan'
option enabled '1'
list track_ip '8.8.4.4'
list track_ip '8.8.8.8'
list track_ip '208.67.222.222'
list track_ip '208.67.220.220'
option reliability '2'
option count '1'
option timeout '2'
option interval '5'
option down '3'
option up '8'

config policy 'balanced'
list use_member 'wan_m1_w3'
list use_member 'wan2_m1_w2'

config policy 'wan_only'
list use_member 'wan_m1_w3'

config policy 'wan2_only'
list use_member 'wan2_m1_w2'

config policy 'wan_wan2'
list use_member 'wan_m1_w3'
list use_member 'wan2_m2_w2'

config policy 'wan2_wan'
list use_member 'wan_m2_w3'
list use_member 'wan2_m1_w2'

config member 'wan_m1_w3'
option interface 'wan'
option metric '1'
option weight '3'

config member 'wan_m2_w3'
option interface 'wan'
option metric '2'
option weight '3'

config member 'wan2_m1_w2'
option interface 'wan2'
option metric '1'
option weight '2'

config member 'wan2_m2_w2'
option interface 'wan2'
option metric '2'
option weight '2'

Output of "cat /etc/config/network" :

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd6d:6c23:40b9::/48'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.2.1'

config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'eth0'
option vlan '1'
option ports '1 2 3 4 5t'

config switch_vlan
option device 'eth0'
option vlan '2'
option ports '0 5t'

config interface 'wan'
option proto 'dhcp'
option metric '20'

config interface 'wan2'
option proto 'dhcp'
option ifname 'eth0.2'
option metric '10'

Output of "ifconfig" :

br-lan    Link encap:Ethernet  HWaddr 64:16:F0:57:27:07 
          inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::6616:f0ff:fe57:2707/64 Scope:Link
          inet6 addr: fd6d:6c23:40b9::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7793 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11093 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1394753 (1.3 MiB)  TX bytes:10935560 (10.4 MiB)

eth0      Link encap:Ethernet  HWaddr 64:16:F0:57:27:07 
          inet6 addr: fe80::6616:f0ff:fe57:2707/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8581 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11547 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1647878 (1.5 MiB)  TX bytes:11049007 (10.5 MiB)
          Interrupt:14

eth0.1    Link encap:Ethernet  HWaddr 64:16:F0:57:27:07 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7793 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11093 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1394753 (1.3 MiB)  TX bytes:10935560 (10.4 MiB)

eth0.2    Link encap:Ethernet  HWaddr 64:16:F0:57:27:07 
          inet addr:192.168.0.209  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::6616:f0ff:fe57:2707/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:750 errors:0 dropped:0 overruns:0 frame:0
          TX packets:447 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:89386 (87.2 KiB)  TX bytes:66481 (64.9 KiB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:368 (368.0 B)  TX bytes:368 (368.0 B)

wlan0     Link encap:Ethernet  HWaddr 64:16:F0:57:27:08 
          inet addr:192.168.1.84  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6616:f0ff:fe57:2708/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8302 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5292 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:9915869 (9.4 MiB)  TX bytes:1169131 (1.1 MiB)

wlan0-1   Link encap:Ethernet  HWaddr 66:16:F0:57:27:08 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:155 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:43020 (42.0 KiB)

Output of "route -n" :

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    10     0        0 eth0.2
0.0.0.0         192.168.1.1     0.0.0.0         UG    20     0        0 wlan0
192.168.0.0     0.0.0.0         255.255.255.0   U     10     0        0 eth0.2
192.168.1.0     0.0.0.0         255.255.255.0   U     20     0        0 wlan0
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan

Output of "ip rule show" :

0: from all lookup local
1001: from all iif eth0.2 lookup main
1002: from all iif wlan0 lookup main
2001: from all fwmark 0x100/0xff00 lookup 1
2002: from all fwmark 0x200/0xff00 lookup 2
2254: from all fwmark 0xfe00/0xff00 unreachable
32766: from all lookup main
32767: from all lookup default
80000: from 192.168.2.1 nop
80000: from 127.0.0.1 nop
80000: from 192.168.0.209 nop
80000: from 192.168.1.84 nop
90000: from 192.168.2.1/24 nop
90000: from 127.0.0.1/8 nop
90000: from 192.168.0.209/24 nop
90000: from 192.168.1.84/24 nop

Output of "ip route list table 1-250" :

1
default via 192.168.0.1 dev eth0.2
2
default via 192.168.1.1 dev wlan0

Firewall default output policy (must be ACCEPT) :

ACCEPT

Output of "iptables -L -t mangle -v -n" :

Chain PREROUTING (policy ACCEPT 561 packets, 73201 bytes)
 pkts bytes target     prot opt in     out     source               destination         
 8321 5693K mwan3_hook  all  --  *      *       0.0.0.0/0            0.0.0.0/0           
  561 73201 fwmark     all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain INPUT (policy ACCEPT 448 packets, 40628 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain FORWARD (policy ACCEPT 113 packets, 32573 bytes)
 pkts bytes target     prot opt in     out     source               destination         
  113 32573 mssfix     all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain OUTPUT (policy ACCEPT 493 packets, 131K bytes)
 pkts bytes target     prot opt in     out     source               destination         
 2027  526K mwan3_hook  all  --  *      *       0.0.0.0/0            0.0.0.0/0           
 2027  526K mwan3_output_hook  all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain POSTROUTING (policy ACCEPT 608 packets, 164K bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain fwmark (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain mssfix (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 TCPMSS     tcp  --  *      wlan0   0.0.0.0/0            0.0.0.0/0            tcp flags:0x06/0x02 /* wan (mtu_fix) */ TCPMSS clamp to PMTU
    0     0 TCPMSS     tcp  --  *      eth0.2  0.0.0.0/0            0.0.0.0/0            tcp flags:0x06/0x02 /* wan (mtu_fix) */ TCPMSS clamp to PMTU

Chain mwan3_connected (2 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            127.0.0.0/8          MARK or 0xff00
    0     0 MARK       all  --  *      *       0.0.0.0/0            224.0.0.0/3          MARK or 0xff00
   38  2009 MARK       all  --  *      *       0.0.0.0/0            192.168.0.0/24       MARK or 0xff00
  114 15587 MARK       all  --  *      *       0.0.0.0/0            192.168.1.0/24       MARK or 0xff00
  760  165K MARK       all  --  *      *       0.0.0.0/0            192.168.2.0/24       MARK or 0xff00

Chain mwan3_hook (2 references)
 pkts bytes target     prot opt in     out     source               destination         
10346 6219K mwan3_ifaces  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
 5976 1345K mwan3_connected  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
 2926  679K mwan3_rules  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
 7272 5549K mwan3_connected  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match ! 0xff00/0xff00

Chain mwan3_iface_wan (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       192.168.1.0/24       0.0.0.0/0            mark match 0x0/0xff00 /* wan */ MARK or 0xff00
  117 15683 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wan */ MARK xset 0x200/0xff00

Chain mwan3_iface_wan2 (1 references)
 pkts bytes target     prot opt in     out     source               destination         
   21  2934 MARK       all  --  *      *       192.168.0.0/24       0.0.0.0/0            mark match 0x0/0xff00 /* wan2 */ MARK or 0xff00
  164 24468 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wan2 */ MARK xset 0x100/0xff00

Chain mwan3_ifaces (1 references)
 pkts bytes target     prot opt in     out     source               destination         
  185 27402 mwan3_iface_wan2  all  --  eth0.2 *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
  117 15683 mwan3_iface_wan  all  --  wlan0  *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00

Chain mwan3_output_hook (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain mwan3_policy_balanced (1 references)
 pkts bytes target     prot opt in     out     source               destination         
  160 23796 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wan 3 3 */ MARK xset 0x200/0xff00

Chain mwan3_policy_wan2_only (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wan2 2 2 */ MARK xset 0x100/0xff00

Chain mwan3_policy_wan2_wan (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wan2 2 2 */ MARK xset 0x100/0xff00

Chain mwan3_policy_wan_only (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wan 3 3 */ MARK xset 0x200/0xff00

Chain mwan3_policy_wan_wan2 (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wan 3 3 */ MARK xset 0x200/0xff00

Chain mwan3_rules (1 references)
 pkts bytes target     prot opt in     out     source               destination         
  160 23796 mwan3_policy_balanced  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* default_rule */
    0     0 mwan3_policy_wan2_wan  tcp  --  *      *       0.0.0.1/-1           0.0.0.0/0            multiport sports 0:65535 multiport dports 443 mark match 0x0/0xff00 /* sticky_odd */
    0     0 mwan3_policy_wan_wan2  tcp  --  *      *       0.0.0.0/-1           0.0.0.0/0            multiport sports 0:65535 multiport dports 443 mark match 0x0/0xff00 /* sticky_even */

Chain mwan3_track_wan (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            208.67.220.220       MARK or 0xff00
    0     0 MARK       all  --  *      *       0.0.0.0/0            208.67.222.222       MARK or 0xff00
    0     0 MARK       all  --  *      *       0.0.0.0/0            8.8.8.8              MARK or 0xff00
    0     0 MARK       all  --  *      *       0.0.0.0/0            8.8.4.4              MARK or 0xff00

Chain mwan3_track_wan2 (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            208.67.220.220       MARK or 0xff00
    0     0 MARK       all  --  *      *       0.0.0.0/0            8.8.8.8              MARK or 0xff00[code/]