Autor Tema: [Desarrollo] OpenWrt en Sagem F@ST2604  (Leído 49998 veces)

0 Usuarios y 1 Visitante están viendo este tema.

elmasvital

  • Visitante
Re: Openwrt en Sagem F@ST2604
« Respuesta #20 en: 26-08-2012, 12:01 (Domingo) »
hola a todos
mi post anterior en Inglés ha sido borrado
Yo no hablo español, yo uso traductor Google
intento instalar openwrt en mi router sagem 2604 pero está bloqueado por el ISP y no acepta 3rd party firmwares
He encontrado una cabecera para JTAG en la parte posterior del router
después de varios intentos logré conectar a través de JTAG




Me recuperé un Backup del CFE bootloader

Necesito tu ayuda para tener una copia de CFE no bloqueado o ayudarme a desbloquear la mía

gracias de antemano

--------------------------------------------------------
editar: el problema se resolvió
Le doy una explicación detallada más adelante


Como se extrae ese fichero? por jtag? serial? Si me explicas cómo hacerlo te podria ayudar.

Saludos



elmasvital

  • Visitante
Re: Openwrt en Sagem F@ST2604
« Respuesta #21 en: 26-08-2012, 12:12 (Domingo) »
Le echaré un ojo cuando pueda.
El problema es que el switch del router que me han dejado ha "muerto" sin motivo aparente. Sólo puedo comunicarme con el bootloader por puerto serie, pero no puedo flashear nuevos firmwares, así que tengo un bonito pisapapeles.

Saludos.

Notari te dejo el volcado serie que suelta con la versión Backfire. Seria muy interesante tener este router con una version funcional de luci aunque fuera antiguita.


Código: [Seleccionar]
getShareBlks: i=1015, sect_size=4096, end_blk=1016
Backup content:[<psitree>
]
getShareBlks: i=1018, sect_size=4096, end_blk=1024
getShareBlks: i=1019, sect_size=4096, end_blk=1024
getShareBlks: i=1020, sect_size=4096, end_blk=1024
getShareBlks: i=1021, sect_size=4096, end_blk=1024
getShareBlks: i=1022, sect_size=4096, end_blk=1024
getShareBlks: i=1023, sect_size=4096, end_blk=1024
PSI content:[ÿÿÿÿÿÿÿÿÿÿ]
Reset  mii_switch_unmanage_mode configuration
CPU type 0x29107: 256MHz, Bus: 128MHz, Ref: 32MHz
Total memory: 16777216 bytes (16MB)

Total memory used by CFE:  0x80401000 - 0x8052ADA0 (1220000)
Initialized Data:          0x8041E2C0 - 0x80421510 (12880)
BSS Area:                  0x80421510 - 0x80428DA0 (30864)
Local Heap:                0x80428DA0 - 0x80528DA0 (1048576)
Stack Area:                0x80528DA0 - 0x8052ADA0 (8192)
Text (code) segment:       0x80401000 - 0x8041E2C0 (119488)
Boot area (physical):      0x0052B000 - 0x0056B000
Relocation Factor:         I:00000000 - D:00000000

Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:26:91:02:68:d2, BoardId=F@ST2604
Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:26:91:02:68:d2, BoardId=F@ST2604
Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:26:91:02:68:d2, BoardId=F@ST2604
Board IP address                  : 192.168.1.1:ffffff00
Host IP address                   : 192.168.1.100
Gateway IP address                :
Run from flash (f)                : f
Default host run file name        : vmlinux
Default host flash file name      : bcm963xx_fs_kernel
Boot delay (0-9 seconds)          : 1
Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:26:91:02:68:d2, BoardId=F@ST2604
Board Id (0-15)                   : F@ST2604
Number of MAC Addresses (1-32)    : 11
Base MAC Address                  : 00:26:91:02:68:d2
PSI Size (1-64) KBytes            : 24
Customer Name (0-4)               : 4

*** Press any key to stop auto run (1 seconds) ***
Auto run second count down: 0
Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:26:91:02:68:d2, BoardId=F@ST2604
Code Address: 0x80010000, Entry Address: 0x80010000
Booting from image (0xbfc10000) ...
Decompression OK!
Entry at 0x80010000
Closing network.
Starting program at 0x80010000
Linux version 2.6.32.27 (noltari@skynet) (gcc version 4.3.3 (GCC) ) #2 Sun Aug 19 13:28:15 CEST 2012
Detected Broadcom 0x6348 CPU revision b0
CPU frequency is 256 MHz
16MB of RAM installed
registering 37 GPIOs
board_bcm963xx: CFE version: 0.51.46-51.54
bootconsole [early0] enabled
CPU revision is: 00029107 (Broadcom BCM6348)
board_bcm963xx: board name: F@ST2604
Determined physical RAM map:
 memory: 01000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00001000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00001000
Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 4064
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
PID hash table entries: 64 (order: -4, 256 bytes)
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Primary instruction cache 16kB, VIPT, 2-way, linesize 16 bytes.
Primary data cache 8kB, 2-way, VIPT, no aliases, linesize 16 bytes
Memory: 13448k/16384k available (2063k kernel code, 2936k reserved, 367k data, 140k init, 0k highmem)
Hierarchical RCU implementation.
NR_IRQS:128
Calibrating delay loop... 254.97 BogoMIPS (lpj=509952)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
registering PCI controller with io_map_base unset
bio: create slab <bio-0> at 0
Switching to clocksource MIPS
PCI: Enabling device 0000:00:01.0 (0000 -> 0002)
ssb: Sonics Silicon Backplane found on PCI device 0000:00:01.0
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
NET: Registered protocol family 1
audit: initializing netlink socket (disabled)
type=2000 audit(0.332:1): initialized
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
msgmni has been set to 26
io scheduler noop registered
io scheduler deadline registered (default)
gpiodev: gpio device registered with major 254
gpiodev: gpio platform device registered with access mask FFFFFFFF
bcm63xx_uart.0: ttyS0 at MMIO 0xfffe0300 (irq = 10) is a bcm63xx_uart
console [ttyS0] enabled, bootconsole disabled
console [ttyS0] enabled, bootconsole disabled
bcm963xx_flash: 0x00400000 at 0x1fc00000
bcm963xx_flash: Failed to probe using CFI
bcm963xx-flash: probe of bcm963xx-flash.0 failed with error -5
bcm63xx_enet MII bus: probed
bcm63xx_wdt started, timer margin: 30 sec
Registered led device: power
------------[ cut here ]------------
WARNING: at fs/sysfs/dir.c:491 0x800e2044()
sysfs: cannot create duplicate filename '/devices/platform/leds-gpio.0/leds/power'
Modules linked in:
Call Trace:[<800195a0>] 0x800195a0
[<800195a0>] 0x800195a0
[<8002f070>] 0x8002f070
[<800e2044>] 0x800e2044
[<8002f0f0>] 0x8002f0f0
[<800e21d8>] 0x800e21d8
[<800e2044>] 0x800e2044
[<800e20c0>] 0x800e20c0
[<800e2794>] 0x800e2794
[<800e2844>] 0x800e2844
[<80125338>] 0x80125338
[<80125490>] 0x80125490
[<80125a14>] 0x80125a14
[<80125338>] 0x80125338
[<80125b10>] 0x80125b10
[<801595d8>] 0x801595d8
[<8015a73c>] 0x8015a73c
[<8015a27c>] 0x8015a27c
[<8015ac68>] 0x8015ac68
[<8015acd4>] 0x8015acd4
[<80019754>] 0x80019754
[<80183f6c>] 0x80183f6c
[<80018e9c>] 0x80018e9c
[<8015d028>] 0x8015d028
[<80125338>] 0x80125338
[<8015d16c>] 0x8015d16c
[<80125a14>] 0x80125a14
[<8015d100>] 0x8015d100
[<8015c76c>] 0x8015c76c
[<80125aa4>] 0x80125aa4
[<80270000>] 0x80270000
[<8015bee8>] 0x8015bee8
[<8027fb10>] 0x8027fb10
[<8015d51c>] 0x8015d51c
[<8027fbd4>] 0x8027fbd4
[<8015d51c>] 0x8015d51c
[<8027fb40>] 0x8027fb40
[<8027f948>] 0x8027f948
[<8027fbd4>] 0x8027fbd4
[<8001bc28>] 0x8001bc28
[<800660a0>] 0x800660a0
[<8027f59c>] 0x8027f59c
[<8027033c>] 0x8027033c
[<8001e67c>] 0x8001e67c
[<8027026c>] 0x8027026c
[<8001e66c>] 0x8001e66c

---[ end trace 821856cfb68bf7c4 ]---
kobject_add_internal failed for power with -EEXIST, don't try to register things with the same name in the same directory.
Call Trace:[<800303ec>] 0x800303ec
[<800195a0>] 0x800195a0
[<800195a0>] 0x800195a0
[<80125578>] 0x80125578
[<80125b10>] 0x80125b10
[<801595d8>] 0x801595d8
[<8015a73c>] 0x8015a73c
[<8015a27c>] 0x8015a27c
[<8015ac68>] 0x8015ac68
[<8015acd4>] 0x8015acd4
[<80019754>] 0x80019754
[<80183f6c>] 0x80183f6c
[<80018e9c>] 0x80018e9c
[<8015d028>] 0x8015d028
[<80125338>] 0x80125338
[<8015d16c>] 0x8015d16c
[<80125a14>] 0x80125a14
[<8015d100>] 0x8015d100
[<8015c76c>] 0x8015c76c
[<80125aa4>] 0x80125aa4
[<80270000>] 0x80270000
[<8015bee8>] 0x8015bee8
[<8027fb10>] 0x8027fb10
[<8015d51c>] 0x8015d51c
[<8027fbd4>] 0x8027fbd4
[<8015d51c>] 0x8015d51c
[<8027fb40>] 0x8027fb40
[<8027f948>] 0x8027f948
[<8027fbd4>] 0x8027fbd4
[<8001bc28>] 0x8001bc28
[<800660a0>] 0x800660a0
[<8027f59c>] 0x8027f59c
[<8027033c>] 0x8027033c
[<8001e67c>] 0x8001e67c
[<8027026c>] 0x8027026c
[<8001e66c>] 0x8001e66c

leds-gpio: probe of leds-gpio.0 failed with error -17
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Cannot open root device "mtdblock2" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Noltari

  • Visitante
Re: Openwrt en Sagem F@ST2604
« Respuesta #22 en: 26-08-2012, 13:05 (Domingo) »
Retry:
https://dl.dropbox.com/u/4708147/openwrt/fast2604/openwrt-F%40ST2604-squashfs-cfe_backfire_10.03.1.bin

Aun así debo deciros que creo que hay un problema con la flash de este router en una versión tan antigua de Openwrt en base al bootlog que habéis proporcionado...

Saludos.

elmasvital

  • Visitante
Re: Openwrt en Sagem F@ST2604
« Respuesta #23 en: 26-08-2012, 13:34 (Domingo) »
Retry:
https://dl.dropbox.com/u/4708147/openwrt/fast2604/openwrt-F%40ST2604-squashfs-cfe_backfire_10.03.1.bin

Aun así debo deciros que creo que hay un problema con la flash de este router en una versión tan antigua de Openwrt en base al bootlog que habéis proporcionado...

Saludos.

Notari sigue sin funcionar. Debe ser lo que dices.


Código: [Seleccionar]
Sagem CFE version: 3.36
Build Date: Mon Jan 19 17:33:14 CST 2009 (chenc@svr1.sagem-szn.com)
Copyright (C) 2005-2006 Sagem communication.

Boot Address 0xbfc00000

Initializing Arena.
Initializing Devices.
Parallel flash device: name SST39VF3201, id 0x235b, size 4096KB
Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:26:91:02:68:d2, BoardId=F@ST2604
getShareBlks: i=1010, sect_size=4096, end_blk=1016
getShareBlks: i=1011, sect_size=4096, end_blk=1016
getShareBlks: i=1012, sect_size=4096, end_blk=1016
getShareBlks: i=1013, sect_size=4096, end_blk=1016
getShareBlks: i=1014, sect_size=4096, end_blk=1016
getShareBlks: i=1015, sect_size=4096, end_blk=1016
Backup content:[<psitree>
]
getShareBlks: i=1018, sect_size=4096, end_blk=1024
getShareBlks: i=1019, sect_size=4096, end_blk=1024
getShareBlks: i=1020, sect_size=4096, end_blk=1024
getShareBlks: i=1021, sect_size=4096, end_blk=1024
getShareBlks: i=1022, sect_size=4096, end_blk=1024
getShareBlks: i=1023, sect_size=4096, end_blk=1024
PSI content:[ÿÿÿÿÿÿÿÿÿÿ]
Reset  mii_switch_unmanage_mode configuration
CPU type 0x29107: 256MHz, Bus: 128MHz, Ref: 32MHz
Total memory: 16777216 bytes (16MB)

Total memory used by CFE:  0x80401000 - 0x8052ADA0 (1220000)
Initialized Data:          0x8041E2C0 - 0x80421510 (12880)
BSS Area:                  0x80421510 - 0x80428DA0 (30864)
Local Heap:                0x80428DA0 - 0x80528DA0 (1048576)
Stack Area:                0x80528DA0 - 0x8052ADA0 (8192)
Text (code) segment:       0x80401000 - 0x8041E2C0 (119488)
Boot area (physical):      0x0052B000 - 0x0056B000
Relocation Factor:         I:00000000 - D:00000000

Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:26:91:02:68:d2, BoardId=F@ST2604
Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:26:91:02:68:d2, BoardId=F@ST2604
Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:26:91:02:68:d2, BoardId=F@ST2604
Board IP address                  : 192.168.1.1:ffffff00
Host IP address                   : 192.168.1.100
Gateway IP address                :
Run from flash (f)                : f
Default host run file name        : vmlinux
Default host flash file name      : bcm963xx_fs_kernel
Boot delay (0-9 seconds)          : 1
Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:26:91:02:68:d2, BoardId=F@ST2604
Board Id (0-15)                   : F@ST2604
Number of MAC Addresses (1-32)    : 11
Base MAC Address                  : 00:26:91:02:68:d2
PSI Size (1-64) KBytes            : 24
Customer Name (0-4)               : 4

*** Press any key to stop auto run (1 seconds) ***
Auto run second count down: 0
Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:26:91:02:68:d2, BoardId=F@ST2604
Code Address: 0x80010000, Entry Address: 0x80010000
Booting from image (0xbfc10000) ...
Decompression OK!
Entry at 0x80010000
Closing network.
Starting program at 0x80010000
Linux version 2.6.32.27 (noltari@skynet) (gcc version 4.3.3 (GCC) ) #1 Sun Aug 26 13:01:35 CEST 2012
Detected Broadcom 0x6348 CPU revision b0
CPU frequency is 256 MHz
16MB of RAM installed
registering 37 GPIOs
board_bcm963xx: CFE version: 0.51.46-51.54
bootconsole [early0] enabled
CPU revision is: 00029107 (Broadcom BCM6348)
board_bcm963xx: board name: F@ST2604
Determined physical RAM map:
 memory: 01000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00001000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00001000
Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 4064
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
PID hash table entries: 64 (order: -4, 256 bytes)
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Primary instruction cache 16kB, VIPT, 2-way, linesize 16 bytes.
Primary data cache 8kB, 2-way, VIPT, no aliases, linesize 16 bytes
Memory: 13448k/16384k available (2063k kernel code, 2936k reserved, 367k data, 140k init, 0k highmem)
Hierarchical RCU implementation.
NR_IRQS:128
Calibrating delay loop... 254.97 BogoMIPS (lpj=509952)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
registering PCI controller with io_map_base unset
bio: create slab <bio-0> at 0
Switching to clocksource MIPS
PCI: Enabling device 0000:00:01.0 (0000 -> 0002)
ssb: Sonics Silicon Backplane found on PCI device 0000:00:01.0
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
NET: Registered protocol family 1
audit: initializing netlink socket (disabled)
type=2000 audit(0.332:1): initialized
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
msgmni has been set to 26
io scheduler noop registered
io scheduler deadline registered (default)
gpiodev: gpio device registered with major 254
gpiodev: gpio platform device registered with access mask FFFFFFFF
bcm63xx_uart.0: ttyS0 at MMIO 0xfffe0300 (irq = 10) is a bcm63xx_uart
console [ttyS0] enabled, bootconsole disabled
console [ttyS0] enabled, bootconsole disabled
bcm963xx_flash: 0x00400000 at 0x1fc00000
bcm963xx_flash: Failed to probe using CFI
bcm963xx-flash: probe of bcm963xx-flash.0 failed with error -5
bcm63xx_enet MII bus: probed
bcm63xx_wdt started, timer margin: 30 sec
Registered led device: green:power
Registered led device: red:power
Registered led device: red:inet
Registered led device: green:wps
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Cannot open root device "mtdblock2" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

moimem

  • Visitante
Re: Openwrt en Sagem F@ST2604
« Respuesta #24 en: 27-08-2012, 18:30 (Lunes) »
Como se extrae ese fichero? por jtag? serial? Si me explicas cómo hacerlo te podria ayudar.

Saludos
por jtag uso HairyDairyMaid_WRT54G_Debrick_Utility

elmasvital

  • Visitante
Re: Openwrt en Sagem F@ST2604
« Respuesta #25 en: 31-08-2012, 13:12 (Viernes) »
Buenas...

He estado investigando sobre luci en routers de 16mb de ram. He encontrado un hilo en el que se habla del tema en otro router y aconsejan Backfire 10.03.01 con Linux 2.4 no el 2.6

https://forum.openwrt.org/viewtopic.php?id=38213

Por otro lado Noltari el problema que dices que puede haber de la flash en esta versión sería solucionable?

También he visto que antiguamente existian otras interfaces para openwrt el x-wrt. Este no es posible instalarlo?

Saludos

Noltari

  • Visitante
Re: Openwrt en Sagem F@ST2604
« Respuesta #26 en: 01-09-2012, 12:45 (Sábado) »
Buenas...

He estado investigando sobre luci en routers de 16mb de ram. He encontrado un hilo en el que se habla del tema en otro router y aconsejan Backfire 10.03.01 con Linux 2.4 no el 2.6

https://forum.openwrt.org/viewtopic.php?id=38213

Por otro lado Noltari el problema que dices que puede haber de la flash en esta versión sería solucionable?

También he visto que antiguamente existian otras interfaces para openwrt el x-wrt. Este no es posible instalarlo?

Saludos

brcm63xx sólo funciona con kernels 2.6+. El kernel 2.4 se usaba como alternativa más compatible y rápida para brcm47xx, sobre todo en cuanto al wifi.

Siempre que hay un problema con el kernel de linux en cuanto a no soportar cierta función es solucionable. La pregunta es si merece la pena el tiempo que hay que invertir para solucionarlo, sobre todo si en nuevas versiones no hay dicho problema.
Por mi parte no voy a solucionar dicho problema, ya que mi F@ST2604 ha muerto y además se puede utilizar la última versión del trunk aunque vaya algo lenta. Mi consejo: utilizar una versión sin LuCI, configurándola por ficheros.

El x-wrt es una interfaz que no se actualiza desde hace bastante tiempo (no utilicé openwrt cuando se usaba por defecto). Tienes que instalar una versión bastante antigua para que funcione decentemente.
https://dev.openwrt.org/roadmap?show=all

Saludos!

elmasvital

  • Visitante
Re: Openwrt en Sagem F@ST2604
« Respuesta #27 en: 03-09-2012, 00:05 (Lunes) »
Vaya... estaba haciendo algunas pruebas de POE con este router y me he cargado uno de los conversores dc/dc de este router :-( Asi que de momento se guarda en el armario hasta que haga alguna compra a farnell o amidata para poder reemplazarlo.

Gracias por la información Noltari. Viendo este post me animé a crear algun script que automatizara las funciones que me venían bien. Pero de momento lo dejaré aparcado hasta ver si puedo rescatarlo.

moimem

  • Visitante
Re: Openwrt en Sagem F@ST2604
« Respuesta #28 en: 12-09-2012, 00:55 (Miércoles) »
Creo que he identificado el problema con openwrt y sagem 2604
https://dev.openwrt.org/ticket/6156
No es el cable TTL3v3_rs232 así que no es console debugging
aplico el patch en el backfire pero no demmare
openwrt-F@ST2604-squashfs-cfe
si se puede dar el boot log
Saludos
« Última modificación: 12-09-2012, 00:56 (Miércoles) por moimem »

Noltari

  • Visitante
Re: Openwrt en Sagem F@ST2604
« Respuesta #29 en: 21-10-2012, 16:59 (Domingo) »
Router soportado oficialmente en la versión r33886.
https://dev.openwrt.org/changeset/33886

Saludos :D!

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4579
Re: Openwrt en Sagem F@ST2604
« Respuesta #30 en: 21-10-2012, 18:16 (Domingo) »
Router soportado oficialmente en la versión r33886.
https://dev.openwrt.org/changeset/33886

Saludos :D!

Estupendo  >:( >:(
Valoraciones positivas en compra/venta:
114 en Htcmania
104 en Har2mano
16 en elchapuzasinformatico
7 en gsmspain
4 en foro2mano
 .... :)
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

fresnillo

  • Visitante
Re: [Desarrollo] OpenWrt en Sagem F@ST2604
« Respuesta #31 en: 01-12-2012, 18:35 (Sábado) »
He estado probando (ya que me dio por monear con el hg556a) el openwrt en el fast2404.

Me he fijado después de un día moneando que el firmware de este router (es que el openwrt va muy justito en este hardware no me deja instalar ni un nfs para montar carpetas de red) parece que tiene perfecta compatiblidad con el fast 2504.

Bueno, la razón por la que pongo el post es que una vez que puse los firms y vi que el fast2504 y fast2404 son totalmente compatibles entre sí, sospecho que ocurre lo mismo con el fast2604.

http://www.mediafire.com/?5359ix14lxr5flo

Por si alguien quiere volver al firm de fábrica, de hecho le he quitado las personalizaciones de Orange al router y de paso mientras le he cambiado la mac al firmware (se hace al cambiar la mac), ya que te lo permite cuando flasheas (F2404_3_18_1a4_flash_image_NONE.w).

Los pasos que seguí son simples:

1) Pulsar largo y tendido el botón de reset y encenderlo con él pulsado (más de un minuto).
1.b) Poner en el equipo una dirección sobre 192.168.1.0/24
2) Subir el archivo F2404_3_18_1a4_flash_image_NONE.w a http://192.168.1.1
2.b) Una vez subido y flasheado permite cambiar la mac, por si alguien quiere personalizarla, cuando la cambié diréctamente ya no me volvió a aparecer la red de tipo Orange sino la que trae el firm (Sagem).
3) Volver al formulario y subir el F2404_3_24a4_fs_kernel_NONE

Con eso sería suficiente, pero está también una actualización a la 3_33, aunque con la que viene está muy bien (para el que quiera quitarse el openwrt y volver a tener el ADSL, siempre muy útil saber que se puede volver atrás).

Saludos!!

IsmaWireless

  • Visitante
Re: [Desarrollo] OpenWrt en Sagem F@ST2604
« Respuesta #32 en: 18-12-2012, 12:32 (Martes) »
Hola, he estado cacharreando con el F@ast2604, el tema es que flasheé el fichero F2404_3_18_1a4_flash_image_NONE.w que aparece en el foro y cuando intento actualizar con openwrt-F@ST2604-squashfs-cfe.bin, dice (el puerto serie) que la imagen no es válida porque es para 2604 y mi cfe dice que el BoardId es 2404.
Este mensaje se traduce en los caracteres extraños que aparecen en el campo MAC Address de la página upload.html
Se puede cambiar la BoardId desde el CFE pero como es del 2404, no lo ofrece en la lista y aunque se ponga su código (15) no lo acepta.

1.-¿Alguien tiene una imagen flash original del 2604?
2.-moimen puso un cfe.bin del 2604 pero este no se puede actualizar desde upload.html, supongo que hay que hacerlo por serie/tftp o en su defecto jtag, ¿qué aconsejáis?
3.-He leído que hay una copia de backup dentro del router, ¿alguien sabe del tema?

Saludos y happy hacking.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Sagem F@ST2604
« Respuesta #33 en: 29-12-2012, 00:42 (Sábado) »
Siento no poder ayudaros más con este router, pero el que me dejaron murió y no puedo seguir haciendo pruebas de ningún tipo :(.

Hay más gente que ha reportado problemas de flasheo en el foro de OpenWrt, pero a mi no me surgieron.

Un saludo.

Flesy_

  • Visitante
Re: [Desarrollo] OpenWrt en Sagem F@ST2604
« Respuesta #34 en: 04-01-2013, 10:27 (Viernes) »
Hola, tengo ese router desde hace varios años y he decidido meterle OpenWrt, por lo que veo aconsejas instalar:

openwrt-F@ST2604-squashfs-cfe_r33006

Pero en la web de openwrt salen todos estos archivos:

openwrt-F@ST2604-cfe-jffs2-64k-cfe
openwrt-F@ST2604-cfe-jffs2-128k-cfe
openwrt-F@ST2604-cfe-squashfs-cfe
openwrt-F@ST2604-jffs2-64k-cfe
openwrt-F@ST2604-jffs2-128k-cfe
openwrt-F@ST2604-squashfs-cfe

¿Cual le pongo de todos?  :'(

Flesy_

  • Visitante
Re: [Desarrollo] OpenWrt en Sagem F@ST2604
« Respuesta #35 en: 05-01-2013, 08:35 (Sábado) »
Me he puesto la vuestra y todo perfecto, pero va a pedales  :-\

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Sagem F@ST2604
« Respuesta #36 en: 05-01-2013, 10:44 (Sábado) »
Me he puesto la vuestra y todo perfecto, pero va a pedales  :-\
Sí, es completamente normal, porque al tener sólo 16MB de RAM y un 6348 de procesador...
Si quieres que sea usable, y aun así se nota algo lento, lo vas a tener que configurar por shell, utilizando una imagen lo más pelada posible (sin LuCI).

Siento no poder ayudarte, pero este problema es debido a que las últimas versiones de linux consumen más memoria RAM.

Un saludo.

Flesy_

  • Visitante
Re: [Desarrollo] OpenWrt en Sagem F@ST2604
« Respuesta #37 en: 05-01-2013, 12:24 (Sábado) »
gracias!!

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Sagem F@ST2604
« Respuesta #38 en: 13-04-2013, 15:49 (Sábado) »
Aquí va un intento de Backport a Backfire. Sin luci de momento, hasta que sea capaz de hacerlo funcionar, si alguien me echa un cable ya que no dispongo del router. Un log de arranque será bienvenido.

https://files.myopera.com/danitool/xx/openwrt-F@ST2604-squashfs-cfe.bin.zip

toneleti

  • Visitante
Re: [Desarrollo] OpenWrt en Sagem F@ST2604
« Respuesta #39 en: 26-04-2013, 21:39 (Viernes) »
Hola, he instalado la version trunk y cuando voy a entrar por ssh o telnet por la ip 192.168.1.1 no se me conecta.

¿Sabeis a que puede ser devido esto?

Gracias.