Autor Tema: [Desarrollo] OpenWRT en routers ZTE MF10  (Leído 17347 veces)

0 Usuarios y 1 Visitante están viendo este tema.

vk496

  • Visitante
[Desarrollo] OpenWRT en routers ZTE MF10
« en: 12-04-2014, 16:03 (Sábado) »
Después de trastear con la M5 y tener que esperar a que me llegue un POE, el mismo amigo me regaló otra cosita que tenía por allí y que estaba a punto de tirar: ZTE MF10  ;D





Él lo vé como un repetidor de un modem anticuado en los tiempos de alta velocidad que hay en nuestros días. Sin embargo, yo veo un puerto USB y un router que pide a gritos OpenWRT  ^-^  :D

El problema es que no encuentro nada respecto a este "router", y mucho menos algo relacionado con OpenWRT...

Tendré que abrirlo en canal para ver que chpset usa o hay algún otro método menos bestia? Lo digo por el tema de compilar y eso, porque me da a mi que nadie se ha fijado en él...

EDITO:

Links de descarga:

Firmware OpenWRT para flashear desde uBoot:
http://goo.gl/vq3g6l

Backup de las particiones del firmware original:
http://goo.gl/BTNE2m

Hilos relevantes:
https://foro.seguridadwireless.net/openwrt/flashear-xte-mf10/msg311974/#msg311974

Salu2


« Última modificación: 25-06-2014, 23:18 (Miércoles) por vk496 »

vk496

  • Visitante
Re: Re: Flashear ZTE MF10
« Respuesta #1 en: 14-04-2014, 13:24 (Lunes) »
Hoy he tenido un tiempo libre para toquetear algo...

Resulta que tiene una Ralink rt3050f...

Se puede darle soporte OpenWRT? Soy muy nuevo en esto, y no sé si podré hacer algo...

Adjunto unas fotos:





Salu2

Pteridium

  • Visitante
Re: Dar soporte a ZTE MF10
« Respuesta #2 en: 14-04-2014, 13:47 (Lunes) »
Simpático cacharro, pero a priori la pega es la poca RAM. https://wikidevi.com/wiki/ZTE_MF10
No debería ser complicado portarlo a openwrt AA o BB pero necesitas localizar el puerto serie que lleva y mandar el bootlog para saber algo más de él, además de que necesitarás ese puerto para poder hacer las pruebas.

vk496

  • Visitante
Re: Re: Dar soporte a ZTE MF10
« Respuesta #3 en: 14-04-2014, 15:13 (Lunes) »
En casa lo más viejo que he encontrado es un cable algo viejo de un Samsung: APCBS10UBE

Me puede servir para conectarlo al serial port?

Salu2

EDITO: o seria mejor que me pillase uno de estos?

http://m.ebay.es/itm/201000826607?nav=SEARCH

Enviado desde mi GT-I9505 mediante Tapatalk

danitool

  • Visitante
Re: Dar soporte a ZTE MF10
« Respuesta #4 en: 14-04-2014, 16:25 (Lunes) »
En mi opinión no está pero que nada mal el cacharro. Si tiene 8 MB de flash como pone en wikidevi al menos ahí tienes margen para hacer cosas. La RAM de 16 MB te limita pero para hacer pequeños proyectos todavía es más que suficiente.
Además siempre cabría la posibilidad de desoldar la RAM y meterle 32 MB, pero ya sería más complicado ya que haría falta un bootloader nuevo.

Seguramente usa Uboot como bootloader. En principio debería ser fácil añadir soporte a OpenWrt. Así que no desperdicies la oportunidad, es un buen dispositivo para explorar posibilidades.

No creo que te sirva el adaptador samsung que mencionas, lo más cómodo es adquirir uno como el que has mencionado, aunque ese modelo que indicas no me suena.

« Última modificación: 14-04-2014, 16:26 (Lunes) por danitool »

vk496

  • Visitante
Re: Dar soporte a ZTE MF10
« Respuesta #5 en: 14-04-2014, 16:37 (Lunes) »
No creo que te sirva el adaptador samsung que mencionas, lo más cómodo es adquirir uno como el que has mencionado, aunque ese modelo que indicas no me suena.

http://www.ebay.com/itm/1pcs-USB-2-0-to-TTL-UART-6PIN-Module-Serial-Converter-CP2102-STC-PRGMR-/400692219989?pt=LH_DefaultDomain_0&hash=item5d4b1e1055

y este?

Quiero pedir uno lo más rápido posible, porque estas cosas tardan un montón en llegar...

Salu2

barriteleves

  • Visitante
Re: Dar soporte a ZTE MF10
« Respuesta #6 en: 14-04-2014, 16:44 (Lunes) »
hola compañero ese modelo ultimo con chips 2102 te vale perfectament y estos otros tambien son asequibles y funcionan:

PL2303HX USB To RS232 TTL Auto Converter Adapter

danitool

  • Visitante
Re: Dar soporte a ZTE MF10
« Respuesta #7 en: 14-04-2014, 17:38 (Lunes) »
El CP2102 todos los que lo probamos nunca tuvimos problemas con él, así que es una apuesta muy fiable.

vk496

  • Visitante
Re:
« Respuesta #8 en: 21-04-2014, 19:33 (Lunes) »
He pedido el cable y todo correcto, el envío ya se ha realizado. El problema es que tardará 20 días en llegar y estoy desesperado por toquetear un poco... Jajaja :D

He encontrado un cable en mi casa que tiene el cable muy gordo:



Solo hay letras en el cable, y pone que el modelo es AWM 2725

Creéis que este me serviría?

Salu2

Enviado desde mi GT-I9505 mediante Tapatalk


vk496

  • Visitante
Re: Re: Dar soporte a ZTE MF10
« Respuesta #9 en: 06-05-2014, 16:49 (Martes) »
Me acaba de llegar el cablecito. Aunque no tenga mucho tiempo, intentaré hacer algo en los ratos libres...

Por donde debería empezar? He localizado el puerto serie, y creo que usa 3v (no estoy seguro).

Estoy muy perdido en esto, es mi primer contacto con OpenWRT de este modo...

Salu2

Enviado desde mi GT-I5800 usando Tapatalk 2


Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1955
Re: Dar soporte a ZTE MF10
« Respuesta #10 en: 06-05-2014, 17:15 (Martes) »
Para conectar el cable utiliza sólo los pines RX, TX y GND. NO CONECTES EL VCC. El adaptador ya recibe la corriente del puerto USB, así que no conectes el VCC a la placa del router o corres el peligro de freírla.
Sobre cómo averiguar dónde están esos pines en la placa ya no te puedo decir, pero seguramente un polímetro sería de ayuda, y lo que más, un analizador de señales...
La conexión de la placa al adaptador USB debe tener los pines RX y TX cambiados, es decir, lo que transmite la placa el adaptador lo debe recibir, y lo que transmite el adaptador la placa lo debe recibir, así que esos pines deben estar cruzados para que lo que manda uno lo reciba el otro.
Para ver lo que se envía por esos pines puedes usar el hyperterminal en Windows o el miniterm.py en linux.
Los parámetros de conexión suelen ser 115200 8N1, pero en algunos dispositivos también pueden ser 57600 8N1.
A ver si tienes suerte y puedes ver el log de arranque del dispositivo.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

vk496

  • Visitante
Re: Dar soporte a ZTE MF10
« Respuesta #11 en: 06-05-2014, 18:41 (Martes) »
Hatsa ahora solo he conseguido que me salgan garabatos...

Citar
▒▒▒▒▒▒▒fg▒睕▒▒▒▒▒▒LS▒▒Ǝ▒X`▒߂cz▒▒
4▒▒Aq▒cA▒▒▒OE▒▒▒▒!L▒f▒rPP%`▒▒
                              ▒1R▒▒;▒H▒▒/▒j1▒▒X ▒▒
                                                  ▒C▒C▒j :▒2▒X▒^▒H)C▒▒O#9C5$9)G▒J▒▒▒▒▒o-A▒▒▒(▒c!7▒▒▒▒▒p▒^       j~.▒▒▒F▒        ▒▒c▒Qo1▒b+▒)▒▒▒#▒VLo▒▒&▒▒CM
                                                                           ▒MS▒▒▒҅b ▒▒▒  +▒▒]▒B9▒x▒▒&t▒j▒q▒Z▒/3▒▒!▒▒▒▒▒´▒▒:▒▒B▒H▒▒▒R▒▒wCk"▒▒▒b|]▒0[▒▒▒R▒
                                               sEJ▒"֞<▒▒BR▒▒▒▒O▒-▒BZR▒▒▒yK▒▒▒▒g▒9k)▒Ǜ▒▒^g▒|▒▒W▒w▒$▒qBHhǶ[▒▒'▒u▒▒▒▒+ʸ▒▒J▒=Ż▒:▒    ▒▒Z▒▒o▒▒▒▒▒}&▒▒▒▒s▒cY▒
                                                                      ]▒▒8`z9F,▒"▒i▒▒n2-▒z▒A▒▒▒A▒▒▒▒j▒?▒p▒纈{R▒▒▒q▒o▒▒▒X▒▒R▒S▒ńi▒▒]▒p▒▒u▒▒▒-▒X▒I▒▒!▒h  8▒Rh▒H▒Ch�▒@B▒▒▒d_▒Zא▒ޜR▒Qg@▒wkk▒▒R!#▒▒▒▒▒KC▒▒z▒=֦▒KC▒▒z▒=֦▒▒Q▒▒▒▒▒Q=֦▒KC▒▒z▒Q▒▒▒Y▒h▒▒▒cg4S▒▒▒▒▒5 ▒B▒▒clj▒▒▒t▒▒c`▒x▒w▒▒G9▒▒W        ]▒mR:▒▒hG       JàA▒KA▒Y▒ӄkb▒▒▒=֦▒CTo▒▒a▒▒b▒▒▒▒im^o▒ B▒a▒!▒W▒▒G▒e▒▒▒v▒XmV▒v!▒▒v1▒v▒e▒3▒a▒Xkph▒mgV▒i▒▒▒R▒pC
                                                                 ▒cRu▒D:▒▒J▒z־▒▒o5▒kK▒L▒MFk▒k▒K▒*▒=֦▒Oh▒ۚ▒kC};▒
▒&▒▒K(▒l▒a▒k   ▒K,L▒k#ˆk)▒i▒▒k!▒k▒▒KK▒▒H▒▒K,▒
            ▒}Z▒▒&▒Q'"E▒▒kT▒▒▒▒▒ƶ▒9▒▒▒F▒▒▒▒k
                                            D▒▒▒LC▒▒▒Q▒▒6S+▒qM▒▒▒oƮ▒▒▒0▒K▒O▒▒t▒O▒K▒▒r▒▒▒▒▒Z▒▒O,1߹▒\▒{▒@▒bH2Xb▒▒Y_▒zP
                                    ▒▒▒▒ͼ▒i▒▒
▒b▒▒V
     Kj▒▒▒▒s$G▒▒i&]▒Q▒B▒▒%a▒ھI▒a▒▒▒ƙ6R▒▒Da▒▒▒▒L▒Y▒Yj▒ӄaB▒▒Ba▒▒▒qH▒▒ĂIZ▒d▒▒:▒▒▒c{ch▒2▒▒Z▒▒▒>3ӞKYSR▒i#▒j1RBh▒ܨ▒▒]\▒g▒c%76▒cR
                                          ▒I▒e▒#H▒Eq▒W▒n▒D%▒w$▒~X),OZ▒fc▒Q▒▒*▒jR▒▒▒P▒Ɋ▒▒KN\▒NY~<▒+▒▒Ż▒▒ͭ▒▒aj▒Lk▒▒ƄbB▒    ▒▒
▒\▒▒tm▒!iXK,▒▒gD▒Bp▒U▒B9▒▒|
                           ▒    ▒I▒▒▒|▒b▒w▒^!▒oH▒q▒▒B▒H
                                                       I`▒      }q▒h▒aߺSWH.▒▒{Ʋ▒Ư
 ▒K"▒▒&BR▒▒B[)▒[(▒
                  p▒gT' ▒▒▒;▒▒B▒Ż▒O▒g▒q▒▒Ż▒▒▒▒▒<▒i▒a~▒k*څ:g▒▒|Q▒n:Nq▒C▒C
                                                                        ▒n▒▒▒:▒ǝ▒▒*▒▒<▒▒▒Lx▒▒▒EG8N▒▒떜"▒o3▒▒▒VF▒J▒`O▒*▒+A▒9▒▒▒Y▒▒Z'|▒▒▒BBXi▒!R)%B▒Hb2BB@BH▒HaBRBB@R@aB!R▒BBR
@RHi▒!Ia%aBCB@AH▒HiBh▒X▒H▒HHASBB@APBh▒X▒CABV▒▒▒a▒7▒▒▒YZ▒▒▒▒▒▒>▒▒)▒_▒n▒ϩ▒▒w▒▒v▒/▒▒X▒▒?ky▒MW▒o6▒W▒▒▒:{▒▒q▒B(B▒+▒{"▒w>▒_▒Ô▒wJ▒▒h▒▒▒▒kQ▒▒kS▒▒▒Q▒(z▒▒▒▒▒kS▒▒KC▒▒=֦▒▒ʛ▒z▒6▒▒ʛ▒=֦▒▒S▒(c▒o▒V▒▒SG▒▒▒▒▒▒B   ▒▒;▒▒Oc▒▒▒X▒J▒▒▒▒m▒▒W\▒$▒t▒ZQʢG▒▒\▒U▒&|^▒▒(▒▒H▒]▒[C▒0+▒w▒KC▒▒i▒▒▒▒!cf▒H▒ZK▒-'e▒
                               ▒S▒▒e▒u▒v!▒▒▒▒߄m▒v!▒6▒▒q▒h▒▒▒i▒^kcC8▒4@▒▒6l[B8▒^pL▒cR▒%"▒=▒▒▒▒▒zRN7▒▒Eg▒▒>▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒ڭ▒O▒▒睕▒▒▒▒▒H'▒cH"X`|jaS▒▒0▒▒▒J▒▒�▒aoG▒▒▒_▒FL▒▒{Z!▒S 1LE2▒X▒1R▒)▒G▒$v{
I▒l▒aSB▒ ;$V)▒)▒S[f▒▒N▒ݨ▒p▒P8▒&▒▒c%76c▒▒▒▒▒N▒▒▒|jз▒=▒▒So▒EQ▒X6"▒)▒<▒N▒▒CCA▒rIa▒▒▒▒▒P▒▒9▒%▒cY▒▒|Q▒▒▒;▒▒ͭ▒▒aj▒lk▒▒ƄbB▒BB▒Wjc▒▒▒³▒$C▒▒
v▒▒▒i▒▒▒▒▒M▒m▒!mXK,▒▒gD▒Bp▒U▒B9▒▒|["y(▒▒▒|▒b▒w▒^!▒oH▒q▒▒B▒H
                                                           I`▒  }▒N▒iߺSWH.▒▒{Ƶ
                                                                              ▒▒▒̹<▒!▒▒z▒▒B[)▒[(▒
                p▒g'"▒▒▒;▒▒B▒Ż▒O▒g▒q▒▒Ż▒▒▒▒▒<▒i▒a~▒k*څ▒N▒▒ͭ"▒]▒m▒OUǖ9J▒▒▒▒▒▒8▒ǝ▒{bXߺv▒▒4▒:d▒~P3s▒i▒▒▒܋▒N▒W▒S▒▒▒,.▒"▒瞕T▒~▒▒P▒hkoo▒▒N▒▒▒Ɯ▒[o▒▒WW▒ؿ▒Ɯ▒[▒▒▒▒▒▒▒Ϫ▒\▒XX▒▒YS▒}c:^▒aRICPb▒RR)%BPBP▒H▒H0BB@R8▒H▒H▒H!▒
▒HCb
B▒B!▒BR!▒HC@H▒A▒CBCB@RX▒X▒X▒A▒S!▒HCBbbPH        h▒Ha▒▒▒4▒▒UC▒k▒1▒!m▒>▒▒▒▒m▒▒▒▒w▒▒▒▒▒P▒▒▒+▒R▒c▒OYh▒lw▒J
▒O▒▒N▒▒_@a▒wKk▒:▒c▒▒As(Rob▒h▒▒  KC▒▒z֦▒▒Q=C2▒z▒v▒KC▒▒z▒=֦▒▒ʛ▒z▒6▒▒▒KC▒▒z▒i.X▒▒V▒▒▒SG▒▒▒▒▒*J       ▒▒;▒▒|Ncc▒X▒▒▒▒fy6▒b▒▒U
▒▒▒eP▒F▒▒:▒^i#r▒▒       <%-R▒H▒o▒YXR▒▒3%▒z▒6▒cV▒▒}c▒[▒▒H▒▒N9Z▒e▒
                                                                ▒▒e▒▒'"▒e▒!▒▒ߧ>▒I▒▒#▒|▒v▒e2EeC3▒▒gf▒CJ▒e▒2▒m▒f▒▒BG▒L▒▒Rc▒L-▒▒C▒▒=▒▒▒_oa▒[▒▒i▒▒ ▒i▒z▒▒i▒▒▒kS▒▒B▒▒▒!▒7cg▒
b▒▒M▒▒Q▒▒S'"0▒▒k▒A▒▒▒KJOa▒▒a▒▒▒k▒C▒3L▒kD▒▒▒▒C▒k▒▒9▒▒▒ez▒▒q5▒▒▒▒▒O▒St▒▒o▒▒▒▒▒IM▒tw▒c▒▒▒▒<▒(SX^vS▒KB▒▒▒=▒O▒▒▒
                          ▒▒▒݈b▒▒3&▒�()M▒w▒▒▒▒

Donde está el problema? Solo conecto el GND, RX y TX

Salu2
« Última modificación: 06-05-2014, 18:56 (Martes) por Pteridium »

Pteridium

  • Visitante
Re: Dar soporte a ZTE MF10
« Respuesta #12 en: 06-05-2014, 18:55 (Martes) »
Hasta ahora solo he conseguido que me salgan garabatos...

Donde está el problema? Solo conecto el GND, RX y TX

Salu2
Ralink casi siempre pone el puerto serie a 57600 baudios en vez de 115200. Ten por seguro que lo hacen por mal.  ;D

vk496

  • Visitante
Re: Dar soporte a ZTE MF10
« Respuesta #13 en: 06-05-2014, 19:14 (Martes) »
Gracias. Mi problema era el speed, que lo dejaba en el por defecto (necesitaba el 115200)

Aquí os dejo el log (Tiene Uboot, eso me da buenas vibraciones  :D )

Código: [Seleccionar]
U-Boot 1.1.3 (Feb 26 2009 - 13:21:58)

Board: Ralink APSoC DRAM:  16 MB
relocate_code Pointer at: 80fac000
mips_cpu_feq=320000000
flash_protect ON: from 0xBF000000 to 0xBF0202E3
protect on 0
protect on 1
protect on 2
protect on 3
protect on 4
protect on 5
protect on 6
protect on 7
protect on 8
protect on 9
flash_protect ON: from 0xBF030000 to 0xBF03FFFF
protect on 10
*** Warning - bad CRC, using default environment

============================================
ZTE UBoot Version: 1.0.1
--------------------------------------------
ASIC 3052_MP2 (Port5<->None)
DRAM COMPONENT: 128Mbits
DRAM BUS: 16BIT
Total memory: 16 MBytes
Date:Feb 26 2009  Time:13:21:58
============================================
icache: sets:256, ways:4, linesz:32 ,total:32768
dcache: sets:128, ways:4, linesz:32 ,total:16384

freq = 320000000 MHZ

 ##### The CPU freq = 320 MHZ ####

SDRAM bus set to 16 bit
 SDRAM size =16 Mbytes
PHY0 and PHY1 are used ,and other PHYS are powered down


Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   9: Load Boot Loader code then write to Flash via TFTP.                     0

3: System Boot system code via Flash.
## Booting image at bf050000 ...
   Image Name:   Linux Kernel Image
   Created:      2009-12-10  13:52:52 UTC

 System Control Status = 0x00400000
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    3104704 Bytes =  3 MB
   Load Address: 80000000
   Entry Point:  802d5000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 802d5000) ...
## Giving linux memsize in MB, 16

Starting kernel ...


LINUX started...

 THIS IS ASIC
Linux version 2.6.21 (root@localhost.localdomain) (gcc version 3.4.2) #57 Thu Dec 10 08:52:33 EST 2009

 The CPU feqenuce set to 320 MHz
CPU revision is: 0001964c
Determined physical RAM map:
 memory: 01000000 @ 00000000 (usable)
Built 1 zonelists.  Total pages: 4064
Kernel command line: console=ttyS1,115200n8 root=/dev/mtdblock4
Primary instruction cache 32kB, physically tagged, 4-way, linesize 32 bytes.
Primary data cache 16kB, 4-way, linesize 32 bytes.
Synthesized TLB refill handler (20 instructions).
Synthesized TLB load handler fastpath (32 instructions).
Synthesized TLB store handler fastpath (32 instructions).
Synthesized TLB modify handler fastpath (31 instructions).
Cache parity protection disabled
cause = 9080000c, status = 1100ff00
PID hash table entries: 64 (order: 6, 256 bytes)
calculating r4koff... 00138800(1280000)
CPU frequency 320.00 MHz
Using 160.000 MHz high precision timer.
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Memory: 13116k/16384k available (2413k kernel code, 3268k reserved, 483k data, 120k init, 0k highmem)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
Time: MIPS clocksource has been installed.
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
squashfs: version 3.2-r2 (2007/01/15) Phillip Lougher
squashfs: LZMA suppport for slax.org by jro
io scheduler noop registered (default)
FLASH_API: MAN_ID=C2 DEV_ID=22CB SIZE=8MB
Ralink gpio driver initialized
spidrv_major = 217
HDLC line discipline: version $Revision: 1.1.1.1 $, maxframe=4096
N_HDLC line discipline registered.
Serial: 8250/16550 driver $Revision: 1.3 $ 2 ports, IRQ sharing disabled
serial8250: ttyS0 at I/O 0xb0000500 (irq = 37) is a 16550A
serial8250: ttyS1 at I/O 0xb0000c00 (irq = 12) is a 16550A
loop: loaded (max 8 devices)
rdm_major = 254
GDMA1_MAC_ADRH -- : 0x00000000
GDMA1_MAC_ADRL -- : 0x00000000
Ralink APSoC Ethernet Driver Initilization. v1.60  64 rx/tx descriptors allocated, mtu = 1500!
GDMA1_MAC_ADRH -- : 0x00000016
GDMA1_MAC_ADRL -- : 0x0026ed2b
PROC INIT OK!
PPP generic driver version 2.4.2
PPP BSD Compression module registered
NET: Registered protocol family 24
ralink flash device: 0x1000000 at 0xbf000000
Ralink SoC physically mapped flash: Found 1 x16 devices at 0x0 in 16-bit bank
 Amd/Fujitsu Extended Query Table at 0x0040
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
Creating 5 MTD partitions on "Ralink SoC physically mapped flash":
0x00000000-0x00030000 : "Bootloader"
0x00030000-0x00040000 : "Config"
0x00040000-0x00050000 : "Factory"
0x00050000-0x00140000 : "Kernel"
0x00140000-0x00800000 : "RootFS"
block2mtd: version $Revision: 1.1.1.1 $
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usbcore: registered new interface driver usbserial
drivers/usb/serial/usb-serial.c: USB Serial support registered for generic
usbcore: registered new interface driver usbserial_generic
drivers/usb/serial/usb-serial.c: USB Serial Driver core
drivers/usb/serial/usb-serial.c: USB Serial support registered for GSM modem (1-port)
usbcore: registered new interface driver option
drivers/usb/serial/option.c: USB Driver for GSM modems: v0.7.1
usbcore: registered new interface driver usb-pcm
drivers/usb/serial/usb-pcm.c: usb to pcm Driver: V2.4.20_uC0_1B12
nf_conntrack version 0.5.0 (128 buckets, 1024 max)
GRE over IPv4 tunneling driver
ip_tables: (C) 2000-2006 Netfilter Core Team, Type=Restricted Cone
TCP cubic registered
NET: Registered protocol family 1
NET: Registered protocol family 10
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
drivers/flash/flash_ioctl.c 538
drivers/flash/flash_ioctl.c 390
drivers/flash/flash_ioctl.c 396
drivers/flash/flash_ioctl.c 401
drivers/flash/flash_ioctl.c 415

DDNSPassword=simcard_roam=HT_MpduDensity=5PktAggregate=1CountryRegion=5wan_l2tp_user=l2tp_user
44444e5350617373776f72643d0073696d636172645f726f616d3d0048545f4d70647544656e736974793d3500506b744167677265676174653d3100436f756e747279526567696f6e3d350077616e5f6c3274705f757365723d6c3274705f7573657200

drivers/flash/flash_ioctl.c 440
drivers/flash/flash_ioctl.c 390
drivers/flash/flash_ioctl.c 396
drivers/flash/flash_ioctl.c 401
the [first:ff].[second:ff].[the last but one:ff].[last:ff], return
drivers/flash/flash_ioctl.c 390
drivers/flash/flash_ioctl.c 396
drivers/flash/flash_ioctl.c 401
the [first:ff].[second:ff].[the last but one:ff].[last:ff], return
drivers/flash/flash_ioctl.c 540
VFS: Mounted root (squashfs filesystem) readonly.
Freeing unused kernel memory: 120k freed
init started: BusyBox v1.12.1 (2009-12-10 08:42:55 EST)
starting pid 602, tty '': '/etc_ro/rcS'
Algorithmics/MIPS FPU Emulator v1.5
devpts: called with bogus options
mount: mounting none on /proc/bus/usb failed: No such file or directory
 * * * * * * * * *     * * * * * * * * * * *     * * * * * * * * *
 * * * * * * * * *     * * * * * * * * * * *     * * * * * * * * *
             * *               *   *             *   *
           * *                 *   *             *   *
         * *                   *   *             *   * * * * * * *
       * *                     *   *             *   * * * * * * *
     * *                       *   *             *   *
   * * * * * * * *             *   *             *   * * * * * * *
 * * * * * * * * *             * * *             * * * * * * * * *

  * *          *  * * * * *     * *        *     *            *
*     *      *            *    *   *      * *   * *         *
*     *    *             *    *     *    *   * *   *       *
* * *     * * *          *    *     *   *     *     *     * * *
*        *     *         *    *     *   *           *    *     *
*        *     *         *     *   *    *           *    *     *
*          * *           *      * *     *           *      * *
ralink_gpio SETPID_CDZERO
ralink_gpio statedect_pid.pid=612
ralink_gpio statedect_pid.use=1
RALINK_GPIO_SET_DIR_OUT cpu_to_le32(tmp)=dfbefe
 internet.sh
Password for 'admin' changed
/sbin/internet.sh: line 257: wc: not found
[: 0: unknown operand
lm: no version for "struct_module" found: kernel tainted.
config usb otg
dwc_otg: version 2.72a 24-JUN-2008
DWC_otg: Core Release: 2.66a
DWC_otg: Periodic Transfer Interrupt Enhancement - disabled
DWC_otg: Multiprocessor Interrupt Enhancement - disabled
DWC_otg: Using DMA mode
DWC_otg: Device using Buffer DMA mode
dwc_otg lm0: DWC OTG Controller
dwc_otg lm0: new USB bus registered, assigned bus number 1
dwc_otg lm0: irq 18, io mem 0x00000000
DWC_otg: Init: Port Power? op_state=1
DWC_otg: Init: Power Port (0)
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
insmod: bridge.ko: module not found
insmod: mii.ko: module not found
insmod: raeth.ko: module not found

phy_tx_ring = 0x009e6000, tx_ring = 0xa09e6000, size: 16 bytes

phy_rx_ring = 0x009e7000, rx_ring = 0xa09e7000, size: 16 bytes
GDMA1_FWD_CFG = 10000
ifconfig: ioctl 0x8913 failed: No such device
ifconfig: ioctl 0x8913 failed: No such device
ifconfig: ioctl 0x8913 failed: No such device
ifconfig: ioctl 0x8913 failed: No such device
ifconfig: ioctl 0x8913 failed: No such device
ifconfig: ioctl 0x8913 failed: No such device
ifconfig: ioctl 0x8913 failed: No such device
ifconfig: ioctl 0x8913 failed: No such device
ifconfig: ioctl 0x8913 failed: No such device
ifconfig: ioctl 0x8913 failed: No such device
ifconfig: ioctl 0x8913 failed: No such device
ifconfig: ioctl 0x8913 failed: No such device
ifconfig: ioctl 0x8913 failed: No such device
rmmod: rt2860v2_ap: No such file or directory
rmmod: rt2860v2_sta: No such file or directory
rt2860v2_ap: module license 'unspecified' taints kernel.
2860 version : 2.0.0.0 (Dec 10 2009)


=== pAd = c11f8000, size = 84120 ===

rmmod: nf_nat_pptp: No such file or directory
rmmod: nf_conntrack_pptp: No such file or directory
rmmod: nf_nat_proto_gre: No such file or directory
rmmod: nf_conntrack_proto_gre: No such file or directory
RX DESC a0b76000  size = 1024
1. Phy Mode = 9
2. Phy Mode = 9
3. Phy Mode = 9
MCS Set = ff 00 00 00 01
The primary RSNIE: c11fbcea, len = 22
0x0000 : 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02
0x0010 : 01 00 00 50 f2 02
zhaoyong isRadioOff==0
Main bssid = 00:26:ed:2b:40:24
The UUID Hex string is:2880288028801880a8800026ed2b4024
The UUID ASCII string is:28802880-2880-1880-a880-0026ed2b4024!
0x1300 = 00064380
insmod: 8021q.ko: module not found
BusyBox v1.12.1 (2009-12-10 08:42:55 EST) multi-call binary

Usage: ifconfig [-a] interface [address]

ifconfig: ioctl 0x8913 failed: No such device
brctl: bridge br0: No such device or address
iptables v1.4.0rc1: can't initialize iptables table `mangle': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.
device ra0 entered promiscuous mode
##### restore RT3052 to dump switch #####
switch reg write offset=14, value=5555
switch reg write offset=40, value=1001
switch reg write offset=44, value=1001
switch reg write offset=48, value=1001
switch reg write offset=4c, value=1
switch reg write offset=50, value=2001
switch reg write offset=70, value=ffffffff
switch reg write offset=98, value=7f7f
switch reg write offset=e4, value=0
device eth2 entered promiscuous mode
br0: port 2(eth2) entering learning state
br0: port 1(ra0) entering learning state
route: ioctl 0x890c failed: No such process
route: ioctl 0x890b failed: Invalid argument
br0: port 2(eth2) entering disabled state
br0: port 1(ra0) entering disabled state
br0: port 2(eth2) entering learning state
br0: port 1(ra0) entering learning state
ifconfig: ioctl 0x8914 failed: Cannot assign requested address
ifconfig: ioctl 0x8914 failed: Cannot assign requested address
/sbin/lan.sh: line 63: hostname: not found
Set: phy[0].reg[0] = 3900
Set: phy[0].reg[0] = 3100
Set: phy[1].reg[0] = 3900
Set: phy[1].reg[0] = 3100
Warning in PHY reset script
Warning in PHY reset script
Warning in PHY reset script
ifconfig: ioctl 0x8913 failed: No such device
killall rt2860apd 1>/dev/null 2>&1
iptables -F -t filter 1>/dev/null 2>&1
iptables -D FORWARD -j macipport_filter 1>/dev/null 2>&1
iptables -F macipport_filter 1>/dev/null 2>&1
iptables -D FORWARD -j web_filter  1>/dev/null 2>&1
iptables -F web_filter  1>/dev/null 2>&1
iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT
iptables -P FORWARD ACCEPT
iptables -t filter -N web_filter 1>/dev/null 2>&1
iptables -t filter -N macipport_filter 1>/dev/null 2>&1
iptables -t filter -A FORWARD -j web_filter 1>/dev/null 2>&1
iptables -t filter -A FORWARD -j macipport_filter 1>/dev/null 2>&1
iptables -A FORWARD -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu 1>/dev/null 2>&1
iptables -t filter -F INPUT
iptables -t filter -A INPUT -i ppp0 -p tcp --dport 80 -j DROP
iptables -t filter -A INPUT -i ppp0 -p icmp -j DROP
save index:0
iptables -t nat -D PREROUTING -j port_forward 1>/dev/null 2>&1
iptables -t nat -F port_forward  1>/dev/null 2>&1; iptables -t nat -X port_forward  1>/dev/null 2>&1
iptables -t nat -D PREROUTING -j DMZ 1>/dev/null 2>&1
iptables -t nat -F DMZ 1>/dev/null 2>&1; iptables -t nat -X DMZ  1>/dev/null 2>&1
iptables -t nat -N port_forward 1>/dev/null 2>&1; iptables -t nat -I PREROUTING 1 -j port_forward 1>/dev/null 2>&1
iptables -t nat -N DMZ 1>/dev/null 2>&1; iptables -t nat -I PREROUTING 2 -j DMZ 1>/dev/null 2>&1
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
ip_table: set wan_name=ppp0
echo 1 > /proc/sys/net/ipv4/ip_forward
ntp.sh
greenap.sh init
ddns.sh
route delete 239.255.255.250 1>/dev/null 2>&1
killall wscd 1>/dev/null 2>&1
killall -9 wscd 1>/dev/null 2>&1
iwpriv ra0 set WscConfMode=0 1>/dev/null 2>&1
iwpriv ra0 set WscConfMode=0 1>/dev/null 2>&1
killall -q klogd
killall -q syslogd
syslogd -C8 1>/dev/null 2>&1
klogd 1>/dev/null 2>&1
killall -q zebra
killall -q ripd
webs: Listening for HTTP requests at address 192.168.0.1
SG device open error, it is not a auto setup modem.
br0: topology change detected, propagating
br0: port 2(eth2) entering forwarding state
br0: topology change detected, propagating
br0: port 1(ra0) entering forwarding state
starting pid 1253, tty '/dev/ttyS1': '/bin/sh'


BusyBox v1.12.1 (2009-12-10 08:42:55 EST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

-> filename:options,path:/var/ppp/options
uaUserNameSvr:vodafone,uaPassWordLoc:vodafone
filename:wcdma_chat,path:/var/ppp/wcdma_chat
uaUserNameSvr:vodafone,uaPassWordLoc:vodafone
filename:pap-secrets,path:/var/ppp/pap-secrets
uaUserNameSvr:vodafone,uaPassWordLoc:vodafone
filename:chap-secrets,path:/var/ppp/chap-secrets
uaUserNameSvr:vodafone,uaPassWordLoc:vodafone
CreateSoftTimer index 0 success:
usTimerID = 4,
ucFlag = 1,
ulCurInterval = 25,
ulNextInterval = 25,
procCallBack = 0x00000000,
args = 0x00000000.
CreateSoftTimer index 1 success:
usTimerID = 1,
ucFlag = 1,
ulCurInterval = 25,
ulNextInterval = 25,
procCallBack = 0x00000000,
args = 0x00000000.
fac Server start
wait...
start accept......
mkdir: cannot create directory '/var/lock': File exists
mkdir: cannot create directory '/var/log': File exists

Edito: Me hará falta usar el puerto serie más veces y durante una mayor cantidad de tiempo? Es por saber si vale la pena soldar, porque es muy incómodo apuntar con agujas a los puertos  :P ;D

Salu2
« Última modificación: 06-05-2014, 22:38 (Martes) por vk496 »

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT en routers ZTE MF10
« Respuesta #14 en: 08-05-2014, 18:05 (Jueves) »
Estoy preparando un firm de prueba a ver si se puede poner a andar openwrt en él.
Lo que me preocupa es que sólo tiene 16MB de RAM; va a ir muy justito...

vk496

  • Visitante
Re: Re: [Desarrollo] OpenWRT en routers ZTE MF10
« Respuesta #15 en: 08-05-2014, 18:56 (Jueves) »
Ok, gracias por molestarte. A mi lo que me preocupa es que no tengo actualmente soldador, y es muy incomodo hacer posturas para acertar a los pines... Jajaja

Salu2

Enviado desde mi GT-I5800 usando Tapatalk 2


Pteridium

  • Visitante
Re: Re: [Desarrollo] OpenWRT en routers ZTE MF10
« Respuesta #16 en: 08-05-2014, 19:31 (Jueves) »
Ok, gracias por molestarte. A mi lo que me preocupa es que no tengo actualmente soldador, y es muy incomodo hacer posturas para acertar a los pines... Jajaja

Salu2

Enviado desde mi GT-I5800 usando Tapatalk 2
Para no tener que pelear con el puerto serie lee el primer post del ASL-26555 donde explica cómo meter openwrt usando un pendrive y poco más, aunque puede que los chinos no lo permitan:
https://foro.seguridadwireless.net/openwrt/nuevos-routers-de-telefonica/msg237269/#msg237269

vk496

  • Visitante
Re: [Desarrollo] OpenWRT en routers ZTE MF10
« Respuesta #17 en: 08-05-2014, 21:16 (Jueves) »
Al parecer desde la web no es posible configurar nada relacionado con el telnet. Sin embargo, yo no me rindo tan facilmente, teniendo en cuenta el gran interes que tienen los fabricantes en tener puertas traseras. Así qeu fuí a por el nmap, y... sorpresa sorpresa, tiene puerta trasera  ^-^ >:(

El puerto 4719 tiene corriendo "Busybox telnetd". Hace falta decir que las creedenciales son las que vienen de fábrica?  ;D

Código: [Seleccionar]
Starting Nmap 6.46 ( http://nmap.org ) at 2014-05-08 21:10 CEST
NSE: Loaded 118 scripts for scanning.
NSE: Script Pre-scanning.
Initiating ARP Ping Scan at 21:10
Scanning 192.168.0.1 [1 port]
Completed ARP Ping Scan at 21:10, 0.01s elapsed (1 total hosts)
Initiating Parallel DNS resolution of 1 host. at 21:10
Completed Parallel DNS resolution of 1 host. at 21:10, 13.00s elapsed
Initiating SYN Stealth Scan at 21:10
Scanning 192.168.0.1 [65535 ports]
Discovered open port 80/tcp on 192.168.0.1
Discovered open port 4719/tcp on 192.168.0.1
Discovered open port 3535/tcp on 192.168.0.1
Completed SYN Stealth Scan at 21:10, 16.85s elapsed (65535 total ports)
Initiating Service scan at 21:10
Scanning 3 services on 192.168.0.1
Completed Service scan at 21:12, 126.17s elapsed (3 services on 1 host)
Initiating OS detection (try #1) against 192.168.0.1
NSE: Script scanning 192.168.0.1.
Initiating NSE at 21:12
Completed NSE at 21:13, 30.11s elapsed
Nmap scan report for 192.168.0.1
Host is up (0.0012s latency).
Not shown: 65532 closed ports
PORT     STATE SERVICE VERSION
80/tcp   open  http    GoAhead httpd (WAP http config)
|_http-favicon: Unknown favicon MD5: F0990331A8F325ED616BEE55FFD6359D
|_http-methods: No Allow or Public header in OPTIONS response (status code 400)
|_http-title: Wireless Broadband Router
3535/tcp open  unknown
4719/tcp open  telnet  BusyBox telnetd
MAC Address: 00:26:ED:2B:40:24 (zte)
Device type: general purpose
Running: Linux 2.6.X
OS CPE: cpe:/o:linux:linux_kernel:2.6
OS details: Linux 2.6.13 - 2.6.32
Uptime guess: 0.005 days (since Thu May  8 21:05:45 2014)
Network Distance: 1 hop
TCP Sequence Prediction: Difficulty=195 (Good luck!)
IP ID Sequence Generation: All zeros
Service Info: Device: WAP

TRACEROUTE
HOP RTT     ADDRESS
1   1.23 ms 192.168.0.1

NSE: Script Post-scanning.
Read data files from: /usr/bin/../share/nmap
OS and Service detection performed. Please report any incorrect results at http://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 192.67 seconds
           Raw packets sent: 65555 (2.885MB) | Rcvd: 65551 (2.623MB)

EDITO:

Estando dentro del dispositivo, dejo estas cosas para añadir info:

Todos los comandos existentes:

Citar
[                    ethtool              lan.sh               ripd
[[                   expr                 lld2d                rm
ash                  facSvr               logger               rmmod
at                   firewall.sh          login                route
at-server            flash                logread              rt2860apd
ated                 free                 ls                   sed
automount.sh         global.sh            lsmod                sh
brctl                goahead              macgo                sigmon
busybox              gpio                 mainControl          sleep
cat                  greenap.sh           mii_mgr              startpppd
cdzero               grep                 mkdir                statedect
cfg                  halt                 mount                switch
chat                 ifconfig             mtd_write            syslogd
chkSvr               igmpproxy            nat.sh               telnetd
chpasswd             igmpproxy.sh         net2tty_dload.sh     test
chpasswd.sh          inadyn               net2tty_qxdm.sh      touch
close                init                 ntp.sh               ttyswitch
comgt                insmod               ntpclient            udhcpc
config-3g-ppp.sh     internet.sh          nvram_daemon         udhcpc.sh
config-dns.sh        iptables             nvram_get            udhcpd
config-igmpproxy.sh  ipupdown             nvram_set            upnp_xml.sh
config-l2tp.sh       iwconfig             ping                 upnpd
config-pppoe.sh      iwevent              poweroff             uptime
config-pptp.sh       iwgetid              pppd                 vconfig
config-udhcpd.sh     iwlist               pptp                 vi
config-vlan.sh       iwpriv               pptp.sh              vpn-passthru.sh
config.sh            iwspy                ps                   wan.sh
cp                   kill                 qos_run              wifi_unload.sh
daemon_zte           killall              radvd                wscd
date                 klogd                ralink_init          zebra
ddns.sh              l2tp-control         reboot               zte_wlan.sh
dnsmasq              l2tp.sh              reg
echo                 l2tpd                remserial

mount output:


Citar
-> mount
rootfs on / type rootfs (rw)
/dev/root on / type squashfs (ro)
proc on /proc type proc (rw)
none on /var type ramfs (rw)
none on /etc type ramfs (rw)
none on /tmp type ramfs (rw)
none on /media type ramfs (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw)

Free output:
Citar
-> free
              total         used         free       shared      buffers
  Mem:        13236        12304          932            0         1124
 Swap:            0            0            0
Total:        13236        12304          932

/dev:

Citar
video0     ttyUSB0    random     ptyp0      mtdblock3  mtd3       mem        flash0
urandom    ttyS1      ram3       pts        mtdblock2  mtd2ro     kmem       console
ttyp1      ttyS0      ram2       ptmx       mtdblock1  mtd2       i2cM0      acl0
ttyp0      swnat0     ram1       ppp        mtdblock0  mtd1ro     hwnat0     ac0
ttyUSB3    spiS0      ram0       null       mtd4ro     mtd1       gpio       PCM
ttyUSB2    sg0        ram        mtr0       mtd4       mtd0ro     flash2     I2S
ttyUSB1    rdm0       ptyp1      mtdblock4  mtd3ro     mtd0       flash1

Nota: Existe el comando mtd_write (buena señal), pero no consigo montar el USB, /ya he probado con mount /dev/ttyUSBX /media/hdd

Salu2
« Última modificación: 08-05-2014, 22:21 (Jueves) por vk496 »

vk496

  • Visitante
Re: [Desarrollo] OpenWRT en routers ZTE MF10
« Respuesta #18 en: 27-05-2014, 14:17 (Martes) »
He podido compilar el firmware basandome en la tabla de particiones del router, pero no me queda claro una cosa. Las imagenes generadas tras la compilación son:

Citar
openwrt-ramips-rt305x-zte-squashfs-sysupgrade.bin
openwrt-ramips-rt305x-vmlinux.elf
openwrt-ramips-rt305x-vmlinux.bin
openwrt-ramips-rt305x-root.squashfs
openwrt-ramips-rt305x-uImage.bin


Como saber cual tengo que usar desde el menu de upgrade del firwmare original?
Perdonen las preguntas de novato  ;D

Salu2

vk496

  • Visitante
Re: [Desarrollo] OpenWRT en routers ZTE MF10
« Respuesta #19 en: 25-06-2014, 23:09 (Miércoles) »
Antes de nada me gustaría agradecer a los guardianes del IRC #seguridadwireless, son unos auténticos máquinas.

Por cortesía de @Noltari, ya hay un firmware disponible (rev. 40878) para este modelo funcionando perfectamente, PERO no es el mas óptimo. Su limitada RAM le impide funcionar correctamente cuando se le activa el Wifi, va muy lento, se bloquea e incluso llega a reiniciarse.

De todas formas, el tema es que se ha conseguido instalarle OpenWRT. Solo falta encontrar una versión que se adapte a su hardware (Attitude Adjustment por ejemplo).

Para instalar el firmware, tenemos que configurar nuestra tarjeta de red a la IP 192.168.0.22, instalar tftpd-hpa (o cualquier otro servidor tftp) y tener acceso al serial port del router.

Los links de descarga están en el primer post.

Pasos a seguir:

  • Conectarse al serial port:
Código: [Seleccionar]
sudo screen -L /dev/ttyUSB0 115200Desde Windows lo podéis hacer con Putty

  • Encender el router y seleccionar la segunda opción del uBoot, darle a Y y tres veces a Enter a las preguntas que nos haga el asistente:

Código: [Seleccionar]
2: System Load Linux Kernel then write to Flash via TFTP.
 Warning!! Erase Linux in Flash then burn new one. Are you sure?(Y/N)
 Please Input new ones /or Ctrl-C to discard
        Input device IP (192.168.0.1) ==:

        Input server IP (192.168.0.22) ==:

        Input Linux Kernel filename () ==:test.bin

  • En una nueva terminal, configurar el servidor tftp

Editar archivo /etc/default/tftpd-hpa

Citar
# /etc/default/tftpd-hpa

TFTP_USERNAME="tftp"
TFTP_DIRECTORY="/var/lib/tftpboot"
TFTP_ADDRESS="192.168.0.22:69"
TFTP_OPTIONS="--secure"

  • Copiar el archivo openwrt-ramips-rt305x-mf10-squashfs-sysupgrade.bin a la ruta /var/lib/tftpboot y renombrar el fichero a test.bin

  • Volver a la terminal del serial port. Veremos que aparecen una T. Eso significa que está esperando al servidor. Lo que tenemos que hacer es reiniciar el servidor tftp con los comandos:

Código: [Seleccionar]
sudo service tftpd-hpa stop
Código: [Seleccionar]
sudo service tftpd-hpa start
Con esto empezará el flasheo, y en 2 min ya tendremos nuestro OpenWRT listo.

También dejo los backup de las particiones origianles del firmware por si acaso... Estaría bien que alguien me ayudase a reconstruir un firmware válido para flashear a partir de los distintas particiones (mtdX).

Salu2

//FINAL Y MÁS DOS RESPUESTAS