Autor Tema: Problema con DNS, no responde.  (Leído 17465 veces)

0 Usuarios y 1 Visitante están viendo este tema.

modsplay

  • Visitante
Problema con DNS, no responde.
« en: 01-04-2013, 13:33 (Lunes) »
Buenas,

intento conectar un router huawei hg556a con firm openwrt a un livebox 2 de orange, hasta ahora me iba pero ahora me encuentro que el livebox no suministra DNS (no se si me explico..), no se como puedo solucionarlo, he probado varias cosas y nada..alguna pista??
Es problema del huawei o del livebox??

Mil gracias de antemano!!

Saludos peña.



Chumpy

  • Visitante
Re: Problema con DNS, no responde.
« Respuesta #1 en: 01-04-2013, 13:45 (Lunes) »
Pues yo creo que no te explicas  :-\

modsplay

  • Visitante
Re: Problema con DNS, no responde.
« Respuesta #2 en: 01-04-2013, 16:41 (Lunes) »
Hola,
bueno.. lo dice el asunto, el servidor DNS del router principal (el conectado a internet) no responde.
Lo raro es que los demás dispositivos si que van bien (los conectados directamente al router principal) es el huawei que no tiene acceso a internet por que el servidor DNS no responde.

He reiniciado ambos, he mirado la configuración del openwrt del huawei y no se que modificar...no se como solucionarlo, tampoco encuentro alguna pista en st. google o es que no pregunto lo correcto...en fin, a ver si alguien tb le ha pasado esto y sabe que solución hay.

Gracias de nuevo.

Un saludo.

crislgga

  • Visitante
Re: Problema con DNS, no responde.
« Respuesta #3 en: 01-04-2013, 16:56 (Lunes) »
Hola,
bueno.. lo dice el asunto, el servidor DNS del router principal (el conectado a internet) no responde.
Lo raro es que los demás dispositivos si que van bien (los conectados directamente al router principal) es el huawei que no tiene acceso a internet por que el servidor DNS no responde.

He reiniciado ambos, he mirado la configuración del openwrt del huawei y no se que modificar...no se como solucionarlo, tampoco encuentro alguna pista en st. google o es que no pregunto lo correcto...en fin, a ver si alguien tb le ha pasado esto y sabe que solución hay.

Gracias de nuevo.

Un saludo.
Hola, lo primero de todo, ¿sabes realmente que es un servidor DNS, y que hace?, porque antes de echar la culpa a algo que nisiquiera sabes.
pues te lo explico, transforma los nombres de web(internet) "https://foro.seguridadwireless.net", por ejemplo, en nombres IP, por ejemplo "78.56.32.97", lo hace para que no tengas que recordar estos numeritos, ya que las palabras son mas faciles de recordar. Si tu huawei no tiene internet no es porque el DNS no responda, sino que no tienes acceso, directamente el fallo son la tabla de direccionamiento IP, DHCP, y/o IP del router en cuestion que quieres conectar a internet con OpenWRT, ya que "Probablemente" no has cambiado su IP, y tendras ambos router en la IP "192.168.1.1", y con sus servidores dhcp respectivamente encendidos, asi que te crea conflicto. Si me equivoco, corrigeme, y explica, y pon mas datos, ya que queremos ayuda, pero no ponemos datos en cuestión.
Saludos
« Última modificación: 01-04-2013, 17:00 (Lunes) por crislgga »

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2383
  • Prácticas precisas precisan práctica
Re: Problema con DNS, no responde.
« Respuesta #4 en: 01-04-2013, 17:02 (Lunes) »
Hola.

Conectate al router por telnet o ssh, ejecuta "cat /etc/config/network", y pega aquí el resultado, así será mas fácil ver lo que está fallando.

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

modsplay

  • Visitante
Re: Problema con DNS, no responde.
« Respuesta #5 en: 01-04-2013, 18:08 (Lunes) »
Hola, llevas razón...

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'type' 'bridge'
        option 'ifname' 'eth0'
        option 'proto' 'static'
        option 'netmask' '255.255.255.0'
        option 'nat' '1'
        option 'ipaddr' '192.168.0.1'

config 'interface' 'wlan'
        option '_orig_ifname' 'wlan0'
        option '_orig_bridge' 'false'
        option 'proto' 'static'
        option 'ipaddr' '192.168.1.251'
        option 'netmask' '255.255.255.0'
        option 'gateway' '192.168.1.1'
        option 'broadcast' '192.168.1.255'
        option 'dns' '192.168.1.1'


Ahí va, gracias.

PD: se lo que el DNS...pero tampoco soy un experto, y el mensaje de error que me da el win7 lo dice bien clarito: servidor dns no responde....gracias a los dos.
« Última modificación: 01-04-2013, 18:10 (Lunes) por modsplay »

crislgga

  • Visitante
Re: Problema con DNS, no responde.
« Respuesta #6 en: 01-04-2013, 18:52 (Lunes) »
¿haces bridge inalambrico?, es decir ¿coges internet a traves del wifi, y lo repartes por lan?
Si es asi, tienes que cambiar la interfaz wlan, a modo cliente, en option 'proto' 'static' del wlan, a "client"
Pero si quieres conectarlo por LAN con el livebox, debes cambiar la opcion "option 'ipaddr' '192.168.0.1'" de la parte de LAN, por una ip "192.168.1.X", diferente a la del livebox, que sera la 1.1

Es por si acaso, aunque windows es muy generico, en respuesta a tu configuracion, claro que no encuentra la DNS, ya que le indicas que sea el router, Livebox, es decir, la config que pones del equipo, ya sea dhcp, esta mal, ya que le dices por la wifi, que sea la 192.168.1.1, en modo AP(que se conecten al huawei), mientras que por LAN, dices que sea la 192.168.0.1
en tema de redes, ya que la DNS, indica que no encuentra el camino hacia el router, no es que no tengas internet, otra cosa seria si tienes la IP del equipo ese la pones automatica o manual, y que intervalo de IP coge, es decir la 192.168.1.X o 192.168.0.X,
Saludos
« Última modificación: 01-04-2013, 19:04 (Lunes) por crislgga »

modsplay

  • Visitante
Re: Problema con DNS, no responde.
« Respuesta #7 en: 01-04-2013, 19:11 (Lunes) »
Hola, gracias por tu info.

te cuento como está la red:

router principal con adsl Livebox2 con ip 192.168.1.1
router bridge huawei con dos interfaces: wlan (wifi) con ip 192.168.1.251...esta es la que se conecta con el livebox, que hasta ahora me iba bien...
hasta aqui una red...

la otra red es la lan con ip 192.168.0.1 (al ser dos interfaces, cada una esta en una red...) a esta lan va conectado un pc.

lo tengo asi por que no tengo antenas wifi, y hasta ahora usaba routers conectados por ethernet a los dispositivos y los routers por wifi a un AP que tengo conectado al livebox...hay una opcion que no conozco el nombre, que te permite conectar 2 o mas routers entre si, pero el livebox no la tiene y por eso añadi un AP (Punto de acceso wifi)

ahora tengo que irme, mirare lo que me has escrito despues...a ver si encontramos la solucion, espero que hayas entendido el esquema de red...un saludo y mil gracias por tu tiempo.

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2383
  • Prácticas precisas precisan práctica
Re: Problema con DNS, no responde.
« Respuesta #8 en: 01-04-2013, 20:21 (Lunes) »
Prueba con esta config:

Código: [Seleccionar]
config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'type' 'bridge'
        option 'ifname' 'eth0'
        option 'proto' 'static'
        option 'netmask' '255.255.255.0'
        option 'nat' '1'
        option 'ipaddr' '192.168.0.1'
        option 'dns' '8.8.8.8 8.8.4.4'

config 'interface' 'wlan'
        option 'proto' 'dhcp'

Después de guardar los cambios reinicia el router.

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

modsplay

  • Visitante
Re: Problema con DNS, no responde.
« Respuesta #9 en: 02-04-2013, 01:59 (Martes) »
Hola, gracias pero nada...
cuentame que entiendo un poco y no me he estudiado tu configuración...que tengo que tener en cuenta??

Mil gracias, saludos!!!

Chumpy

  • Visitante
Re: Problema con DNS, no responde.
« Respuesta #10 en: 02-04-2013, 02:43 (Martes) »
A ver si no aclaramos. Tu conexión a internet necesita de un servidor DNS para poder resolver las direcciones, es decir, para convertir los dominios, como google.es en direcciones ip XXX.XXX.XXX.XXX

En la configuración que has puesto el dns es 192.168.1.1, es decir, tu router livebox, que no es un servidor dns. En la modificación de geminis_deamon a sustituido este valor por 8.8.8.8 y 8.8.4.4 que son los DNS de google.

Si hay algún error yo no lo se, que de esto aún no controlo mucho.

Quizás deberías contarnos como tienes configurado el livebox, y si en los equipos conectados directamente al livebox tienes algún problema.

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2383
  • Prácticas precisas precisan práctica
Re: Problema con DNS, no responde.
« Respuesta #11 en: 02-04-2013, 03:15 (Martes) »
Hola, gracias pero nada...
cuentame que entiendo un poco y no me he estudiado tu configuración...que tengo que tener en cuenta??

Mil gracias, saludos!!!

Lo que tienes que tener en cuenta es que en el apartado "lan" tienes que tener configurada una ip diferente a la del router principal (el livebox), y un servidor dns cualquiera y una mascara de subred que tiene que ser la misma que la del livebox, y el partado "wan" en modo dhcp para que sea el livebox el que le asigne la dirección ip, dns y demás.

En principio con la config que te he puesto debería funcionar, pero claro también cuenta como tengas configuradas las reglas del firewall y como tengas configurado el router principal.

Es que no sabemos lo que has tocado y lo que no, y al estar a ciegas puede ser una locura dar con el problema.

Yo creo que lo mejor que puedes hacer es resetear la configuración tanto del router con Openwrt como del Livebox a los valores por defecto y seguir los pasos como se muestran aquí, y sin tocar nada mas: https://foro.seguridadwireless.net/openwrt/(tutorial)-modo-clienterepetidor-openwrt/

Tienes que seguir los pasos de la parte 1: Modo cliente enrutado (Routed Client Mode).

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

modsplay

  • Visitante
Re: Problema con DNS, no responde.
« Respuesta #12 en: 02-04-2013, 14:13 (Martes) »
Hola,

ya os digo que hasta ahora funcionaba, lo habia configurado bien ambos routers, es ahora que el DNS de Orange no responde...y a saber por que.

El livebox está bien configurado, de fábrica, vamos. Voy a seguir el tuto que me has pasado. Por cierto en la interface wlan le ponia ip estática e iba bien.

Y por cierto, creo que entretodos hemos aclarado el problema, pero desconocemos el por que no funciona, no creo que sea un lio el hilo, solo que desconocemos el fallo, que a mi parecer tiene que ser de la gente de Orange (los llamé y me comentaron que puede haber una incompatibilidad entre los routers, pero bueno...ya sabemos el nivel que tienen algunos técnicos...)

Gracias, os comento en breve.

modsplay

  • Visitante
Re: Problema con DNS, no responde.
« Respuesta #13 en: 02-04-2013, 14:45 (Martes) »
Hola de nuevo:

resetenado el huawei con openwrt y dejando la wlan en dhcp dinamico, windows no señala ningún erro en la conexión, pero no sale a internet...

reseteando el livebox2, el problema continua...

he desabilitado firewall en ambos

Ahora he probado con ip estatica en la wlan y dns 8.8.8.8 (que quizas aqui está la clave, en poner los de orange...)
Y nada...win7 no reconoce errores, pero no sale a internet...

Gracias de nuevo, algo hemos avanzado...un saludo

EDITO: para añadir más leña al fuego, en la pestaña de diagnostico del openwrt, él si que hace ping  ala web openwrt.org, el tracerouter muestra resultado, etc...ahora si que ya flipo, se me escapa este tema xabales...
« Última modificación: 02-04-2013, 14:59 (Martes) por modsplay »

crislgga

  • Visitante
Re: Problema con DNS, no responde.
« Respuesta #14 en: 02-04-2013, 15:03 (Martes) »
Una duda que tengo, aunque no tengas internet,
¿eres capaz de visualizar o acceder a dispositivos conectados al livebox, desde el huawei?, aunque esten en interfaces distintas, al menos se podria acceder, incluso desde el huawei a la config del livebox. SI no es asi, no es que no tengas internet es que no se ven ambos router

modsplay

  • Visitante
Re: Problema con DNS, no responde.
« Respuesta #15 en: 02-04-2013, 15:06 (Martes) »
Hola,

otra cosa que me di cuenta, que aunque funcione el acceso a internet, y los routers se vean, el livebox no responde a ping, y no puedo acceder a la configuracion del livebox desde el pc conectado al openwrt.

A tu pregunta, según la configuracion del openwrt, sí se ven...esto tampoco nunca lo he entendido, que aun viensose no responda a ping.
Hay tráfico entre los dos...

Añado que tb he colocado unas routas estaticas a ver que tal, y nada...

Vuelve a salir el error de win7: Servidor DNS no responde.

Un saludo.
« Última modificación: 02-04-2013, 15:11 (Martes) por modsplay »

crislgga

  • Visitante
Re: Problema con DNS, no responde.
« Respuesta #16 en: 02-04-2013, 17:16 (Martes) »
puedess hacer un ping desde el livebox al huawei, en este caso la ip sera del intervalo de 192.168.1.x, ya que al estar conectado al dhcp del livebox lleva una ip, hazlo con una herramienta de scaner de red como colasoft mac scanner, que hace un ping a todo el intervalo, y alguno contestara
« Última modificación: 02-04-2013, 18:45 (Martes) por crislgga »

modsplay

  • Visitante
Re: Problema con DNS, no responde.
« Respuesta #17 en: 03-04-2013, 12:46 (Miércoles) »
Ok, ahora lo pruebo...pero tiene tela el asunto..
Por cierto, uso ubuntu...
« Última modificación: 03-04-2013, 12:49 (Miércoles) por modsplay »