Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 1924401 veces)

0 Usuarios y 1 Visitante están viendo este tema.

anmorfe

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2900 en: 30-12-2016, 14:09 (Viernes) »
Hola:
Lo primero, me presento, soy Antonio y leyendo este post he aprendido todo lo (poco) que se de Openwrt y el router hg556a. Empecé utilizando el modo repetidor para una casa grande de tres plantas.  Me fui animando e instale transmisión con éxito. Ha caído en mis manos otro router igual y pensé en darle una utilidad distinta. Mi intención era colocarlo lejos del router que tiene Internet, conectarlo por WiFi como cliente a este, instalarle transmission, minidlna, samba y utilizarlo como un Nas para una raspberry con OSMC, de manera que descargo pelis al router y las veo directamente en la tele. Y aquí viene mi problema. No puedo acceder al router por WiFi, solo por cable, creo que el problema puede ser algo relacionado con el firewall, pero debe haber algo más. Si desactivo el firewall puedo acceder por WiFi mediante ssh  a la consola, pero no puedo acceder como disco de red. El rango en la Red lan por cable lo tengo puesto distinto al de la Red con Internet y en el mismo rango la Red principal con Internet y y la wan que conecta al hg556a con este.
Estoy perdido, no se que más toquetear ni como buscar la solución en el foro...  Un alma caritativa que me ayude?


« Última modificación: 30-12-2016, 14:20 (Viernes) por anmorfe »

Garcad

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2901 en: 02-01-2017, 21:47 (Lunes) »
@anmorfe

Prueba con la intefaz del navegador, Red > Cortafuegos.

En Wan aceptar entrada, salida y traspasar.

Dejalo como en la imagen de abajo y guarda cambios.

« Última modificación: 03-01-2017, 19:12 (Martes) por Garcad »

demonho

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2902 en: 17-01-2017, 21:40 (Martes) »
Hola a todos,

Gracias a este foro he aprendido algunas cosillas y he dado vida a un HG556a que estaba hace mucho guardado.

Ahora tengo Vodafone-ONO HFC 50Mb/5MB con router Technicolor TC7230, si alguno lo conoce sabrá que el wifi de este va muy mal, baja velocidad y señal poco estable.

La idea es usar el HG556a HG56BZRB Ver.A conectado por cable LAN al Techicolor y usarlo para dar Wifi 2.4 Gh y los otro 3 puertos RJ45 como SW.

He instalado la versión LEDE Reboot r1619 del 18/9 de pepexx HG556a tipo C.

Después de leer varios post he conseguido que funcione tal como queria, el problema que tengo es que conectado por wifi al HG556a la velocidad max que obtengo en el speedtest es de 28Mbps (justo al lado del router), eso si mucho más estable la grafica que con el Technicolor. Conectado a un RJ45 del HG556a obtengo los 50MB contratados.

¿Se puede mejorar la velocidad del wifi?


Gracias de antemano
« Última modificación: 17-01-2017, 21:43 (Martes) por demonho »

crislgga

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2903 en: 18-01-2017, 10:51 (Miércoles) »
Puede ser limitacion del wifi en el equipo o en el router que por defecto pone el modo G,54mbps en vez de N, 300Mbps 20/40
saludos

demonho

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2904 en: 18-01-2017, 21:22 (Miércoles) »
Puede ser limitacion del wifi en el equipo o en el router que por defecto pone el modo G,54mbps en vez de N, 300Mbps 20/40
saludos


En el router lo he configurado como N 40MHz y el link se establece con varios dispositivos a 144 Mbps pero con el speedtest no saco más de 28Mbps, como dije antes, por cable si que obtengo los 50Mbps de mi línea.

Puede ser limitación del Ralink o del firmware que uso?


Un saludo

crislgga

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2905 en: 18-01-2017, 23:59 (Miércoles) »
Si los tienes a 144mbps, ahi esta la cuestion, limitada por hardware, ya que N 40 debe dar 300 en los dispositivos, el cable olvidalo, no tiene limitacion mas que la del propio puerto, es el wifi
saludos

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2202
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2906 en: 19-01-2017, 08:21 (Jueves) »
Puede ser limitacion del wifi en el equipo o en el router que por defecto pone el modo G,54mbps en vez de N, 300Mbps 20/40
saludos


En el router lo he configurado como N 40MHz y el link se establece con varios dispositivos a 144 Mbps pero con el speedtest no saco más de 28Mbps, como dije antes, por cable si que obtengo los 50Mbps de mi línea.

Puede ser limitación del Ralink o del firmware que uso?


Un saludo

Si tan sólo uno de los dispositivos va más lento, toda la red irá más lenta. Incorpora los dispositivos uno a uno y mira cuál es el que va más lento.
Da igual que lo configures a 40Mhz, si tienes redes alrededor del canal que usas, no los va a alcanzar nunca por el tema de no interferir con las redes cercanas.


demonho

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2907 en: 19-01-2017, 15:51 (Jueves) »
Puede ser limitacion del wifi en el equipo o en el router que por defecto pone el modo G,54mbps en vez de N, 300Mbps 20/40
saludos


En el router lo he configurado como N 40MHz y el link se establece con varios dispositivos a 144 Mbps pero con el speedtest no saco más de 28Mbps, como dije antes, por cable si que obtengo los 50Mbps de mi línea.

Puede ser limitación del Ralink o del firmware que uso?


Un saludo

Si tan sólo uno de los dispositivos va más lento, toda la red irá más lenta. Incorpora los dispositivos uno a uno y mira cuál es el que va más lento.
Da igual que lo configures a 40Mhz, si tienes redes alrededor del canal que usas, no los va a alcanzar nunca por el tema de no interferir con las redes cercanas.



Nada, hice varias pruebas con diferentes equipos y sigo sin conseguir más de 28Mbps por wifi.

Me recomendais otro firmware para el HG556a chipset Ralink para mejorar esto??


Un saludo

pepexx

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2908 en: 20-01-2017, 09:43 (Viernes) »
Demonho,

En mi hg556a funciona sin problemas, pero si quieres descartar el firmware, puedes probar algún openwrt del primer mensaje del hilo. Coge el más moderno cuyo enlace siga activo. Si no hubiera ninguno, yo todavía conservo algunos en mi ordenador.

También puedes probar a desactivar firewall, qos y otros servicios que no sean necesarios.

Como ha dicho Tki2000, haz las pruebas siempre con un sólo equipo conectado al wifi y que sea un PC o portátil.

Saludos.

demonho

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2909 en: 21-01-2017, 08:12 (Sábado) »
Hol pepexx,

Tu firmware funciona perfectamente, solo es que no consigo por Wifi más de 28Mb en el speedtest (por cable consigo los 50Mb contratados)

He probado en firmware de Chaos Calmer 15.05 y parece que hay algún poco hasta los 30Mb pero nada más.

Lo que quisiera saber si es un límite del propio router/ratlink o es algo que se puede mejorar.

Un saludo

Garcad

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2910 en: 21-01-2017, 13:38 (Sábado) »
@demonho cuando se repite la señal de wifi a wifi, se divide la velocidad.

Una mitad de subida y otra mitad de bajada.

Salu2

pixapo

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2911 en: 22-01-2017, 00:01 (Domingo) »
Gracias PEPEXX, tu compilación lede para el hg556a funciona como la seda. Ahora estoy intentando instalar miniDLNA para compartir el disco USB con la smart TV, ya que con samba, el pc lo ve sin problemas pero la tele ni se entera. Sin embargo, ese paquete no aparece en los repositorios. Intenté instalar uno de Openwrt en local pero da un error de incompatibilidad ¿Alquien sabe cómo instalarlo?



















« Última modificación: 22-01-2017, 12:42 (Domingo) por pixapo »

pepexx

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2912 en: 25-01-2017, 15:12 (Miércoles) »
Hol pepexx,

Tu firmware funciona perfectamente, solo es que no consigo por Wifi más de 28Mb en el speedtest (por cable consigo los 50Mb contratados)

He probado en firmware de Chaos Calmer 15.05 y parece que hay algún poco hasta los 30Mb pero nada más.

Lo que quisiera saber si es un límite del propio router/ratlink o es algo que se puede mejorar.

Un saludo

Demonho,

Hasta donde yo sé, nunca he tenido velocidades tan bajas teniendo al hg556a como punto de acceso wifi y como clientes ordenadores o portátiles. Con tablets y móviles si me ha pasado, pero es por culpa de éstos y no del router.

¿Has probado a cambiar a un canal menos saturado (si lo hay)? A ver si vas a tener muchas interferencias de los vecinos.

Otra prueba que podrías hacer es ponerlo como cliente wifi del router Vodafone lo más cerca posible de éste y ver qué velocidad obtienes con un ordenador conectado por cable al hg556a.

¿Podrías poner unas capturas de las pestañas donde se configura el wifi?

Saludos.

pepexx

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2913 en: 25-01-2017, 15:18 (Miércoles) »
Gracias PEPEXX, tu compilación lede para el hg556a funciona como la seda. Ahora estoy intentando instalar miniDLNA para compartir el disco USB con la smart TV, ya que con samba, el pc lo ve sin problemas pero la tele ni se entera. Sin embargo, ese paquete no aparece en los repositorios. Intenté instalar uno de Openwrt en local pero da un error de incompatibilidad ¿Alquien sabe cómo instalarlo?

Pixapo,

El problema es que hasta ahora sólo ha habido versiones snapshot de lede y, como cambian cada día, siempre vas a tener incompatibilidad entre lo que quieras instalar y la versión del kernel con la que se compiló. Acabo de ver que, si no hay ningún problema, el día 30 van a sacar una versión release de lede (17.01). Cuando lo hagan, compilaré los firmware de los hg556a con esa versión, y así no habrá problemas al instalar los paquetes del repositorio.

Si no sacaran una versión release, no me importaría compilarte una nueva versión que incluya minidlna.

Saludos.
« Última modificación: 25-01-2017, 15:22 (Miércoles) por pepexx »

Jcperdi

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2914 en: 26-01-2017, 08:48 (Jueves) »
Hola buenos días, a ver si podéis echarme una mano, teniendo en cuenta que soy novatillo y no controlo la terminología técnica. Os comento mi problema.

Tengo Fibra Jazztel 200mb en router principal un ZTE f680, con 2 bandas 2.4 y 5G. Con test de velocidad por wifi en 2.4G me llegan 90mb. algo muy normal.
He configurado un router Huawei hg556a (Tipo C) como repetido wifi y con firm de openWrt conectado por wifi al principal por el canal 2.4G.
Funciona correctamente, me enlaza con el principal y me emite wifi.

¿Cual es el problema?
Que aunque tenga el router huawei pegando al ZTE cuando hago test de velocidad en el huawei, tanto por wifi como por cable a pc la velocidad que emite es de entre 14 y 19 mb. más menos simétricos.
¿Alguien sabría porqué estando a 5cm. uno del otro y saliendo del principal cerca de 100mb., el huawei sólo da en torno a 20mb. un tercio de la velocidad?

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2202
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2915 en: 26-01-2017, 09:31 (Jueves) »
Hola buenos días, a ver si podéis echarme una mano, teniendo en cuenta que soy novatillo y no controlo la terminología técnica. Os comento mi problema.

Tengo Fibra Jazztel 200mb en router principal un ZTE f680, con 2 bandas 2.4 y 5G. Con test de velocidad por wifi en 2.4G me llegan 90mb. algo muy normal.
He configurado un router Huawei hg556a (Tipo C) como repetido wifi y con firm de openWrt conectado por wifi al principal por el canal 2.4G.
Funciona correctamente, me enlaza con el principal y me emite wifi.

¿Cual es el problema?
Que aunque tenga el router huawei pegando al ZTE cuando hago test de velocidad en el huawei, tanto por wifi como por cable a pc la velocidad que emite es de entre 14 y 19 mb. más menos simétricos.
¿Alguien sabría porqué estando a 5cm. uno del otro y saliendo del principal cerca de 100mb., el huawei sólo da en torno a 20mb. un tercio de la velocidad?

Si los tienes tan cerca, usa un cable.
Al repetir por wifi pierdes la mitad de ancho de bancha, más lo que puedas perder por capacidad de procesamiento, por ser el router bastante más lento, más lo que puedas perder por eventuales interferencias. En wifi, todo son pérdidas.
Desde que se inventaron los PLC, para mí no existen las wifis, nada más que para poder configurar remotamente los "paratos".  ;)


Jcperdi

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2916 en: 26-01-2017, 20:44 (Jueves) »
Gracias Tki2000 por tus comentarios, cuando hablaba de la proximidad es porque en las pruebas lo he puesto al lado uno de otro, pero evidentemente, no estarán tan cerca ya que lo necesito para ampliar la cobertura wifi en mi casa. En este sentido no puedo conectarlos por cable, sólo por wifi, mi pregunta iba más en caminada hacia que : haciendo las pruebas de velocidad y estando pegados uno con el otro, ¿porqué me llega un tercio de la velocidad de emisión y si existe algún parámetro en openWrt que se pueda modificar para ganar velocidad de transferencia?

Muchas gracias igualmente por tu intención y tu comentario.
Un saludo.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2202
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2917 en: 26-01-2017, 21:48 (Jueves) »
Gracias Tki2000 por tus comentarios, cuando hablaba de la proximidad es porque en las pruebas lo he puesto al lado uno de otro, pero evidentemente, no estarán tan cerca ya que lo necesito para ampliar la cobertura wifi en mi casa. En este sentido no puedo conectarlos por cable, sólo por wifi, mi pregunta iba más en caminada hacia que : haciendo las pruebas de velocidad y estando pegados uno con el otro, ¿porqué me llega un tercio de la velocidad de emisión y si existe algún parámetro en openWrt que se pueda modificar para ganar velocidad de transferencia?

Muchas gracias igualmente por tu intención y tu comentario.
Un saludo.

La pérdida es por lo que te he dicho. Si quieres saber cuánto corresponde a la wifi, entonces engánchalo por cable y vuelve a probar. Seguramente te saldrá como el doble, o más. Si esa velocidad te es suficiente, entonces optaría por engancharlos por PLC, ya que es como si estuvieran conectados por un cable.


pixapo

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2918 en: 06-02-2017, 14:11 (Lunes) »
Hola PEPEXX. Parece que la versión sigue en RC1, por lo que, si pudieras añadir miniDLNA a la compilación actual te quedaría eternamente agradecido. Saludos.

pepexx

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2919 en: 07-02-2017, 20:55 (Martes) »
Voy a compilarlo. En cuánto lo tenga, te lo subo.

¿Que tipo es el hg556a que tienes?

Saludos.

« Última modificación: 07-02-2017, 21:00 (Martes) por pepexx »