?>/script>'; } ?> [Desarrollo] OpenWrt en Comtrend AR-5387un Widgets Magazine

Autor Tema: [Desarrollo] OpenWrt en Comtrend AR-5387un  (Leído 800081 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #480 en: 20-06-2013, 13:56 (Jueves) »
Ahora te entiendo. Pensé que tampoco podías 'ver' los ficheros  >:D

Abre WinSCP, conécta al router y desplázate hasta la carpeta /mnt. Ahora verás /sda1, pincha con el botón derecho del ratón sobre el y dale a propiedades. Marca en lectura, escritura y ejecución  'Propietario, Grupo y Otros' hasta que el Octal te quede como 0777

No es la mejor forma, ni más ortodoxa de hacerlo, pero ... así debería de funcionarte  ;)


jbconpepsi

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #481 en: 20-06-2013, 17:10 (Jueves) »
si claro los veo todos desde el princio me pide contraseña y user y todo correcto lo que no puedo es arastrar a ese pen o copiar a ase pen
por cierto lo del 3g esta resuelto tenia mal el numero #99 es el que tenia que estar y tenia este #99***1

oooooooooooooooooohh

Windows no puede escribir en ese formato
sera por eso  ??? ???
me parece que soy un poco tonto

pues si he montado ntfs y todo correcto

Siento la perdida de tiempo

mirare la impresora
¿Cómo miro el fichero  p910 ?

 :-\ :-\
 


Compi, Si pudieras compartir la compilación en la que te funciona el modem usb e173 y explicar como lo has hecho rular, muchos te lo agradeceríamos, yo el primero. Llevo inentándolo varios días para llevarme el router de vacaciones y poder aprovechar el pincho de jazztel y no ha habido manera de hacerlo funcionar.

Gracias y saludos.


javidecris

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #482 en: 20-06-2013, 20:02 (Jueves) »
jar229  >:( >:( >:( >:( >:( >:( >:(

Todo funcionando, router como ap, usb wifi como cliente
3g funcionando, test de velocidad 4 de bajada 0,25 de subida
memoria usb, por wifi perfecto me pide contraseña y puedo copiar pegar arrastrar etc

ahora me pongo con la impresora desde 0


jbconpepsi Claro que si lo subo a dropbox si se puede y pongo el enlace

desde luci crea una interface le llamas xxxxx

Protocol             UMTS/GPRS/EV-DO
Modem device    /dev/ tty/USB0        Ese es mi device puede ser otro USB1 USB2
APN    internet             Ese es el mio (yoig..) en tu caso puede ser otro  pones en googl.. APN y te salen al momento
PIN tu pin Yo para las pruebas se lo saque y no se si funciona con el porque no me acorde de colocarlo otra vez
PAP CHAP USERNAME igual que con apn
PAP CHAP pasdword lo mismo  

el apn y el pap chap son datos de la compañía que te da servicio

te dejo mi log yo utilice nano por que no sabia como se guardaba ni nada con vi
 

nano /etc/config/network
      
config 'interface' 'wan'
          option 'ifname' 'ppp0'
          option 'proto' '3g'
          option 'device' '/dev/ttyUSB1'
          option 'apn' 'internet'

este es el de movistar
config 'interface' 'wan'
          option 'ifname' 'ppp0'
          option 'proto' '3g'
          option 'pincode' '1234'
          option 'device' '/dev/ttyUSB4'
          option 'apn' 'movistar.es'
          option 'service' 'umts'
          option 'username' 'movistar'
          option 'password' 'movistar'

después yo no conseguía que funcionara casualidad encontré en la wiki de openwrt esto
es el numero de marcado si lla utilizaste el 3g en el ordenador esto te sonara al configurarlo
 
nano /etc/chatscripts/3g.chat

 OK      "ATD*99#"         este es el que tiene que poner

la compilación va perfecta en principio pero cuando configuras wifi como ap acuérdate marcar lan
en las que use no hacia falta pero aquí aun me pase unas orillas dale que te pego

« Última modificación: 20-06-2013, 20:17 (Jueves) por javidecris »

jbconpepsi

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #483 en: 20-06-2013, 20:55 (Jueves) »
Muchas gracias compi, en cuanto pongas el enlace de dropbox me pongo a trastear yo también.

Saludos.


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: Re: Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #484 en: 20-06-2013, 21:08 (Jueves) »



jbconpepsi Claro que si lo subo a dropbox si se puede y pongo el enlace



Por supuesto que puedes poner el enlace a tu compilación :)

Me alegro que ya tengas todo funcionando ;D

Enviado desde mi Cube U30GT


javidecris

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #485 en: 20-06-2013, 21:47 (Jueves) »
Aquí tienes el enlace:
jbconpepsicola
https://www.dropbox.com/s/bsvt06lgnnb7hc5/openwrt-96328A-1441N1-generic-squashfs-cfe.bin

se me olvido ponerle mount-block  y un par de cosillas
pero de momento todo perfecto

jar229 estoy con la impresora y tampoco funciona me pediste un log p910

como puedo mirarlo?
he puesto esta regla

 /etc/config/firewall

config 'rule'
        option 'src' 'lan'
        option 'proto' 'tcp'
        option 'dest_port' '9100'
        option 'target' 'ACCEPT'
pero nada

en el system log me pone esto
Jun 20 18:28:29 OpenWrt lpr.err p9100d[1215]: socket: Address family not supported by protocol

Jun 20 20:44:16 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory
Jun 20 20:44:16 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory, will try opening later
Jun 20 20:44:26 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory
Jun 20 20:44:26 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory, will try opening later
Jun 20 20:44:36 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory
Jun 20 20:44:36 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory, will try opening later
Jun 20 20:44:46 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory
Jun 20 20:44:46 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory, will try opening later
Jun 20 20:44:56 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory
Jun 20 20:44:56 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory, will try opening later
Jun 20 20:45:06 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory
Jun 20 20:45:06 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory, will try opening later
Jun 20 20:45:16 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory
Jun 20 20:45:16 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory, will try opening later
Jun 20 20:45:26 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory
Jun 20 20:45:26 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory, will try opening later
Jun 20 20:45:36 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory
Jun 20 20:45:36 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory, will try opening later
Jun 20 20:45:46 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory
Jun 20 20:45:46 OpenWrt lpr.err p9100d[1525]: /dev/lp0: No such file or directory, will try opening
graciñas ;) ;)

« Última modificación: 20-06-2013, 23:54 (Jueves) por javidecris »

victorperezmon

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #486 en: 21-06-2013, 10:45 (Viernes) »
Quizás no me he explicado bien no se

Yo lo que hago con la fonera es conectarse vía wireless al router principal.

Creo una interfaz virtual y después creo una red wireless con SSID y canal diferentes de la wifi principal.
A esta wifi se conectan los móviles portátiles etc

Además por las bocas RJ45 también hay internet.

Saludos

Te has explicado perfectamente  ;D

Y la respuesta sigue siendo la misma, este router NO puede actuar como repetidor wireless (sí como cliente wireless) a no ser que instalemos un pincho wifi usb.

Esa característica, la de crear un interfaz virtual, es sólo compatible con determinados chipsets wifi (que yo sepa, atheros en todos los casos, y algunos antiguos broadcom).

Buenas de nuevo.

Veamos tengo una wireless usb, Ovislink Evo-W300USB.

Concretamente lleva chipset RT3072L

Cabria la posibilidad de hacer lo que yo quiero con ese Wifi USB ????

Saludos...


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: Re: Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #487 en: 21-06-2013, 11:04 (Viernes) »
Aquí tienes el enlace:
jbconpepsicola
https://www.dropbox.com/s/bsvt06lgnnb7hc5/openwrt-96328A-1441N1-generic-squashfs-cfe.bin

se me olvido ponerle mount-block  y un par de cosillas
pero de momento todo perfecto

jar229 estoy con la impresora y tampoco funciona me pediste un log p910


Edita el fichero /etc/config/p910nd . En la línea option device pon '/dev/usb/lp0'
Reinicia el router y prueba.

Enviado desde mi Cube U30GT


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: Re: Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #488 en: 21-06-2013, 11:09 (Viernes) »
Quizás no me he explicado bien no se

Yo lo que hago con la fonera es conectarse vía wireless al router principal.

Creo una interfaz virtual y después creo una red wireless con SSID y canal diferentes de la wifi principal.
A esta wifi se conectan los móviles portátiles etc

Además por las bocas RJ45 también hay internet.

Saludos

Te has explicado perfectamente  ;D

Y la respuesta sigue siendo la misma, este router NO puede actuar como repetidor wireless (sí como cliente wireless) a no ser que instalemos un pincho wifi usb.

Esa característica, la de crear un interfaz virtual, es sólo compatible con determinados chipsets wifi (que yo sepa, atheros en todos los casos, y algunos antiguos broadcom).

Buenas de nuevo.

Veamos tengo una wireless usb, Ovislink Evo-W300USB.

Concretamente lleva chipset RT3072L

Cabria la posibilidad de hacer lo que yo quiero con ese Wifi USB ????

Saludos...

Sí. Deberías buscar una compilación que incluyera soporte para dicho chipset.
La 36114 del primer post debería valerte.

Enviado desde mi Cube U30GT


javidecris

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #489 en: 21-06-2013, 13:47 (Viernes) »
No hay manera por mucho que lo intente   :-[ :-[ :-[

 haber si ves algo fueron los logs que me parecieron a mi de la impresora

system log

Jun 21 09:03:11 OpenWrt kern.info kernel: [   43.480000] usblp 1-1.1:1.1: usblp0: USB Bidirectional printer dev 3 if 1 alt 0 proto 2 vid 0x04B8 pid 0x082E
Jun 21 09:03:11 OpenWrt kern.info kernel: [   43.488000] usbcore: registered new interface driver usblp

kernel log

[   13.336000] scsi 0:0:0:0: Direct-Access     EPSON    Stylus Storage   1.00 PQ: 0 ANSI: 2
[   43.480000] usblp 1-1.1:1.1: usblp0: USB Bidirectional printer dev 3 if 1 alt 0 proto 2 vid 0x04B8 pid 0x082E

[   43.488000] usbcore: registered new interface driver usblp


Para instalar la impresora en win uso esta configuracion

 *- Agregar Impresora
 *- Agregar Impresora Local
 *- Pulsa en  'Crear un nuevo puerto' 
 *- Selecciona  Standard TCP/IP Port 
 *-  Siguiente 
 *- Nombre del host o dirección IP: escribe la IP del router
 *- Nombre de puerto: dejar lo que está escrito
 *- Consultar impresora... marcado
 *- Pulsar en  Siguiente 
 *- Comienza a detectar puerto TCP/IP .. no encuentra nada y en la siguiente pantalla que salta pulsar en  Personalizado. 
 *- Pulsar en  Configuración 
 *- En el nombre del puerto escribe lo que quieras, ejemplo, Impresora Router.
 *- El resto déjalo igual y pulsa en Aceptar
 *- Salta pantalla y pulsa en Siguiente, Windows intenta comunicar con Impresora para detectar controlador...
 *- No lo encuentra y salta a pantalla de Instalar controlador Impresora, selecciona Marca y modelo.
 *- Usar el controlador recomendado o actualmente instalado y pulsar en Siguiente
 *- Escribir un nombre para la Impresora
 *- No compartir esta impresora.
 *- Siguiente
 *- Imprimir página de prueba.. y pulsa en finalizar.


Al darle a imprimir me pone esto

Epson: error de comunicacion

Compruebe todas las conexiones y asegúrese que todos los dispositivos estén encendidos.
Si se apagó durante la impresión, cancele el trabajo de impresión.
Si el error no desaparece, consulte la documentación de su impresora.

La impresora conectada al ordenador imprime sin problemas

Lo he probado por wifi y por cable en el router con openwrt

tengo el antivirus cerrado y el de windows también

Gracias




Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #490 en: 21-06-2013, 16:28 (Viernes) »
Ahora en el log, ya no aparece el error de /dev/lp0

Tienes habilitado el servicio?  Puedes verlo desde LuCi (en servicios).

Luego, cuando tenga un ordenador a mano, miro el proceso de instalación de la impresora con más calma.

Enviado desde mi U8500 usando Tapatalk 2


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #491 en: 21-06-2013, 23:00 (Viernes) »
Pues la verdad es que parece que lo has hecho de forma correcta.
Asegúrate de tener el servicio activado.
Y si puedes, prueba desde algún otro equipo.
No debería afectar pero ... desactiva temporalmente el firewall de windows.

Enviado desde mi Cube U30GT


javidecris

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #492 en: 22-06-2013, 00:37 (Sábado) »
 >:( >:( >:(
En primer lugar dar las gracias a jar229  y  a todo el equipo de seguridadwireless  sois de lo mejor

el problema con la impresora era una mezcla de pequeños detalles,
como dices la configuración estaba bien pero con algún detalle que otro
  Después de editar
 /etc/config/p910nd,  en la línea option device y poner   '/dev/usb/lp0'

seguía sin funcionar
me di cuenta que no tenia el servicio habilitado
lo habilite y nada después de un rato recordé que en la wifi no me funcionba si no ponía lan
y lo habilite y tachan todo funcionando

Después también comentar que Windows hace lo que quiere y a veces se pone tonto al conectarte y desconectar wifi o cable se queda pillado
y no te deja entrar en la impresora o en el usb
pero ahora mismo todo correcto

a partir de ahora estaré  mas liado pero mirare lo del escáner y en cuanto pueda subiré una compilación con las cosas que se me olvido poner
como mount block, etc
y una explicación de lo que tiene
y seguire trasteando

un detalle curioso en ie esta siempre en ingles y en chrome en español 
Sabeis por que?

 8) 8) 8) 8) 8) 8) 8) 8)

« Última modificación: 22-06-2013, 00:41 (Sábado) por javidecris »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #493 en: 22-06-2013, 10:37 (Sábado) »
Bien está lo que bien acaba ;D

Enviado desde mi Cube U30GT


swattsniper

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #494 en: 22-06-2013, 14:58 (Sábado) »
no va con el tema, pero es posible montar servidor web , mysql php en el propio openwrt.? ...
alguien sabe algún tuto ?

GRACIAS


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: Re: Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #495 en: 22-06-2013, 15:24 (Sábado) »
no va con el tema, pero es posible montar servidor web , mysql php en el propio openwrt.? ...
alguien sabe algún tuto ?

GRACIAS

Mírate el hilo del hg553. Algo hay ... :P

Enviado desde mi Cube U30GT


lavitz

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #496 en: 22-06-2013, 15:50 (Sábado) »
Hola, es posible poner este router con el openwrt que coja linea por un cable de red y la distribuya por su wifi?
Gracias y saludos


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: Re: Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #497 en: 22-06-2013, 17:00 (Sábado) »
Hola, es posible poner este router con el openwrt que coja linea por un cable de red y la distribuya por su wifi?
Gracias y saludos

Sí.
Pero ojo, que el driver WiFi aún no está 'pulido'.

Enviado desde mi Cube U30GT


c.arabaolaza

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #498 en: 22-06-2013, 23:55 (Sábado) »
hola, disculpen la simplicidad de la pregunta pero soy totalmente nuevo y nose como cargarle el firm a mi router, intente por web y me dice Image uploading failed. The selected file contains an illegal image. Como puedo hacer?


ruloalg

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #499 en: 23-06-2013, 05:52 (Domingo) »
hola, disculpen la simplicidad de la pregunta pero soy totalmente nuevo y nose como cargarle el firm a mi router, intente por web y me dice Image uploading failed. The selected file contains an illegal image. Como puedo hacer?


ip pc en rango (192.168.1.2 por ej) ; encender router con reset pulsado 15 seg aprox ; 192.168.1.1 en navegador ; cargar y esperar un par de minutos ;    (miniresumen)
si así no te sube algo falla

« Última modificación: 23-06-2013, 06:30 (Domingo) por ruloalg »