Autor Tema: [Desarrollo] OpenWrt en Comtrend AR-5381u  (Leído 140739 veces)

0 Usuarios y 1 Visitante están viendo este tema.

frankiii

  • Visitante
Re:
« Respuesta #220 en: 15-08-2014, 11:54 (Viernes) »
Definitivamente el paquete minidlna junto con su luci-app-minidlna no funciona con barrieron breaker en cualquiera de su versiones 14.0x

Alguien lo puede probar, quizás este ya loco y no atino jeje



Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2113
Re:
« Respuesta #221 en: 15-08-2014, 12:12 (Viernes) »
Definitivamente el paquete minidlna junto con su luci-app-minidlna no funciona con barrieron breaker en cualquiera de su versiones 14.0x

Alguien lo puede probar, quizás este ya loco y no atino jeje

Acaba de salir la rc3 de Barrier Breaker ¿por qué no pruebas ese repositorio?

http://downloads.openwrt.org/barrier_breaker/14.07-rc3/brcm63xx/generic/packages/

Desinstala lo anterior e instálalo de nuevo con ese repositorio.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

frankiii

  • Visitante
Re:
« Respuesta #222 en: 15-08-2014, 18:38 (Viernes) »
En el repo de la rc3 no está el paquete minidlna, solo el luci-app-minidlna así q lo he pillado de la rc2.
 
Mirando los procesos veo q tengo duplicado el minidlna, por lo q creo q por ahi vienen los tiros, tengo investigarlo.


frankiii

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #223 en: 18-08-2014, 14:46 (Lunes) »
vale ya está funcionando el servicio minidlna, lo que pasa es que se ha vuelto extremadamente lento en comparación como estaba con el firmare openwrt-96328A-1241N-generic-squashfs-cfe_r38342.bin

Lo seguiremos observando.

El paquete luci-app-minidlna, aunque no marca el total de ficheros que está compartiendo como servidor dlna el router, si que funciona para modificar los parámetros, accediendo al router con 192.168.1.4:8200 se pueden ver los ficheros compartidos (el total quiero decir).


chiribe

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #224 en: 06-09-2014, 12:34 (Sábado) »
He instalado una compilación de 14.04 de Noltari. Funciona todo correctamente, es más diria que mejor que en la r38342.

De todas maneras no me voy a librar de compilar el firm por mi mismo, necesito levantar un tunel pptp contra mi servidor y tengo problemas con las dependencias.

wolfox

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #225 en: 11-09-2014, 16:42 (Jueves) »
He instalado el firm del primer post, y efectivamente, no puedo acceder a traves del navegador a LuCi, solamente por ssh en consola.

Asi que he instalado el firm del compañero:
Buenas, te pongo los links para que descargues los firmwares:

Barrier-breaker-14.04
https://dl.dropboxusercontent.com/u/107584583/OPENWRT%20Comtrend%205381u/openwrt-AR-5381u-squashfs-cfe.bin

El cual no me detecta ningún wifi usb conectado Atheros ni RT2800USB. ¿Por que no lo detecta?
« Última modificación: 11-09-2014, 16:52 (Jueves) por wolfox »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2113
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #226 en: 11-09-2014, 17:39 (Jueves) »
He instalado el firm del primer post, y efectivamente, no puedo acceder a traves del navegador a LuCi, solamente por ssh en consola.

Asi que he instalado el firm del compañero:
Buenas, te pongo los links para que descargues los firmwares:

Barrier-breaker-14.04
https://dl.dropboxusercontent.com/u/107584583/OPENWRT%20Comtrend%205381u/openwrt-AR-5381u-squashfs-cfe.bin

El cual no me detecta ningún wifi usb conectado Atheros ni RT2800USB. ¿Por que no lo detecta?


Haz un opkg list-installed y mira si tienes los módulos
Código: [Seleccionar]
kmod-rt2800-usb
kmod-ath9k
Si no están es porque la imagen no tiene los drivers.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

wolfox

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #227 en: 11-09-2014, 17:45 (Jueves) »
He instalado el firm del primer post, y efectivamente, no puedo acceder a traves del navegador a LuCi, solamente por ssh en consola.

Asi que he instalado el firm del compañero:
Buenas, te pongo los links para que descargues los firmwares:

Barrier-breaker-14.04
https://dl.dropboxusercontent.com/u/107584583/OPENWRT%20Comtrend%205381u/openwrt-AR-5381u-squashfs-cfe.bin

El cual no me detecta ningún wifi usb conectado Atheros ni RT2800USB. ¿Por que no lo detecta?


Haz un opkg list-installed y mira si tienes los módulos
Código: [Seleccionar]
kmod-rt2800-usb
kmod-ath9k
Si no están es porque la imagen no tiene los drivers.

Pues lo dicho, no tiene los drivers instalados.
¿Como los puedo instalar desde LuCi? Pues en el buscador no aparecen.
Gracias.

frankiii

  • Visitante
Re:
« Respuesta #228 en: 14-09-2014, 17:34 (Domingo) »
Opkg update
Opkg install xxxxxx

Instalas los paquetes q te hagan falta

De de Luci entras en  sistemas - administración de programas
1. Actualizas
2. Buscas e instala el paquete

Me gusta más por telnet o por ssh q por luci, me suele dar menos problemaa

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2113
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #229 en: 14-09-2014, 18:36 (Domingo) »
Por luci te va a dar problemas de dependencias.
Lo tendrás que hacer por Telnet/SSH forzando dependencias y si la versión del kernel no es la adecuada, tendrás que cambiar los drivers de directorio para que te los reconozca el router: https://foro.seguridadwireless.net/openwrt/(tutorial)-como-intentar-instalar-paquetes-dependientes-del-kernel/
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

chiribe

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #230 en: 03-10-2014, 17:44 (Viernes) »
Han publicado la versión final, ¿se sabe si han corregido el problema del wifi? En uno de los post de Noltari dijo que en la rama trunk ya estaban implementados los parches.

chinchulin

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #231 en: 10-02-2015, 21:56 (Martes) »
Hola a todos!
Me he registrado en el foro porque creo que he brickeado este router y buscando en google he visto que en este post

Tengo un conector USB-jtag que compré hace un tiempo pero no he usado nunca y no tengo ni idea de cómo cargar el firm de este router para revivirlo. Seríais tan amables de darme unas directrices para hacerlo?

Gracias!

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2113
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #232 en: 11-02-2015, 09:27 (Miércoles) »
Hola a todos!
Me he registrado en el foro porque creo que he brickeado este router y buscando en google he visto que en este post

Tengo un conector USB-jtag que compré hace un tiempo pero no he usado nunca y no tengo ni idea de cómo cargar el firm de este router para revivirlo. Seríais tan amables de darme unas directrices para hacerlo?

Gracias!

No dices cómo lo has brickeado, ni qué es lo que le pasa. Tampoco dices si tenía openwrt instalado, o si es lo que quieres poner.
El router tiene una página de auxilio para subir nuevos firmwares al arrancar. Esta explicado en el primer post.
« Última modificación: 11-02-2015, 09:28 (Miércoles) por Tki2000 »
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

chinchulin

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #233 en: 11-02-2015, 10:24 (Miércoles) »
Hola otra vez. Muchas gracias por la rápida respuesta, Tki2000.

El router es de jazztel. Llevaba firm original y la cobertura WiFi era muy limitada, así que estaba intentando actualizarlo para ver si mejoraba algo. Bajé un par de firms cuyo nombre no recuerdo, eran "cocinados", no Wrt. Intenté instalar uno de ellos. En la pantalla del PC no aparecía ningún tipo de actividad. Esperé un rato y lo apagué. Cuando reinicié ya no conseguí acceder a él. Probé a mantener el reset pulsado al encenderlo y un par de veces no consecutivas dio señales de vida pero ahora ya sólo se quedan las luces parpadeando y no consigo hacer nada con él.
Le he soldado unos terminales a la placa para cargar un firm mediante jtag pero no lo he hecho nunca y no se como proceder. Os agradecería la orientación.

Gracias otra vez!

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2113
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #234 en: 11-02-2015, 17:58 (Miércoles) »
Hola otra vez. Muchas gracias por la rápida respuesta, Tki2000.

El router es de jazztel. Llevaba firm original y la cobertura WiFi era muy limitada, así que estaba intentando actualizarlo para ver si mejoraba algo. Bajé un par de firms cuyo nombre no recuerdo, eran "cocinados", no Wrt. Intenté instalar uno de ellos. En la pantalla del PC no aparecía ningún tipo de actividad. Esperé un rato y lo apagué. Cuando reinicié ya no conseguí acceder a él. Probé a mantener el reset pulsado al encenderlo y un par de veces no consecutivas dio señales de vida pero ahora ya sólo se quedan las luces parpadeando y no consigo hacer nada con él.
Le he soldado unos terminales a la placa para cargar un firm mediante jtag pero no lo he hecho nunca y no se como proceder. Os agradecería la orientación.

Gracias otra vez!

Si no te funciona la recuperación del primer post, yo probaría primero a soldar los pines del puerto serie y mirar qué "escupe" el CFE.
El pinout está aquí: http://wiki.openwrt.org/toh/comtrend/ar5381u
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

chinchulin

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #235 en: 11-02-2015, 18:30 (Miércoles) »
Hola. Ya tengo los hilos soldados así. Ahora no tengo ni idea de dónde o cómo lo tengo que conectar... :S

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2113
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #236 en: 13-02-2015, 12:09 (Viernes) »
Hola. Ya tengo los hilos soldados así. Ahora no tengo ni idea de dónde o cómo lo tengo que conectar... :S

He hecho un tutorial al respecto:
https://foro.seguridadwireless.net/openwrt/(tutorial)-puerto-serie-como-acceder/
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

chinchulin

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #237 en: 13-02-2015, 21:12 (Viernes) »
He hecho un tutorial al respecto:
https://foro.seguridadwireless.net/openwrt/(tutorial)-puerto-serie-como-acceder/

Gracias x 100.000!!! Lo leeré con detalle este finde!

chinchulin

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #238 en: 23-02-2015, 22:04 (Lunes) »
Hecho! Gracias por el tutorial. Esto es lo que escupe el router una y otra vez:


CFE version 1.0.37-106.5-9 for BCM96328 (32bit,SP,BE)
Build Date: 2010-12-20 22:52:56 (tony@broadcom_eu)
Copyright (C) 2000-2009 Broadcom Corporation.

HS Serial flash device: name MX25L128, id 0xc218 size 16384KB
Total Flash size: 16384K with 256 sectors
Chip ID: BCM6328B0, MIPS: 320MHz, DDR: 320MHz, Bus: 160MHz
Main Thread: TP0
Memory Test Passed
Total Memory: 67108864 bytes (64MB)
Boot Address: 0xb8000000

Board IP address                  : 192.168.1.1:ffffff00
Host IP address                   : 192.168.1.100
Gateway IP address                :
Run from flash/host (f/h)         : f
Default host run file name        : vmlinux
Default host flash file name      : bcm963xx_fs_kernel
Boot delay (0-9 seconds)          : 1
Boot image (0=latest, 1=previous) : 0
Board Id (0-5)                    : 96328A-1241N
Number of MAC Addresses (1-32)    : 11
Base MAC Address                  : xx:xx:xx:xx:xx:xx
PSI Size (1-64) KBytes            : 24
Enable Backup PSI [0|1]           : 0
System Log Size (0-256) KBytes    : 0
Main Thread Number [0|1]          : 0
Serial Number                     :
Default PSK key                   : xxxxxxxxxxxxxxxxxxxx

*** Press any key to stop auto run (1 seconds) ***
Auto run second count down: 0
Booting from latest image (0xb8010000) ...
Code Address: 0x80010000, Entry Address: 0x80292f40
Decompression OK!
Entry at 0x80292f40
Closing network.
Disabling Switch ports.
Flushing Receive Buffers...
0 buffers found.
Closing DMA Channels.
Starting program at 0x80292f40
Linux version 2.6.30 (lucien@localhost.localdomain) (gcc version 4.4.2

(Buildroot 2010.02-git) ) #3 Fri Oct 28 13:22:45 CST 2011
HS Serial flash device: name MX25L128, id 0xc218 size 16384KB
96328A-1241N prom init
CPU revision is: 0002a075 (Broadcom4350)
Determined physical RAM map:
 memory: 03f00000 @ 00000000 (usable)
Zone PFN ranges:
  DMA      0x00000000 -> 0x00001000
  Normal   0x00001000 -> 0x00003f00
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00003f00
On node 0 totalpages: 16128
free_area_init_node: node 0, pgdat 8031cf10, node_mem_map 81000000
  DMA zone: 32 pages used for memmap
  DMA zone: 0 pages reserved
  DMA zone: 4064 pages, LIFO batch:0
  Normal zone: 94 pages used for memmap
  Normal zone: 11938 pages, LIFO batch:1
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16002
Kernel command line: root=31:0 ro noinitrd console=ttyS0,115200
wait instruction: enabled
Primary instruction cache 32kB, VIPT, 4-way, linesize 16 bytes.
Primary data cache 32kB, 2-way, VIPT, cache aliases, linesize 16 bytes
NR_IRQS:128
PID hash table entries: 256 (order: 8, 1024 bytes)
console [ttyS0] enabled
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Memory: 60384k/64512k available (2595k kernel code, 4108k reserved, 533k data,

124k init, 0k highmem)
Calibrating delay loop... 319.48 BogoMIPS (lpj=159744)
Mount-cache hash table entries: 512
--Kernel Config--
  SMP=0
  PREEMPT=0
  DEBUG_SPINLOCK=0
  DEBUG_MUTEXES=0
Broadcom Logger v0.1 Oct 28 2011 13:07:23
net_namespace: 812 bytes
NET: Registered protocol family 16
Total Flash size: 16384K with 4096 sectors
registering PCI controller with io_map_base unset
registering PCI controller with io_map_base unset
bio: create slab <bio-0> at 0
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
pci 0000:00:09.0: reg 10 32bit mmio: [0x10002600-0x100026ff]
pci 0000:00:0a.0: reg 10 32bit mmio: [0x10002500-0x100025ff]
pci 0000:01:00.0: PME# supported from D0 D3hot
pci 0000:01:00.0: PME# disabled
pci 0000:02:00.0: reg 10 64bit mmio: [0x000000-0x003fff]
pci 0000:02:00.0: supports D1 D2
pci 0000:01:00.0: PCI bridge, secondary bus 0000:02
pci 0000:01:00.0:   IO window: disabled
pci 0000:01:00.0:   MEM window: 0x10f00000-0x10ffffff
pci 0000:01:00.0:   PREFETCH window: disabled
PCI: Enabling device 0000:01:00.0 (0000 -> 0002)
PCI: Setting latency timer of device 0000:01:00.0 to 64
BLOG v3.0 Initialized
BLOG Rule v1.0 Initialized
Broadcom IQoS v0.1 Oct 28 2011 13:09:14 initialized
NET: Registered protocol family 8
NET: Registered protocol family 20
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 2048 (order: 2, 16384 bytes)
TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
TCP reno registered
NET: Registered protocol family 1
squashfs: version 4.0 (2009/01/31) Phillip Lougher
squashfs: version 4.0 with LZMA457 ported by BRCM
fuse init (API version 7.11)
msgmni has been set to 117
io scheduler noop registered (default)
pcieport-driver 0000:01:00.0: device [14e4:6328] has invalid IRQ; check vendor

BIOS
PCI: Setting latency timer of device 0000:01:00.0 to 64
Driver 'sd' needs updating - please use bus_type methods
PPP generic driver version 2.4.2
PPP Deflate Compression module registered
PPP BSD Compression module registHELO
CPUI
L1CI
DRAM
----
PHYS
ZQDN
PHYE
DINT
LSYN
USYN
MSYN
LMBE
PASS
----
ZBSS
CODE
DATA
L12F
MAIN


Me gustaría utilizarlo como repetidor wifi. Qué firmware me recomendáis y cómo lo instalo?
Gracias!

Editado para borrar los datos del router
« Última modificación: 24-02-2015, 08:23 (Martes) por Tki2000 »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2113
Re: [Desarrollo] OpenWrt en Comtrend AR-5381u
« Respuesta #239 en: 24-02-2015, 08:51 (Martes) »
Hecho! Gracias por el tutorial. Esto es lo que escupe el router una y otra vez:

[...]

Me gustaría utilizarlo como repetidor wifi. Qué firmware me recomendáis y cómo lo instalo?
Gracias!


Se queda bloqueado a mitad del arranque, como si hubiera tenido un mal flasheo.
Yo que tú, probaría a quemar otro firmware con el método del CFE del primer post. Ahí tienes todo lo necesario, tanto para quemar openwrt, como para volver al firmware original.
Para utilizarlo como repetidor wifi, necesitarás un picho wifi, ya que la wifi interna es Broadcom, y no soporta el modo repetidor en openwrt. Aún así, el rendimiento va a ser bastante malo.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.