Autor Tema: Informe de posibles problemas y mejoras para wifislax-2.2  (Leído 2520 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15019
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #40 en: 02-10-2020, 15:54 (Viernes) »
vaya lio me haces liarme a mi tambien con los modulos y me haces dudar que coño estoy actualizando,
que ya habia terminado.

o sea que has dejado la 7.12??
a mi me salian 2 pero deje la 7.80 logico

si ya lei lo del bootinstall pero no lo probe ya me arranca

no hay modulos de nmap,  la final 2.2  lleva el paquete de slackware , asi quitaba el updater y menos royo que mantener.

los ficheros git peridos estan en el modulo pentest  ;) , creo que son de beef , no hacen da;o pero hacen feo en la raiz del sistema perdidos.  ;D



Desconectado Enol321

  • ****
  • Mensajes: 69
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #41 en: 03-10-2020, 17:23 (Sábado) »
lo 1º gran curro felicidades..........
2º no va bien en esta version de Fluxion no te deja entra....cuando le das a una de las opiones simpre sale lo de abajo una y otra vez


[~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~]
[                                                                                                                                          ]
[                                                 FLUXION 6.9    < Fluxion Is The Future >                                                 ]
[                                                                                                                                          ]
[~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~]


  • Seleccione un ataque inalámbrico para el punto de acceso


                                                    ESSID: "[N/A]" / [N/A]                                                                 
                                                  Channel:  [N/A]                                                                           
                                                    BSSID:  [N/A] ([N/A])                                                       

head: no se puede abrir '/usr/share/fluxion/attacks/*/language/es.sh' para lectura: No existe el fichero o el directorio
head: no se puede abrir '/usr/share/fluxion/attacks/Captive Portal/language/es.sh' para lectura: No existe el fichero o el directorio
head: no se puede abrir '/usr/share/fluxion/attacks/Handshake Snooper/language/es.sh' para lectura: No existe el fichero o el directorio
        [1] Captive Portal
        [2] Handshake Snooper
        [3] Atrás

[fluxion@wifislax64.example.net]-[~]

« Última modificación: 03-10-2020, 17:25 (Sábado) por Enol321 »

Desconectado waydehawai

  • *****
  • Mensajes: 150
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #42 en: 03-10-2020, 18:57 (Sábado) »
porque arrancas los programas desde desktop asinnn???
Código: [Seleccionar]
Exec=sh -c airgeddon;${SHELL:-bash}"

a la que le cambias de escritorio no funciona ni uno de los que arrancan asi se cierra la konsola,
esta vez no me digas que es por compatibilidad porque es al reves,

asi si funciona todo a lo normal de toda la piii vida lo que usas no es muy standard por eso peta
Código: [Seleccionar]
Exec=airgeddon;bash

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15019
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #43 en: 03-10-2020, 21:45 (Sábado) »
porque arrancas los programas desde desktop asinnn???
Código: [Seleccionar]
Exec=sh -c airgeddon;${SHELL:-bash}"

a la que le cambias de escritorio no funciona ni uno de los que arrancan asi se cierra la konsola,
esta vez no me digas que es por compatibilidad porque es al reves,

asi si funciona todo a lo normal de toda la piii vida lo que usas no es muy standard por eso peta
Código: [Seleccionar]
Exec=airgeddon;bash

siempre lo he hecho asi , si alguno se pone rebelde  ...

 ;D

Código: [Seleccionar]
TerminalOptions=-noclose
tambien puedes probar por ejemplo a xfce , no le gustan si los *.desktop , no estan marcados como ejecutable, o al reves,,   la orden al final es la misma , solo que yo uso la variable SHELL  , que si la usas en consola veras que te devuelve  SHELL=/bin/bash

Código: [Seleccionar]
echo $SHELL
« Última modificación: 03-10-2020, 22:15 (Sábado) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15019
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #44 en: 03-10-2020, 21:48 (Sábado) »
enol , efectivamente le faltan los idiomas ...  ;D ;D ;D

bajate este.


https://mega.nz/file/HlxFDQhS#w_0hDkc-xLalQCmW-nmqIvSWbHumaakH8Txj9O7Mgeg

Desconectado waydehawai

  • *****
  • Mensajes: 150
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #45 en: 05-10-2020, 02:16 (Lunes) »
el archivo que tienes en /usr/bin/ipscan
que casualmente llama a angry ipscan pone esto
Código: [Seleccionar]
#!/bin/sh
java -jar /usr/lib64/ipscan/ipscan-linux64-3.7.2.jar

asi queda mas limpio y te olvidas de versiones
Código: [Seleccionar]
#/bin/sh
java -jar /usr/lib64/ipscan/ipscan*.jar

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15019
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #46 en: 05-10-2020, 20:15 (Lunes) »
el archivo que tienes en /usr/bin/ipscan
que casualmente llama a angry ipscan pone esto
Código: [Seleccionar]
#!/bin/sh
java -jar /usr/lib64/ipscan/ipscan-linux64-3.7.2.jar

asi queda mas limpio y te olvidas de versiones
Código: [Seleccionar]
#/bin/sh
java -jar /usr/lib64/ipscan/ipscan*.jar

bien visto , modificare el script updater para que al empaquetarlo , lo renombre sin numero de version , buen punto este si.

En el fondo tampoco es algo grave, al fin y al cabo los empaqueta un script  , el tema de llamarlo ipscan , es por aprovechar el slack-desk  de slackbuilds, los actualizadores si estan configurados para empaquetar en txz, es como los paquetes originales de slackware , y si encuentran un slack-desk lo usan , aunque solo buscan en slackbuilds , es muy comodo para despues descomprimir y usar simplemente

Código: [Seleccionar]
upgradepkg
el script al final desde consola se llama igual ipscan , pero bueno , queda mas limpio y la version siempre va en  el paquete, no es necesraio mantenerla en el fichero jar.

no se si el desktop se genrara tambien al vuelo supongo , asi que podre separarlo como los otros si dejo el ejecutable sin version y no generar el desktop e icono a cada actualizacion.
« Última modificación: 05-10-2020, 20:53 (Lunes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15019
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #47 en: 05-10-2020, 22:23 (Lunes) »
pues ya esta , en lugar de mover el jar , tal cual se descarga , lo movemos con el name basico sin numeros. , a quedado supercorto

el icono , desktop y script en bin , ahora estan en el paquete starter y no se generan cada vez , buscando numeros ni nada raro.

https://raw.githubusercontent.com/wifislax-ng/wifislax64-updaters/master/2.2/Auditoria/ipscan_updater
« Última modificación: 05-10-2020, 22:32 (Lunes) por USUARIONUEVO »

Desconectado waydehawai

  • *****
  • Mensajes: 150
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #48 en: 21-10-2020, 02:53 (Miércoles) »
entre los modulos 030-Wifislax_Python y 010-SBo_Python hay algunos repetidos y distinta version,
easy_install, pip, netaddr y alguno mas

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15019
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #49 en: 21-10-2020, 05:37 (Miércoles) »
entre los modulos 030-Wifislax_Python y 010-SBo_Python hay algunos repetidos y distinta version,
easy_install, pip, netaddr y alguno mas

claro , lo de python3-netaddr , no te da pistas ?¿

python-netaddr-0.8.0-x86_64-1slackbuilds
python3-netaddr-0.7.19-x86_64-1wifislax

si algo esta mal te saldria con  pip chech , pip3 check
« Última modificación: 21-10-2020, 05:38 (Miércoles) por USUARIONUEVO »

Desconectado waydehawai

  • *****
  • Mensajes: 150
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #50 en: 21-10-2020, 14:48 (Miércoles) »
si algo esta mal te saldria con  pip chech , pip3 check
no te dicho que este mal solo que estan repetidos,
los del modulo 010-SBo_Python son las versiones antiguas deberian ser anikilados

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15019
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #51 en: 22-10-2020, 09:20 (Jueves) »
si algo esta mal te saldria con  pip chech , pip3 check
no te dicho que este mal solo que estan repetidos,
los del modulo 010-SBo_Python son las versiones antiguas deberian ser anikilados

no , veo que no entiendes nada , se usan los de sb0 y los que no dan soporte python3 los tengo que a;adir yo.

se complementan no puedes anikilar nada ,  los de python2  van  a /usr/lib64/python2.7   y los de python 3 a /usr/lib64/python3.7

Y ademas hay muchas otras buenas razones para mantenerlos en paquetes separados como hace arch ,una de ellas es tan simple como que alguno modulos python ya no reciben soporte para python2 , con lo que te debes quedar en el que tienes , sin embargo los que van para python3 tienen todos soporte.

Y aun rizando mas el rizo , puede ser que un proyecto python te pida una version exacta de un modulo ...

¿tu los quieres quitar? ..quitalos ,  ya te he sicho , pip check  y pip3 check son tus amigos ..


repetidos en mi pueblo seria

python-netaddr-sbo
python-netaddr-wifislax

pero el de sbo es solo python2 y el de wifislax es solo el de python3  , cuando en sbo , aun modulo le añaden el soporte de python3 , entonces empaqueta los dos en uno , y quito el mio , pero mientras tanto , si  necesito algo que no esta en sbo  , lo tengo que añadir yo , solo la parte que necesite.

asi que abogado ...

protesta denegada  ;D
« Última modificación: 22-10-2020, 09:23 (Jueves) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15019
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #52 en: 22-10-2020, 09:25 (Jueves) »
ademas fijate que es al reves ,el mio es mas viejo que el de sbo ... me suena que algo de python3 me pidio esa version exacta , es un coñazo cuadrar todo  lo de python.

pienso en como haciamos antes las cosas y no se como no reventabamos los pc de la peña jajaja
« Última modificación: 22-10-2020, 09:33 (Jueves) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15019
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #53 en: 22-10-2020, 09:31 (Jueves) »
de todas maneras entiendo lo que me quieres decir he  , que deberia dejar uno , con los soportes de los dos python , pero creeme, es mejor tenerlos separados , un claro ejemplo es pip , que para python2 ya no hay mas , asi que no puedes juntar pip y pip3 en el mismo paquete por que pip3 es el unico que recibe actualizaciones.

desde febrero que se supone que caducaba el python2 , muchos ya no tienen soporte y progresivamente desapareceran del todo , tenerlos en separado es mas curro , pero te permite mas control.
« Última modificación: 22-10-2020, 09:34 (Jueves) por USUARIONUEVO »

Desconectado waydehawai

  • *****
  • Mensajes: 150
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #54 en: 22-10-2020, 20:17 (Jueves) »
ya habias dicho algo asi sobre el tema ese yo no gestiono tanto por sbo,
aunque no salgan actualizaciones de pip2 siempre va bien cuando un programa de python 2 necesita algo,

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15019
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #55 en: 22-10-2020, 22:31 (Jueves) »
ya habias dicho algo asi sobre el tema ese yo no gestiono tanto por sbo,
aunque no salgan actualizaciones de pip2 siempre va bien cuando un programa de python 2 necesita algo,

aunque no lo gestiones por sbo , siempre es mejor separarlos , el setuptools pasa lo mismo , para python2 ya no hay actualizaciones, pero para python3 si , entonces no vas a empaquetar los dos juntos , ...dejas el de python2 en uno , ya sin actualizaciones y el otro en otro paquete python3-loquesea  , en la rama -current lo tienen asi tambien , de hecho patrick ,creo que ya lleva un tiempo intentado deshacerse del todo de python2 ,pero hay cosas como nmap , que no han migrado a python3..no se a que esperan la verdad  ;)

la ventaja de apoyarse en sbo , es que es como si un monton de gente trabajara para ti , ya que gestionan ellos los builds , y ya saben las dependencias y  los prueban ellos antes  , cuando yo necesito un modulo python , slapt-src  me lo compila e instala, con las dependencias y todo , eso es muy comodo , y con perl ya ni te cuento , que a veces hay 15 dependencias antes ...  en 1 minuto esta todo hecho  ;D


Insisto y aclaro , lo que hay en wifislax_python  ,  es por que no lo hay en SBo ,  y lo he necesitado añadir yo  , ya sea un paquete completo , o solo una de las partes python2 o python3

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15019
Re:Informe de posibles problemas y mejoras para wifislax-2.2
« Respuesta #56 en: 22-10-2020, 22:40 (Jueves) »
deberias confiar mas en SBo , los que llevan los paquetes saben muy bien lo que hacen , te muestro un ejemplo justo del que me ponias aqui , el python-netaddr  , y luego si miras el slackbuild , veras que no es tan facil como solo hacer setup.py install  , ...   ahora seguramente pensaras que con pip , ya esta todo arreglado , PERO NO , pip esta diseñado y pensado para instalar , ...  EMPAQUETAR es distinto , ya que envias el contenido a una ruta que no es un sistema ...

mira el build y veras cosas ,que son para que al empaquetar no pille la ruta del empaquetado ...
https://slackbuilds.org/repository/14.2/python/python-netaddr/

https://slackbuilds.org/slackbuilds/14.2/python/python-netaddr/python-netaddr.SlackBuild

yo lo de NEWDATA  , no lo meto nunca , pero  si lo metiera se corrige la ruta de instalacion ..
Código: [Seleccionar]
PYTHONPATH="." python netaddr/eui/ieee.py
o bien lo instalas con pip ,,, y luego pierdes un tiempo valioso , en desgranar que pertenece a ese paquete  y que no , y si has instalado varios con pip ya olvidate de tenerlos organizados.

yo lo tengo todo con sus logs, y empaquetados de uno en uno ,  antes era todo un desastre ahora esta todo bastante bien organizado , lo unico que me da pena es los paquetes base de slackware , que ya se van quedando viejos para muchas cosas , y la current aun tardara en llegar.
« Última modificación: 22-10-2020, 22:43 (Jueves) por USUARIONUEVO »