Autor Tema: Problema con el GRUB  (Leído 4634 veces)

0 Usuarios y 1 Visitante están viendo este tema.

recluta

  • Visitante
Problema con el GRUB
« en: 02-03-2014, 18:11 (Domingo) »
Tengo instalado wifislax y W7 y hasta ahora no he tenido ningún problema. Al iniciar arrancaba el grub y elegía con qué sistema iniciar. De pronto el portátil arranca directamente en W7, sin cargarse el grub. He comprobado el disco duro con el partition wizard y el wifislax sigue instalado en su partición. Alguna idea de qué está pasando y cómo volver a la normalidad?



Chumpy

  • Visitante
Re: Problema con el GRUB
« Respuesta #1 en: 02-03-2014, 19:27 (Domingo) »
Supongo que por alguna razón W7 habrá reinstalado su grub. Inicia con el LiveCD o LiveUSB de Wifislax y prueba a poner en consola update-grub, si no es suficiente, que es lo más probable, tendrás que volver a instalar el grub, se que se puede hacer desde alguno de los lanzadores del menú incio, pero ahora mismo no te lo puedo mirar y no recuerdo donde estaba.

papadelta196

  • Visitante
Re: Problema con el GRUB
« Respuesta #2 en: 05-03-2014, 22:04 (Miércoles) »
Hola buenas tengo un problemilla, pues he instalado wifislax 4.7.2 en un neetbook que tenia windows 7 pero ahora solo me arranca wifislax y no me sale para arrancar windows 7 me podeis ayudar???
no se como recuperar el arranque selectivo de los dos sistemas operativos

sol666

  • Visitante
Re: Problema con el GRUB
« Respuesta #3 en: 05-03-2014, 22:34 (Miércoles) »
Hola buenas tengo un problemilla, pues he instalado wifislax 4.7.2 en un neetbook que tenia windows 7 pero ahora solo me arranca wifislax y no me sale para arrancar windows 7 me podeis ayudar???
no se como recuperar el arranque selectivo de los dos sistemas operativos
pues si lo has instalado bien,es decir,que no te has cargao la particion donde esta win7 ejecuta desde wifislax en consola update-grub y reinicia a ver.

papadelta196

  • Visitante
Re: Problema con el GRUB
« Respuesta #4 en: 05-03-2014, 23:10 (Miércoles) »
acabo de ejecutar el comando que me dijiste y me sale
generando grub.cfg ...
tema encontrado: /boot/grub/themes/default/theme.txt
se encontro una imagen linux /boot/vmlinuz-3.12.0-wifislax
no volumen groups found
hecho
ahora arranca y se queda la pantalla negra

sol666

  • Visitante
Re: Problema con el GRUB
« Respuesta #5 en: 05-03-2014, 23:15 (Miércoles) »
pues me parece que te has cargao la particion de win7 porque solo te detecta la imagen de wifislax,te recomiendo que empieces de cero y de paso instalas la 4.8 que es mas reciente.

papadelta196

  • Visitante
Re: Problema con el GRUB
« Respuesta #6 en: 05-03-2014, 23:17 (Miércoles) »
he entrado en gparted y aun esta la particion de windows 7 y esta como boot

papadelta196

  • Visitante
Re: Problema con el GRUB
« Respuesta #7 en: 05-03-2014, 23:22 (Miércoles) »
ahora estoy dentro de gparted y tengo tres particiones
/dev/sda2 linux swap
/dev/sda1 ext wifislax
/dev/sda3 windows 7

Tengo recien instalado windows 7 me fastidiaria mucho tener que volver a instalarlo.

papadelta196

  • Visitante
Re: Problema con el GRUB
« Respuesta #8 en: 05-03-2014, 23:33 (Miércoles) »
JAJAJAJAJJA soy un grackkkkkk

ya lo solucione yujjjuuuu

Por si le puede servir a alguien hice lo siguiente

entre en gparted
Quite la particion de windows 7 como boot
monte la imagen de windows 7
y luego en una shell puse update-grub
reinicie

y se hizo la magia

saludidos y gracias por vuestra colavoravion

sol666

  • Visitante
Re: Problema con el GRUB
« Respuesta #9 en: 05-03-2014, 23:34 (Miércoles) »
la swap no es necesaria a menos que el pc tenga poca ram,yo tengo las particiones asi en este orden,a lo mejor es por eso por lo que no te va bien,a ver si alguien te da una segunda opinion.

/dev/sda1 ntfs Reservado para el sistema 100 mb

/dev/sda2 nfts win7

/dev/sda3 ext4 wifislax

sol666

  • Visitante
Re: Problema con el GRUB
« Respuesta #10 en: 05-03-2014, 23:36 (Miércoles) »
JAJAJAJAJJA soy un grackkkkkk

ya lo solucione yujjjuuuu

Por si le puede servir a alguien hice lo siguiente

entre en gparted
Quite la particion de windows 7 como boot
monte la imagen de windows 7
y luego en una shell puse update-grub
reinicie

y se hizo la magia

saludidos y gracias por vuestra colavoravion

me alegro que lo hayas solucionado,yo de ti instalaria la 4.8,primero probandola en liveusb claro.

papadelta196

  • Visitante
Re: Problema con el GRUB
« Respuesta #11 en: 05-03-2014, 23:38 (Miércoles) »
no toque las particiones las deje tal cual te dije pero ahora ya he podido arrancar windows 7.
Te agradezco tu ayuda
antes estaba muy metido en estos temas pero llevo casi 3 años que no los toco y voy algo perdido.

papadelta196

  • Visitante
Re: Problema con el GRUB
« Respuesta #12 en: 05-03-2014, 23:40 (Miércoles) »
hay mucha diferencia con la de wifislax 4.7.2
No la quise instalar porque ley que aun no estaba acabada y daba algunos errores

zorionak

  • Visitante
Re: Problema con el GRUB
« Respuesta #13 en: 17-03-2014, 12:21 (Lunes) »
Hay que tener montadas las particiones antes de hacer el update-grub, para que las reconozca

//FINAL Y MÁS DOS RESPUESTAS