Autor Tema: Problema al instalar wifislax en hdd. (Solucionado)  (Leído 17912 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2383
  • Prácticas precisas precisan práctica
Re: Problema al instalar wifislax en hdd.
« Respuesta #20 en: 19-09-2013, 17:41 (Jueves) »
Terminare tirando el portatil por la ventana o formateando el hdd entero y cogiendolo pa guardar episodios de "un pais en la mochila"...al hacer lo q me dices me arroja:

chattr: No existe el fichero o el directorio mientras se intentaba ver el estado del fichero /mnt/sdxx/boot/grub/i-386pc.core.img

Esto ya mas q informatica parece IV milenio...

Pero hombre, donde pone sdxx tienes que poner el disco donde tienes instalado Wifislax...



La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Canfoxinho

  • Visitante
Re: Problema al instalar wifislax en hdd.
« Respuesta #21 en: 19-09-2013, 17:49 (Jueves) »
Eso hago Geminis lo he hecho en todas las particiones desde sda1 a sda 9 y me arroja lo mismo.

Creo q es un problema d permisos ya q accedo desde el buscador d archivos e intento cambiar los permisos a lectura y escritura y no me deja.




« Última modificación: 19-09-2013, 18:05 (Jueves) por Canfoxinho »

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2383
  • Prácticas precisas precisan práctica
Re: Problema al instalar wifislax en hdd.
« Respuesta #22 en: 19-09-2013, 18:18 (Jueves) »
Ok culpa mía, sorry.

El comando correcto es este:
Código: [Seleccionar]
chattr -i /mnt/sda9/boot/grub/i386-pc/core.img

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Canfoxinho

  • Visitante
Re: Problema al instalar wifislax en hdd.
« Respuesta #23 en: 20-09-2013, 12:44 (Viernes) »
Hecho, y ya no me arranco windows nunca mas hasta q ejecute un BOOTREC/FIXMBR desde la consola d recuperacion del sistema...despues instale el grub de ubuntu y todo como estaba al principio, estoy planteandome seriamente utilizar wifislax en live usb con persintent changes redireccionando las carpetas al hdd. No puedo entender q ocurre con mi sistema.

Por si sirve de algo tengo un Acer Extensa con 4gb d ram y 500gb de hdd con grafica NVIDIA.
« Última modificación: 20-09-2013, 13:03 (Viernes) por Canfoxinho »

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2383
  • Prácticas precisas precisan práctica
Re: Problema al instalar wifislax en hdd.
« Respuesta #24 en: 20-09-2013, 13:16 (Viernes) »
No entiendo muy bien lo que dices. Conseguiste instalar el grub de Wifislax pero no arrancaba windows? o después de ejecutar ese comando intentaste arrancar windows directamente? no se.. da un poco de información de lo que has hecho, que errores te has encontrado..

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Canfoxinho

  • Visitante
Re: Problema al instalar wifislax en hdd.
« Respuesta #25 en: 20-09-2013, 13:32 (Viernes) »
Hice lo ultimo q comentaste y ejecute la instalacion del grub, cuando arranque tampoco me salia wifislax, entre en ubuntu y ejecute un update-grub y aunque enumero la particion con wifislax a la hora d arrancar no aparecia enumerada en la lista d particiones arrancables...despues intente entrar en windows y me salia q no podia arrancar ...ejecute reparacion d inicio y me decia q mirara q hardware nuevo habia instalado q era imposible arreglar el arranque de windows....entre en consola d recuperacion y quite el grub ejecutando un BOOTREC/FIXMBR...quedando el arranque de win7 unicamente, luego con un pendrive con una live d ubuntu instale y actualice el grub y todo esta como al principio...particiones de windows ubuntu y backtrack accesibles desde el grub y wifislax missng.

alist3r

  • Visitante
Re: Problema al instalar wifislax en hdd.
« Respuesta #26 en: 20-09-2013, 15:52 (Viernes) »
como podeis llegar a complicar algo tan sencillo?
he intentado leerme repetidas veces este hilo, y no entiendo nada todavia.
jopetasssss

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2383
  • Prácticas precisas precisan práctica
Re: Problema al instalar wifislax en hdd.
« Respuesta #27 en: 20-09-2013, 16:40 (Viernes) »
como podeis llegar a complicar algo tan sencillo?
he intentado leerme repetidas veces este hilo, y no entiendo nada todavia.
jopetasssss

Pues lo que pasa es que al instalar el grub y reiniciar no le sale la entrada de wifislax en el menú del grub.

Y yo estoy convencido de que el problema es que el kernel de Wifislax no está en su sitio, porque cuando el kernel no está en su sitio, el script que se encarga de crear los menús de arranque del grub piensa que en esa partición no hay ningún sistema operativo.

Es lógico, si no hay kernel no hay ningún sistema y por lo tanto no creo ninguna entrada en el grub.

@Canfoxinho Creo que no has seguido bién este paso: https://foro.seguridadwireless.net/live-wifislax/problema-al-instalar-wifislax-en-hdd/msg288041/#msg288041

Donde están las x tienes que poner los números que corresponden tanto a la versión del kernel (que lo puedes saber ejecutando "uname -r") como el número de partición.

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Canfoxinho

  • Visitante
Re: Problema al instalar wifislax en hdd.
« Respuesta #28 en: 20-09-2013, 17:34 (Viernes) »
como podeis llegar a complicar algo tan sencillo?
he intentado leerme repetidas veces este hilo, y no entiendo nada todavia.
jopetasssss

Pues lo que pasa es que al instalar el grub y reiniciar no le sale la entrada de wifislax en el menú del grub.

Y yo estoy convencido de que el problema es que el kernel de Wifislax no está en su sitio, porque cuando el kernel no está en su sitio, el script que se encarga de crear los menús de arranque del grub piensa que en esa partición no hay ningún sistema operativo.

Repasando el post, he de decirte Geminis q tienes toda la razon, debido a mi ofuscamiento de ayer el paso q señalas lo hice tal cual sin sustituir las x por la version del kernel. T pido disculpas por la perdida de tiempo en algo tan sencillo y q excuses mi inexperiencia ya q el nivel de frustracion aumulado ayer me propicio comneter dicho error...Todo instalado correctamente y muchas gracias, no todos los dias uno puede intentar resolver el problema q le acarrea cualquier tipo de aplicacion o software directamente con el creador.

Es lógico, si no hay kernel no hay ningún sistema y por lo tanto no creo ninguna entrada en el grub.

@Canfoxinho Creo que no has seguido bién este paso: https://foro.seguridadwireless.net/live-wifislax/problema-al-instalar-wifislax-en-hdd/msg288041/#msg288041

Donde están las x tienes que poner los números que corresponden tanto a la versión del kernel (que lo puedes saber ejecutando "uname -r") como el número de partición.

Todo es como lo has descrito, ayer motivado por la frustracion cometi el error q señalas, t pido disculpas por la perdida de tiempo q t haya podido acarrear geminis, y espero q disculpes mi inexperiencia. Muchas gracias a todos.
« Última modificación: 20-09-2013, 17:38 (Viernes) por Canfoxinho »

alist3r

  • Visitante
Re: Problema al instalar wifislax en hdd.
« Respuesta #29 en: 20-09-2013, 17:39 (Viernes) »
como podeis llegar a complicar algo tan sencillo?
he intentado leerme repetidas veces este hilo, y no entiendo nada todavia.
jopetasssss

Pues lo que pasa es que al instalar el grub y reiniciar no le sale la entrada de wifislax en el menú del grub.

sin duda. la carpeta /boot no está en su sitio. seguro.

Y yo estoy convencido de que el problema es que el kernel de Wifislax no está en su sitio, porque cuando el kernel no está en su sitio, el script que se encarga de crear los menús de arranque del grub piensa que en esa partición no hay ningún sistema operativo.

Es lógico, si no hay kernel no hay ningún sistema y por lo tanto no creo ninguna entrada en el grub.

@Canfoxinho Creo que no has seguido bién este paso: https://foro.seguridadwireless.net/live-wifislax/problema-al-instalar-wifislax-en-hdd/msg288041/#msg288041

Donde están las x tienes que poner los números que corresponden tanto a la versión del kernel (que lo puedes saber ejecutando "uname -r") como el número de partición.

tambien me llama la atención cómo ha llegado un disco duro a tener sda9. corregidme si me equivoco:


sda1 system (boot) de windows vista/7/8
sda2 data de windows vista/7/8
sda3 OEM recovery de windows vista/7/8
sda4 extended (contenedor de las unidades lógicas)

vale, pero ¿y ahora? de sda5 a sda9 son 5 unidades lógicas.
Quizás habéis separado el directorio raíz, /boot, /usr, /home y la swap? porque son un montón de unidades lógicas


Canfoxinho

  • Visitante
Re: Problema al instalar wifislax en hdd.
« Respuesta #30 en: 20-09-2013, 17:45 (Viernes) »
como podeis llegar a complicar algo tan sencillo?
he intentado leerme repetidas veces este hilo, y no entiendo nada todavia.
jopetasssss

Pues lo que pasa es que al instalar el grub y reiniciar no le sale la entrada de wifislax en el menú del grub.

sin duda. la carpeta /boot no está en su sitio. seguro.

Y yo estoy convencido de que el problema es que el kernel de Wifislax no está en su sitio, porque cuando el kernel no está en su sitio, el script que se encarga de crear los menús de arranque del grub piensa que en esa partición no hay ningún sistema operativo.

Es lógico, si no hay kernel no hay ningún sistema y por lo tanto no creo ninguna entrada en el grub.

@Canfoxinho Creo que no has seguido bién este paso: https://foro.seguridadwireless.net/live-wifislax/problema-al-instalar-wifislax-en-hdd/msg288041/#msg288041

Donde están las x tienes que poner los números que corresponden tanto a la versión del kernel (que lo puedes saber ejecutando "uname -r") como el número de partición.

tambien me llama la atención cómo ha llegado un disco duro a tener sda9. corregidme si me equivoco:


sda1 system (boot) de windows vista/7/8
sda2 data de windows vista/7/8
sda3 OEM recovery de windows vista/7/8
sda4 extended (contenedor de las unidades lógicas)

vale, pero ¿y ahora? de sda5 a sda9 son 5 unidades lógicas.
Quizás habéis separado el directorio raíz, /boot, /usr, /home y la swap? porque son un montón de unidades lógicas




Asi es como lo tengo:

Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sda1            2048      206847      102400    7  HPFS/NTFS/exFAT -Reservado para el sistema
/dev/sda2   *      208845   641710484   320750820    7  HPFS/NTFS/exFAT- Win7
/dev/sda3       641712128   649902079     4094976    7  HPFS/NTFS/exFAT - disco de instalcion Win7
/dev/sda4       649904126   906459135   128277505    5  Extendida
/dev/sda5       649904128   653107199     1601536   82  Linux swap
/dev/sda6       653109248   705542143    26216448   83  Linux - Raiz Ubuntu 12.04
/dev/sda7       705544192   781457407    37956608   83  Linux - Home Ubuntu 12.04
/dev/sda8       781459456   865949695    42245120   83  Linux - Raiz Bactrack 5
/dev/sda9       865951744   906459135    20253696   83  Linux - Raiz Wifislax

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2383
  • Prácticas precisas precisan práctica
Re: Problema al instalar wifislax en hdd.
« Respuesta #31 en: 20-09-2013, 17:56 (Viernes) »
como podeis llegar a complicar algo tan sencillo?
he intentado leerme repetidas veces este hilo, y no entiendo nada todavia.
jopetasssss

Pues lo que pasa es que al instalar el grub y reiniciar no le sale la entrada de wifislax en el menú del grub.

Y yo estoy convencido de que el problema es que el kernel de Wifislax no está en su sitio, porque cuando el kernel no está en su sitio, el script que se encarga de crear los menús de arranque del grub piensa que en esa partición no hay ningún sistema operativo.

Repasando el post, he de decirte Geminis q tienes toda la razon, debido a mi ofuscamiento de ayer el paso q señalas lo hice tal cual sin sustituir las x por la version del kernel. T pido disculpas por la perdida de tiempo en algo tan sencillo y q excuses mi inexperiencia ya q el nivel de frustracion aumulado ayer me propicio comneter dicho error...Todo instalado correctamente y muchas gracias, no todos los dias uno puede intentar resolver el problema q le acarrea cualquier tipo de aplicacion o software directamente con el creador.

Es lógico, si no hay kernel no hay ningún sistema y por lo tanto no creo ninguna entrada en el grub.

@Canfoxinho Creo que no has seguido bién este paso: https://foro.seguridadwireless.net/live-wifislax/problema-al-instalar-wifislax-en-hdd/msg288041/#msg288041

Donde están las x tienes que poner los números que corresponden tanto a la versión del kernel (que lo puedes saber ejecutando "uname -r") como el número de partición.

Todo es como lo has descrito, ayer motivado por la frustracion cometi el error q señalas, t pido disculpas por la perdida de tiempo q t haya podido acarrear geminis, y espero q disculpes mi inexperiencia. Muchas gracias a todos.

No tiene importancia, suele pasar, a veces con estas cosas es mejor dejarlo y volver a intentarlo al día siguiente con la cabeza despejada.

Me alegro de que ya esté solucionado  ;)

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.