Autor Tema: pequeño fallo en wifislax 4.12 (xfce)  (Leído 3298 veces)

0 Usuarios y 1 Visitante están viendo este tema.

barquerito

  • Visitante
pequeño fallo en wifislax 4.12 (xfce)
« en: 07-08-2016, 13:33 (Domingo) »
Hola, estoy probando wifislx 4.12 y está genial..uso Xfce

Acabo de detectar un fallo: botón derecho del ratón sobre un tar.gz no es capaz de extraer.
Si pueden reportar la solución o arreglo.... gracias.



Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14463
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #1 en: 07-08-2016, 14:35 (Domingo) »
Hola, estoy probando wifislx 4.12 y está genial..uso Xfce

Acabo de detectar un fallo: botón derecho del ratón sobre un tar.gz no es capaz de extraer.
Si pueden reportar la solución o arreglo.... gracias.


pues si que es raro ...

¿aparecen los menus de 7zip?  ¿funcionan los de 7zip?

Desconectado Vodker

  • ******
  • Mensajes: 290
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #2 en: 07-08-2016, 15:20 (Domingo) »
Probado con uno al azar (gcc-java-4.6.2.tar.gz) todo sale perfecto en KDE, pero en XFce sí sale el menú y dice que no encuentra el gestos de archivadores adecuado.
« Última modificación: 07-08-2016, 15:25 (Domingo) por Vodker »
Aprendiendo... o al menos intentándolo.

Desconectado Vodker

  • ******
  • Mensajes: 290
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #3 en: 07-08-2016, 15:34 (Domingo) »
Perdón por el repost. Quería decir que Los archivos .7z también dan ese mismo error.
« Última modificación: 07-08-2016, 15:36 (Domingo) por Vodker »
Aprendiendo... o al menos intentándolo.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14463
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #4 en: 07-08-2016, 16:10 (Domingo) »
lo que peguntaba de 7zip era si usando este..pasaba lo mismo.

pero acabo de caer en que 7zip solo tiene acciones de click derecho en kde  ;D

podeis probar a recompilar file-roller

Código: [Seleccionar]
slapt-src -u
slapt-src -i file-roller

barquerito

  • Visitante
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #5 en: 07-08-2016, 19:08 (Domingo) »

podeis probar a recompilar file-roller

Código: [Seleccionar]
slapt-src -u
slapt-src -i file-roller

Bueno, pues he intentado recompilar, pero aborta...:

fileroller-module.c:25:60: error fatal: libnautilus-extension/nautilus-extension-types.h: No existe el fichero o el directorio
compilación terminada.
Makefile:384: fallo en las instrucciones para el objetivo 'fileroller-module.lo'
make[2]: *** [fileroller-module.lo] Error 1
make[2]: *** Se espera a que terminen otras tareas....
nautilus-fileroller.c:28:60: error fatal: libnautilus-extension/nautilus-extension-types.h: No existe el fichero o el directorio
compilación terminada.
Makefile:384: fallo en las instrucciones para el objetivo 'nautilus-fileroller.lo'
make[2]: *** [nautilus-fileroller.lo] Error 1
make[2]: se sale del directorio '/usr/src/slapt-src/system/file-roller/file-roller-2.32.2/nautilus'
Makefile:396: fallo en las instrucciones para el objetivo 'all-recursive'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio '/usr/src/slapt-src/system/file-roller/file-roller-2.32.2'
Makefile:323: fallo en las instrucciones para el objetivo 'all'
make: *** [all] Error 2
sh file-roller.SlackBuild Error

barquerito

  • Visitante
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #6 en: 11-09-2016, 15:41 (Domingo) »
Buenas...  ¿Alguien puede ayudar para solucionar este fallo (falla al recompilar fileroller)?

saludos...

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17713
    • GNU/Linux Wifislax
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #7 en: 11-09-2016, 18:41 (Domingo) »
Código: [Seleccionar]
error fatal: libnautilus-extension/nautilus-extension-types.h: No existe el fichero o el directorio


barquerito

  • Visitante
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #8 en: 23-09-2016, 18:42 (Viernes) »
Pues nada, no consigo hacerlo funcionar,,,, si alguien puede reparar el error, agradecido....
para mí que el fallo debe estar en algun fichero de configuracion del ejecutable fileroller.
« Última modificación: 23-09-2016, 18:45 (Viernes) por barquerito »

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #9 en: 23-09-2016, 19:36 (Viernes) »
el fallo ya te lo han dicho, lo pone en la primera linea:

error fatal: libnautilus-extension/nautilus-extension-types.h: No existe el fichero o el directorio

te faltan las "libnautilus-extension", si no instalas eso primero no podrás instalar lo demás.


saludos
« Última modificación: 23-09-2016, 19:37 (Viernes) por drvalium »

barquerito

  • Visitante
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #10 en: 24-09-2016, 16:37 (Sábado) »
compilado está, pero no funciona:

después de compilado, convierto el .txz a .xzm y lo meto en /modules
reinicio y cuando intento crear un archivador me tira el mismo error del mensaje inicial.

ahora viene lo bueno:

hago: deactivate file-roller........xzm
y activate file-roller...........xzm
y ahora sí funciona...
----
por eso creo que el file-roller de serie funciona bien, solo que hay algo mal (fichero o configuracion).

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #11 en: 24-09-2016, 16:50 (Sábado) »
hi

podrías hacer el modulo con la opción "Salvar cambios en .xzm", quizás así te funcione bien. Lo tienes en Menu KDE/Sistema/

es muy fácil de usar, solo inicialo antes de empezar la compilación y sigue las instrucciones, cuando termines clickas con el botón derecho sobre la carpeta que te crea y seleccionas "Crear modulo xzm Wifislax".


suerte


barquerito

  • Visitante
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #12 en: 24-09-2016, 19:00 (Sábado) »
Pues creo que he dado con algo importante:

   El fichero /usr/share/applications/mimeinfo.cache queda muy pequeño,
pero si lo sustituyo por el que se crea al hacer la compilacion
entonces sí funciona.

Parece que el proceso de arranque no respeta ese fichero,
y el que crea el sistema es insuficiente.


Todo esto se refiere a la version que compilo y que es la 2.32.2 ,
y no la 3.16.3 que es la que viene de serie y que no se
porqué no funciona, aunque el mensaje de error es el mismo.



Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #13 en: 24-09-2016, 20:46 (Sábado) »
 El fichero /usr/share/applications/mimeinfo.cache queda muy pequeño, pero si lo sustituyo por el que se crea al hacer la compilación
entonces sí funciona.

Descomprime el modulo, cambia ese archivo en la carpeta que está y vuelve a crear el modulo como te explicaba antes:

clickas con el botón derecho sobre la carpeta que te crea y seleccionas "Crear modulo xzm Wifislax".

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14463
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #14 en: 24-09-2016, 20:48 (Sábado) »
me esta picando la curiosidad , jajaja.

pueden ser 2 cosas

1 - al inicio no se actualiza el listado de apps y asociacion (mimetypes)
2 - algo relacionado con el fichero gschema.compiled

lo primero que habria que hacer es buscar las cabeceras de nautilus en /usr/include y eliminarlas ,para evitar el error al compilar.

barquerito

  • Visitante
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #15 en: 24-09-2016, 22:08 (Sábado) »
Pues lo hice y no funciona. Creo que ese fichero se crea al vuelo al actualizar la bd mime y machaca al que yo pongo en el modulo.

El fichero /usr/share/applications/mimeinfo.cache queda muy pequeño, pero si lo sustituyo por el que se crea al hacer la compilación
entonces sí funciona.

Descomprime el modulo, cambia ese archivo en la carpeta que está y vuelve a crear el modulo como te explicaba antes:

clickas con el botón derecho sobre la carpeta que te crea y seleccionas "Crear modulo xzm Wifislax".
« Última modificación: 24-09-2016, 22:19 (Sábado) por barquerito »

barquerito

  • Visitante
Re: pequeño fallo en wifislax 4.12 (xfce)
« Respuesta #16 en: 24-09-2016, 22:15 (Sábado) »
Yo desde el principio vengo insinuando algo así, pero es que yo no sé más, a ver si alguien puede echar un ojo.

me esta picando la curiosidad , jajaja.

pueden ser 2 cosas

1 - al inicio no se actualiza el listado de apps y asociacion (mimetypes)
2 - algo relacionado con el fichero gschema.compiled

lo primero que habria que hacer es buscar las cabeceras de nautilus en /usr/include y eliminarlas ,para evitar el error al compilar.