Autor Tema: Versión 4.11.1 + Optimus  (Leído 2328 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Victiki

  • Visitante
Versión 4.11.1 + Optimus
« en: 10-08-2015, 12:10 (Lunes) »
Saludos,

Este es mi primer post en este foro, ya que hace poco que trasteo con Wifislax y la verdad hasta ahora no había tenido nada que aportar.

Como no, y para seguir la tradición, lo primero que escribiré será para dar la lata un poco a ver si alguien conoce el tema o me echa una mano.

Por supuesto, y antes de nada, me disculpo por adelantado si inclumplo las normas del foro (me las he leido antes, así que espero que no), o este no es el canal mas adecuado para la consulta, por lo que espero que me perdonéis si se da alguna de estas circunstancias.

Adicionalmente, he estado buscando información en este y otros acerca del tema que voy a consultar, y no he encontrado solución posible.

Una vez dicho esto, voy al lío:

Tengo (como otros, supongo) un laptop con tarjeta de video en sistema Optimus de NVIDIA, que consiste básicamente para los que no lo sepáis en una tarjeta de video integrada (creo que Intel para todos los casos) y una mas potente para usos gráficos (Geforce GTX860M mas concretamente en mi caso).

Windows alterna entre ellas sin problema, pero la resignada comunidad de Linux se está peleando con un driver (Bumblebee) que cuenta con la ayuda directa de NVIDIA para su desarrollo, y de hecho lo he compilado y hecho funcionar en otras distribuciones sin problema.

Pero con Wifislax me he encontrado un hueso duro de roer:
- He probado con los módulos que en un aporte se habían hecho para la 4.10, sobre la 4.10 mismamente, sin suerte (se queda al iniciar el sistema gráfico).
- He probado a compilar yo mismo todo el sistema, con sus dependencias, desde los paquetes de slackware. En un principio compilan correctamente, genero los módulos sin problema, pero al arrancarlos en la LIVE me da el mismo problema que anteriormente. Una cosa curiosa es que comparando estos módulos que tuve que generar, con los que encontré para la 4.10, a estos últimos les faltaba la libvdpau, creo que al estar basada Wifislax en la Slackware 14.1 hacen falta.

Mis preguntas:
- ¿Alguien ha echado a andar esta versión con bumblebee?
- Y alguna de las anteriores (entiendo que sí).
- Si alguna de las preguntas anteriores es afirmativa, ¿cómo y en qué estoy fallando?
- Y si alguien me orienta, y finalmente lo dejo en condiciones para que en una LIVE pueda operar con la GPU y Optimus, cómo puedo hacer para dejar mi aporte y colgar un tutorial de cómo compilar y hacer los módulos para Bumblebee.

Gracias a todos. ;)



jostey

  • Visitante
Re: Versión 4.11.1 + Optimus
« Respuesta #1 en: 10-08-2015, 12:51 (Lunes) »
Me apunto por si hay que hacer algún tipo de prueba, porque estoy en tus mismas condiciones. Suerte, a ver si alguien nos orienta un poco.

Victiki

  • Visitante
Re: Versión 4.11.1 + Optimus
« Respuesta #2 en: 10-08-2015, 20:10 (Lunes) »
En un principio me he ayudado de esta guía:
http://docs.slackware.com/howtos:hardware:nvidia_optimus

Parece ser que en este hilo, para 14 de Slackware, lo han echado a andar:
http://www.linuxquestions.org/questions/slackware-14/installing-nvidia-drivers-with-optimus-support-startx-gives-error-no-screens-found-4175464491/

Seguiré investigando esta noche.

Fr3dY

  • Visitante
Re: Versión 4.11.1 + Optimus
« Respuesta #3 en: 25-08-2015, 21:09 (Martes) »