Autor Tema: Linux Display Driver Version 96.43.23  (Leído 16709 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Algierd

  • Visitante
Linux Display Driver Version 96.43.23
« en: 24-01-2014, 17:40 (Viernes) »
   Hello, all!

  I installed on my PC Wifislax 4.7.2. After i put Nvidia display driver 96.43.23 for my GeForce 4 MX Integrated video. It is set, but X Window System X Window System not loaded :( I get the message:


[    34.893]
X.Org X Server 1.14.3
Release Date: 2013-09-12
[    34.907] X Protocol Version 11, Revision 0
[    34.921] Build Operating System: Slackware 14.1 Slackware Linux Project
[    34.950] Current Operating System: Linux wifislax 3.12.0-wifislax #1 SMP PREEMPT Sun Nov 17 22:55:12 UTC 2013 i686
[    34.950] Kernel command line: quiet BOOT_IMAGE=/boot/vmlinuz-3.12.0-wifislax root=/dev/sda1 ro vga=788
[    34.979] Build Date: 09 October 2013  09:56:03PM
[    34.993]
[    35.015] Current version of pixman: 0.30.2
[    35.080]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[    35.081] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    35.139] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan  9 20:36:13 2014
[    35.196] (==) Using config file: "/etc/X11/xorg.conf"
[    35.210] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    35.242] (==) ServerLayout "Layout0"
[    35.242] (**) |-->Screen "Screen0" (0)
[    35.242] (**) |   |-->Monitor "Monitor0"
[    35.256] (**) |   |-->Device "Device0"
[    35.256] (**) |-->Input Device "Keyboard0"
[    35.256] (**) |-->Input Device "Mouse0"
[    35.256] (**) Option "IgnoreABI" "True"
[    35.256] (**) Ignoring ABI Version
[    35.256] (==) Automatically adding devices
[    35.256] (==) Automatically enabling devices
[    35.256] (==) Automatically adding GPU devices
[    35.296] (WW) The directory "/usr/share/fonts/local" does not exist.
[    35.296]     Entry deleted from font path.
[    35.296] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/TTF".
[    35.296]     Entry deleted from font path.
[    35.296]     (Run 'mkfontdir' on "/usr/share/fonts/TTF").
[    35.296] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    35.296]     Entry deleted from font path.
[    35.296] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    35.296]     Entry deleted from font path.
[    35.296] (WW) The directory "/usr/share/fonts/CID" does not exist.
[    35.296]     Entry deleted from font path.
[    35.296] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[    35.296]     Entry deleted from font path.
[    35.296] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[    35.296]     Entry deleted from font path.
[    35.296] (WW) The directory "/usr/share/fonts/cyrillic" does not exist.
[    35.296]     Entry deleted from font path.
[    35.296] (**) FontPath set to:
    /usr/lib/X11/fonts/misc/:unscaled,
    /usr/lib/X11/fonts/75dpi/:unscaled,
    /usr/lib/X11/fonts/misc/,
    /usr/lib/X11/fonts/75dpi/,
    /usr/share/fonts/misc,
    /usr/share/fonts/75dpi/:unscaled,
    /usr/share/fonts/75dpi
[    35.296] (==) ModulePath set to "/usr/lib/xorg/modules"
[    35.296] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    35.296] (WW) Disabling Keyboard0
[    35.296] (WW) Disabling Mouse0
[    35.305] (II) Loader magic: 0x82553a0
[    35.305] (II) Module ABI versions:
[    35.305]     X.Org ANSI C Emulation: 0.4
[    35.305]     X.Org Video Driver: 14.1
[    35.305]     X.Org XInput driver : 19.1
[    35.305]     X.Org Server Extension : 7.0
[    35.307] (--) PCI:*(0:2:0:0) 10de:01f0:17f2:3401 rev 163, Mem @ 0xe0000000/16777216, 0xd8000000/67108864, 0xdc000000/524288, BIOS @ 0x????????/131072
[    35.308] (II) Open ACPI successful (/var/run/acpid.socket)
[    35.323] Initializing built-in extension Generic Event Extension
[    35.337] Initializing built-in extension SHAPE
[    35.350] Initializing built-in extension MIT-SHM
[    35.363] Initializing built-in extension XInputExtension
[    35.376] Initializing built-in extension XTEST
[    35.388] Initializing built-in extension BIG-REQUESTS
[    35.400] Initializing built-in extension SYNC
[    35.413] Initializing built-in extension XKEYBOARD
[    35.424] Initializing built-in extension XC-MISC
[    35.434] Initializing built-in extension XINERAMA
[    35.444] Initializing built-in extension XFIXES
[    35.455] Initializing built-in extension RENDER
[    35.465] Initializing built-in extension RANDR
[    35.475] Initializing built-in extension COMPOSITE
[    35.484] Initializing built-in extension DAMAGE
[    35.494] Initializing built-in extension MIT-SCREEN-SAVER
[    35.504] Initializing built-in extension DOUBLE-BUFFER
[    35.513] Initializing built-in extension RECORD
[    35.522] Initializing built-in extension DPMS
[    35.531] Initializing built-in extension X-Resource
[    35.540] Initializing built-in extension XVideo
[    35.549] Initializing built-in extension XVideo-MotionCompensation
[    35.557] Initializing built-in extension XFree86-VidModeExtension
[    35.565] Initializing built-in extension XFree86-DGA
[    35.572] Initializing built-in extension XFree86-DRI
[    35.579] Initializing built-in extension DRI2
[    35.579] (II) LoadModule: "glx"
[    35.594] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    36.044] (II) Module glx: vendor="NVIDIA Corporation"
[    36.044]     compiled for 4.0.2, module version = 1.0.0
[    36.044]     Module class: X.Org Server Extension
[    36.044] (II) NVIDIA GLX Module  96.43.23  Fri Aug 31 15:03:31 PDT 2012
[    36.051] Loading extension GLX
[    36.051] (II) LoadModule: "nvidia"
[    36.051] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    36.126] (II) Module nvidia: vendor="NVIDIA Corporation"
[    36.126]     compiled for 4.0.2, module version = 1.0.0
[    36.126]     Module class: X.Org Video Driver
[    36.133] ================ WARNING WARNING WARNING WARNING ================
[    36.161] This server has a video driver ABI version of 14.1 that is not
supported by this NVIDIA driver.  Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
[    36.169] =================================================================
[    36.177] (WW) NVIDIA: The driver will continue to load, but may behave strangely.
[    36.191] (WW) NVIDIA: This server has an unsupported input driver ABI version (have 19.1, need < 17.0).  The driver will continue to load, but may behave strangely.
[    36.202] (II) NVIDIA dlloader X Driver  96.43.23  Fri Aug 31 14:57:26 PDT 2012
[    36.202] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    36.202] (--) using VT number 7

[    36.230] (II) Loading sub module "fb"
[    36.230] (II) LoadModule: "fb"
[    36.230] (II) Loading /usr/lib/xorg/modules/libfb.so
[    36.246] (II) Module fb: vendor="X.Org Foundation"
[    36.246]     compiled for 1.14.3, module version = 1.0.0
[    36.246]     ABI class: X.Org ANSI C Emulation, version 0.4
[    36.260] (WW) NVIDIA: Unresolved symbol: fbGetGCPrivateKey
[    36.260] (II) Loading sub module "ramdac"
[    36.260] (II) LoadModule: "ramdac"
[    36.260] (II) Module "ramdac" already built-in
[    36.266] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    36.266] (==) NVIDIA(0): RGB weight 888
[    36.267] (==) NVIDIA(0): Default visual is TrueColor
[    36.267] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    36.267] (**) NVIDIA(0): Enabling RENDER acceleration
[    36.267] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
[    36.267] (II) NVIDIA(0):     enabled.
[    37.062] (II) NVIDIA(0): NVIDIA GPU GeForce4 MX Integrated GPU at PCI:2:0:0 (GPU-0)
[    37.062] (--) NVIDIA(0): Memory: 32768 kBytes
[    37.062] (--) NVIDIA(0): VideoBIOS: 04.1f.00.07.02
[    37.062] (II) NVIDIA(0): Detected AGP rate: 4X
[    37.062] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[    37.062] (--) NVIDIA(0): Connected display device(s) on GeForce4 MX Integrated GPU at
[    37.062] (--) NVIDIA(0):     PCI:2:0:0:
[    37.062] (--) NVIDIA(0):     LG F920P (CRT-0)
[    37.062] (--) NVIDIA(0):     NVIDIA TV Encoder (TV-0)
[    37.062] (--) NVIDIA(0): LG F920P (CRT-0): 300.0 MHz maximum pixel clock
[    37.062] (--) NVIDIA(0): NVIDIA TV Encoder (TV-0): 300.0 MHz maximum pixel clock
[    37.062] (--) NVIDIA(0): TV encoder: NVIDIA
[    37.063] (II) NVIDIA(0): Assigned Display Device: CRT-0
[    37.063] (II) NVIDIA(0): Validated modes:
[    37.067] (II) NVIDIA(0):     "1600x1200"
[    37.067] (II) NVIDIA(0):     "1280x1024"
[    37.067] (II) NVIDIA(0):     "1024x768"
[    37.067] (II) NVIDIA(0):     "800x600"
[    37.067] (II) NVIDIA(0):     "640x480"
[    37.067] (II) NVIDIA(0): Virtual screen size determined to be 1600 x 1200
[    37.070] (--) NVIDIA(0): DPI set to (112, 112); computed from "UseEdidDpi" X config
[    37.070] (--) NVIDIA(0):     option
[    37.070] (--) Depth 24 pixmap format is 32 bpp
[    37.074] (EE)
[    37.074] (EE) Backtrace:
[    37.074] (EE) 0: /usr/bin/X (xorg_backtrace+0x49) [0x81d6099]
[    37.074] (EE) 1: /usr/bin/X (0x8048000+0x191ac4) [0x81d9ac4]
[    37.074] (EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb778c410]
[    37.074] (EE) 3: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0xb5da5000+0x6f77c9) [0xb649c7c9]
[    37.074] (EE)
[    37.074] (EE) Segmentation fault at address 0x4
[    37.074] (EE)
Fatal server error:
[    37.074] (EE) Caught signal 11 (Segmentation fault). Server aborting
[    37.074] (EE)
[    37.074] (EE)
Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.
[    37.074] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    37.075] (EE)
[    37.172] (EE) Server terminated with error (1). Closing log file.


I can fix this? ???



shaola

  • Visitante
Re: Linux Display Driver Version 96.43.23
« Respuesta #1 en: 24-01-2014, 21:36 (Viernes) »
you need to uninstall the driver, your gpu is way too old.  It's not supported any more by nvidia.


You won't be able to use the privative driver with that card, and there is not  a good reason for trying neither.

So just stick to the generic driver vesa or nouveau (i don't even know if nouveau will support a GPU that old).

¿Can i ask what kind of computer are you using?  it's been a really long time since i haven't seen an agp GPU card.

Algierd

  • Visitante
Re: Linux Display Driver Version 96.43.23
« Respuesta #2 en: 01-06-2014, 14:54 (Domingo) »
I can not use vesa-driver, 1024x768 60 Hz screen refresh does not work on my system: image on the monitor shaking :(