Autor Tema: librerias  (Leído 1373 veces)

0 Usuarios y 1 Visitante están viendo este tema.

bari

  • Visitante
librerias
« en: 22-09-2017, 05:12 (Viernes) »
Estoy tratando de actualizar las librerias de wifislax 4.11.1 a las del slackware 14.2.

Trate d empezar actualizando glib2, baje las fuentes y slackbuild de:
https://ftp.heanet.ie/mirrors/ftp.slackware.com/pub/slackware/slackware-14.2/source/

compile y al tratar d upgradear el paquete me sale:
wifislax packages # upgradepkg glib2-2.46.2-i586-2.txz
+==============================================================================
| Upgrading glib2-2.42.2-i486-1 package using ./glib2-2.46.2-i586-2.txz
+==============================================================================
Pre-installing package glib2-2.46.2-i586-2...
ERROR:  Package ./glib2-2.46.2-i586-2.txz did not install correctly.  You may need to
reinstall your old package to avoid problems.  Make sure the new package is not corrupted.

Supuse q era un problema de dependencias y decidi actualizarlas.
Revise sus dependencias en www.linuxfromscratch.org/blfs/view/cvs/general/glib2.html

Asi que baje todas las fuentes y slackbuilds de cada dependencia, las compile y al tratar d actualizar d nuevo me salen los siguientes errores,


wifislax packages # upgradepkg pcre-8.39-i586-1.txz
+==============================================================================
| Upgrading pcre-8.36-i486-1 package using ./pcre-8.39-i586-1.txz
+==============================================================================
Pre-installing package pcre-8.39-i586-1...
ERROR:  Package ./pcre-8.39-i586-1.txz did not install correctly.  You may need to
reinstall your old package to avoid problems.  Make sure the new package is not corrupted.


wifislax packages # upgradepkg shared-mime-info-1.6-i586-1.txz
+==============================================================================
| Upgrading shared-mime-info-1.3-i486-2 package using ./shared-mime-info-1.6-i586-1.txz
+==============================================================================
Pre-installing package shared-mime-info-1.6-i586-1...
ERROR:  Package ./shared-mime-info-1.6-i586-1.txz did not install correctly.  You may need
to reinstall your old package to avoid problems.  Make sure the new package is not corrupted.


wifislax packages # upgradepkg dbus-glib-0.106-i586-1.txz
+==============================================================================
| Upgrading dbus-glib-0.104-i486-1 package using ./dbus-glib-0.106-i586-1.txz
+==============================================================================
Pre-installing package dbus-glib-0.106-i586-1...
ERROR:  Package ./dbus-glib-0.106-i586-1.txz did not install correctly.  You may need to
reinstall your old package to avoid problems.  Make sure the new package is not corrupted.


wifislax packages # upgradepkg dbus-python-1.2.4-i586-1.txz
+==============================================================================
| Upgrading dbus-python-1.2.0-i486-1 package using ./dbus-python-1.2.4-i586-1.txz
+==============================================================================
Pre-installing package dbus-python-1.2.4-i586-1...
ERROR:  Package ./dbus-python-1.2.4-i586-1.txz did not install correctly.  You may need to
reinstall your old package to avoid problems.  Make sure the new package is not corrupted.


« Última modificación: 22-09-2017, 22:24 (Viernes) por bari »

sol666

  • Visitante
Re: librerias
« Respuesta #1 en: 22-09-2017, 14:16 (Viernes) »
y no seria mas comodo bajarte wifislax 4.12 32 bits o wifislax 1.1 64 bits que ya esta mas actualizada?

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14696
Re: librerias
« Respuesta #2 en: 22-09-2017, 14:29 (Viernes) »
Seria la clave , usar una de las de 64 bits que se basan en slackware 14.2 estable ..y a lo mejor le seria mas fácil.

//FINAL Y MÁS DOS RESPUESTAS