Autor Tema: GOYscript (WEP, WPA & WPS)  (Leído 948484 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14483
Re: GOYscript (WEP, WPA & WPS)
« Respuesta #940 en: 10-10-2013, 20:19 (Jueves) »
Espera que lo mire ...

y te digo goy.  ;D



 :-\ :-\ :-\ :-\ :-\ :-\ :-\ :-\ :-\ :-\ :-\ :-\ :-\ :-\




« Última modificación: 10-10-2013, 20:25 (Jueves) por USUARIONUEVO »

goyfilms

  • Visitante
Re: GOYscript (WEP, WPA & WPS)
« Respuesta #941 en: 10-10-2013, 20:26 (Jueves) »
Bueno, para ir tirando... el problema de las integradas se debería solucionar con esto:
http://www.sendspace.com/file/j39fxg -> liveUSB
http://www.sendspace.com/file/v490r0 -> liveCD & HDD

Lo de las ubiquiti ya son palabras mayores. Miraré de hacerme con una para mi colección  ;D

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14483
Re: GOYscript (WEP, WPA & WPS)
« Respuesta #942 en: 10-10-2013, 20:29 (Jueves) »
NO LEES AMIGO ... NO ME LEEESSS



abro el goyscriptwep  ... y me veo esto


Código: [Seleccionar]
echo -e $cyanC"Reiniciando la interfaz $INTERFAZ $grisC(DRIVER=$DRIVER)$cyanC..."
echo -e $grisC
rmmod -f "$DRIVER" >/dev/null 2>&1 #reiniciamos la interfaz
ifconfig $INTERFAZ >/dev/null 2>&1
while [ $? -eq 0 ] #esperamos a que se desactive el módulo de la interfaz
do



¿¿¿¿ dond estan los sleep de 1 segundo entre desmontar y remonatr el driver ???????


NO SON PALABRAS AMYORES SOLO UN SLEEEEEPPPPPPPP    >:D >:D >:D >:D >:D >:D

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14483
Re: GOYscript (WEP, WPA & WPS)
« Respuesta #943 en: 10-10-2013, 20:31 (Jueves) »
PD: Te voy matar .. 8)



En todos los script a la hora de rmmod y modprobe un sleep de 1


rmmod
sleep 1
modprobe
sleep 1


las ar9271 son un poco lentas y necesitan ese sleep ....que esto ya nos paso en bullywpsdialog  y era un sleep lo que necesitaban.


era facil y lo has complicado infinito ..ya no van ni con sleep ni nada.  :'(
« Última modificación: 10-10-2013, 20:37 (Jueves) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14483
Re: GOYscript (WEP, WPA & WPS)
« Respuesta #944 en: 10-10-2013, 20:41 (Jueves) »
Esto es lo que funciona.


Código: [Seleccionar]
#ACTIVA EL MODO MONITOR DE LA INTERFAZ
function activar_modo_monitor
{
if [ "$DRIVER" = "" ] #si pasamos la interfaz como parámetro al llamar al script hay que averiguar el driver antes
then
DRIVER=`ls -l /sys/class/net/$INTERFAZ/device/driver | awk -F '/' '{print $NF}'`
fi
echo -e $cyanC"Reiniciando la interfaz $INTERFAZ $grisC(DRIVER=$DRIVER)$cyanC..."
echo -e $grisC
rmmod -f "$DRIVER" >/dev/null 2>&1 #reiniciamos la interfaz
sleep 1
modprobe "$DRIVER" >/dev/null 2>&1
sleep 1
echo -e ""$cyan"Activando modo monitor en $INTERFAZ [MAC="$MAC_INTERFAZ"]..."$grisC""
$AIRMON start $INTERFAZ $CANAL
ifconfig mon0 > /dev/null 2>&1
if [ $? = 0 ] #SI LA ORDEN ANTERIOR SE COMPLETO CORRECTAMENTE, SIGNIFICA QUE EXISTE LA INTERFAZ "mon0"
then
INTERFAZ_MONITOR=mon0
else
INTERFAZ_MONITOR=$INTERFAZ
fi
}

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14483
Re: GOYscript (WEP, WPA & WPS)
« Respuesta #945 en: 10-10-2013, 20:49 (Jueves) »
sigue confundiendose de driver a desmontar...


maryo15151

  • Visitante
Re: GOYscript (WEP, WPA & WPS)
« Respuesta #946 en: 10-10-2013, 21:20 (Jueves) »
ola buenas cheria comentar una cosa sobre el script me pone el eror este che se falta un (()) no encuentra ninguna red .
gracias ....

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14483
Re: GOYscript (WEP, WPA & WPS)
« Respuesta #947 en: 10-10-2013, 21:24 (Jueves) »
Uppsssssssssssss  no vi la

3.2.1 beta ....


voy a ello.



maryo15151

  • Visitante
Re: GOYscript (WEP, WPA & WPS)
« Respuesta #948 en: 10-10-2013, 21:49 (Jueves) »
ola buenas confirmo  che la 3.2.1 beta tiene la misma eror como 3.2 gracias

goyfilms

  • Visitante
Re: Re: Re: GOYscript (WEP, WPA & WPS)
« Respuesta #949 en: 10-10-2013, 21:54 (Jueves) »
NO LEES AMIGO ... NO ME LEEESSS



abro el goyscriptwep  ... y me veo esto


Código: [Seleccionar]
echo -e $cyanC"Reiniciando la interfaz $INTERFAZ $grisC(DRIVER=$DRIVER)$cyanC..."
echo -e $grisC
rmmod -f "$DRIVER" >/dev/null 2>&1 #reiniciamos la interfaz
ifconfig $INTERFAZ >/dev/null 2>&1
while [ $? -eq 0 ] #esperamos a que se desactive el módulo de la interfaz
do



¿¿¿¿ dond estan los sleep de 1 segundo entre desmontar y remonatr el driver ???????


NO SON PALABRAS AMYORES SOLO UN SLEEEEEPPPPPPPP    >:D >:D >:D >:D >:D >:D
Parece mentira viniendo de ti...
Los "sleep" son los bucles while

Enviado desde el móvil

goyfilms

  • Visitante
Re: Re: Re: GOYscript (WEP, WPA & WPS)
« Respuesta #950 en: 10-10-2013, 21:55 (Jueves) »
ola buenas cheria comentar una cosa sobre el script me pone el eror este che se falta un (()) no encuentra ninguna red .
gracias ....
Otro que tiene una ubiquiti de las narices

Enviado desde el móvil

goyfilms

  • Visitante
Re: Re: Re: GOYscript (WEP, WPA & WPS)
« Respuesta #951 en: 10-10-2013, 22:01 (Jueves) »
Espera que lo mire ...

y te digo goy.  ;D



 :-\ :-\ :-\ :-\ :-\ :-\ :-\ :-\ :-\ :-\ :-\ :-\ :-\ :-\



Pues yo he probado con la integrada y 2 usb más simultáneamente y me funciona perfectamente.
Como el reiniciar la interfaz siga fallando la mando a tomar por saco y a otra cosa...

Enviado desde el móvil

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14483
Re: GOYscript (WEP, WPA & WPS)
« Respuesta #952 en: 10-10-2013, 22:02 (Jueves) »
La 3.2.1  YA FUNCIONA BIEN TODO.

Incluido las ubiquiti.


No se casi nada de bash ..asi que. .. para mi sleep es sleep y otras formas son otras formas.

Si hace lo mismo con un porcentaje de acierto mayor , pues mejor que mejor.


Lo he dicho muchas veces NO SE NADA DE BASH.



La 3.2.1 con 5 tarjetas no me ha dado problemas.



PD: NO TE FUSTIGES MAS QUE YA FUNCIONA TODO  ;D ;D ;D
« Última modificación: 10-10-2013, 22:04 (Jueves) por USUARIONUEVO »

venturi

  • Visitante
Re:
« Respuesta #953 en: 10-10-2013, 22:10 (Jueves) »

[imghttp://


@venturi
Qué driver usa tu Ubiquiti? Es que no se ve en la captura...
Sera la misma que la de drvalium? Porque el ha dicho que le funciona bien

Enviado desde el móvil

Es este que se ve en la captura

Enviado desde mi ME301T usando Tapatalk 4

venturi

  • Visitante
Re:
« Respuesta #954 en: 10-10-2013, 22:13 (Jueves) »

[imghttp://


@venturi
Qué driver usa tu Ubiquiti? Es que no se ve en la captura...
Sera la misma que la de drvalium? Porque el ha dicho que le funciona bien

Enviado desde el móvil

Es este que se ve en la captura : ath9k_htc

Enviado desde mi ME301T usando Tapatalk 4


Enviado desde mi ME301T usando Tapatalk 4

goyfilms

  • Visitante
Re: Re: Re: GOYscript (WEP, WPA & WPS)
« Respuesta #955 en: 10-10-2013, 22:48 (Jueves) »
La 3.2.1  YA FUNCIONA BIEN TODO.

Incluido las ubiquiti.


No se casi nada de bash ..asi que. .. para mi sleep es sleep y otras formas son otras formas.

Si hace lo mismo con un porcentaje de acierto mayor , pues mejor que mejor.


Lo he dicho muchas veces NO SE NADA DE BASH.



La 3.2.1 con 5 tarjetas no me ha dado problemas.



PD: NO TE FUSTIGES MAS QUE YA FUNCIONA TODO  ;D ;D ;D
Nunca es tarde para aprender.
Lo que hago con el bucle while es que espere el tiempo justo hasta que se desactive/active el módulo.
Y no funciona todo aun. Me falta lo de los errores que dá al escanear redes con las ubiquiti.

Enviado desde el móvil

goyfilms

  • Visitante
Re: Re: Re:
« Respuesta #956 en: 10-10-2013, 22:48 (Jueves) »

[imghttp://


@venturi
Qué driver usa tu Ubiquiti? Es que no se ve en la captura...
Sera la misma que la de drvalium? Porque el ha dicho que le funciona bien

Enviado desde el móvil

Es este que se ve en la captura : ath9k_htc

Enviado desde mi ME301T usando Tapatalk 4


Enviado desde mi ME301T usando Tapatalk 4
Estas capturas son de la 3.2.1-beta?

Enviado desde el móvil

alonsote

  • Visitante
Re: GOYscript (WEP, WPA & WPS)
« Respuesta #957 en: 10-10-2013, 22:51 (Jueves) »
Probado chipset AR9271 con la versión 3.2.1 beta y ahora si la detecta y ve redes al escanear.

Gracias goy.

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17408
  • Misántropo
Re: GOYscript (WEP, WPA & WPS)
« Respuesta #958 en: 10-10-2013, 23:34 (Jueves) »
probado en Wifislax 4.7 RC1 y GOYscript 3.2

  

la que no me funciona es la Intel, no es que me importe demasiado por que es una basura de WiFi, pero si quieres hacerla funcionar y te puedo ayudar en algo dime que quieres que haga.

un saludo
« Última modificación: 10-10-2013, 23:36 (Jueves) por drvalium »

goyfilms

  • Visitante
Re: Re: Re: GOYscript (WEP, WPA & WPS)
« Respuesta #959 en: 10-10-2013, 23:45 (Jueves) »
probado en Wifislax 4.7 RC1 y GOYscript 3.2

  

la que no me funciona es la Intel, no es que me importe demasiado por que es una basura de WiFi, pero si quieres hacerla funcionar y te puedo ayudar en algo dime que quieres que haga.

un saludo
Con la beta que puse antes te debería funcionar

Enviado desde el móvil