Autor Tema: Problemas para instalar madwifi en Wifislax 4.0  (Leído 2938 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Dick_53

  • Visitante
Problemas para instalar madwifi en Wifislax 4.0
« en: 07-04-2012, 12:44 (Sábado) »
Hola ante todos mis agradecimientos por este excelente foro para neófitos.

He estado incursionando en el mundo de las auditorías para conocer las las debilidades de mi red y tengo el livecd de wifislax 4.0
El sistema reconoce mi tarjeta wireless en mi caso una pcmcia DWL-G650 de D-Link, y cuando ejecuto el comando iwconfig y me aparece:
lo     no wireless extensions.
eth0    no wireless extensions.
wlan0   IEEE 802.11 bg ESSID:off/any
            Mode: Managed .......................etc,etc
o sea que mi tarjeta es reconocida e incluso puedo activar el modo monitor.
Nota: ¿Porque me sale wlan0 y no ath0 si el chipset de la tarjeta es atheros y el sistema reconoce que tiene drivers atheros instalados?
Al aplicar el comando lspci me sale al final:
03:00.0 Ethernet controller: atheros Comunications Inc. AR5212/ar5213 Wireless Network Adapter (rev 01)
Hasta aquí todo perfecto. Ahora cuando deseo instalar el paquete o como se llame de driver madwifi viene todo el problema.
Que he hecho?
Paso 1  Descargar el archivo comprimido madwifi-0.9.4.tar.gz y ponerlo en /root
Paso2  ejecutar en la consola:
$sudo bash
tar -zxvf madwifi-0.9.4.tar.gz  (y el fichero se descomprime sin problemas)
cd madwifi-0.4.9.4   (y regreso a la raiz del archivo madwifi para comenzar la instalacion)
Aquí es donde se complica todo. Ejecuto el comando:
 
make clean    y me sale esto:

wifislax madwifi-0.9.4 # make clean
bash: make: command not found

Alguien me dice que si tengo instalado el buil-essential, ahí si ya me pierdo
La pregunta del millon: ¿Porqué  Wifislax 3.0 si reconoce el madwifi y Wifislax 4.0 no?
Como puedo compilar estos driver aquí? Gracias por vuestra paciencia.... ???


« Última modificación: 07-04-2012, 13:02 (Sábado) por Dick_53 »

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8411
Re: Re: Problemas para instalar madwifi en Wifislax 4.0
« Respuesta #1 en: 07-04-2012, 13:25 (Sábado) »
Hola

¿para que necesitas madwifi? Si tu tarjeta se pone en modo monitor con los que trae la distro.

Lo del wla0 hace ya tiempo que se muestran todos los dispositicos wifi como wlan que yo recuerde a partir se wifiway 1,0 esa fuen la ultima que me mostro los atheros como ath.

Saludos

si sale este mensaje, es que estoy en el movil

Dick_53

  • Visitante
Re: Problemas para instalar madwifi en Wifislax 4.0
« Respuesta #2 en: 07-04-2012, 14:07 (Sábado) »
Gracias Sanson por responder. En verdad no lo necesito, pero me asalta la curiosidad que no pueda realizar este proceso como cualquier otro aquí en Wifislax 4. Si me permites una obsevacion hasta la version wifislax 3.1 reconocía los drivers atheros como ath0.
Me gustaría poder saber hacerlo o no? ¿Me podría ayudar alguien?  :-\
« Última modificación: 07-04-2012, 14:24 (Sábado) por Dick_53 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14440
Re: Problemas para instalar madwifi en Wifislax 4.0
« Respuesta #3 en: 07-04-2012, 22:28 (Sábado) »
madwifi esta SUPEROBSOLETO , no creo siquiera que compile en kerneles tan NUEVOS.

no necesitas madwifi para absolutamente nada.

ahora se identifican como wlan , POR QUE EL DRIVER ES OTRO.

SI METES LOS MADWIFI VAS A ROMPER EL SISTEMA , te vas a cargar los ath9k y ath5k , o eso creo yo.

¿por que razon quieres intentar meter losd madwifi?

ten en cuenta que el madwifi ,si no me equivoco solo soporta hasta los atheros 5007 , ...y ahora mismo hay hasta los 9000 , ...

si aun asi quieres seguir intentandolo , SUERTE , por que la vas a encesitar.

si dentro de la carpeta d elos madwifi no existe el fichero makefile , obviamente no podras ejecutar el make clean....la primera norma al intentar instalar algo desde su codigo , es entrar a la carpeta y buscar el fichero INSTALL ,O README ..O ALGO ASI.

Dick_53

  • Visitante
Re: Problemas para instalar madwifi en Wifislax 4.0
« Respuesta #4 en: 08-04-2012, 16:30 (Domingo) »
Gracias a todos por vuestro ocmentarios, recuerden que soy un usuario novato en esto de Linux y sus distribuciones, pensé que al tener una tarjeta superobsoleta, necesitaba tener tambien unos driver que se crearon en su momento para ella.  Soy experto en windows en Linux aún no he nacido.
Gracias nuevamente por los comentarios son todos muy útiles. Y efectivamente ya descubrí que en el kernel de Wifislax 4.0 no se puede instalar madwifi, despues de romperme los sesos varias horas y probar con otras distribuciones.
Un saludo.