Autor Tema: error con el update de vlc  (Leído 6507 veces)

0 Usuarios y 1 Visitante están viendo este tema.

sol666

  • Visitante
error con el update de vlc
« en: 19-12-2014, 00:56 (Viernes) »
al intentar crear el modulo me tira esto

configure: error: libavcodec versions 56 and later are not supported yet.
wifislax Multimedia #

a alguien mas le pasa esto?



Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14540
Re: error con el update de vlc
« Respuesta #1 en: 19-12-2014, 00:58 (Viernes) »
estas usando wifislax-4.10 a pelo ?

o le has metido cositas ?

actualizaste el ffmpeg que salio ayer o entes de ayer ?


CONFIRMADO

pero es por que se baja las sources de vlc 2.1.4 cuando deberia bajar las 2.1.5


« Última modificación: 19-12-2014, 01:02 (Viernes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14540
Re: error con el update de vlc
« Respuesta #2 en: 19-12-2014, 01:23 (Viernes) »
de momento , podeis ir a

/opt/wifislax-updaters/multimedia

abrir el de vlc , y donde pone

VERSION= .............

SUSTITUIR LA LINEA POR

Código: [Seleccionar]
VERSION=`curl -s $WEB/$PRGNAM/ | grep "[0-9]/" | cut -d '"' -f2 | tail -1 | cut -d '/' -f1`
mañana lo actualizare en el ftp.

sol666

  • Visitante
Re: error con el update de vlc
« Respuesta #3 en: 19-12-2014, 12:22 (Viernes) »
en que modulo de la carpeta base estan los updaters para retocar el de vlc desde live?

vk496

  • Visitante
Re: error con el update de vlc
« Respuesta #4 en: 19-12-2014, 20:02 (Viernes) »
Yo propongo esta:

Código: [Seleccionar]
VERSION=$(curl -s $WEB/$PRGNAM/ | grep -Po 'href="\K.*(?=")' | sed 's/\///g' | sort -g | tail -1)
@geminis_demon Tu que opinas?

@sol666

/opt/wifislax-updaters/Multimedia/vlc_updater

Salu2

sol666

  • Visitante
Re: error con el update de vlc
« Respuesta #5 en: 19-12-2014, 20:10 (Viernes) »
lo que quiero es coger el log pakage comvertirlo a xzm,despues extraerlo para modificarlo y volverlo a poner en la carpeta base  ;D ;D

Garcad

  • Visitante
Re: error con el update de vlc
« Respuesta #6 en: 19-12-2014, 21:30 (Viernes) »
@sol666

log2xzm /var/log/packages/archivolog /directorio/nombre.xzm

Salu2
« Última modificación: 19-12-2014, 21:31 (Viernes) por Garcad »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14540
Re: error con el update de vlc
« Respuesta #7 en: 19-12-2014, 22:54 (Viernes) »
lo que sol quieres es modificar el script de forma que al usar el modo live le arranque ya siempre reparado.


el script ya lo he actualizado esta mañana en el ftp -.-..  mejor que editar los modulos originales, usa en

sistema -->> updater de updaters  ,veras que encuentra 3 o 4 scripts con fecha mas nueva y te creara el xzm con los scripts nuevos.


el updater se deberia autoactualizar solo , pero el ftp es de juguete , empiezo a cansarme , mas alla de las 10 de la mañana y ya es inusable.

 :P

sol666

  • Visitante
Re: error con el update de vlc
« Respuesta #8 en: 20-12-2014, 00:17 (Sábado) »
eso mismo era lo que queria,al final usando tu truco en buscar archivos y carpetas wifislax_updaters /mnt/live/memory/images y esta en el modulo 006 en base.
Tambien de paso le he añadido el firmare http://www.mediafire.com/download/51ofycsymv4bo0m/rtl8188eu-driver-firmware.xzm y este otro tuyo http://www.mediafire.com/download/8b53ze339tj339u/rtl8192se-firmware-18122014-fw-1sw.xzm que se ve que faltaban  ;) ;)
« Última modificación: 20-12-2014, 00:26 (Sábado) por sol666 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14540
Re: error con el update de vlc
« Respuesta #9 en: 20-12-2014, 00:27 (Sábado) »
eso mismo era lo que queria,al final usando tu truco en buscar archivos y carpetas wifislax_updaters /mnt/live/memory/images y esta en el modulo 006 en base.
Tambien de paso le he añadido el firmare http://www.mediafire.com/download/51ofycsymv4bo0m/rtl8188eu-driver-firmware.xzm y este otro tuyo http://www.mediafire.com/download/8b53ze339tj339u/rtl8192se-firmware-18122014-fw-1sw.xzm que se ve que faltaban  ;) ;)


bien , yo sabia perfectamente que querias ditar directamente sobre el xzm base.

pero debes tener mucho cuidado ... sobretodo si algun dia tocas el de CORE  ...

lo ideal seria, copiarte el xzm a escritorio , modificas lo que necesitas , creas xzm SIN LOG PACKAGE ,es importante sin log , ... y por ultimo cuando lo tengas creado , copias el nuevo modificado a algun sitio , y ya fuera del sistema live, lo sustituyes.

normalmente se puede hacer al vuelo ...estando en mode live ,te vas al pendrive , copias y sobreescribes el xzm y reinicias , ... PERO CON EL CORE NO PUEDES HACER ESO , ... y repito si sobreescribes algo en base al vuelo , debes reiniciar en el acto , ... EL CORE ES MUY MUY DELICADO.

lo mejor y mas seguro es crear el xzm nuevo , y ya fuera del modo live, cambiarlos en la carpeta base ...con el sistema desmontado.

sol666

  • Visitante
Re: error con el update de vlc
« Respuesta #10 en: 20-12-2014, 00:50 (Sábado) »
del 001-core no he tocao nada  ;D ;D pero del 006 y el 009 y eliminao un monton de cosas,pa decirte que en la seccion wpa solo tengo el goyscript en internet solo el mozilla,en multimedia igual,pelao pelao  >:D >:D ahora voy a arreglar el update del vlc cambiando las lineas que has puesto a ver.
« Última modificación: 20-12-2014, 00:51 (Sábado) por sol666 »

sol666

  • Visitante
Re: error con el update de vlc
« Respuesta #11 en: 21-12-2014, 01:11 (Domingo) »
 ??? ??? pues he cambiado las lineas a por estas

VERSION=`curl -s $WEB/$PRGNAM/ | grep "[0-9]/" | cut -d '"' -f2 | tail -1 | cut -d '/' -f1`

y me da otro error despues de un rato

rootwrap.c: En la función ‘main’:
rootwrap.c:244:12: aviso: se descarta el valor de devolución de ‘setuid’, se declaró con el atributo warn_unused_result [-Wunused-result]
     setuid (uid);
            ^
  CCLD     vlc-wrapper
  CC       vlc_static-vlc.o
  CC       vlc_static-override.o
  CCLD     vlc-static
  CC       cachegen.o
  CCLD     vlc-cache-gen
  GEN      ../modules/plugins.dat
/bin/sh: línea 4: 23048 Violación de segmento  ./vlc-cache-gen ../modules
make[2]: *** [../modules/plugins.dat] Error 139
make[2]: se sale del directorio `/tmp/build/vlc/vlc-2.1.5/bin'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/tmp/build/vlc/vlc-2.1.5'
make: *** [all] Error 2
wifislax Multimedia #

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14540
Re: error con el update de vlc
« Respuesta #12 en: 21-12-2014, 01:21 (Domingo) »
pues tu veras que has tocao.  ;D



sol666

  • Visitante
Re: error con el update de vlc
« Respuesta #13 en: 21-12-2014, 01:31 (Domingo) »
usuarionuevo a ti te va bien?el de dvdstyler me ha funcionado pero el de vlc  ??? no se voy a intentarlo con la live original pero no se,de la que me falla no he eliminao ninguna libreria.
« Última modificación: 21-12-2014, 01:35 (Domingo) por sol666 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14540
Re: error con el update de vlc
« Respuesta #14 en: 21-12-2014, 01:35 (Domingo) »
usuarionuevo a ti te va bien?

si

de lo contrario habria dicho algo , pero me va bien.

lo voy a compilar ahora otra vez, a ver que pasa, pero me funciono bien ayer 3 veces que probe.
« Última modificación: 21-12-2014, 01:36 (Domingo) por USUARIONUEVO »

sol666

  • Visitante
Re: error con el update de vlc
« Respuesta #15 en: 21-12-2014, 01:50 (Domingo) »
buff,desde los slackbuilds me tira el mismo error de ayer

configure: error: libavcodec versions 56 and later are not supported yet.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14540
Re: error con el update de vlc
« Respuesta #16 en: 21-12-2014, 02:16 (Domingo) »

sol666

  • Visitante
Re: error con el update de vlc
« Respuesta #17 en: 21-12-2014, 03:36 (Domingo) »
bufff,el fallo era mio,algo me e cargao,al final lo he arreglado utilizando la live original lo e compilado con el script y bien me a creado el modulo y despues lo e puesto en mi live modificada y funciona,lo que me he dado cuenta que al no tener el smplayer y darle a un video abrir con me da a elegir entre el vlc o el actualizador del smplayer,se ve que interpreta el script como si fuera un reproductor,por lo demas bien,updaters de brasero,dvdstyler,exaile y algunos mas bien  >:( >:( >:( >:( >:( ahora a dormir y mañana mas.
« Última modificación: 21-12-2014, 03:38 (Domingo) por sol666 »

//FINAL Y MÁS DOS RESPUESTAS