Autor Tema: Instalación, arrepentimiento y caridad.  (Leído 4909 veces)

0 Usuarios y 1 Visitante están viendo este tema.

tasseguro

  • Visitante
Instalación, arrepentimiento y caridad.
« en: 10-05-2014, 17:25 (Sábado) »
Primero el arrepentimiento: Me arrepiento de todo lo malo. Y no es cachondeo.

Caridad: El tocho que va a continuación tiene pa un rato (y supongo que está lleno de pifiadas). Solicito ayuda.

Instalación:

Formateo del Ahtec para instalarle Windows 7 x64  + WifiSlax 4.8:

Darle caña en la unidad de CD al Ubuntu Live 10 final (Hacerlo con esta versión).
Pasar de hacerlo con Live de WifiSlax o WifiWay.
Con el Gparted del Ubuntu dejar el disco totalmente vacio: 289.09 GB sin asignar.Reiniciar.

Instalar Win7x64; Dice que son 298.1 Gb.
Al instalar hacer 2 particiones:
La 1ª: 124.000 megas (121.0 GB) donde va Windows.
La 2ª: Con todo el resto: 181.243 megas (177.0 GB).
Es decir, a la 2ª partición darle también formato.
Seleccionar la partición de 121 Gigas y darle a siguiente para instalar Windows ahí.

Al terminar la instalación El ***** de Windows no deja formateada la 2ª Partición.
En el AdministradorDeDiscos aparece la 2ª partición de 177 Gigas, como RAW, puede ser que con el formato de operaciones anteriores en ext4.

Y ahora qué coño hacemos hacemos.

No hacemos nada más en Windows. Aunque nos salte algún mensaje para dar formato a la 2ª partición. Tampoco instalamos drivers ni tocamos a na de na.

Reiniciamos y nos vamos al Live de Ubuntu 10 a ver qué dice Gparted:
sin asignar                           1 Mega
/dev/sda1   ntfs      ReservSistema       100 Megas       boot
/dev/sda2   ntfs                        121 Gigas
/dev/sda3   desconocido             177 Gigas

sda3 ni se nos ocurra eliminarla. La Formateamos aquí en Ubuntu en ntfs. Reiniciamos Ubuntu para que en el nuevo inicio la vuelva a ubicar no vaya a ser que nos joda.

Todo como estaba y no hay iconos de advertencia en ninguna de las particiones.
Se supone que ésta partición de 177 Gigas es primaria. Tiene el recuadro verde igual que la de Windows y la de su arranque.
Hay una al principio, la de "sin asignar" de 1 Mega, con cuadrito gris.
Se supone que sólo puede haber 4 primarias en un sistema...

Boton derecho en sda3, redimensionar:
Tamaño nuevo: 165.86 Gb - Espacio libre a continuación 11.400 megas.

Queda:
/dev/sda1   ntfs      ReservSistema      100 Megas       boot
/dev/sda2   ntfs                       121 Gigas
/dev/sda3   ntfs                       165 Gigas
sin asignar                              11 Gigas

Boton derecho en "sin asignar" - Crear nueva partición:
Tamaño nuevo: 11.400 megas (todo lo que tiene)
La creamos como partición extendida (Aquí es donde la hemos estado cagando todo el fin de semana. Extendidaaaaaaaaaa, tiene que ser EXTENDIDA).

Queda:
/dev/sda1   ntfs      ReservSistema      100 Megas       boot
/dev/sda2   ntfs                       121 Gigas
/dev/sda3   ntfs                       165 Gigas
/dev/sda4    extended             11.13 Gigas
 --->sin asignar                         11,13 Gigas

Botón derecho en "sin asignar": Nuevo:
Tamaño nuevo: 9350 megas -  EspacioLIbreAcontinuacion: 2048 megas
La creamos como ParticionLogica (no deja de otra forma) y ext4

Queda:
/dev/sda1   ntfs      ReservSistema      100 Megas       boot
/dev/sda2   ntfs                       121 Gigas
/dev/sda3   ntfs                       165 Gigas
/dev/sda4    extended             11.13 Gigas
 -->/dev/sda5   ext4                        9.13 Gigas
 -->sin asignar                         2.00 Gigas

Botón derecho en "sin asignar": Nuevo:
Tamaño nuevo: 2047 (todo, no queda más, estamos al final del disco).
Sistema de archivos: swap.
Crear como: Partición lógica (no deja de otra forma).

De momento va la cosa bien:
sin asignar                    1 Mega
/dev/sda1   ntfs      ReservSistema     100 Megas       boot
/dev/sda2   ntfs                 121 Gigas
/dev/sda3   ntfs                 165 Gigas
/dev/sda4   extended              11 Gigas
 -->/dev/sda5   ext4                  9.13 Gigas
 -->/dev/sda6    swap                   2.00 Gigas

Reiniciamos Ubuntu Live a ver si no hay jodidos iconitos de advertencia.

Todo ok. 2 iconitos de llaves en /dev/sda4 extended   y en  /dev/sda6 swap.

Reiniciamos otra vez, o apagamos-encendemos y nos vamos a Windows 7 a ver qué se cuenta de bueno...

Se pone a comprobar errores en una de las unidades...
Parece que no ve nada raro y carga el Logon.

El AdministradorDeDiscos de Win7 ve todo ok:
C - D - Las 110 megas para sistema - y las particiones de WifiSlax y Swap. Éstas ahora las ve como Tipo Básico y no como RAW como las veía cuando iba jodida la cosa.

En Equipo aparece C con 120 Gigas y D con 166 Gigas.
En D aparece un archivito: bootsqm.dat (y no como oculto). Unbuntu nos envía saludos desde el otro lado. La partición D la hemos formateado en ntfs desde allí. Si conseguimos hacer que rule el WifiSlax sin problemas, cuando volvamos a Win7
formateamos desde aquí D en ntfs de nuevo, antes de meterle nada, y con formateo lento.
Pasamos del archivo pues, no probamos a copiar nada en D, no hay que tentar al diablo.
Reiniciamos.

Metemos WifiSlax 4.8 en la Unidad de CD.
Solicita ¿Arrancar con Kernel Normal o con Kernel PAE?
Probamos con Kernel Normal, aunque en anteriores intentos, en el Gparted de WifiSlax, el cabronazo siempre salía con varios mensajes de advertencia en ingles sobre el kernel o yo no sé qué coño. Y es que esto de no tener ni **** idea no mola. Así nos va. En fins.

Probamos esta primera vez con "Kernel Normal", (otra vez, verás tú cagarla).
(Aunque parece ser que el PAE es para equipos de más de 4 Gigas de RAM. No es nuestro caso en el Ahtec).

La Siguiente Pantalla te deja elegir Modos de Escritorios.
No creo que esto dé ningún problema.
Elegimos el primero, KDE.

Cojunudoooooooooo. El Gparted de WifiSlax no da mensajes de advertencia.
Ext4 y Swap limpitas y listas para instalar. Al ataquer.

Seleccionamos en este caso /mnt/sda5. Asegurarse de que el Gparted de WifiSlax la identenfica como tal él también, no vayamos a cagarla.

Ya ha copiado los archivos, (90%) dice. Le damos a siguiente. Queda el jodido Grub.
Nos da elegir Instalación Recomendada o para Expertos. Como llegamos aquí Recomendados por nuestro Tio el Mantecas hacemos lo propio.

En modo Experto al parecer instala el Grub en otro directorio, parece ser que en el root de WifiSlax. Nosotros lo dejamos que lo instale donde le salgalosraviolli cruzando los dedos para que no machaque el Loader de Windows.

Atentos a los mensajitos de la pantallita que van saliendo, si hay alguna frase de error ya nos podemos ir despacito atomarporculo.

Buf, no sé yo. Dice que la instalación ha finalizado bla bla.
E indica que para poder iniciar otros sistemas hay que reiniciar ahora, entrar en el WifiSlax ya instalado en el DiscoDuro, y ejecutar update-grub en un terminal.

Sale bien el boot de WifiSlax. Entramos de nuevo. update-grub.

Lo hace. Reiniciamos. Nos vamos a Windows. Espero no tener que cagarmeenla****madredealguien.

Y no se de quién. Porque parece ser que el Loader de Windows7 dice quemejoda.

Probamos de nuevo... A disk read error ocurred quetejodasmedice.

De nuevo a WifiSlax. Qué bonito el escritorio. Esta bien currado. A Cesar lo que es de Cesar. update-grub.

Generando grub.cfg...
Tema encontrado:  /boot/grub/themes/default/theme.txt
Se encontró una imagen linux: /boot/vmlinuz-3.13.0-wifislax
   No volume groups found
Encontrado en ¨Windows 7 (loader) en /dev/sda1
hecho

Reiniciamos

Windows 7 (loader) (en /dev/sda1)

A disk read error ocurred
Pres Ctrl+Alt+Del to restar y NoVuelvasmásAintentarloDeÉstaFormaQueParecesGili****sJódete.

¿Alguien me pude echar una mano?



SpanishGroove

  • Visitante
Re: Instalación, arrepentimiento y caridad.
« Respuesta #1 en: 10-05-2014, 17:43 (Sábado) »
Muy Buenas!

No me ha quedado claro si el Grub lo instalaste en modo maestro o no.  :-\

Que te parecería volver a instalar el sector de arranque de Windows y volver a instalar Grub? En todos los casos que conozco, Grub ha reconocido a Windows desde lejos (vamos, desde la própia instalación), asi que lo veo un poco raro.

Por cierto, comprobaste el MD5 de las descargas?  ;)

Un Saludo!

tasseguro

  • Visitante
Re: Instalación, arrepentimiento y caridad.
« Respuesta #2 en: 10-05-2014, 18:29 (Sábado) »
Muchas gracias por tu ayuda, ManuMoore.

El Grub lo he intentado ésta vez en el modo predeterminado recomendado.

Voy a probar con el SuperGrub a reinstalarle el MBR.

Y después meter el Grub desde el Live de WifiSlax.

¿Es esto a lo que te referías, no?

El MD5 lo comprobé sobre la imagen y daba bien. No lo hice sobre el CD (si es que esto se puede o ha de hacerse o no). Voy a comprobarlo sobre el CD a ver qué tal.

Ya lo he probado y el exe del MD5 abre la unidad de CD y se encuentra con las carpetas de WifiSlax. Que qué me estás contando, me dice MD5.

En cuanto al SuperGrub, tengo el 0.9 y el 2.0. 

Con el 2.0 no he visto la forma de colocarle el MBR. He probado varias veces y, no sé si es porque está ingles, no he llegado a ver la opción de instalar o remplazar el MBR de Windows. Pero probaré de nuevo.

Con el SuperGrub 0.9 sí llegaba a la opción de instalar MBR. Lo que no sé es si, al ser Windows 7, y x64, la versión MBR es la misma que para XP, o si el 0.9 puede reemplazarla en este caso.





SpanishGroove

  • Visitante
Re: Instalación, arrepentimiento y caridad.
« Respuesta #3 en: 10-05-2014, 18:39 (Sábado) »
De nada, amigo.

Hehe, de acuerdo.

Personalmente, te recomendaría reinstalarlo desde el DVD/USB de instalación de Windows, para descartar errores innecesarios.  ^-^

Si, me refería exactamente a eso. Instalar MBR y despues Grub.

Si el MD5 en la descarga es correcto, debe de estár íntegra.

Por cierto, otra cosa que no se me quedo clara: En que momento dejas de lado a Windows, despues de instalarlo o despues de dejarlo configurado?

Saludos!
« Última modificación: 10-05-2014, 18:40 (Sábado) por ManuMoore »

tasseguro

  • Visitante
Re: Instalación, arrepentimiento y caridad.
« Respuesta #4 en: 10-05-2014, 19:08 (Sábado) »
Instalo Windows con 2 particiones y me voy a tratar de instalarle WifiSlax.

No me he puesto a configurar nada de Windows porque llevo con el tema 2 o 3 días y formateado ya 7 u 8 veces.

Y El caso es que en la instalación anterior tenía XP, Windows 7 32bit, Ubuntu y WifiSlax, y una partición D.

Pero esta vez me he atascado que no puedor.

El MBR desde el propio DVD de Windows, y se descartan errores. No lo sabía. Muchas gracias de nuevo por tu apoyo, tronqo.

Supongo que será en la opción de reparar sistema al inicio. Y quizá Windows haga un reparación general.

Quiero decir que no hay una opción directa para reparar el sector de arranque.

A MSDOS no llego y cuando acabo allí suelo terminar algo más cabreado de lo que entré. A ver qué le hacemos.

Antes de leer tu 2º mensaje le pasado el SuperGrub 0.9. Está en español y he ido leyendo despacio. Dice que lo que hace es eliminar el Grub del MBR.

Después ha arrancado Windows 7 bien.

Voy a aprobar ahora el Grub de nuevo desde el Live de WifSlax.

Y si no, la opción que dices desde el DVD de Windows 7, y luego Grub desde Wifislax.

Y si no, MBR y Grub desde SuperGrub.

Y si no...

El problema es que marcho con la informática como marchaba la vieja con la cuenta. :-[

SpanishGroove

  • Visitante
Re: Instalación, arrepentimiento y caridad.
« Respuesta #5 en: 11-05-2014, 02:03 (Domingo) »
Hehe...  ;D

Verás, la recuperación del MBR la hago desde la terminal de el modo de reparación de Windows desde el DVD/USB de instalación. A puro golpe de comando.  ;)

Lo de si configurabas Windows y tal, lo decía por si dejabas Windows a medio configurar, y eso (según creo) no termina de crear la entrada definitiva a Windows, es necesario que entres al escritorio, osea que llegues hasta el final de la instalación.

Un Saludo!

tasseguro

  • Visitante
Re: Instalación, arrepentimiento y caridad.
« Respuesta #6 en: 11-05-2014, 12:23 (Domingo) »
Sí sí, claro, he terminado con la instalación inicial de Windows. Me he dado un pequeño voltio por administración de discos.

Aunque en esta ocasión no he llegado a instalar drivers. Ni tampoco he mirado nada sobre habilitar permisos y demás. La activación del Loader no he llegado aún a parchearla.

Al final desisto de WifiSlax y me voy con los trastos a WifiWay. Algo jodido me voy, eso sí.

Cuando me pongo a los mandos del cacharro me vuelvo de un cabezón estratosférico.

O Yo, o ElMulitiplicador. Sólo puede quedar uno. Ésta vez ElMultiplicador. Y por KO. Despachurrado sobre la lona toy ahora mismo, colegón.

Pero se va a enterar, se va a enterar. Ya le he dicho que me EspereEnLaCalleSiTieneCantaplines. 8)

Salud! :D

FABERG

  • Visitante
Re: Instalación, arrepentimiento y caridad.
« Respuesta #7 en: 23-05-2014, 01:50 (Viernes) »

Mensajes: 21


Ver Perfil Email Mensaje Privado (Conectado)    
   
Re: copia el sistema al disco pero no lo reconoce el grub2 installer
« Respuesta #28 : Ayer a las 21:38 »    Responder con cita Modificar mensaje
Error cagando GRUB.

Buenas tardes, he instalado el Wifislax 4.8 en disco duro, previamente verificado su MD5 etc, la idea era que corriera a la par con windows 7 como la habia hecho con la version anterior y funcionaba excelente, el tema es que hice lo siguiente: lo instale en una particion ext3 de 30 gb la cual se llama sda/8 y cree la particion swap que segun lei debe ser la mitad de mi RAM osea 2 gb, el sistema se instalo correctamente, luego al instalar el GRUB escojo la opcion recomendada e instalar en MBR, aparece ahi en el cuadrito azul sda/1 por defecto, bueno reinicie el pc y sale el siguiente error y ya no inicia ningunos de los 2 s.o.

GRUB LOADING

WELCOME TO GRUB

error:file/boot/grub/i36-pc/normal.mod not found

enterin rescue mode...


Gracias de antemano por su valiosa ayuda.