Autor Tema: error al actualizar  (Leído 3489 veces)

0 Usuarios y 1 Visitante están viendo este tema.

nykotyno

  • Visitante
error al actualizar
« en: 24-03-2015, 18:13 (Martes) »
Hola. por fin me decidi a instalar wifislax 4.10 en mi disco duro. con los tutoriales me salio todo al pelo y a la primera. pero al reiniciar despues de actualizar me da el siguiente error :

Application: plasma-desktop (4.10.5)
KDE Platform Version: 4.10.5
Qt Version: 4.8.6
Operating System: Linux 3.12.36-pae-wifislax i686

-- Information about the crash:
<En detalle, comente que estaba haciendo cuando la aplicación se cerró.>

-- Backtrace:
A useful backtrace could not be generated


y se me queda la pantalla en negro con el puntero pero no puedo hacer nada.
gracias por vuestra ayuda de antemano.




perdon pido ayuda para saber que es lo que ha ocurrido e intentar arreglarlo o en su defecto cuando lo vuelva a instalar que es lo que no debo actualizar. Gracias otra vez


« Última modificación: 24-03-2015, 18:39 (Martes) por nykotyno »

taka-bo

  • Visitante
Re: error al actualizar
« Respuesta #1 en: 26-03-2015, 16:12 (Jueves) »

pastilla

  • Visitante
Re: error al actualizar
« Respuesta #2 en: 27-03-2015, 01:25 (Viernes) »
Bueno pues cogiendo numero para los que venimos con live-usb, lo mejor seria para no tener que hacer capturas por pantallas que el modo debug funcione por terminal para al menos poder copiar y pegar lo que sale cuando se paraliza la actualizacion, porque si le haces un control + c (para copiar y despues pegar)  se cierra el actualizador.

Asi por encima whireshark te da modulo corrupto cuando compila, el smtube aborta la descarga desde un principio, el wxGTK3 te dice que le falta la libreria png o es muy vieja, ya con los firmwares se queda bloqueado con el "cloning into linux firmware" y de ahi ya no pasa el actualizador.

Esto con changes de 4 gigas.

He visto que con el actualizador de la distro si que me sale la consola con lo que pondre el error por si se repite al actualizar de nuevo:

whireshark

Citar
wireshark-1.12.4/ui/qt/sctp_all_assocs_dialog.h
wireshark-1.12.4/ui/qt/uat_dialog.cpp
wireshark-1.12.4/ui/qt/packet_range_group_box.cpp

bzip2: Data integrity error when decompressing.
   Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now
wifislax Auditoria #


Lo he vuelto a crear borrando el temporal, a traves del actualizador de la distro y ahora si que se ha instalado,

Citar
/tmp/build/wireshark/package-wireshark/usr/lib/wireshark/plugins/opcua.la
/tmp/build/wireshark/package-wireshark/usr/lib/wireshark/plugins/m2m.la


Instalando y creando modulo xzm ...

  • Creando log var/log/packages/wireshark-1.12.4-i486-1sw

Parallel mksquashfs: Using 2 processors
Creating 4.0 filesystem on /root/Desktop/Auditoria/wireshark-1.12.4-i486-1sw.xzm, block size 262144.
[===================================================================================================================\] 1649/1649 100%

Exportable Squashfs 4.0 filesystem, xz compressed, data block size 262144
   compressed data, compressed metadata, compressed fragments, compressed xattrs
   duplicates are removed
Filesystem size 13824.56 Kbytes (13.50 Mbytes)
   17.40% of uncompressed filesystem size (79441.65 Kbytes)
Inode table size 11538 bytes (11.27 Kbytes)
   22.76% of uncompressed inode table size (50699 bytes)
Directory table size 14862 bytes (14.51 Kbytes)
   41.19% of uncompressed directory table size (36085 bytes)
Number of duplicate files found 3
Number of inodes 1545
Number of files 1384
Number of fragments 45
Number of symbolic links  8
Number of device nodes 0
Number of fifo nodes 0
Number of socket nodes 0
Number of directories 153
Number of ids (unique uids + gids) 1
Number of uids 1
   root (0)
Number of gids 1
   root (0)

Parallel unsquashfs: Using 2 processors
1392 inodes (1657 blocks) to write

[===================================================================================================================/] 1657/1657 100%

created 1384 files
created 153 directories
created 8 symlinks
created 0 devices
created 0 fifos


Creado modulo del paquete wireshark-1.12.4

Las tareas han finalizado

Bye Bye

wifislax Auditoria #

El smtube se ha arreglado al utilizar el actualizador de la distro en vez del de geminis 1.0 el problema es que como no se ha creado el modulo con el actualizador de geminis 1.0 me obliga a descargarlo de nuevo si quiero tener el modulo en el escritorio.

Citar
       ******************************
           Actualizador/Instalador    
           Paquete: smtube
                                    
           www.seguridadwireless.net  
        ******************************

Version Script: 30/12/2014

Comprobando si hay actualizaciones para el script....
NUEVA VERSION

Version Server: 03/02/2015

Actualizando smtube_updater
LISTO

    ******************************
           Actualizador/Instalador    
           Paquete: smtube
                                    
           www.seguridadwireless.net  
        ******************************

Version Script: 03/02/2015

La version del sistema es...smtube-15.1.0

__________________________________________

La version mas nueva en su pagina web es...smtube-15.1.0

Pulsa ENTER si deseas actualizarla



wxGTK3 tambien parece haberse arreglado con el proceso anterior pero tengo que volverlo a descargar por el mismo motivo.


Citar
       ******************************
           Actualizador/Instalador    
           Paquete: wxGTK3
                                    
           www.seguridadwireless.net  
        ******************************

Version Script: 31/01/2015

Comprobando si hay actualizaciones para el script....
NUEVA VERSION

Version Server: 10/02/2015

Actualizando wxGTK3_updater
LISTO


   ******************************
           Actualizador/Instalador    
           Paquete: wxGTK3
                                    
           www.seguridadwireless.net  
        ******************************

Version Script: 10/02/2015

La version del sistema es...wxGTK3-3.0.2

__________________________________________

La version mas nueva en su pagina web es...wxGTK3-3.0.2

Pulsa ENTER si deseas actualizarla



Un saludo
« Última modificación: 27-03-2015, 13:51 (Viernes) por pastilla »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14479
Re: error al actualizar
« Respuesta #3 en: 27-03-2015, 12:25 (Viernes) »
y si leyeses los errores ya serias dios...


It is possible that the compressed file(s) have become corrupted.


el archivo tar , esta corrupto ..o no se bajo completo ...

asi que te vas a tmp/build ..eliminas la carpeta wireshark ..y vuelves a empezar.

pastilla

  • Visitante
Re: error al actualizar
« Respuesta #4 en: 27-03-2015, 13:53 (Viernes) »
¡Hola! No te habia leido, ya me he puesto en ello y estoy ampliando el post con los problemas que van saliendo, a ver como acabo la actualizacion de todos los paquetes.

Un saludo       

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14479
Re: error al actualizar
« Respuesta #5 en: 27-03-2015, 14:27 (Viernes) »
el paquete sysvinitscripts

rompe el sistema.

si acaso dehabilitad el autoupdater, e id tirando manualmente ...

o bien dejais el automatico para ver updates y luego lanzais a mano los que quereis.


los paquetes de slack , se instalan con el gestor de paquetes wifislax gslatp grafico ...  podréis marcar los que quereis y los que no.

pastilla

  • Visitante
Re: error al actualizar
« Respuesta #6 en: 29-03-2015, 00:11 (Domingo) »
Para los usuarios de live-usb que creo que siempre estamos dandote problemas y ya que casi la distro esta a punto de ser autosuficente para los nomadas como nosotros, lo perfecto seria que el actualizador de Geminis se dejara marcar y desmarcar los paquetes, para de esa forma  los paquetes de gran tonelaje ( a partir de 70 megas o por ahi ) se pudieran descargar a traves del jdownloader, como ya lo has trabajado ese programa podrias hacer esa variante de descargar paquetes pesados a traves de ese gestor de descargas, con el jdownloader no hay paquete que se resista con el apartado que dispone del "http links" que siempre reanuda la descarga y me he descargado esta distro despues de casi diez roturas en las conexiones dandome el md5 correcto al final.

De esa forma no habria ningun problema sobre la actualizacion de los paquetes, con el programa abierto se consigue.

Seria la tercera opcion con el jdownloader poniendo: actualizacion de la distribucion y entonces poder escribir el paquete, ya con eso seria perfecta la distro.

Un saludo y gracias

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14479
Re: error al actualizar
« Respuesta #7 en: 29-03-2015, 01:19 (Domingo) »
eso no se puede , por que sencillamente el codigo hay que compilarlo.

para hacer eso, alguien debe compilar y crear ya el xzm ... es lo que yo hacia antes , y paso de seguir en esa tonica de generar modulos pa to quisky.

la idea de los actualizadores ademas es la de poder estar al corriente, sin necesidad de que yo , os de paquetes hechos en xzm.

Los que son TXZ , son de slackware , que viene ya compilados y solo es instalar , es como los xzm.

Pero los extras , son compilados desde la fuente , no hay xzm ni txz a no ser que se compile el code.

Los modulos grandes , ya estan en xzm en su zona , como hashcat o los driver de tarjeta grafica dedicada NVIDIA / AMD , o el libreoffice , metasploit ...
 
Lo que no voy a hacer es estar siempre pringado , cuando lo teneis a un click de raton.


__________

ademas pides que se puedan desmarcar , por que son de tonelaje ,pero pretendes descargarlos con jdown , que a lo sumo es lo mismo ...si el paquete pesa 200 megas , pesa lo mismo desde el updater que desde jdownloader.

ademas , si tienes la version retocada del updater , (la que publico geminis por un bug) , puedes blacklistear , para que no busque de tal o cual cosa ...

pero vamos , ... lo descargas con jdownloader muy bien ...  ¿y despues sabes lo que tienes que hacer para tener el xzm al final? ,¿sabes configurar ? ¿compilar? ..etc etc ..?¿  NO

Asi que las opciones son pocas , o lo haces como esta planteado , o no lo haces.

/etc/WifislaxUpdaterGUI/blacklist

Hay esta ñla lista de scripts updater que se "omitiran" , en la busqueda de actualizaciones.


por ejemplo yo tengo puesto en ese fichero..

wifislax-updaters_updater
hashcat_updater
Driver_ATI_updater


con lo que esos updaters , seran omitidos , y no se incluiran en la busqueda de paquetes del updater.


y bla bla bla y un millon de cosas mas , que no preguntais.  ;D



_______________________

los updaters solo muestran versiones nuevas , si el sistema ya tiene una version del programna que busca , en caso contrario , no se muestra nada.

si no tienes gimp , el updater de gimp , no mostrara actualizaciones , asi que deberas lanzarlo manualmente si decides que quieres ese programa. y entonces ya si apareceran en los mensajes si hay versiones nuevas de gimp.


cuando aparece un mensaje de programa nuevo , es por que el sistema ya lo lleva , pero salio uno nuevo.
« Última modificación: 29-03-2015, 01:30 (Domingo) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14479
Re: error al actualizar
« Respuesta #8 en: 29-03-2015, 01:36 (Domingo) »
Un ejemplo ...

pongamos que usas el modulo de libreoffice de la seccion de modulos , y ya hay version nueva de libreoffice y no para de salirte el mensaje , pero no quieres actualizarlo , por que es un paquete de 200 megas comprimido que descomprimido son 500 0 mas y si no tienes mucha memoria el sistema se colapsara , asi que quieres que ese paquete no se toque , por que te perjudica.


pues facil

te vas a la ruta del fichero blacklist  y añades


LibreOffice_updater

y se acabo , ya no mas mensajes de verion nueva de libreoffice.

y si despues lo instalas a disco duro , pues puedes desblacklistearlo .. o ejecutarlo a mano desde el menu de actualizadores.


________________________

como sabemos el nombre del script que quiero que se omitan busquedas de updates ?¿

te vas a

/opt/wifislax-updaters y miras dentro de las carpetas hasta ver el que quieres, y copias el name , para pegarlo en el blacklist.
« Última modificación: 29-03-2015, 01:38 (Domingo) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14479
Re: error al actualizar
« Respuesta #9 en: 29-03-2015, 01:41 (Domingo) »
Solo tengo una cosa en mente , y es solventar cuando un fichero se descargo a medias.

cuando eso sucede , al descomprimir, sale un mensaje de error .. entonces seria , que si el script ve error al descomprimir , pues que elimine el fichero y vuelva a descargarlo ... hasta que este OK.

Tipico caso de cancelar el proceso a medias de la descarga,.  ;)


mmmm , estoy probando , y no consigo que se quede algo a media descarga ,,, por que cuando cierro d ela X de la ventana o cuando cancelo usando ctrl-C , el directorio es eliminado ..para empezar de limpio al siguiente intento.

esto ,desde KDE , solo puede ser que en xfce al cerrar de la X , no se limpie , ... voy a probar.


________________

pues en xfce tambien funciona bien , ..no se como haceis para que se os quede el archivo a medias, ya que si el proceso se detiene , el script elimina todo lo que ha heco hasta ese momento.
« Última modificación: 29-03-2015, 01:58 (Domingo) por USUARIONUEVO »