Autor Tema: problema kismet  (Leído 3123 veces)

0 Usuarios y 1 Visitante están viendo este tema.

fdogr

  • Visitante
problema kismet
« en: 24-02-2008, 23:18 (Domingo) »
Antes que nada no estoy seguro de estar publicandolo en el sitio correcto si no es asi perdon y redireccionar.
Me presento, me llamo Fernando, soy de Asturias y estoy dando mis primeros pasos con linux. Uso la distro Back Track 2.0 y me pasa algo curioso con kismet. Cuando lo abro por primera vez tngo dos interfaces wifi0 y ath0, para que funcione tengo que usar wifi0 pero si salgo y vuelvo a arrancar kismet me salen mas interfaces y no me funciona ninguno, lo mas curioso es que despues tampoco me funciona el conectarme a la web porque me usa el ath1, ath2, ath3, etc.
Por supuesto airodump ya ni lo menciono ;D
Gracias de antemano y espero seguir aprendiendo



berni69

  • Visitante
Re: problema kismet
« Respuesta #1 en: 25-02-2008, 14:44 (Lunes) »
 normal que para internet no te funcione ya que el kismet lo pone en modo monitor y tu lo que necesitas para poder asociarte y usar internet es el modo managed  ;)

fdogr

  • Visitante
Re: problema kismet
« Respuesta #2 en: 26-02-2008, 17:08 (Martes) »
Gracias por contestar, pero creo que no me he explicado bien, entiendo que lo ponga en modo monitor y como tal funciona la primera vez que lo uso, pero mas tarde no funciona ni el kismet ni nada haga lo que haga (de lo poco que se) ni habilitando tarjeta, ni desabilitando (ifconfig) ni cambiando modos (iwconfig). La verdad otra cosa no se me ha ocurrido.Me recuerda aquellos viejos tiempos de mi primer inicio en red hat y descubrir que mi modem no servia porque era solo para windous.
Es mas, por si sirve el comentario, la primera vez que entro en kismet aparecen en mi zona una media de 6 redes, selecciono mi red,perfecto,miro los detalles de mi red, ok, salgo y ya no va y si vuelvo a escanear despues ya no me encuentra ninguna red.
Aun no he tenido tiempo de probar wifiway y wifislax pero por lo poco que he leido por aqui son semejantes en el fondo a BT 2.0.
De nuevo gracias Berni, seguire investigando.

Espero no haberme liado demasiado y que se me entienda minimamente.
Salu2

berni69

  • Visitante
Re: problema kismet
« Respuesta #3 en: 26-02-2008, 17:45 (Martes) »
prueba destruyendo y volviendo a crear la interfaz ath0

si alguien se acuerda del comando que se lo curre y que lo ponga porque yo estoy acostumbrado a usar los lanzadores de wifislax  :-[ :P

chinitiw

  • Visitante
Re: problema kismet
« Respuesta #4 en: 26-02-2008, 18:03 (Martes) »
wlanconfig athX destroy --->(Destruye la interfaz X)

airmon-ng start wifi0 --->(crea una nueva en modo monitor)

Pero para completar:

El típico de siempre:
Código:

iwconfig ath0 mode monitor

Si da da error. Eliminamos la interfaz ath0:
Código:

wlanconfig ath0 destroy

Creamos una sola interfaz para modo monitor:
Código:

modprobe -r ath_pci

modprobe ath_pci autocreate=monitor

Y ya lo tenemos:
Código:

iwconfig ath0 mode monitor

Que quieres instalar mas interfaces:
Código:

wlanconfig ath create wlandev wifi0 wlanmode monitor nosbeacon

Y tenemos la ath0 y ath1. ¿Que quieres quitar la interfaz ath1?
Código:

wlanconfig ath1 destroy

Si partimos de la base que tenemos solo la interfaz ath0 pero no entra en modo monitor, pues:
Código:

wlanconfig ath0 destroy

wlanconfig ath create wlandev wifi0 wlanmode monitor nosbeacon


iwconfig ath0 mode monitor

Si usamos la suite 0.9 del aircrack-ng, tenemos mas facilidades:

En lugar de:

modprobe -r ath_pci
modprobe ath_pci autocreate=monitor

es suficente con:

airmon-ng start wifi0

os crea una nueva interface en modo monitor.

Y, mediante:

airmon-ng stop athX

os destruye esa interfaz.


Saludos  ;)

berni69

  • Visitante
Re: problema kismet
« Respuesta #5 en: 26-02-2008, 18:06 (Martes) »
 :-' :-' :-'
currada  ;)

fdogr

  • Visitante
Re: problema kismet
« Respuesta #6 en: 27-02-2008, 10:57 (Miércoles) »
Muchisimas gracias, voy a probar ahora mismo.
Si no va bien de esta no se si cortarme las venas o arreglar el router a martillazos.
salu2

fdogr

  • Visitante
Re: problema kismet
« Respuesta #7 en: 27-02-2008, 12:47 (Miércoles) »
Ta arreglao mas o menos, es problema del kismet que algo raro hace, de hecho aircrack y demas funciona a la pereccion pero si entro en kismet, tal y como viene en la distro se estropea todo, empieza a abrir ath1,2 y uno que se llama kis y tengo que matar todos los interfaces y cargarlos de nuevo, incluso despues me deja problemas con el iwconfig puesto que no puedo cambiarlo a managed.
De todas formas gracias.
Salu2
« Última modificación: 03-03-2008, 09:42 (Lunes) por fdogr »