Autor Tema: Inyectar con 4965  (Leído 180320 veces)

0 Usuarios y 1 Visitante están viendo este tema.

kyocarlos

  • Visitante
Re: Inyectar con 4965
« Respuesta #60 en: 16-12-2008, 20:57 (Martes) »
hola a todos,

Tengo una duda respecto a todo lo explicado aquí respecto a lo del wpa_supplicant con Wifiway 1.0 final y la 4965

La inyeccion cuando hay algun cliente asociado debería funcionar directamente?

Lo digo pq contra un cliente asociado me inyecta pero los data no suben.

Haciendo lo mismo con mi ubuntu con el kernel 2.6.26.5 el mismo equipo contra el mismo cliente si que me suben los data.
Deduzco que el comportamiento de los kernels y/o versiones de los drivers hace que lo detecte mejor o peor pq si no no sé.

Seguiré experimentando.


Aprovecho para dar una sugerencia a los que lo tengan instalado.

Yo en mi ubuntu, tunee el airoscript para que cuando tuviera que hacer la asocicion falsa te generara el fichero <nomre_red>.conf con los datos necesarios y que lanzara automaticamente el wpa_supplicant contra este fichero. Así te ahorras de hacerlo a mano. Al acabar hasta lo puedes destruir y limpiar el proceso si quieres.


Gracias.




Bht Sata

  • Visitante
Re: Inyectar con 4965
« Respuesta #61 en: 16-12-2008, 21:39 (Martes) »
Haces la desautentificacion para conseguir que suban los arp? ;D

kyocarlos

  • Visitante
Re: Inyectar con 4965
« Respuesta #62 en: 16-12-2008, 22:46 (Martes) »
No, si esta conectado, solamente navego con el cliente con el que quiero hacer la prueba (es mio) y con ubuntu cuando inyecta suben los data pero con wifiway no.

dexter back

  • Visitante
Re: Inyectar con 4965
« Respuesta #63 en: 17-12-2008, 00:33 (Miércoles) »

Aprovecho para dar una sugerencia a los que lo tengan instalado.

Yo en mi ubuntu, tunee el airoscript para que cuando tuviera que hacer la asocicion falsa te generara el fichero <nomre_red>.conf con los datos necesarios y que lanzara automaticamente el wpa_supplicant contra este fichero. Así te ahorras de hacerlo a mano. Al acabar hasta lo puedes destruir y limpiar el proceso si quieres.


Gracias.



seria bueno que lo subieras para probar  >:(

un saludo

dario

  • Visitante
Re: Inyectar con 4965
« Respuesta #64 en: 17-12-2008, 11:47 (Miércoles) »
Con respecto a mi problema nadie respondio ?

Alguno tiene idea ?

Gracias :D

*dudux

  • Visitante
Re: Inyectar con 4965
« Respuesta #65 en: 17-12-2008, 12:10 (Miércoles) »
estoy siguiendo la guia paso a paso del video ! obvio modificando los datos por los de mi red WEP y me da error aqui !

airodump-ng  -w dario  --bssid (mac de nuestro router )  -C  X mon0

me da el error con la red q pruebe  me dice

checking available frequencies, this could take few seconds.
done        --------- aca flashee que iba a funcionar pero el destino dijo no !   
No valid frequency given

o sea me dice que la frecuencia dada no es valida !


-c de canal en minusculas

dexter back

  • Visitante
Re: Inyectar con 4965
« Respuesta #66 en: 18-12-2008, 03:02 (Jueves) »
estoy siguiendo la guia paso a paso del video ! obvio modificando los datos por los de mi red WEP y me da error aqui !

airodump-ng  -w dario  --bssid (mac de nuestro router )  -C  X mon0

me da el error con la red q pruebe  me dice

checking available frequencies, this could take few seconds.
done        --------- aca flashee que iba a funcionar pero el destino dijo no !   
No valid frequency given

o sea me dice que la frecuencia dada no es valida !


-c de canal en minusculas

muy buen ojo  ;D

dario

  • Visitante
Re: Inyectar con 4965
« Respuesta #67 en: 18-12-2008, 11:11 (Jueves) »
Ante todo una vez mas muchas gracias no solo a los del staff sino a todos los que toman su tiempo y responden .

Si era ese el error se me paso la C en mayuscula !!

Luego una pregunta pude crackear mi propia red (la clave en hexa que me dio es de  26 caracteres o sea 13 pares hay algo mal no??)



pero lo que no me subian eran los ACKS nunca se movieron de  0 ..  puede ser  que haya que desactivar korec ?

si es asi como se hace o sea en que paso se debe hacer y si dejan el comando se agradeceria.. 
acaro ando googleando al respecto :D
Muchisimas Gracias  // Dario

« Última modificación: 18-12-2008, 14:33 (Jueves) por dario »

kyocarlos

  • Visitante
Re: Inyectar con 4965
« Respuesta #68 en: 20-12-2008, 15:21 (Sábado) »
Hola a todos,

Sigo sin poder inyecar con la 4965 con el wifiway 1.0 final instalado.

Inyecto sobre un cliente que ya existe y si que me dice que envia un monton de paquetes pero los Data a penas se mueven.

Otra cosa:

Como os paso mi moficación de airoscript que lanza el cliente con wpa_supplicant para que la probeis?

Gracias.

Jacko

  • Visitante
Re: Inyectar con 4965
« Respuesta #69 en: 20-12-2008, 17:34 (Sábado) »
cuélgalo en algun sitio de modo que los que usamos la liveCD tan solo tengamos que hacer wget  ...

Un saludo.

*dudux

  • Visitante
Re: Inyectar con 4965
« Respuesta #70 en: 20-12-2008, 17:55 (Sábado) »
Hola a todos,

Sigo sin poder inyecar con la 4965 con el wifiway 1.0 final instalado.

Inyecto sobre un cliente que ya existe y si que me dice que envia un monton de paquetes pero los Data a penas se mueven.

Otra cosa:

Como os paso mi moficación de airoscript que lanza el cliente con wpa_supplicant para que la probeis?

Gracias.

mandamelo por mail y lo subo

kyocarlos

  • Visitante
Re: Inyectar con 4965
« Respuesta #71 en: 21-12-2008, 14:00 (Domingo) »
hola a todos,

He colgado un 3  archivos que contienen las modificaciones que comentaba del wpa_supplicant en un espacio web que tengo en google:

Basicamente he modificado:
- el airoscript.es que venia en el wifiway 1.0 beta2  para que llame a la shell que crea el cliente falso
(clienteFalso.sh)
- He fijado la interficie de inyeccion a mon0
- He creado un script monitor.sh para preparar la tarjeta en modo monitor poniendole la mac falsa, fijada en airoscriptes.sh
- He modificado la manera de usar wlandecrypter para que use wepattack en vez del el ataque de diccionario con el flag -w que no funcionaba en versiones anteriores de aircrack-ng

Código: [Seleccionar]
function fakeauth {
 killall -9 wpa_supplicant > /dev/null
xterm $HOLD -title "Asociando con: $Host_SSID " $BOTTOMRIGHT -bg "#000000" -fg "#FF0009" -e ./clienteFalso.sh "$Host_SSID" $Host_MAC
}


Os podeis bajar clienteFalso.sh y airoscriptes.sh y monitor.sh de las siguientes urls:

http://sites.google.com/site/wificorsg/airoscript/airoscriptes.sh

http://sites.google.com/site/wificorsg/airoscript/clienteFalso.sh

http://sites.google.com/site/wificorsg/airoscript/monitor.sh

monitor.sh puede aceptar como parametro el canal.

Probadlo y el que pueda mejorarlo y adaptarrlo a la nueva version de airoscript pues mejor.

Todo esto lo he usado en ubuntu hardy.
« Última modificación: 21-12-2008, 14:29 (Domingo) por kyocarlos »

Jacko

  • Visitante
Re: Inyectar con 4965
« Respuesta #72 en: 21-12-2008, 15:14 (Domingo) »
Hola, he probado tus scripts: el de monitor me rula bien, pero el airoscriptes.sh no me escanea las redes, justo antes de ponerse a escanear me suelta:

fopen failed: No such file or directory
Could not create "/home/corsg/wifi/capturas/dump-01.txt"


He probado dandole permisos  y tambien creando yo mismo los directorios siguiendo la misma ruta, e incluso creando el .txt pero me sigue dando el mismo error.

kyocarlos

  • Visitante
Re: Inyectar con 4965
« Respuesta #73 en: 21-12-2008, 22:00 (Domingo) »
Ahora que lo dices, es verdad que en el airoscriptes.sh deje fijadas rutas a
mi máquina:

Código: [Seleccionar]
#The path where the data is stored (FOLDER MUST EXIST !)
DUMP_PATH="/home/corsg/wifi/capturas"
# Path to your wordlist file (for WPA dictionnary attack, maybe for WEP in next release to)
WORDLIST="/home/corsg/wifi/capturas/wordlist"
WORDLIST1="/home/corsg/wifi/capturas/wordlist/diccionariodlink"


Habría que reemplazar estas rutas por unas que tengais.

Yo este script lo uso con Ubuntu.

Haré la prueba con wifiway a ver si hay alguna peculiaridad que hace que de ese error pero existiendo los directorios no tendría que dar problemas.

De todas formas a ver si tengo un momento y lo pruebo.

Jacko

  • Visitante
Re: Inyectar con 4965
« Respuesta #74 en: 21-12-2008, 23:29 (Domingo) »
He vuelto a probar creando yo la ruta y me ha funcionado, aunque no he podido inyectar, sin embargo luego lo he intentado por comandos, siguiendo los pasos anteriormente descritos y si he podido inyectar aunque no me ha valido de nada porque aunque el aireplay decia que inyectaba a 498 pps, en el airodump, los data (IV's) subian a una velocidad desesperantemente lenta, a lo mejor en un segundo subian 10 data de golpe, y luego de tiraba varios segundos sin subir nada, aunque los packets si que subian a 498 al segundo. Para que veais mejor la situacion os dejo al siguiente captura.





P.D. ¿Alguien sabe por qué me pasa eso de que los data me suban con tanta lentitud?

kyocarlos

  • Visitante
Re: Inyectar con 4965
« Respuesta #75 en: 21-12-2008, 23:57 (Domingo) »
Jacko,

Entonces has conseguido que airoscriptes.sh te cree el cliente wpa_supplicant automatico con mi script? Cualquier mejora será bien recibida.

Respecto a lo de los data lento, es justamente lo que me pasa a mi:

aireplay-ng dice que inyecta y de hecho se ve que envia paquetes a gran velocidad pero airodump-ng muestra que los data a penas se mueven.

Alguien ha conseguido inyectar con exito de forma que los data suban rapido?

Si lo habeis conseguido es con inyección sobre un cliente existente o con uno falso?

Gracias.

Jacko

  • Visitante
Re: Inyectar con 4965
« Respuesta #76 en: 22-12-2008, 02:25 (Lunes) »
kyocarlos, respecto a tu pregunta, la respuesta es afirmativo   ;D

Me encantaría ayudarte con la programación del script, pero el caso es que no se nada de perl (ya no se enseña eso en ninguna facultad). Yo si pasas eso a Java, te ayudo en lo que quieras  ;)

Saludos.

P.D. La incógnita de aún inyectando a full, los data suben lentos sigue estando en el aire. Un compañero me ha dicho que podría ser porque estamos demasiado lejos del router, aunque no me convence.

eldayicara

  • Visitante
Re: Inyectar con 4965
« Respuesta #77 en: 24-12-2008, 13:38 (Miércoles) »
Hola a todos, he seguido el manual con las diferentes opciones que dais pero me he atascado en un paso. Esto es lo que hago, teniendo ya creado el wpa.conf (lo guardo en el escritorio y uso wifiway 1.0 final):
Código: [Seleccionar]
iwconfig

lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Tx-Power=0 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

wifiway ~ # airmon-ng start wlan0


Interface       Chipset         Driver

wlan0           Unknown         iwlagn - [phy0]
                                (monitor mode enabled on mon0)

wifiway ~ # sudo wpa_supplicant -c/root/Desktop/wpa.conf -Dwext -iwlan0
bash: sudo: command not found
wifiway ~ # -wpa_supplicant -c/root/Desktop/wpa.conf -Dwext -iwlan0
bash: -wpa_supplicant: command not found
wifiway ~ # sudo wpa_supplicant -c/root/Desktop/wpa.conf -Dwext -iwlan0
bash: sudo: command not found
wifiway ~ # sudo -wpa_supplicant -c/root/Desktop/wpa.conf -Dwext -iwlan0
bash: sudo: command not found
wifiway ~ # -sudo wpa_supplicant -c/root/Desktop/wpa.conf -Dwext -iwlan0
bash: -sudo: command not found
wifiway ~ # sudo wpa_supplicant -c/root/Desktop/wpa.conf -Dwext wlan0
bash: sudo: command not found
wifiway ~ # sudo wpa_supplicant -c/root/Desktop/wpa.conf -Dwext -iwlan0
bash: sudo: command not found
wifiway ~ # sudo wpa_supplicant -c/root/Desktop/wpa.conf -Dwext -imon0
bash: sudo: command not found
wifiway ~ # sudo wpa_supplicant -c/root/Desktop/wpa.conf -Dwext -suscuernos0
bash: sudo: command not found

Amos creo que ya lo he probao todo y nanai ;D Se os ocurre algo?
« Última modificación: 24-12-2008, 13:40 (Miércoles) por eldayicara »

Bht Sata

  • Visitante
Re: Inyectar con 4965
« Respuesta #78 en: 24-12-2008, 14:01 (Miércoles) »
 :D Si, en wifiway no tienes que logearte como root, repite el comando pero sin el sudo  ;)

monkmonk

  • Visitante
Re: Inyectar con 4965
« Respuesta #79 en: 24-12-2008, 15:26 (Miércoles) »
Hola, yo no se que es lo que hago mal, pero no consigo que coja nada >.<

mira, uno Wifiway 1.0 final, i supuestamente, con la 4965 sin tenerle que hacer nada ya tiene que inyectar no?

bueno, pues los pasos que yo ago son estos:

1- ifconfig wlan0 down
2- macchanger -m 00:11:22:33:44:55 wlan0 (se cambia perfectamente)
3- miro, y si, esta en managed
4- ifconfig wlan0 up (sino no me deja escaniar con iwlist)
5- iwlist wlan0 scan
6- cambio la config con los datos de mi red para el wpa_supplicant
7- airmon-ng start wlan0 channel "micanal" (y sep, se pone en mon0)
8- airodump-ng -w "prueva" --bssid "laMACdelrouter" -c "micanal" mon0 (empieza a obserbar)
9-me asocio con: wpa_supplicant -c/root/Desktop/wpa.conf -Dwext -iwlan0 (/root/Desktop/wpa.conf esto es en mi caso solo) y lo hace, pero con un mensaje 1 poco diferente, esto ya me suena 1 poco raro ejeje aki os pongo la foto:

http://img131.imageshack.us/img131/1032/21238603zd9.png

10- aireplay-ng -3 -b "laMACdelrouter" -h "MACdela4965" mon0 (y empieza tan tranquila)


ahora viene el problema, y es que llevo 1 hora i media esperando, i no abanza ejejejjejj aqui os pongo las fotos:

http://img512.imageshack.us/img512/3775/14937798sa7.png

http://img512.imageshack.us/img512/5743/41816547ls5.png

(no estan hechas en el mismo tiempo)

no se si es el mensaje este raro que me tiro el wpa_supplicant, o es que no inyecta.. nosep..^^

espero que alguien me pueda ayudar jejeje

gracias por leerlo!^^





MODIFICADOOOO xddd


una cosa!!, que me acabo de despistar un rato, y empezo a inyectar!!!
pero mi pergunta ahora es.... porque me empieza a las 2 horas?? que tengo que hacer para que empieze mas rapido?

foto:

http://img262.imageshack.us/img262/8346/12nh5.png

xddd




MODIFICADOOOO (por segunda vez xd)

es normal que me pase esto con tantos ivs??

foto:
http://img253.imageshack.us/my.php?image=13cb0.png

estoy hecho un lio >.<

PD: espero que me explique bien con tanta foto  jejejjej




MODIFICADOOOO (por tercera vez xd)

al final lo prove con PTW i me funciono, pero porque con PTW no tardo ni 1 segundo y de la forma normal no lo conseguia??

foto:

http://img185.imageshack.us/img185/1716/152ud2.png

PD: siento tantas modificaciones, pero es que no queria spammear y a la vez queria mantereros informados de lo que me pasava^^ nose si ice bien o mal ejejej
grax^^
« Última modificación: 24-12-2008, 16:16 (Miércoles) por monkmonk »