Autor Tema: Actualizar paquetes de openwrt  (Leído 757 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Ficht

  • Visitante
Actualizar paquetes de openwrt
« en: 31-01-2018, 20:29 (Miércoles) »
Hoy a medio día comprobe que ya la vieja dirección del feed para instalar paquetes, ya ha sido pasado a la dirección: http://archive.openwrt.org
Citar
src/gz chaos_calmer_base http://archive.openwrt.org/chaos_calmer/15.05.1/brcm63xx/generic/packages/base
src/gz chaos_calmer_luci http://archive.openwrt.org/chaos_calmer/15.05.1/brcm63xx/generic/packages/luci
src/gz chaos_calmer_management http://archive.openwrt.org/chaos_calmer/15.05.1/brcm63xx/generic/packages/management
src/gz chaos_calmer_packages http://archive.openwrt.org/chaos_calmer/15.05.1/brcm63xx/generic/packages/packages
src/gz chaos_calmer_routing http://archive.openwrt.org/chaos_calmer/15.05.1/brcm63xx/generic/packages/routing
Pero por algún motivo no funciona adecuadamente..
solo he logrado hacerlo funcionar cambiando el dominio por su IP.

Quedandome así.

Código: [Seleccionar]
src/gz chaos_calmer_base 81.0.124.218/chaos_calmer/15.05/brcm63xx/generic/packages/base
src/gz chaos_calmer_luci 81.0.124.218/chaos_calmer/15.05/brcm63xx/generic/packages/luci
src/gz chaos_calmer_management 81.0.124.218/chaos_calmer/15.05/brcm63xx/generic/packages/management
src/gz chaos_calmer_packages 81.0.124.218/chaos_calmer/15.05/brcm63xx/generic/packages/packages
src/gz chaos_calmer_routing 81.0.124.218/chaos_calmer/15.05/brcm63xx/generic/packages/routing
src/gz chaos_calmer_targets 81.0.124.218/chaos_calmer/15.05/brcm63xx/generic/packages/targets
src/gz chaos_calmer_telephony 81.0.124.218/chaos_calmer/15.05/brcm63xx/generic/packages/telephony

Esta solución funciona bien pero aún no se el motivo, igual necesita mas tiempo de actualizar dominio=IP  no idea  ???



peperfus

  • Visitante
Re: Actualizar paquetes de openwrt
« Respuesta #1 en: 01-02-2018, 23:31 (Jueves) »
Las actualizaciones en los servidores de DNS, creo que tardan entre 24 y 48 horas en propagarse por todo el mundo (me suena que era algo así).
Supongo que debe de ser por eso.

Ficht

  • Visitante
Re: Actualizar paquetes de openwrt
« Respuesta #2 en: 01-02-2018, 23:42 (Jueves) »
Las actualizaciones en los servidores de DNS, creo que tardan entre 24 y 48 horas en propagarse por todo el mundo (me suena que era algo así).
Supongo que debe de ser por eso.

No se, era extraño, hoy funciona con normalidad, ayer la redirección funcionaba bien en http desde el navegador, pero desde la consola del router no, no resolvía los gz, a no ser que usara el cambio del dominio por la ip.

peperfus

  • Visitante
Re: Actualizar paquetes de openwrt
« Respuesta #3 en: 02-02-2018, 12:15 (Viernes) »
¿Igual es que tienes en el router unos DNS's distintos a los del PC ??

Si no es eso, sí que me parece raro y supongo que habrá sido por otra cosa. ¿Probaste a borrar la caché...?

Por cierto, ¿qué secuencia de comandos usas para actualizar los paquetes?

Encontré por ahí esta que va fenomenal:
(La guardé en un script que ejecuto de vez en cuando para actualizarlos)

Código: [Seleccionar]
#!/bin/sh

opkg update
opkg list-upgradable | awk -F ‘ – ‘ ‘{print $1}’ | xargs opkg upgrade
« Última modificación: 02-02-2018, 12:30 (Viernes) por peperfus »

Ficht

  • Visitante
Re: Actualizar paquetes de openwrt
« Respuesta #4 en: 02-02-2018, 14:17 (Viernes) »
¿Igual es que tienes en el router unos DNS's distintos a los del PC ??

Si no es eso, sí que me parece raro y supongo que habrá sido por otra cosa. ¿Probaste a borrar la caché...?

Por cierto, ¿qué secuencia de comandos usas para actualizar los paquetes?

A ver, cuento la película para que se entienda la cara de poker que se me quedó...
 Flasheo una imagen, actualizo, he instalo varios programas... todo ok.
veo que algún módulo que hay que incluirlo en el kernel desde "make kernel_menuconfig" me faltó. vuelvo a compilar y al día siguiente, flasheo.
Al lanzar opkg update falló, lanzó un mansaje parecido a wget faultxxxxx no existe la dirección "archive.openwrt.org". (las dns en mi red están bien configuradas)
Introduje desde en navegador la línea de actualización y me devolvió un mensaje algo extraño, que no entendí, pero lo importante era que el servidor estaba, resolví la ip y la sustituí en la línea así, funcionó perfecto, el  tercer día vuelvo a probar por curiosidad y la línea original funcionaba otra vez perfectamente. No sé que pasó, tampoco fue grave.