Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 592584 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Hemin

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #60 en: 07-11-2013, 17:50 (Jueves) »
Buenos días,

En primer lugar siento no haber podido contestar antes, pero el Máster me está quitando más tiempo del que me gustaría, junto con ciertos problemas con Apple que me han hecho quedarme sin portátil desde hace casi un mes (http://www.mbp2011.com/), y para colmo me han robado el iPad Mini (mala racha, supongo xD). Menos mal que tengo un sobremesa nuevo :/...

Voy a dar una serie de consejos generales sobre cómo obtener las IPs necesarias y cuál se utiliza para cada cosa y alguna otra explicación general. Si alguien tiene dudas después, que vuelva a postear e intentaré solucionarlas cuanto antes.

Para obtener las direcciones IPs necesarias para Imagenio lo mejor es hacer un backup de la configuración del router de Movistar.

Una vez que tenemos dicho backup (backupsettings.conf), lo abrimos con un editor de texto y buscamos lo siguiente:
Código: [Seleccionar]
br0:0De esta forma, encontraremos la sección relacionada con el alias de la LAN:
Código: [Seleccionar]
<IPInterface instance="2">
<Enable>TRUE</Enable>
<IPInterfaceIPAddress>10.217.47.233</IPInterfaceIPAddress>
<IPInterfaceSubnetMask>255.255.255.248</IPInterfaceSubnetMask>
<X_BROADCOM_COM_IfName>br0:0</X_BROADCOM_COM_IfName>
</IPInterface>
Esa es la IP y máscara de subred del alias de la LAN.
Código: [Seleccionar]

config 'alias'
option 'interface' 'lan'
option 'proto' 'static'
option ipaddr '10.217.47.233'
option netmask '255.255.255.248'

Por otro lado, si queremos saber la dirección IP de la interfaz IPTV buscamos lo siguiente:
Código: [Seleccionar]
eth0.2Y nos encontramos con la sección:
Código: [Seleccionar]
<WANIPConnection instance="2">
<Enable>TRUE</Enable>
<ConnectionType>IP_Routed</ConnectionType>
<Name>2</Name>
<AddressingType>Static</AddressingType>
<ExternalIPAddress>172.26.208.63</ExternalIPAddress>
<SubnetMask>255.255.240.0</SubnetMask>
<DefaultGateway>172.26.208.1</DefaultGateway>
<X_BROADCOM_COM_IGMPEnabled>TRUE</X_BROADCOM_COM_IGMPEnabled>
<X_TELEFONICA-ES_IGMPEnabled>TRUE</X_TELEFONICA-ES_IGMPEnabled>
<RouteProtocolRx>RIPv2</RouteProtocolRx>
<X_BROADCOM_COM_IfName>eth0.2</X_BROADCOM_COM_IfName>
<X_BROADCOM_COM_VlanMux8021p>4</X_BROADCOM_COM_VlanMux8021p>
<X_BROADCOM_COM_VlanMuxID>2</X_BROADCOM_COM_VlanMuxID>
<PortMappingNumberOfEntries>0</PortMappingNumberOfEntries>
</WANIPConnection>
Esa es la IP, máscara de subred y gateway de la IPTV:
Código: [Seleccionar]
config interface 'iptv'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '172.26.208.63'
option netmask '255.255.240.0'
option gateway '172.26.208.1'

En cuanto a la VOIP no debería haber ninguna duda, dado que la configuración se realiza por DHCP, y si está bird4 bien configurado como aparece en el tutorial y la interfaz VOIP también, debería funcionar sí o sí xD.

Saludos!

La verdad es que no se me habia ocurrido lo de la configuración, creia que no estava en texto plano.

Ahora puedo confirmar definitivamente que yo no tengo alias, y mi ip de la iptv es del rango 10.128.0.0/9, donde la puerta de enlace es 10.128.0.1. Poniendo el IGMPProxy en modo debug veo que me llegan paquetes de la red 172.26, pero la mayoria son de mi propia ip de la iptv y el mensaje dice que al ser del propio router las descarta.

Creo que el esquema seria el siguiente:

RED IPTV MOVISTAR (172.26.x.x)------Router Movistar (10.128.0.1)-------NAT-------Router de mi casa(iptv 10.246.x.x)--Red Deco=LAN(192.168.1.0/24)

En el ejemplo tuyo el esquema seria este:

RED IPTV MOVISTAR (172.26.x.x)---------Router de mi casa(iptv 172.26.x.y)---Red Deco (alias 10.x.x.x)

Como la ip del router de esta en la misma red que la de la iptv de movistar, no aplica nat, y el deco tiene otra red diferente de la lan.

Teniendo esto claro, estoy intentando hacer pruebas, pero de momento sin exito



Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #61 en: 07-11-2013, 18:34 (Jueves) »
Noltari te lo curras que da gusto tio. Muchas gracias, si a ti te quita tiempo el Master, a mí, entre el trabajo, programar y un muchachito de 6 meses, no tengo tiempo de nada. Te agradezco enormemente tú esfuerzo para que los más nuevos entendamos todo este entramado, da gusto ver gente que ayuda tan desinteresadamente.

Un 10 para tí compi. En cuanto tenga una ratillo empiezo a hacer pruebas.

Una vez más muchas gracias compañero. >:(

PD: Yo tengo una MacBook Pro 15" Retina display que compré el año pasado y un MAC Pro con 4 años ya y de momento tocaré madera pero ni un fallo en ninguno de los dos. Has probado ya Mavericks?
Sí, he probado Mavericks las 10 horas que me duró vivo el Macbook después de realizar un primer cambio de la placa base, que costó bastante dinero :(. En lo que queda de tarde/noche me pasaré por la Apple Store para recoger el Mac con otra placa base nueva (esta ya es la tercera, contando la original y la que petó en 10 horas).

La verdad es que no se me habia ocurrido lo de la configuración, creia que no estava en texto plano.

Ahora puedo confirmar definitivamente que yo no tengo alias, y mi ip de la iptv es del rango 10.128.0.0/9, donde la puerta de enlace es 10.128.0.1. Poniendo el IGMPProxy en modo debug veo que me llegan paquetes de la red 172.26, pero la mayoria son de mi propia ip de la iptv y el mensaje dice que al ser del propio router las descarta.

Creo que el esquema seria el siguiente:

RED IPTV MOVISTAR (172.26.x.x)------Router Movistar (10.128.0.1)-------NAT-------Router de mi casa(iptv 10.246.x.x)--Red Deco=LAN(192.168.1.0/24)

En el ejemplo tuyo el esquema seria este:

RED IPTV MOVISTAR (172.26.x.x)---------Router de mi casa(iptv 172.26.x.y)---Red Deco (alias 10.x.x.x)

Como la ip del router de esta en la misma red que la de la iptv de movistar, no aplica nat, y el deco tiene otra red diferente de la lan.

Teniendo esto claro, estoy intentando hacer pruebas, pero de momento sin exito
Pues entonces sí que tienes una configuración distinta a la mía :$.

¿Qué router tienes? ¿Comtrend o Teldat?
¿Me puedes enviar el fichero de configuración por mensaje privado/email? (si tengo tiempo le echo un ojo)

Saludos!

Hemin

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #62 en: 07-11-2013, 19:28 (Jueves) »
Noltari te lo curras que da gusto tio. Muchas gracias, si a ti te quita tiempo el Master, a mí, entre el trabajo, programar y un muchachito de 6 meses, no tengo tiempo de nada. Te agradezco enormemente tú esfuerzo para que los más nuevos entendamos todo este entramado, da gusto ver gente que ayuda tan desinteresadamente.

Un 10 para tí compi. En cuanto tenga una ratillo empiezo a hacer pruebas.

Una vez más muchas gracias compañero. >:(

PD: Yo tengo una MacBook Pro 15" Retina display que compré el año pasado y un MAC Pro con 4 años ya y de momento tocaré madera pero ni un fallo en ninguno de los dos. Has probado ya Mavericks?
Sí, he probado Mavericks las 10 horas que me duró vivo el Macbook después de realizar un primer cambio de la placa base, que costó bastante dinero :(. En lo que queda de tarde/noche me pasaré por la Apple Store para recoger el Mac con otra placa base nueva (esta ya es la tercera, contando la original y la que petó en 10 horas).

La verdad es que no se me habia ocurrido lo de la configuración, creia que no estava en texto plano.

Ahora puedo confirmar definitivamente que yo no tengo alias, y mi ip de la iptv es del rango 10.128.0.0/9, donde la puerta de enlace es 10.128.0.1. Poniendo el IGMPProxy en modo debug veo que me llegan paquetes de la red 172.26, pero la mayoria son de mi propia ip de la iptv y el mensaje dice que al ser del propio router las descarta.

Creo que el esquema seria el siguiente:

RED IPTV MOVISTAR (172.26.x.x)------Router Movistar (10.128.0.1)-------NAT-------Router de mi casa(iptv 10.246.x.x)--Red Deco=LAN(192.168.1.0/24)

En el ejemplo tuyo el esquema seria este:

RED IPTV MOVISTAR (172.26.x.x)---------Router de mi casa(iptv 172.26.x.y)---Red Deco (alias 10.x.x.x)

Como la ip del router de esta en la misma red que la de la iptv de movistar, no aplica nat, y el deco tiene otra red diferente de la lan.

Teniendo esto claro, estoy intentando hacer pruebas, pero de momento sin exito
Pues entonces sí que tienes una configuración distinta a la mía :$.

¿Qué router tienes? ¿Comtrend o Teldat?
¿Me puedes enviar el fichero de configuración por mensaje privado/email? (si tengo tiempo le echo un ojo)

Saludos!

Bueno, al fin ya me funciona, aunque la verdad es que he tocado tantas cosas que no se a partir de que momento ha empezado a funcionar.

Tenia configurado el router según tu guía y había cambiando las cosas con la configuración que tengo imagenio, todas las pruebas las hacia con VLC, el problema era que con el router de movistar hacia las pruebas con el portátil del trabajo y funcionaba bien. Para el router con openwrt utilizaba el sobremesa de casa y no me iba... Al final he probado con el portátil en el openwrt y funciona!

Hace tiempo cuando tenia el imagenio de adsl, recordé que tenia problemas porque tenia una interface en el pc que tenia multiples ips, ahora no era el caso, pero si que tengo diferentes interfaces del VMware y una VPN. Ha sido deshabilitar estas interfaces virtuales y ya me funciona, incluso el proxy udp para wifi que se ve de coña. Por lo visto el multicast no se lleva bien con múltiples interfaces.

Ahora mi dilema es que no sé si dejar el router de telefónica y utilizar el tp-link para el piso de arriba con DDwrt. Con OpenWRT tengo muchos problemas para que me funcione la vpn pptp, y peor aun con openvpn, en contrapartida con el DDWRT no funciona la gestión del switch al tener, según ellos, el chip atheros que no lo soporta?¿ y por tanto es imposible configurar para la fibra de movistar.

@Noltari, si quieres igualmente te envío la configuración del Comtrend por si quieres añadir un segundo tipo de configuración en el manual, aunque básicamente lo que he hecho es ignorar la parte del alias, cambiar las subredes por las que tocan y habilitar el NAT para la interficie de iptv No hace falta habilitar el NAT
« Última modificación: 07-11-2013, 19:40 (Jueves) por Hemin »

psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #63 en: 07-11-2013, 20:24 (Jueves) »
Noltari, yo si te voy a enviar el fichero por que tampoco tengo esa misma estructura, en br0:0 si, pero en eth0.2 no, los datos creo estan en eth0.3... te mando el fichero por privado.

Mi router es un Comtrend ct5813n

Gracias.
« Última modificación: 07-11-2013, 21:27 (Jueves) por psdos »

Goyete

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #64 en: 07-11-2013, 21:06 (Jueves) »
Hola Noltari, gracias por tu info pero mi fichero de backup no contiene nada de eso y es un Comtrend actualizado supongo hace dos días por Telefónica cuando me instalaron el tema. Te adjunto por privado el backup a ver si puedes ver algo más que yo porque ni siquiera está el br0:0. Saludos!

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #65 en: 07-11-2013, 23:02 (Jueves) »
Vayamos por partes, como Dexter, que si no me lío xD...

Bueno, al fin ya me funciona, aunque la verdad es que he tocado tantas cosas que no se a partir de que momento ha empezado a funcionar.

Tenia configurado el router según tu guía y había cambiando las cosas con la configuración que tengo imagenio, todas las pruebas las hacia con VLC, el problema era que con el router de movistar hacia las pruebas con el portátil del trabajo y funcionaba bien. Para el router con openwrt utilizaba el sobremesa de casa y no me iba... Al final he probado con el portátil en el openwrt y funciona!

Hace tiempo cuando tenia el imagenio de adsl, recordé que tenia problemas porque tenia una interface en el pc que tenia multiples ips, ahora no era el caso, pero si que tengo diferentes interfaces del VMware y una VPN. Ha sido deshabilitar estas interfaces virtuales y ya me funciona, incluso el proxy udp para wifi que se ve de coña. Por lo visto el multicast no se lleva bien con múltiples interfaces.

Ahora mi dilema es que no sé si dejar el router de telefónica y utilizar el tp-link para el piso de arriba con DDwrt. Con OpenWRT tengo muchos problemas para que me funcione la vpn pptp, y peor aun con openvpn, en contrapartida con el DDWRT no funciona la gestión del switch al tener, según ellos, el chip atheros que no lo soporta?¿ y por tanto es imposible configurar para la fibra de movistar.

@Noltari, si quieres igualmente te envío la configuración del Comtrend por si quieres añadir un segundo tipo de configuración en el manual, aunque básicamente lo que he hecho es ignorar la parte del alias, cambiar las subredes por las que tocan y habilitar el NAT para la interficie de iptv No hace falta habilitar el NAT
Si no te importa pásamelo y le echo un ojo para comparar (por privado por favor, que tiene información sensible).

Yo personalmente no lo tengo configurado como en la guía, sino con estas modificaciones:
https://foro.seguridadwireless.net/openwrt/(tutorial)-movistar-ftth-con-openwrt/msg290396/#msg290396
Tenía pensado publicar un manual alternativo con esa configuración, pero la verdad es que no he tenido tiempo y el que he tenido lo he usado para algo de vida social :P (es lo que tiene haberme comido el Trabajo de Fin de Grado en verano :/).
A mi personalmente me gusta más esa configuración porque separo la LAN de la TV. Esto hace que se sature mucho menos la red si hay bastantes dispositivos (como es mi caso), pero implica tener que discriminar un puerto del switch para tal propósito. De esta forma, si quiero acceder a Imagenio desde cualquier cliente de la LAN no tengo más que utilizar la redirección udpxy del router y así no se establecen conexiones IGMP que saturan la red y sobre todo el WiFi.

En cuanto a DDWrt utilizan las herramientas y el código GPL de los fabricantes para generar los firmwares. Precisamente por eso es por lo que no soportan VLANs para ningún switch excepto para los Broadcom 47xx, que son los que en el código GPL tienen el driver.
En OpenWrt los drivers están desarrollados a partir de Ingeniería Inversa. Por eso hay más y mejor soporte.

Noltari, yo si te voy a enviar el fichero por que tampoco tengo esa misma estructura, en br0:0 si, pero en eth0.2 no, los datos creo estan en eth0.3... te mando el fichero por privado.

Mi router es un Comtrend ct5813n

Gracias.
En la configuración que me has enviado no veo Imagenio por ningún lado. Si está la configuración de la VOIP pero no está la de Imagenio.

¿Lo has probado con el router de Movistar y te funciona?
¿El backup es antiguo?

Hola Noltari, gracias por tu info pero mi fichero de backup no contiene nada de eso y es un Comtrend actualizado supongo hace dos días por Telefónica cuando me instalaron el tema. Te adjunto por privado el backup a ver si puedes ver algo más que yo porque ni siquiera está el br0:0. Saludos!
En tu caso la configuración es distinta...
De hecho es como si se hubieran cargado el Alias de la LAN, porque han metido la DNS del decodificador (172.26.23.3) en la misma LAN, sin alias ni nada...

Según creo no necesitas ningún alias de la LAN, así que no lo pongas.
Lo que sí tienes que poner es la dirección estática de la IPTV como la siguiente:
Código: [Seleccionar]
config interface 'iptv'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '10.255.151.1'
option netmask '255.128.0.0'
option gateway '10.128.0.1'

Es muy extraña la configuración y puede que no te funcione y que haya que hacer más pruebas.
¿Puedes facilitarme las IPs que están configuradas en el Deco? (Apagar totalmente el deco y cuando se esté encendiendo presionar la tecla menú).

Saludos!

Goyete

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #66 en: 07-11-2013, 23:54 (Jueves) »
Vayamos por partes, como Dexter, que si no me lío xD...

Bueno, al fin ya me funciona, aunque la verdad es que he tocado tantas cosas que no se a partir de que momento ha empezado a funcionar.

Tenia configurado el router según tu guía y había cambiando las cosas con la configuración que tengo imagenio, todas las pruebas las hacia con VLC, el problema era que con el router de movistar hacia las pruebas con el portátil del trabajo y funcionaba bien. Para el router con openwrt utilizaba el sobremesa de casa y no me iba... Al final he probado con el portátil en el openwrt y funciona!

Hace tiempo cuando tenia el imagenio de adsl, recordé que tenia problemas porque tenia una interface en el pc que tenia multiples ips, ahora no era el caso, pero si que tengo diferentes interfaces del VMware y una VPN. Ha sido deshabilitar estas interfaces virtuales y ya me funciona, incluso el proxy udp para wifi que se ve de coña. Por lo visto el multicast no se lleva bien con múltiples interfaces.

Ahora mi dilema es que no sé si dejar el router de telefónica y utilizar el tp-link para el piso de arriba con DDwrt. Con OpenWRT tengo muchos problemas para que me funcione la vpn pptp, y peor aun con openvpn, en contrapartida con el DDWRT no funciona la gestión del switch al tener, según ellos, el chip atheros que no lo soporta?¿ y por tanto es imposible configurar para la fibra de movistar.

@Noltari, si quieres igualmente te envío la configuración del Comtrend por si quieres añadir un segundo tipo de configuración en el manual, aunque básicamente lo que he hecho es ignorar la parte del alias, cambiar las subredes por las que tocan y habilitar el NAT para la interficie de iptv No hace falta habilitar el NAT
Si no te importa pásamelo y le echo un ojo para comparar (por privado por favor, que tiene información sensible).

Yo personalmente no lo tengo configurado como en la guía, sino con estas modificaciones:
https://foro.seguridadwireless.net/openwrt/(tutorial)-movistar-ftth-con-openwrt/msg290396/#msg290396
Tenía pensado publicar un manual alternativo con esa configuración, pero la verdad es que no he tenido tiempo y el que he tenido lo he usado para algo de vida social :P (es lo que tiene haberme comido el Trabajo de Fin de Grado en verano :/).
A mi personalmente me gusta más esa configuración porque separo la LAN de la TV. Esto hace que se sature mucho menos la red si hay bastantes dispositivos (como es mi caso), pero implica tener que discriminar un puerto del switch para tal propósito. De esta forma, si quiero acceder a Imagenio desde cualquier cliente de la LAN no tengo más que utilizar la redirección udpxy del router y así no se establecen conexiones IGMP que saturan la red y sobre todo el WiFi.

En cuanto a DDWrt utilizan las herramientas y el código GPL de los fabricantes para generar los firmwares. Precisamente por eso es por lo que no soportan VLANs para ningún switch excepto para los Broadcom 47xx, que son los que en el código GPL tienen el driver.
En OpenWrt los drivers están desarrollados a partir de Ingeniería Inversa. Por eso hay más y mejor soporte.

Noltari, yo si te voy a enviar el fichero por que tampoco tengo esa misma estructura, en br0:0 si, pero en eth0.2 no, los datos creo estan en eth0.3... te mando el fichero por privado.

Mi router es un Comtrend ct5813n

Gracias.
En la configuración que me has enviado no veo Imagenio por ningún lado. Si está la configuración de la VOIP pero no está la de Imagenio.

¿Lo has probado con el router de Movistar y te funciona?
¿El backup es antiguo?

Hola Noltari, gracias por tu info pero mi fichero de backup no contiene nada de eso y es un Comtrend actualizado supongo hace dos días por Telefónica cuando me instalaron el tema. Te adjunto por privado el backup a ver si puedes ver algo más que yo porque ni siquiera está el br0:0. Saludos!
En tu caso la configuración es distinta...
De hecho es como si se hubieran cargado el Alias de la LAN, porque han metido la DNS del decodificador (172.26.23.3) en la misma LAN, sin alias ni nada...

Según creo no necesitas ningún alias de la LAN, así que no lo pongas.
Lo que sí tienes que poner es la dirección estática de la IPTV como la siguiente:
Código: [Seleccionar]
config interface 'iptv'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '10.255.151.1'
option netmask '255.128.0.0'
option gateway '10.128.0.1'

Es muy extraña la configuración y puede que no te funcione y que haya que hacer más pruebas.
¿Puedes facilitarme las IPs que están configuradas en el Deco? (Apagar totalmente el deco y cuando se esté encendiendo presionar la tecla menú).

Saludos!
Aquí te va! A ver si te sirve de algo porque a mi todo esto me suena a chino.




Enviado desde mi iPhone con Tapatalk

Hemin

  • Visitante
Re: Re: Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #67 en: 07-11-2013, 23:55 (Jueves) »
Hola Noltari, gracias por tu info pero mi fichero de backup no contiene nada de eso y es un Comtrend actualizado supongo hace dos días por Telefónica cuando me instalaron el tema. Te adjunto por privado el backup a ver si puedes ver algo más que yo porque ni siquiera está el br0:0. Saludos!
En tu caso la configuración es distinta...
De hecho es como si se hubieran cargado el Alias de la LAN, porque han metido la DNS del decodificador (172.26.23.3) en la misma LAN, sin alias ni nada...

Según creo no necesitas ningún alias de la LAN, así que no lo pongas.
Lo que sí tienes que poner es la dirección estática de la IPTV como la siguiente:
Código: [Seleccionar]
config interface 'iptv'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '10.255.151.1'
option netmask '255.128.0.0'
option gateway '10.128.0.1'

Es muy extraña la configuración y puede que no te funcione y que haya que hacer más pruebas.
¿Puedes facilitarme las IPs que están configuradas en el Deco? (Apagar totalmente el deco y cuando se esté encendiendo presionar la tecla menú).

Saludos!

Mi configuración creo que debe ser como esta. Creo que los de movistar han visto que eso de poner una ip directa de la subred de la iptv era un poco "peligroso" y han puesto una red intermedia que haga de filtro. Han aprovechado las opciones del dhcp para poner directamente a los receptores un dns diferente a los de los clientes "normales", el cual pertenece a la red de streaming. Mañana te la paso.

Ahora que veo mas o menos como funciona me parece que es mejor tener un puerto separado para la tv igual que las primeras soluciones de iptv, pero eso de perder un puerto me implica poner un switch adicional en el comedor, y poner otro  aparato significa un debate intensivo con la parienta...

Realmente la tv en directo no la veo mucho ya que no tengo el fútbol, así que creo que pondré la ddwrt y con el router de movistar desviaré los puertos que necesite al tplink.

Sent from my GT-I9300 using Tapatalk
« Última modificación: 08-11-2013, 00:11 (Viernes) por Noltari »

Hemin

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #68 en: 08-11-2013, 10:05 (Viernes) »

Aquí te va! A ver si te sirve de algo porque a mi todo esto me suena a chino.




Enviado desde mi iPhone con Tapatalk

Es como la mía, a ver si durante el día de hoy pongo mi configuración que funciona sin problemas y te sirve a tí. Lo único que no he probado es lo de modificar el dhcp para que de diferentes IPs al receptor de imagenio, de todas formas eso se soluciona rápido configurando el receptor con la IP manualmente.

Goyete

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #69 en: 08-11-2013, 15:12 (Viernes) »

Aquí te va! A ver si te sirve de algo porque a mi todo esto me suena a chino.




Enviado desde mi iPhone con Tapatalk

Es como la mía, a ver si durante el día de hoy pongo mi configuración que funciona sin problemas y te sirve a tí. Lo único que no he probado es lo de modificar el dhcp para que de diferentes IPs al receptor de imagenio, de todas formas eso se soluciona rápido configurando el receptor con la IP manualmente.
Muchas gracias, aún no he podido probar la otra configuración que me han dado pero si me das la tuya la pruebo también. Gracias!


Enviado desde mi iPhone con Tapatalk

Goyete

  • Visitante
[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #70 en: 08-11-2013, 15:55 (Viernes) »
Perdonad porque seguramente será una pregunta absurda pero cuando pone eth.2 no significa que la conexión física del cable que va al deco deba estar en el puerto 2 verdad?

Y otra cosa, la configuración que me habéis dicho que pruebe, entiendo que además debo hacer todo lo del manual para editar los archivos vía ssh. Lo digo porque he añadido una nueva interfaces con esos datos (sin hacer todavía lo del manual) y no va el deco.

Gracias!


Enviado desde mi iPhone con Tapatalk

psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #71 en: 08-11-2013, 20:01 (Viernes) »
Noltari pues llevabas razón, no sé por que motivos no se me ve veia imagenio. Probe a acceder al menu para ver las configuraciones IP, que estaban en estáticas las puse en DHCP y nada de nada. Llamé al instalador que me lo puso y me dijo que esas IPs en mi caso son fijas y del rango 10.xx.xx.xx, así que como me había guardado la configuración las restauré, pero esto no era suficiente, tuve que hacer también la segunda parte que me indicó el instalador. Restaurar a valores de fábrica el router, y una vez restaurado, apagar el router desde su boton de power y volver a encenderlo. Y ahora si vuelvo a ver imagenio de nuevo. Lo raro es que yo en el router no he tocado nada de nada, por que de echo no lo uso, solo para probar imagenio, nada más.

Saludos.

PD: Noltari, voy a ver si ahora si me salen todos los datos como indicabas en tu última guia. Si no te vuelvo a enviar el fichero de configuración. Gracias compi.

PD2: Noltari, te confirmo que ahora sí aparecen los datos según tu última guía, ahora a ver si tengo suerte y hago que funcione en el TP-Link 4300 v1.6.
« Última modificación: 08-11-2013, 20:17 (Viernes) por psdos »

Hemin

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #72 en: 08-11-2013, 20:44 (Viernes) »
Perdonad porque seguramente será una pregunta absurda pero cuando pone eth.2 no significa que la conexión física del cable que va al deco deba estar en el puerto 2 verdad?

Y otra cosa, la configuración que me habéis dicho que pruebe, entiendo que además debo hacer todo lo del manual para editar los archivos vía ssh. Lo digo porque he añadido una nueva interfaces con esos datos (sin hacer todavía lo del manual) y no va el deco.

Gracias!


Enviado desde mi iPhone con Tapatalk

eth0.2 quiere decir que es la ethernet 0 vlan 2, para ver imagenio puedes poner la conexión donde quieras de los puertos lan.

La parte de crear la interficie y del firewall se pueden hacer con luci, pero si no sabes muy bien lo que estas haciendo mejor hazlo por ssh editando los archivos de configuración.

La configuración que yo tengo la parte de firewall es la misma, la parte del proxy udp también, para el igmp tengo esto:

Código: [Seleccionar]
config igmpproxy
option quickleave 1

config phyint
option network iptv
option direction upstream
list altnet 172.26.0.0/16
list altnet 10.128.0.0/9

config phyint
option network lan
option direction downstream

Para el rip tengo puesto esto para la iptv, aunque no sé si hace falta:

Código: [Seleccionar]
protocol rip iptv {
 import all;
 export filter iptv_filter;
 interface "eth0.2";
}
filter iptv2_filter {
 if net ~ 10.0.0.0/8 then accept;
 else reject;
}
protocol rip iptv2 {
 import all;
 export filter iptv2_filter;
 interface "eth0.2";
}

La parte del alias la elimino, y la parte de la interficie, le pongo mi ip que la tienes que ver en la configuración del router:

Código: [Seleccionar]

config interface 'iptv'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '10.Z.X.Y'
option netmask '255.128.0.0'

Fíjate que la mascara es 255.128.0.0 y no he puesto gateway por que ya la aprende con el RIP

Finalmente haría falta configurar el dhcp con las opciones del receptor imagenio, eso no he mirado como se hace, pero lo que puedes hace es lo siguiente:

Tal cual tienes la configuración del receptor imagenio, cambias el modo de red a "Manual" y rellenas los campos con los que había cogido automáticamente. Aquí mi configuración difiere en que el DNS en mi caso es 172.26.23.3 en vez de 192.168.1.1, supongo que servirá igual, ya que en tu caso el DNS lo hace el propio router.

Prueba a ver si te va, yo para hacer las pruebas rápido utilizaba el VLC desde el ordenador

psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #73 en: 08-11-2013, 21:48 (Viernes) »
Pues nada. he hecho todo lo del tutorial e imagenio sigue sin verse. La verdad es que estoy empezando a creer que esto no es tan facil...

El deco de imagenio no coje la hora, con lo cual deduzco que no le está llegando lo que debe.

Pongo una captura de la parte del Firewall, por si veis algo raro, pero he seguido al pie de la letra el tutorial.

https://www.dropbox.com/s/hugpsycmkmz8rbu/Captura%20de%20pantalla%202013-11-08%2021.51.11.png

Y otra de las VLANs

https://www.dropbox.com/s/m3ua6gjnewx4amb/Captura%20de%20pantalla%202013-11-08%2022.22.42.png


Saludos.
« Última modificación: 08-11-2013, 22:23 (Viernes) por psdos »

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #74 en: 08-11-2013, 22:45 (Viernes) »
Pues nada. he hecho todo lo del tutorial e imagenio sigue sin verse. La verdad es que estoy empezando a creer que esto no es tan facil...

El deco de imagenio no coje la hora, con lo cual deduzco que no le está llegando lo que debe.

Pongo una captura de la parte del Firewall, por si veis algo raro, pero he seguido al pie de la letra el tutorial.

https://www.dropbox.com/s/hugpsycmkmz8rbu/Captura%20de%20pantalla%202013-11-08%2021.51.11.png

Y otra de las VLANs

https://www.dropbox.com/s/m3ua6gjnewx4amb/Captura%20de%20pantalla%202013-11-08%2022.22.42.png


Saludos.
Las VLANs están mal.

Has definido manualmente las VLANs tal y como aparecen en el tutorial (eth0), pero en tu router el switch es "switch0".

Por eso sólo tienes internet, porque la VLAN 6 de "switch0" está correctamente definida.
Postea tu fichero /etc/config/network y lo edito para que sea correcto.

psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #75 en: 08-11-2013, 22:58 (Viernes) »
Acabo de liarla parda, me he cargado el fichero /etc/config/network y he copiado tal cual lo que tú ponias en tu manual de como deberia quedar, solo que modifiqué las IPs conforme mi configuración, y ahora solo tengo internet si me conecto al router via WiFi. Imagino que así no te valdrá, no? querras el original que crea el propio router... tendre que restaurarlo para que lo repare. Con que te ponga aqui el contenido de network te vale? o he de sacarlo de alguna manera? es que no se como se saca ese fichero del router...

Gracias por tú ayuda y tú paciencia, tienes el cielo ganado dos o tres veces jeje

Te pego aquí el código:
Código: [Seleccionar]
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdba:f459:a649::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option ifname 'eth0.6'
- /etc/config/network 1/47 2%

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdba:f459:a649::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option ifname 'eth0.6'
        option username 'adslppp@telefonicanetpa'
        option password 'adslppp'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1t'
        option vid '6'


Una pregunta más, el resto del tutorial varía debido a mi configuración?
« Última modificación: 08-11-2013, 23:24 (Viernes) por psdos »

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #76 en: 08-11-2013, 23:23 (Viernes) »
Acabo de liarla parda, me he cargado el fichero /etc/config/network y he copiado tal cual lo que tú ponias en tu manual de como deberia quedar, solo que modifiqué las IPs conforme mi configuración, y ahora solo tengo internet si me conecto al router via WiFi. Imagino que así no te valdrá, no? querras el original que crea el propio router... tendre que restaurarlo para que lo repare. Con que te ponga aqui el contenido de network te vale? o he de sacarlo de alguna manera? es que no se como se saca ese fichero del router...

Gracias por tú ayuda y tú paciencia, tienes el cielo ganado dos o tres veces jeje
Pues necesito el que tenías más o menos cuando sacaste la foto :$...

Con pegar el contenido me vale.

psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #77 en: 08-11-2013, 23:31 (Viernes) »
Ese que te puse es solo funcionando internet, por que supongo que de poco te vale tenerlo con lo que aparecia en tú tutorial no?

Es que tuve que restaurar la configuración hasta ese punto.

El resto del tutorial varia para mi configuración?

Goyete

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #78 en: 08-11-2013, 23:38 (Viernes) »
Perdonad porque seguramente será una pregunta absurda pero cuando pone eth.2 no significa que la conexión física del cable que va al deco deba estar en el puerto 2 verdad?

Y otra cosa, la configuración que me habéis dicho que pruebe, entiendo que además debo hacer todo lo del manual para editar los archivos vía ssh. Lo digo porque he añadido una nueva interfaces con esos datos (sin hacer todavía lo del manual) y no va el deco.

Gracias!


Enviado desde mi iPhone con Tapatalk

eth0.2 quiere decir que es la ethernet 0 vlan 2, para ver imagenio puedes poner la conexión donde quieras de los puertos lan.

La parte de crear la interficie y del firewall se pueden hacer con luci, pero si no sabes muy bien lo que estas haciendo mejor hazlo por ssh editando los archivos de configuración.

La configuración que yo tengo la parte de firewall es la misma, la parte del proxy udp también, para el igmp tengo esto:

Código: [Seleccionar]
config igmpproxy
option quickleave 1

config phyint
option network iptv
option direction upstream
list altnet 172.26.0.0/16
list altnet 10.128.0.0/9

config phyint
option network lan
option direction downstream

Para el rip tengo puesto esto para la iptv, aunque no sé si hace falta:

Código: [Seleccionar]
protocol rip iptv {
 import all;
 export filter iptv_filter;
 interface "eth0.2";
}
filter iptv2_filter {
 if net ~ 10.0.0.0/8 then accept;
 else reject;
}
protocol rip iptv2 {
 import all;
 export filter iptv2_filter;
 interface "eth0.2";
}

La parte del alias la elimino, y la parte de la interficie, le pongo mi ip que la tienes que ver en la configuración del router:

Código: [Seleccionar]

config interface 'iptv'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '10.Z.X.Y'
option netmask '255.128.0.0'

Fíjate que la mascara es 255.128.0.0 y no he puesto gateway por que ya la aprende con el RIP

Finalmente haría falta configurar el dhcp con las opciones del receptor imagenio, eso no he mirado como se hace, pero lo que puedes hace es lo siguiente:

Tal cual tienes la configuración del receptor imagenio, cambias el modo de red a "Manual" y rellenas los campos con los que había cogido automáticamente. Aquí mi configuración difiere en que el DNS en mi caso es 172.26.23.3 en vez de 192.168.1.1, supongo que servirá igual, ya que en tu caso el DNS lo hace el propio router.

Prueba a ver si te va, yo para hacer las pruebas rápido utilizaba el VLC desde el ordenador
Gracias Hemin y Noltari. A ver como no habíais contestado hace un rato me liado a modificar los ficheros siguiendo el manual de Noltari por probar y resulta que siguiendo ese manual (sin el tema de VOIP que no lo voy a usar) y poniendo la configuración que me indicó Noltari tras ver mi fichero resulta que me funciona casi casi. Digo casi casi porque puedo ver Imagenio sin problemas pero al darle al botón de Menú me dice que hay un problema con la conexión y no puedo acceder al Menú por ejemplo para ir a la videoteca. He reseteado y todo sigue igual.

Voy a hacer una copia de seguridad y probaré la configuración que me propone Hemin.

También he notado que ya no sé si tendrá que ver es que el wifi por la banda de 5 GHz ha bajado la velocidad un huevo. Antes de tener configurado Imagenio me daba unos 70 Mbps en un iPhone 5 y ahora me va por los 10 como mucho. Con Imagenio encendido a ver si es que era un problema de consumo de ancho de banda y cableado con el PC me da las 100 Mbps así que si alguien tiene alguna sugerencia... Por cierto es un TP Link WRD4900.

Gracias y voy a seguir con las pruebas.

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #79 en: 09-11-2013, 00:25 (Sábado) »
Ese que te puse es solo funcionando internet, por que supongo que de poco te vale tenerlo con lo que aparecia en tú tutorial no?

Es que tuve que restaurar la configuración hasta ese punto.

El resto del tutorial varia para mi configuración?
La configuración sería algo parecido a esto:
Código: [Seleccionar]
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 2 3 4 5'
option vid '1'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0t 1t'
option vid '2'

config switch_vlan
option device 'switch0'
option vlan '3'
option ports '0t 1t'
option vid '4'

config switch_vlan
option device 'switch0'
option vlan '4'
option ports '0t 1t'
option vid '6'

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdba:f459:a649::/48'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option proto 'pppoe'
option ifname 'eth0.6'
option username 'adslppp@telefonicanetpa'
option password 'adslppp'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'

config interface 'iptv'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '172.26.X.Y'
option netmask '255.255.240.0'
option gateway '172.26.X.Z'

config 'alias'
option 'interface' 'lan'
option 'proto' 'static'
option ipaddr '10.X.Y.Z'
option netmask '255.255.255.248'
Al final como tú mismo has indicado la configuración que me enviaste no tenía las IPs, así que tienes que cambiarlas tú mismo :$.

Saludos!