Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 585217 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

Goyete

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #100 en: 26-11-2013, 20:00 (Martes) »
Ademas a mi desde hace unos días no se me ve el canal 10, el de Fox HD, el resto sí. Rarísimo porque he restaurado una de las configuraciones que funcionaba. Ahora al reiniciar me ha actualizado el firmware el deco y sigue sin funcionar el canal 10 y menus.


Enviado desde mi iPhone con Tapatalk



psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #101 en: 30-11-2013, 08:57 (Sábado) »
Goyete, yo ya he decidido ponerme un router microbio. Con estos va todo y es bastante fácil de configurar. Si necesitas más información envíame un privado y te doy modelo de router y tutorial. Si los administradores quieren que se ponga aquí no tengo ningún problema en hacerlo y así también lo puede ver todo el que lo pueda necesitar.

Saludos!!!

danimopa

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #102 en: 30-11-2013, 19:47 (Sábado) »
Hola a todos,
soy nuevo en esta comunidad, espero aprender mucho con vosotros... En primer lugar quería dar las gracias a Noltari por el tutorial, tengo el WDR4300 funcionando con los problemas habituales descritos en el foro (wifi cae con imagenio y éste sin menús, etc..) pero me preocupa el tema de la voz ip.
Utilizo android con Zoiper para realizar llamadas desde el móvil a través de wifi pero con el TP-Link no consigo que se registre, con el comtrend no tengo problema. He revisado la configuración y en el log del router puedo leer:

Nov 30 18:12:53 OpenWrt daemon.notice netifd: voip (2374): Received SIGTERM
Nov 30 18:12:53 OpenWrt daemon.notice netifd: Interface 'voip' is now down
Nov 30 18:12:53 OpenWrt daemon.notice netifd: voip (7093): udhcpc (v1.19.4) started
Nov 30 18:12:53 OpenWrt daemon.notice netifd: voip (7093): Sending discover...

¿alguien tiene alguna idea?.
Gracias.

danimopa

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #103 en: 30-11-2013, 20:18 (Sábado) »
En el log del router también se registran eventos con el desco activado y la conexión wifi se resiente:

Nov 30 20:16:55 OpenWrt daemon.warn dnsmasq[7650]: possible DNS-rebind attack detected: www-60.svc.imagenio.telefonica.net
Nov 30 20:16:55 OpenWrt daemon.warn dnsmasq[7650]: possible DNS-rebind attack detected: www-60.svc.imagenio.telefonica.net
« Última modificación: 30-11-2013, 20:20 (Sábado) por danimopa »

psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #104 en: 30-11-2013, 23:49 (Sábado) »
danimopa, yo creo que salvo que se use el metodo que Noltari tiene en su router tp-link 4300, de dejar un puerto RJ45 exclusivo para imagenio, esto de momento, no tieene solución. Otra cosa es comprar un router mikrotik... estos si parece que van finos finos.

Saludos!!

Slartibartfast

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #105 en: 01-12-2013, 01:49 (Domingo) »
danimopa, a mí los problemas con la wifi se me solucionaron activando el igmp snooping.

danimopa

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #106 en: 01-12-2013, 14:54 (Domingo) »
Muchas gracias por las ideas, probaré la solución de Slartibartfast, parece mas simple.
El tema de la voz ip me supera, volveré a comprobar el manual de noltari porque no consigue registrar la voz ip con android ni con Twinkle (aplicación de PC para linux).

saludos

danimopa

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #107 en: 01-12-2013, 21:14 (Domingo) »
Hola de nuevo,
la solución de igmp snooping no ha sido posible, al intentar instalar el paquete kmod-bridge me salta un error de dependencias, el kernel es antiguo y no se puede instalar (uso la versión de openwrt que puso noltari en este mismo hilo). En cuanto a dedicar un puerto para el desco, he seguido los pasos aportados por Noltari pero ahora imagenio no se visualiza  ???, ¿qué puerto se asigna en esa configuración?.
Viendo los problemas que tengo con el tutorial, me surgen dudas:
¿ponéis la configuración del manual según aparece en el pdf sustituyendo todo el contenido configurado por defecto?, ¿influyen espacios, tabulados, saltos de línea....?, lo he revisado varias veces y no consigo vozip ni quitar la caída del wifi al ver imagenio.

psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #108 en: 02-12-2013, 07:04 (Lunes) »
Prueba con este firm, fue el último que me pasó Noltari. Si pruebas lo de la wifi con este y te va bien, me animaré a hacerlo yo.

https://dl.dropboxusercontent.com/u/13133686/openwrt-ar71xx-generic-tl-wdr4300-v1-squashfs-sysupgrade_r38537.bin

Saludos!!

PD: A mi mira que me fastidia tener que cambiar de router, no me hace nada de gracia cambiarme a Mikrotik, ojalá logremos solventar todos los fallitos que hay.
« Última modificación: 02-12-2013, 07:06 (Lunes) por psdos »

Slartibartfast

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #109 en: 02-12-2013, 09:35 (Lunes) »
Probablemente tampoco funcione porque no tendrá integrado el soporte para el snooping. Esta tarde a ver si saco un ratillo y os compilo uno con todo lo necesario. Eso sí, no lo podré probar, yo estoy utilizando el Comtrend.

danimopa

  • Visitante
Re:
« Respuesta #110 en: 02-12-2013, 11:27 (Lunes) »
Gracias Slartibartfast, supongo que si se basa en una versión compatible con el WDR4300 v1 funcionará, es una pena tener este router potente y no darle uso con la fibra.

Slartibartfast

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #111 en: 03-12-2013, 00:45 (Martes) »
Aquí tenéis el firmware para el wdr4300 compilado con soporte para el snooping. Acordaos de activarlo con:

Código: [Seleccionar]
echo "1" > /sys/devices/virtual/net/br-lan/bridge/multicast_snooping
openwrt-ar71xx-generic-tl-wdr4300-v1-squashfs-sysupgrade.bin

Incluye: luci, luci-app-ddns, luci-app-ntpc, luci-app-upng, kmod-bridge, bird4, igmpproxy y udpxy

OJO: No tengo este router, así que no lo he podido probar. Usadlo bajo vuestra propia responsabilidad.
« Última modificación: 03-12-2013, 23:11 (Martes) por Slartibartfast »

danimopa

  • Visitante
Re: Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #112 en: 03-12-2013, 09:05 (Martes) »
Muchas gracias por el trabajo, me aventuraré a probarlo, tengo el router parado y eso me consume :-\, tengo que sacar tiempo pero os contaré el resultado en cuanto pueda probarlo.

Un saludo.

Goyete

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #113 en: 04-12-2013, 10:28 (Miércoles) »
Goyete, yo ya he decidido ponerme un router microbio. Con estos va todo y es bastante fácil de configurar. Si necesitas más información envíame un privado y te doy modelo de router y tutorial. Si los administradores quieren que se ponga aquí no tengo ningún problema en hacerlo y así también lo puede ver todo el que lo pueda necesitar.

Saludos!!!
Hola, yo también he optado por un MikroTik. He comprado un RB493G y ya tengo todo funcionando como quería, e Imagenio funciona perfectamente incluyendo menús y todo.

Lo he conseguido con el post principal de configuración del Mikrotik (http://www.adslzone.net/postt311611.html) y con la configuración para los que tenemos IP dinámica de Imagenio (http://www.adslzone.net/postx350338-0-0.html).

Gracias!

psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #114 en: 04-12-2013, 10:45 (Miércoles) »
Estupendo Goyete, ese modelo lleva WiFi? Ponte algunas foticos y dime donde lo pillaste, que yo aún estoy por decidirme por el modelo de Mikrotik.

Felices fiestas a todos!!!

Goyete

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #115 en: 04-12-2013, 11:05 (Miércoles) »
Estupendo Goyete, ese modelo lleva WiFi? Ponte algunas foticos y dime donde lo pillaste, que yo aún estoy por decidirme por el modelo de Mikrotik.

Felices fiestas a todos!!!
No lleva wifi. El wifi lo tengo puesto con el TP-Link N900 (WRD4900) como AP ya que quería banda de 5 Ghz. Lo he comprado en Landashop (http://landashop.com/catalog/mikrotik-rbr493g-minirouter-basado-rb493g-p-1989.html), es como el RB450G que recomienda Malosa en ADSL Zone solo que con más puertos ethernet. Quería conectar directamente al router varias cosas y por eso no me cogí el otro (PS3, deco Imagenio, impresora red, AP, NAS y ordenador cableado).

bonkilla

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #116 en: 07-12-2013, 09:08 (Sábado) »
Perdonad porque seguramente será una pregunta absurda pero cuando pone eth.2 no significa que la conexión física del cable que va al deco deba estar en el puerto 2 verdad?

Y otra cosa, la configuración que me habéis dicho que pruebe, entiendo que además debo hacer todo lo del manual para editar los archivos vía ssh. Lo digo porque he añadido una nueva interfaces con esos datos (sin hacer todavía lo del manual) y no va el deco.

Gracias!


Enviado desde mi iPhone con Tapatalk

eth0.2 quiere decir que es la ethernet 0 vlan 2, para ver imagenio puedes poner la conexión donde quieras de los puertos lan.

La parte de crear la interficie y del firewall se pueden hacer con luci, pero si no sabes muy bien lo que estas haciendo mejor hazlo por ssh editando los archivos de configuración.

La configuración que yo tengo la parte de firewall es la misma, la parte del proxy udp también, para el igmp tengo esto:

Código: [Seleccionar]
config igmpproxy
option quickleave 1

config phyint
option network iptv
option direction upstream
list altnet 172.26.0.0/16
list altnet 10.128.0.0/9

config phyint
option network lan
option direction downstream

Para el rip tengo puesto esto para la iptv, aunque no sé si hace falta:

Código: [Seleccionar]
protocol rip iptv {
 import all;
 export filter iptv_filter;
 interface "eth0.2";
}
filter iptv2_filter {
 if net ~ 10.0.0.0/8 then accept;
 else reject;
}
protocol rip iptv2 {
 import all;
 export filter iptv2_filter;
 interface "eth0.2";
}

La parte del alias la elimino, y la parte de la interficie, le pongo mi ip que la tienes que ver en la configuración del router:

Código: [Seleccionar]

config interface 'iptv'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '10.Z.X.Y'
option netmask '255.128.0.0'

Fíjate que la mascara es 255.128.0.0 y no he puesto gateway por que ya la aprende con el RIP

Finalmente haría falta configurar el dhcp con las opciones del receptor imagenio, eso no he mirado como se hace, pero lo que puedes hace es lo siguiente:

Tal cual tienes la configuración del receptor imagenio, cambias el modo de red a "Manual" y rellenas los campos con los que había cogido automáticamente. Aquí mi configuración difiere en que el DNS en mi caso es 172.26.23.3 en vez de 192.168.1.1, supongo que servirá igual, ya que en tu caso el DNS lo hace el propio router.

Prueba a ver si te va, yo para hacer las pruebas rápido utilizaba el VLC desde el ordenador

Hemi a ver si nos puedes arrojar un poco mas de luz.


He intentado configurar mi router openwrt como dices tu pero sin suerte.

He dejado los ficheros como comentas ya que tu y yo tenemos la misma configuracion de movistar tv pero movistar tv sigue sin verse.

No se si alguien mas ha conseguido que funcione con la nueva configuracion que movistar esta llevando a cabo pero estaría bien que postease una mini guía.

Espero que alguien me pueda ayudar.

Por cierto el router que uso es un N600 (TL-WDR3600)

Goyete

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #117 en: 07-12-2013, 11:16 (Sábado) »
Perdonad porque seguramente será una pregunta absurda pero cuando pone eth.2 no significa que la conexión física del cable que va al deco deba estar en el puerto 2 verdad?

Y otra cosa, la configuración que me habéis dicho que pruebe, entiendo que además debo hacer todo lo del manual para editar los archivos vía ssh. Lo digo porque he añadido una nueva interfaces con esos datos (sin hacer todavía lo del manual) y no va el deco.

Gracias!


Enviado desde mi iPhone con Tapatalk

eth0.2 quiere decir que es la ethernet 0 vlan 2, para ver imagenio puedes poner la conexión donde quieras de los puertos lan.

La parte de crear la interficie y del firewall se pueden hacer con luci, pero si no sabes muy bien lo que estas haciendo mejor hazlo por ssh editando los archivos de configuración.

La configuración que yo tengo la parte de firewall es la misma, la parte del proxy udp también, para el igmp tengo esto:

Código: [Seleccionar]
config igmpproxy
option quickleave 1

config phyint
option network iptv
option direction upstream
list altnet 172.26.0.0/16
list altnet 10.128.0.0/9

config phyint
option network lan
option direction downstream

Para el rip tengo puesto esto para la iptv, aunque no sé si hace falta:

Código: [Seleccionar]
protocol rip iptv {
 import all;
 export filter iptv_filter;
 interface "eth0.2";
}
filter iptv2_filter {
 if net ~ 10.0.0.0/8 then accept;
 else reject;
}
protocol rip iptv2 {
 import all;
 export filter iptv2_filter;
 interface "eth0.2";
}

La parte del alias la elimino, y la parte de la interficie, le pongo mi ip que la tienes que ver en la configuración del router:

Código: [Seleccionar]

config interface 'iptv'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '10.Z.X.Y'
option netmask '255.128.0.0'

Fíjate que la mascara es 255.128.0.0 y no he puesto gateway por que ya la aprende con el RIP

Finalmente haría falta configurar el dhcp con las opciones del receptor imagenio, eso no he mirado como se hace, pero lo que puedes hace es lo siguiente:

Tal cual tienes la configuración del receptor imagenio, cambias el modo de red a "Manual" y rellenas los campos con los que había cogido automáticamente. Aquí mi configuración difiere en que el DNS en mi caso es 172.26.23.3 en vez de 192.168.1.1, supongo que servirá igual, ya que en tu caso el DNS lo hace el propio router.

Prueba a ver si te va, yo para hacer las pruebas rápido utilizaba el VLC desde el ordenador

Hemi a ver si nos puedes arrojar un poco mas de luz.


He intentado configurar mi router openwrt como dices tu pero sin suerte.

He dejado los ficheros como comentas ya que tu y yo tenemos la misma configuracion de movistar tv pero movistar tv sigue sin verse.

No se si alguien mas ha conseguido que funcione con la nueva configuracion que movistar esta llevando a cabo pero estaría bien que postease una mini guía.

Espero que alguien me pueda ayudar.

Por cierto el router que uso es un N600 (TL-WDR3600)
Hola con ayuda de Noltari en mi caso conseguimos hacer funcionar todo menos lo de los menus. Si quieres te paso mi ultima configuracion que funcionaba (sin menus). Ahora mismo a mi me funciona todo perfecto pero con un MikroTik. Saludos!


Enviado desde mi iPhone con Tapatalk

bonkilla

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #118 en: 07-12-2013, 14:13 (Sábado) »
Gracias pero necesitaría hacerlo para el opewrt.

El microtik no me solucionada nada ( no quiero comprarme un router nuevo)

danimopa

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #119 en: 07-12-2013, 15:14 (Sábado) »
Aquí tenéis el firmware para el wdr4300 compilado con soporte para el snooping. Acordaos de activarlo con:

Código: [Seleccionar]
echo "1" > /sys/devices/virtual/net/br-lan/bridge/multicast_snooping
openwrt-ar71xx-generic-tl-wdr4300-v1-squashfs-sysupgrade.bin

Incluye: luci, luci-app-ddns, luci-app-ntpc, luci-app-upng, kmod-bridge, bird4, igmpproxy y udpxy

OJO: No tengo este router, así que no lo he podido probar. Usadlo bajo vuestra propia responsabilidad.

Hola a tod@s, finalmente he probado con el firmware que se indica y no funciona con la configuración de Noltari, el router no me da acceso una vez realizadas las modificaciones y tengo que resetear aunque la imagen la coge sin problemas.

Goyete, si puedes pasarme por privado la configuración que te funcionó me harías un favor antes de deshacerme del TP-Link  :'(

gracias