Autor Tema: [Desarrollo] OpenWrt en Observa Telecom VH4032N  (Leído 127618 veces)

0 Usuarios y 1 Visitante están viendo este tema.

anv

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #440 en: 08-01-2018, 16:18 (Lunes) »
Otro problema con este router: estoy intentando usar el switch como puente entre dos tramos de cable. El propio router llega a los dos lados sin problema pero si mando pings de un lado, no llegan al otro. Es como si el switch no estuviera dejando pasar los paquetes.

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.103'
        option gateway '192.168.1.1'
        option dns '8.8.8.8'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 8t'



Ficht

  • Visitante
Re: Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #441 en: 08-01-2018, 16:29 (Lunes) »
Otro problema con este router: estoy intentando usar el switch como puente entre dos tramos de cable. El propio router llega a los dos lados sin problema pero si mando pings de un lado, no llegan al otro. Es como si el switch no estuviera dejando pasar los paquetes.

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.103'
        option gateway '192.168.1.1'
        option dns '8.8.8.8'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 8t'
Efectivamente, es un problema de este switch no se comunican las bocas entre sí.

Enviado desde mi PRA-LX1 mediante Tapatalk


anv

  • Visitante
Re: Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #442 en: 08-01-2018, 16:40 (Lunes) »
Efectivamente, es un problema de este switch no se comunican las bocas entre sí.

Uff... se ve que todavía le falta a este firm...

lomismo1

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #443 en: 02-04-2018, 10:55 (Lunes) »
Hola, ante todo muchas gracias a todos por vuestro excelente trabajo.
He seguido el tutorial https://foro.seguridadwireless.net/openwrt/(desarrollo)-observa-telecom-vh4032n/msg310444/#msg310444
y le he cargado el firmware que hay en dicho tutorial sin problemas. Ahora me gustaria probar un firm mas moderno y me he bajado el lede que hay en la pagina de openwrt http://downloads.lede-project.org/releases/17.01.2/targets/brcm63xx/smp/lede-17.01.2-brcm63xx-smp-VH4032N-squashfs-cfe.bin y tambien me he bajado el 17.01.4 y no consigo instalar ninguno de los 2 usando el metodo del tutorial. en los 2 firms me da el siguiente error:
Illegal image ! Image crc failed.
No se si es que se meten de otra forma o si hay que hacerles algo para poder instalarlos con el metodo descrito en el tutorial.
¿alguien podria orientarme?
He leido casi todo el hilo, asi por encimilla, y he visto que se habia dicho que con chip pl2303 no funcionaba. yo uso el cable con el que se liberaban los nokia antiguos que tiene chip pl2303 y me ha funcionado bien. Con hyperterminal no hacia nada pero con putty a la primera


Ficht

  • Visitante
Re: Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #444 en: 02-04-2018, 11:04 (Lunes) »
Hola, ante todo muchas gracias a todos por vuestro excelente trabajo.
He seguido el tutorial https://foro.seguridadwireless.net/openwrt/(desarrollo)-observa-telecom-vh4032n/msg310444/#msg310444
y le he cargado el firmware que hay en dicho tutorial sin problemas. Ahora me gustaria probar un firm mas moderno y me he bajado el lede que hay en la pagina de openwrt http://downloads.lede-project.org/releases/17.01.2/targets/brcm63xx/smp/lede-17.01.2-brcm63xx-smp-VH4032N-squashfs-cfe.bin y tambien me he bajado el 17.01.4 y no consigo instalar ninguno de los 2 usando el metodo del tutorial. en los 2 firms me da el siguiente error:
Illegal image ! Image crc failed.
No se si es que se meten de otra forma o si hay que hacerles algo para poder instalarlos con el metodo descrito en el tutorial.
¿alguien podria orientarme?
He leido casi todo el hilo, asi por encimilla, y he visto que se habia dicho que con chip pl2303 no funcionaba. yo uso el cable con el que se liberaban los nokia antiguos que tiene chip pl2303 y me ha funcionado bien. Con hyperterminal no hacia nada pero con putty a la primera
Lo del adaptador ttl, si te funciona, pues perfecto. ( El mío, sin embargo nunca funcionó en este router, en cambio en otros si)
Lo que no me queda claro es desde donde estas haciendo el upgrade, desde el CFE o desde la página de actualización?

Si no es así, prueba hacerlo desde el CFE.


Saludos.

Enviado desde mi PRA-LX1 mediante Tapatalk


lomismo1

  • Visitante
Re: Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #445 en: 02-04-2018, 11:07 (Lunes) »
Hola, ante todo muchas gracias a todos por vuestro excelente trabajo.
He seguido el tutorial https://foro.seguridadwireless.net/openwrt/(desarrollo)-observa-telecom-vh4032n/msg310444/#msg310444
y le he cargado el firmware que hay en dicho tutorial sin problemas. Ahora me gustaria probar un firm mas moderno y me he bajado el lede que hay en la pagina de openwrt http://downloads.lede-project.org/releases/17.01.2/targets/brcm63xx/smp/lede-17.01.2-brcm63xx-smp-VH4032N-squashfs-cfe.bin y tambien me he bajado el 17.01.4 y no consigo instalar ninguno de los 2 usando el metodo del tutorial. en los 2 firms me da el siguiente error:
Illegal image ! Image crc failed.
No se si es que se meten de otra forma o si hay que hacerles algo para poder instalarlos con el metodo descrito en el tutorial.
¿alguien podria orientarme?
He leido casi todo el hilo, asi por encimilla, y he visto que se habia dicho que con chip pl2303 no funcionaba. yo uso el cable con el que se liberaban los nokia antiguos que tiene chip pl2303 y me ha funcionado bien. Con hyperterminal no hacia nada pero con putty a la primera
Lo del adaptador ttl, si te funciona, pues perfecto. ( El mío, sin embargo nunca funcionó en este router, en cambio en otros si)
Lo que no me queda claro es desde donde estas haciendo el upgrade, desde el CFE o desde la página de actualización?

Si no es así, prueba hacerlo desde el CFE.


Saludos.

Enviado desde mi PRA-LX1 mediante Tapatalk



tengo ya intalado openwrt. Intento instalar los que he dicho desde el cfe porque me ha parecido entender que desde luci no se puede

Ficht

  • Visitante
Re: Re: Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #446 en: 02-04-2018, 11:19 (Lunes) »
Hola, ante todo muchas gracias a todos por vuestro excelente trabajo.
He seguido el tutorial https://foro.seguridadwireless.net/openwrt/(desarrollo)-observa-telecom-vh4032n/msg310444/#msg310444
y le he cargado el firmware que hay en dicho tutorial sin problemas. Ahora me gustaria probar un firm mas moderno y me he bajado el lede que hay en la pagina de openwrt http://downloads.lede-project.org/releases/17.01.2/targets/brcm63xx/smp/lede-17.01.2-brcm63xx-smp-VH4032N-squashfs-cfe.bin y tambien me he bajado el 17.01.4 y no consigo instalar ninguno de los 2 usando el metodo del tutorial. en los 2 firms me da el siguiente error:
Illegal image ! Image crc failed.
No se si es que se meten de otra forma o si hay que hacerles algo para poder instalarlos con el metodo descrito en el tutorial.
¿alguien podria orientarme?
He leido casi todo el hilo, asi por encimilla, y he visto que se habia dicho que con chip pl2303 no funcionaba. yo uso el cable con el que se liberaban los nokia antiguos que tiene chip pl2303 y me ha funcionado bien. Con hyperterminal no hacia nada pero con putty a la primera
Lo del adaptador ttl, si te funciona, pues perfecto. ( El mío, sin embargo nunca funcionó en este router, en cambio en otros si)
Lo que no me queda claro es desde donde estas haciendo el upgrade, desde el CFE o desde la página de actualización?

Si no es así, prueba hacerlo desde el CFE.


Saludos.

Enviado desde mi PRA-LX1 mediante Tapatalk



tengo ya intalado openwrt. Intento instalar los que he dicho desde el cfe porque me ha parecido entender que desde luci no se puede
Si, desde Luci ya se puede, desde el parche de tki2000 y danitool, es decir desde la disponibilidad en lede.
Aunque no debería de fallar desde el CFE.
Pero piensa que es trunk y pueden haber fallos, con el Kernel 4.9 actual me ha pasado lo mismo compilando un firm para otro router.
Prueba de las don maneras y cuanta si sigue fallando, yo también probaré ( más tarde)

Enviado desde mi PRA-LX1 mediante Tapatalk


lomismo1

  • Visitante
Re: Re: Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #447 en: 02-04-2018, 11:21 (Lunes) »
Hola, ante todo muchas gracias a todos por vuestro excelente trabajo.
He seguido el tutorial https://foro.seguridadwireless.net/openwrt/(desarrollo)-observa-telecom-vh4032n/msg310444/#msg310444
y le he cargado el firmware que hay en dicho tutorial sin problemas. Ahora me gustaria probar un firm mas moderno y me he bajado el lede que hay en la pagina de openwrt http://downloads.lede-project.org/releases/17.01.2/targets/brcm63xx/smp/lede-17.01.2-brcm63xx-smp-VH4032N-squashfs-cfe.bin y tambien me he bajado el 17.01.4 y no consigo instalar ninguno de los 2 usando el metodo del tutorial. en los 2 firms me da el siguiente error:
Illegal image ! Image crc failed.
No se si es que se meten de otra forma o si hay que hacerles algo para poder instalarlos con el metodo descrito en el tutorial.
¿alguien podria orientarme?
He leido casi todo el hilo, asi por encimilla, y he visto que se habia dicho que con chip pl2303 no funcionaba. yo uso el cable con el que se liberaban los nokia antiguos que tiene chip pl2303 y me ha funcionado bien. Con hyperterminal no hacia nada pero con putty a la primera
Lo del adaptador ttl, si te funciona, pues perfecto. ( El mío, sin embargo nunca funcionó en este router, en cambio en otros si)
Lo que no me queda claro es desde donde estas haciendo el upgrade, desde el CFE o desde la página de actualización?

Si no es así, prueba hacerlo desde el CFE.


Saludos.

Enviado desde mi PRA-LX1 mediante Tapatalk



tengo ya intalado openwrt. Intento instalar los que he dicho desde el cfe porque me ha parecido entender que desde luci no se puede
Si, desde Luci ya se puede, desde el parche de tki2000 y danitool, es decir desde la disponibilidad en lede.
Aunque no debería de fallar desde el CFE.
Pero piensa que es trunk y pueden haber fallos, con el Kernel 4.9 actual me ha pasado lo mismo compilando un firm para otro router.
Prueba de las don maneras y cuanta si sigue fallando, yo también probaré ( más tarde)

Enviado desde mi PRA-LX1 mediante Tapatalk


ok gracias, lo he hecho desde luci y lo ha cargado correctamente. me ha surgido otra duda ¿cargandolo asi encima del otro hay que vigilar tambien que se cargue en la zona 0? es que no he caido en mirar en putty a ver si lo cargaba bien
« Última modificación: 02-04-2018, 12:01 (Lunes) por lomismo1 »

Ficht

  • Visitante
Re: Re: Re: Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #448 en: 02-04-2018, 12:20 (Lunes) »
Hola, ante todo muchas gracias a todos por vuestro excelente trabajo.
He seguido el tutorial https://foro.seguridadwireless.net/openwrt/(desarrollo)-observa-telecom-vh4032n/msg310444/#msg310444
y le he cargado el firmware que hay en dicho tutorial sin problemas. Ahora me gustaria probar un firm mas moderno y me he bajado el lede que hay en la pagina de openwrt http://downloads.lede-project.org/releases/17.01.2/targets/brcm63xx/smp/lede-17.01.2-brcm63xx-smp-VH4032N-squashfs-cfe.bin y tambien me he bajado el 17.01.4 y no consigo instalar ninguno de los 2 usando el metodo del tutorial. en los 2 firms me da el siguiente error:
Illegal image ! Image crc failed.
No se si es que se meten de otra forma o si hay que hacerles algo para poder instalarlos con el metodo descrito en el tutorial.
¿alguien podria orientarme?
He leido casi todo el hilo, asi por encimilla, y he visto que se habia dicho que con chip pl2303 no funcionaba. yo uso el cable con el que se liberaban los nokia antiguos que tiene chip pl2303 y me ha funcionado bien. Con hyperterminal no hacia nada pero con putty a la primera
Lo del adaptador ttl, si te funciona, pues perfecto. ( El mío, sin embargo nunca funcionó en este router, en cambio en otros si)
Lo que no me queda claro es desde donde estas haciendo el upgrade, desde el CFE o desde la página de actualización?

Si no es así, prueba hacerlo desde el CFE.


Saludos.

Enviado desde mi PRA-LX1 mediante Tapatalk



tengo ya intalado openwrt. Intento instalar los que he dicho desde el cfe porque me ha parecido entender que desde luci no se puede
Si, desde Luci ya se puede, desde el parche de tki2000 y danitool, es decir desde la disponibilidad en lede.
Aunque no debería de fallar desde el CFE.
Pero piensa que es trunk y pueden haber fallos, con el Kernel 4.9 actual me ha pasado lo mismo compilando un firm para otro router.
Prueba de las don maneras y cuanta si sigue fallando, yo también probaré ( más tarde)

Enviado desde mi PRA-LX1 mediante Tapatalk


ok gracias, lo he hecho desde luci y lo ha cargado correctamente. me ha surgido otra duda ¿cargandolo asi encima del otro hay que vigilar tambien que se cargue en la zona 0? es que no he caido en mirar en putty a ver si lo cargaba bien
Si inicia bien, pues muy mal no ha de estar...
De todas maneras, ejecuta dmesg en la consola ver qué la carga como ha ido.


Enviado desde mi PRA-LX1 mediante Tapatalk


danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #449 en: 02-04-2018, 13:04 (Lunes) »
Código: [Seleccionar]
Illegal image ! Image crc failed.
Este error ocurre si flasheamos desde la línea de comandos de CFE, y provoado por el tamaño de la imagen de Openwrt.

Para flashear la imagen "squash-cfe.bin" en este router solo se puede usar la interfaz web de CFE, a la que tenemos acceso una vez que nos hemos parado el router en CFE.

http://192.168.1.1/

daviddrf

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #450 en: 03-05-2018, 23:47 (Jueves) »
Hola, muchas gracias a todos por vuestro gran trabajo. Yo estaba buscando el modo de obtener el firmware original de Vodafone para volver a él una vez he probado OpenWRT/LEDE. No sé si alguno sabe de esta posibilidad jejeje. Saludos y gracias por leerme.

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #451 en: 05-05-2018, 11:17 (Sábado) »
Hola, muchas gracias a todos por vuestro gran trabajo. Yo estaba buscando el modo de obtener el firmware original de Vodafone para volver a él una vez he probado OpenWRT/LEDE. No sé si alguno sabe de esta posibilidad jejeje. Saludos y gracias por leerme.

Creo que el problema es que la mayoría no contempló esa posibilidad, y una vez instalado Openwrt en la flash ya no puedes hacer el backup.

Hay dos opciones para hacer el backup del firmware y en ambas necesitas un adaptador UART TTL de puerto serie (por eemplo un CP2102):

- Mediante puerto serie con el cfetool de Noltari. Resulta algo lento.
- Arrancando un firmware OpenWrt tipo RAM, para luego salvar la partición Linux en un pendrive por ejemplo.  Es necesario compilar la versión RAM.

Luego posteriormente en caso necesario habría arreglar la cabecera del firmware. Es posible que le hayan hecho algo raro y no se pueda hacer correctamente.

Creo que puedo compilarte un firmware OpenWrt RAM sin problemas, ahora que ya está soportado es seleccionar dos cosas en los menús antes de compilar.

daviddrf

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #452 en: 05-05-2018, 17:35 (Sábado) »
Hola danitool. Gracias en primer lugar por tu respuesta y por tu atención. Lo que ocurrió en mi caso es que hace meses tenía este router con el firmware original de Vodafone y le metí exitosamente OpenWRT (ahora LEDE creo recordar) porque lo necesitaba para algo en concreto que no podía hacer con el firmware original de fábrica.
Ahora quería reaprovechar este router con su firmware original de fábrica Vodafone para emplear en una instalación de ADSL indirecto en la que necesito reinyección de voz para teléfonos que tengo en rosetas anteriores al router y posteriores al PTR.
Por el adaptador UART TTL de puerto serie no creo que haya problema porque tengo un CP2102 exactamente igual que este:

http://www.surplusgizmos.com/Silicon-Labs-CP2102-USB-to-Serial-TTL-Module_p_2476.html

De hecho creo recordar que fue con este mismo adaptador UART TTL de puerto serie con el que le metí OpenWRT al router previamente...
Ahora lo que busco es devolver el router a su firmware original de fábrica desde OpenWRT. Si me puedes echar un cable te estaría muy agradecido. Un saludo y gracias otra vez.

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #453 en: 07-05-2018, 10:54 (Lunes) »
Hola daviddrf compilé esta imagen RAM

VH4032N-initramfs.elf

La cual se carga ejecutando el comando en CFE, en la consola serie:
Código: [Seleccionar]
r 192.168.1.100:VH4032N-initramfs.elf
Una vez cargado el firmware en RAM, debes montar un pendrive donde meterás el backup
Código: [Seleccionar]
mount /dev/sda /mnt/
Examinamos que particiones tenemos
Código: [Seleccionar]
cat /proc/mtd
Nos interesa hacer backup de la partición línux, si es la mtd4 ejecutamos
Código: [Seleccionar]
dd if=/dev/mtd4 of=/mnt/mtd4-linux.bin
desmontamos el pendrive, para poder quitarlo físicamente del puerto de forma segura
Código: [Seleccionar]
umount /mnt/
Extraemos el pendrive del puerto USB. Ya tenemos el archivo de backup listo para extraer el firmware desde nuestro PC, en principio solo habría que cortar el archivo con los bytes que sobren.

Saludos

daviddrf

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #454 en: 07-05-2018, 15:00 (Lunes) »
Hola daviddrf compilé esta imagen RAM

VH4032N-initramfs.elf

La cual se carga ejecutando el comando en CFE, en la consola serie:
Código: [Seleccionar]
r 192.168.1.100:VH4032N-initramfs.elf
Una vez cargado el firmware en RAM, debes montar un pendrive donde meterás el backup
Código: [Seleccionar]
mount /dev/sda /mnt/
Examinamos que particiones tenemos
Código: [Seleccionar]
cat /proc/mtd
Nos interesa hacer backup de la partición línux, si es la mtd4 ejecutamos
Código: [Seleccionar]
dd if=/dev/mtd4 of=/mnt/mtd4-linux.bin
desmontamos el pendrive, para poder quitarlo físicamente del puerto de forma segura
Código: [Seleccionar]
umount /mnt/
Extraemos el pendrive del puerto USB. Ya tenemos el archivo de backup listo para extraer el firmware desde nuestro PC, en principio solo habría que cortar el archivo con los bytes que sobren.

Saludos

Gracias danitool nuevamente por tu respuesta. Creo que lo he entendido correctamente. Si no me equivoco sería:

1) Cargar tu imagen RAM con extensión .elf.
2) Hacer una copia de seguridad con extensión .bin de la partición Linux.
3) Te paso el archivo en cuestión para "cortarlo" o "adecuarlo" para que posteriormente podamos flashear con él el router y éste quede con el firmware Vodafone stock o de fábrica.

¿Es correcto? En caso afirmativo deduzco que la llave USB empleada para la copia de seguridad podría ser con formato o sistema de archivos FAT32...Saludos y gracias una vez más por responder.
« Última modificación: 07-05-2018, 15:01 (Lunes) por daviddrf »

Jeronimo17

  • Visitante
Re: Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #455 en: 15-05-2018, 00:33 (Martes) »
Otro problema con este router: estoy intentando usar el switch como puente entre dos tramos de cable. El propio router llega a los dos lados sin problema pero si mando pings de un lado, no llegan al otro. Es como si el switch no estuviera dejando pasar los paquetes.

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.103'
        option gateway '192.168.1.1'
        option dns '8.8.8.8'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 8t'
Efectivamente, es un problema de este switch no se comunican las bocas entre sí.

Enviado desde mi PRA-LX1 mediante Tapatalk



Esto es fundamental, llevaba todo el día intentándolo, ¿no se ha conseguido en este router?