Autor Tema: [Desarrollo] OpenWrt en Observa Telecom VH4032N  (Leído 127671 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Yona

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #100 en: 21-06-2014, 17:27 (Sábado) »
En modo repetidor creo que si se puede
El problema es que no escanea redes, saludos.

Sí que escanea redes, el problema es que para escanear redes tienes que tener la wifi desactivada. Conéctate por cable, desactiva la wifi y escanea.
Entiendo que te refieres a que no funciona por que esta en modo AP y por eso no puede escanear.

Pero yo quiero usar la signal king como cliente que tiene el modo AP desactivado y la detecta perfectamente y se queda en blanco al intentar escanear, tiene chipset ralink 3070 con la alfa (rtl9197L) sucede lo mismo.

El wifi del router lo quiero como AP, saludos.



Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1866
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #101 en: 21-06-2014, 17:48 (Sábado) »
En modo repetidor creo que si se puede
El problema es que no escanea redes, saludos.

Sí que escanea redes, el problema es que para escanear redes tienes que tener la wifi desactivada. Conéctate por cable, desactiva la wifi y escanea.
Entiendo que te refieres a que no funciona por que esta en modo AP y por eso no puede escanear.

Pero yo quiero usar la signal king como cliente que tiene el modo AP desactivado y la detecta perfectamente y se queda en blanco al intentar escanear, tiene chipset ralink 3070 con la alfa (rtl9197L) sucede lo mismo.

El wifi del router lo quiero como AP, saludos.

Me refiero a que mientras que la wifi esté activa, no escanea. Pero después de escanear puedes volver a activarla, ¿no?
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.

Yona

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #102 en: 21-06-2014, 18:14 (Sábado) »
Desactivada tampoco escanea, yo uso la radio0 que es el wifi del router para conectarme a el, y la radio1 que es la signal king quiero usarla para escanear redes y que se conecte aún que sea de forma manual.

Pero le doy a escanear estando desactivada y se queda todo en blanco excepto la barra del menú.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1866
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #103 en: 21-06-2014, 19:43 (Sábado) »
Desactivada tampoco escanea, yo uso la radio0 que es el wifi del router para conectarme a el, y la radio1 que es la signal king quiero usarla para escanear redes y que se conecte aún que sea de forma manual.

Pero le doy a escanear estando desactivada y se queda todo en blanco excepto la barra del menú.

Mira a ver si este post te soluciona algo. A veces hay que activar/desactivar y/o resetear para que escanee.

https://foro.seguridadwireless.net/openwrt/antenas-usb-rt3572-y-openwrt/msg310887/#msg310887
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.

dekod

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #104 en: 23-06-2014, 14:42 (Lunes) »
has conseguido algo?

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1866
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #105 en: 23-06-2014, 14:55 (Lunes) »
has conseguido algo?

¿A quién preguntas y sobre qué?  ???
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.

dekod

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #106 en: 23-06-2014, 15:17 (Lunes) »
has conseguido algo?

¿A quién preguntas y sobre qué?  ???

Perdon. A Yona por su problema

Yona

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #107 en: 26-06-2014, 22:58 (Jueves) »
has conseguido algo?

Disculpa por tardar en responder, he tenido que reinstalar de nuevo openwrt (demontar el router etc).

Pues por ahora escanea redes con el wifi propio y la Alfa de 1W que no tiene tecnología N, con la signal king no escanea supongo que es por que tiene tecnología N no sé si se puede solucionar eso.

El problema es que configuro todo según el tutorial y sin usar ningún adaptador wifi USB y la red del router desaparece.

Lo que hago es conectarme por cable, y si activo el wifi del router si aparece correctamente en mi lista de redes, lo desactivo escaneo redes y lo configuro con la la red y la correspondiente contraseña, seguidamente pulso sobre "add" para que el router cree un punto de acceso lo activo y no aparece la red en mi PC del router.

He probado a activar primero el wifi del router y tampoco, una vez que se configura la otra parte como cliente el AP desaparece...

(Lo que quiero hacer es usar el wifi del router como cliente y como AP), sin adaptador wifi usb externo.

Pero como ya digo, en cuando se configura como cliente desaparece el punto de acceso, y si lo creo después el punto de acceso no aparece en mi lista de redes, pero en el router aparece todo correctamente configurado.

Es muy extraño, ya que una cosa es que no me diera Internet pero otra cosa es que no me aparezca el AP (y no esta oculto).

A ver si sabéis alguna solución para esto.

Y por cierto, ¿no hay manera aún de usar un adaptador wifi usb con tecnología N como cliente?

saludos.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1866
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #108 en: 27-06-2014, 09:13 (Viernes) »
(Lo que quiero hacer es usar el wifi del router como cliente y como AP), sin adaptador wifi usb externo.

Pues con este router no lo vas a conseguir porque la wifi es Broadcom y no puede actuar como cliente y AP a la vez.

Y por cierto, ¿no hay manera aún de usar un adaptador wifi usb con tecnología N como cliente?

Sí claro, cualquiera con chipset Atheros o Ralink sirve. Yo le conecté un pincho con RT3572 y va bien. https://foro.seguridadwireless.net/openwrt/antenas-usb-rt3572-y-openwrt/
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.

Yona

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #109 en: 27-06-2014, 10:09 (Viernes) »
(Lo que quiero hacer es usar el wifi del router como cliente y como AP), sin adaptador wifi usb externo.

Pues con este router no lo vas a conseguir porque la wifi es Broadcom y no puede actuar como cliente y AP a la vez.

Y por cierto, ¿no hay manera aún de usar un adaptador wifi usb con tecnología N como cliente?

Sí claro, cualquiera con chipset Atheros o Ralink sirve. Yo le conecté un pincho con RT3572 y va bien. https://foro.seguridadwireless.net/openwrt/antenas-usb-rt3572-y-openwrt/
Pues no hay manera de conseguir que funcione, he probado con la Alfa 1W de cliente y el AP del router deja de funcionar una vez el adaptador se configura como cliente, directamente no deja ni activarlo, clicko sobre "ENABLE" y se queda igual y en donde debería de poner "Access point o Cliente" pone Unknown.

Y eso que la Alfa 1w no tiene tecnología N, eso si, el chip es RTL8187L, pero escanea la redes correctamente a la primera y conecta y demás el problema esta con el router que deja de funcionarle el AP wifi al configurar el modo cliente en radio1.

¿Sabes que podría ser?

Saludos.


Añado:
¿Como se instalar el driver wifi .bin sin tener internet en el router?
veo que explicas esto "El firmware rt2870.bin hay que ponerlo en /lib/firmware sobreescribiendo el anterior." pero no sé exactamente como se sube, supongo que tal vez es por comandos pero ni idea de si se puede desde la interfaz.
« Última modificación: 27-06-2014, 12:13 (Viernes) por Yona »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1866
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #110 en: 27-06-2014, 15:14 (Viernes) »
(Lo que quiero hacer es usar el wifi del router como cliente y como AP), sin adaptador wifi usb externo.

Pues con este router no lo vas a conseguir porque la wifi es Broadcom y no puede actuar como cliente y AP a la vez.

Y por cierto, ¿no hay manera aún de usar un adaptador wifi usb con tecnología N como cliente?

Sí claro, cualquiera con chipset Atheros o Ralink sirve. Yo le conecté un pincho con RT3572 y va bien. https://foro.seguridadwireless.net/openwrt/antenas-usb-rt3572-y-openwrt/
Pues no hay manera de conseguir que funcione, he probado con la Alfa 1W de cliente y el AP del router deja de funcionar una vez el adaptador se configura como cliente, directamente no deja ni activarlo, clicko sobre "ENABLE" y se queda igual y en donde debería de poner "Access point o Cliente" pone Unknown.

Y eso que la Alfa 1w no tiene tecnología N, eso si, el chip es RTL8187L, pero escanea la redes correctamente a la primera y conecta y demás el problema esta con el router que deja de funcionarle el AP wifi al configurar el modo cliente en radio1.

¿Sabes que podría ser?

Saludos.


Añado:
¿Como se instalar el driver wifi .bin sin tener internet en el router?
veo que explicas esto "El firmware rt2870.bin hay que ponerlo en /lib/firmware sobreescribiendo el anterior." pero no sé exactamente como se sube, supongo que tal vez es por comandos pero ni idea de si se puede desde la interfaz.

Si estás usando mi compilación puedes grabar el fichero en un pincho USB y pasárselo al router. Tiene los drivers para NTFS, FAT y EXT.
O si prefieres pasárselo por red, puedes usar WinSCP bajo Windows, o algún otro cliente SCP bajo Linux.
O si quieres puedes activar el pure-ftpd en /etc/config/pure-ftpd y pasarle el fichero por FTP.
O si tienes funcionando algún servidor web local, ponerlo ahí y hacer un wget desde el router.

Posibilidades hay...
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.

Yona

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #111 en: 27-06-2014, 15:52 (Viernes) »
(Lo que quiero hacer es usar el wifi del router como cliente y como AP), sin adaptador wifi usb externo.

Pues con este router no lo vas a conseguir porque la wifi es Broadcom y no puede actuar como cliente y AP a la vez.

Y por cierto, ¿no hay manera aún de usar un adaptador wifi usb con tecnología N como cliente?

Sí claro, cualquiera con chipset Atheros o Ralink sirve. Yo le conecté un pincho con RT3572 y va bien. https://foro.seguridadwireless.net/openwrt/antenas-usb-rt3572-y-openwrt/
Pues no hay manera de conseguir que funcione, he probado con la Alfa 1W de cliente y el AP del router deja de funcionar una vez el adaptador se configura como cliente, directamente no deja ni activarlo, clicko sobre "ENABLE" y se queda igual y en donde debería de poner "Access point o Cliente" pone Unknown.

Y eso que la Alfa 1w no tiene tecnología N, eso si, el chip es RTL8187L, pero escanea la redes correctamente a la primera y conecta y demás el problema esta con el router que deja de funcionarle el AP wifi al configurar el modo cliente en radio1.

¿Sabes que podría ser?

Saludos.


Añado:
¿Como se instalar el driver wifi .bin sin tener internet en el router?
veo que explicas esto "El firmware rt2870.bin hay que ponerlo en /lib/firmware sobreescribiendo el anterior." pero no sé exactamente como se sube, supongo que tal vez es por comandos pero ni idea de si se puede desde la interfaz.

Si estás usando mi compilación puedes grabar el fichero en un pincho USB y pasárselo al router. Tiene los drivers para NTFS, FAT y EXT.
O si prefieres pasárselo por red, puedes usar WinSCP bajo Windows, o algún otro cliente SCP bajo Linux.
O si quieres puedes activar el pure-ftpd en /etc/config/pure-ftpd y pasarle el fichero por FTP.
O si tienes funcionando algún servidor web local, ponerlo ahí y hacer un wget desde el router.

Posibilidades hay...
Una puesto el archivo .bin en el usb y el usb conectado al router ¿a que parte de la interfaz tengo que acceder para continuar con la instalación?.

disculpa mi ignorancia, he probado a buscar en system > software y no aparece.

Saludos.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1866
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #112 en: 27-06-2014, 20:51 (Viernes) »
Dado que veo que no tienes muchos conocimientos y no sabes cómo realizar una conexión con el router, vamos a ver si puedo ayudarte a matar moscas a cañonazos. Voy a intentar explicar como hacerlo desde la interfaz de LuCI, aunque esa no es la opción adecuada.
Deberías buscar cómo hacer una conexión SSH con el router para abrir una consola y teclear los comandos. Esa es la forma adecuada.

-->>> El fichero rt2870.bin debe estar grabado en el raíz del pincho USB o los comandos no funcionarán.

Desde LuCI vete a System -> Custom Commands
En la parte de arriba, dale a la pestaña Configure

Dale a botón Add para añadir un comando
En el primer cuadro de la izquierda pon de descripción Montar unidad USB
En el segundo cuadro teclea esto: mount /dev/sda1 /mnt
Pincha en el botón Save & Apply para guardar el comando

Dale a botón Add para añadir un comando
En el primer cuadro de la izquierda pon de descripción Copiar fichero
En el segundo cuadro teclea esto: cp -f /mnt/rt2870.bin /lib/firmware
Pincha en el botón Save & Apply para guardar el comando

Ahora en la parte de arriba, pincha en la pestaña Dashboard. Verás que los comandos que has puesto en la otra pestaña ahora aparecen aquí.
Pincha el USB en el router.
Pincha en Run en el comando Montar unidad USB
Pincha en Run en el comando Copiar fichero

Si todo ha ido bien y no ha habido errores, el fichero se debe haber copiado en /lib/firmware
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.

Yona

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #113 en: 27-06-2014, 21:42 (Viernes) »
Dado que veo que no tienes muchos conocimientos y no sabes cómo realizar una conexión con el router, vamos a ver si puedo ayudarte a matar moscas a cañonazos. Voy a intentar explicar como hacerlo desde la interfaz de LuCI, aunque esa no es la opción adecuada.
Deberías buscar cómo hacer una conexión SSH con el router para abrir una consola y teclear los comandos. Esa es la forma adecuada.

-->>> El fichero rt2870.bin debe estar grabado en el raíz del pincho USB o los comandos no funcionarán.

Desde LuCI vete a System -> Custom Commands
En la parte de arriba, dale a la pestaña Configure

Dale a botón Add para añadir un comando
En el primer cuadro de la izquierda pon de descripción Montar unidad USB
En el segundo cuadro teclea esto: mount /dev/sda1 /mnt
Pincha en el botón Save & Apply para guardar el comando

Dale a botón Add para añadir un comando
En el primer cuadro de la izquierda pon de descripción Copiar fichero
En el segundo cuadro teclea esto: cp -f /mnt/rt2870.bin /lib/firmware
Pincha en el botón Save & Apply para guardar el comando

Ahora en la parte de arriba, pincha en la pestaña Dashboard. Verás que los comandos que has puesto en la otra pestaña ahora aparecen aquí.
Pincha el USB en el router.
Pincha en Run en el comando Montar unidad USB
Pincha en Run en el comando Copiar fichero

Si todo ha ido bien y no ha habido errores, el fichero se debe haber copiado en /lib/firmware

Muchas gracias por la explicación tan perfecta, parece que se ha instalado correctamente y no ha dado ningún error.

EDITO:
Parece ser que ya funciona correctamente, radio1 que es la signal king me ha escaneado redes y se conecta correctamente y radio0 el wifi del router hace de AP y parece funcionar todo correctamente, ahora tan solo necesito configurar bien el modo puente de radio1 a radio0 no parece fácil así que será cuestión de probar, muchas gracias una vez más, saludos.

Vuelvo a editar:
Ya esta, funciona perfectamente, tan solo era cuestión de instalar el driver y configurar todo correctamente, me ha llevado unas horas por que a veces era como que se deshabilitaba tanto el AP como el modo cliente y era algo muy extraño pero ya funciona correctamente, primero he configurado la signal king como cliente y donde pone wwan he puesto el nombre de la red y arriba la correspondiente contraseña y eso + clickar submit + save and aply ya daba internet al router, después el wifi del router "radio0" lo he configurado como AP tan solo había que marcar la casilla lan y todo perfecto.
Echaba bastante de menos una buena señal wifi en el móvil, saludos y gracias de nuevo jaja, ya no tendré que dar mas la vara o eso espero.
« Última modificación: 27-06-2014, 23:37 (Viernes) por Yona »

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #114 en: 05-08-2014, 15:59 (Martes) »
Buenas,

Ahora mismo ando de viaje, pero cuando vuelva mandaré los parches para este router y para el HG622 si funciona todo al 100%.
Por favor, cuando podáis, comprobad si añadiendo el flag "--pad 16" el firmware se flashea bien sin tener que hacer nada específico.
El flag --pad 16 sirve para crear un firmware de al menos 16MB, para que el router se vea obligado a utilizar toda la flash en vez de utilizar sólo la mitad.

Saludos.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1866
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #115 en: 06-08-2014, 00:08 (Miércoles) »
Buenas,

Ahora mismo ando de viaje, pero cuando vuelva mandaré los parches para este router y para el HG622 si funciona todo al 100%.
Por favor, cuando podáis, comprobad si añadiendo el flag "--pad 16" el firmware se flashea bien sin tener que hacer nada específico.
El flag --pad 16 sirve para crear un firmware de al menos 16MB, para que el router se vea obligado a utilizar toda la flash en vez de utilizar sólo la mitad.

Saludos.

El fallo que le encuentro al HG622 es que no se puede actualizar openwrt desde openwrt. Siempre falla la actualización y al rearrancar salta la web del bootloader. Se soluciona resubiendo el firmware, pero se pierde la configuración anterior completamente.
Con respecto al VH4032N, ya probé con --pad16 y tampoco se podía forzar la parte de la flash en la que se graba la imagen. Siempre es alternativa y sólo se puede ver por consola serie. ¡Ah! y lo más gracioso es que no se puede quemar más de una longitud dada en la flash. Por muy grande que sea la imagen sólo flashea una longitud máxima, con lo que no podemos generar una imagen de 32MB para flashear. Por lo que estuve comentando con gmtii la longitud máxima de flasheo es 0xB00000 (11534336) lo cual no llega ni para una imagen de 16MB.
El que diga que esto no es raro....  ???
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #116 en: 06-08-2014, 10:08 (Miércoles) »
Buenas,

Ahora mismo ando de viaje, pero cuando vuelva mandaré los parches para este router y para el HG622 si funciona todo al 100%.
Por favor, cuando podáis, comprobad si añadiendo el flag "--pad 16" el firmware se flashea bien sin tener que hacer nada específico.
El flag --pad 16 sirve para crear un firmware de al menos 16MB, para que el router se vea obligado a utilizar toda la flash en vez de utilizar sólo la mitad.

Saludos.

El fallo que le encuentro al HG622 es que no se puede actualizar openwrt desde openwrt. Siempre falla la actualización y al rearrancar salta la web del bootloader. Se soluciona resubiendo el firmware, pero se pierde la configuración anterior completamente.
Con respecto al VH4032N, ya probé con --pad16 y tampoco se podía forzar la parte de la flash en la que se graba la imagen. Siempre es alternativa y sólo se puede ver por consola serie. ¡Ah! y lo más gracioso es que no se puede quemar más de una longitud dada en la flash. Por muy grande que sea la imagen sólo flashea una longitud máxima, con lo que no podemos generar una imagen de 32MB para flashear. Por lo que estuve comentando con gmtii la longitud máxima de flasheo es 0xB00000 (11534336) lo cual no llega ni para una imagen de 16MB.
El que diga que esto no es raro....  ???
Lo del VH4032N igual es por falta de RAM. En el VR-3025u flashea sin problemas, pero tiene 64 MB de RAM...
Le preguntaré a jogo si hay alguna solución para forzar que el firmware se flashee al principio, aunque creo que no, porque el problema es que la mayoría de los CFE ignoran los flags destinados a ese cometido...
Con respecto al HG622 ya preguntaré a alguien que lo tenga, pero es necesario un log de la actualización del firmware para ver qué error da al reiniciar.

Saludos!

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1866
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #117 en: 06-08-2014, 10:56 (Miércoles) »
Lo del VH4032N igual es por falta de RAM. En el VR-3025u flashea sin problemas, pero tiene 64 MB de RAM...

No creo que sea por falta de RAM. El VH4032N tiene 128MB.
En este mensaje puedes ver lo de la longitud truncada en las imágenes y lo que le comentaba a Pteridium: https://foro.seguridadwireless.net/openwrt/(desarrollo)-observa-telecom-vh4032n/msg310334/#msg310334
Ahora mismo no tengo un log del HG622, pero creo recordar que lo que pasaba era que no reconocía la imagen del kernel al arrancar (creo que decía que estaba corrupta y no la descomprime del lzma) y por eso saltaba el servidor web de rescate del bootloader. No te lo puedo decir con seguridad pero tengo sospechas de que es porque la imagen o no se graba en su sitio o hay algo que no se tiene en cuenta cuando se hace el sysupgrade que no pasa cuando quemas la imagen diretamente desde el bootloader. Desde mi supina ignorancia en este tema no puedo aportar más ideas que las de intentar diagnosticar, para que las "cabezas pensantes" intenten encontrar alguna explicación.  ;D
Por cierto al VH4032N también le pasa lo mismo que al HG622 con lo del sysupgrade, no es capaz de actualizar openwrt desde luci y salta la web del bootloader.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.

seny

  • Visitante
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #118 en: 06-08-2014, 13:46 (Miércoles) »
Hola, aunque ya habia compilado con éxito algun modelo, no estoy seguro que se pueda considerar mi prueba definitiva porque algunos conceptos no los domino todavia.

He compilado esta noche y el resultado al arrancar ha sido este:
Citar
CFE version 1.0.37-102.15 for BCM96368 (32bit,SP,BE)
Build Date: Wed Feb 10 09:57:47 CST 2010 (link@hpnb)
Copyright (C) 2000-2009 Broadcom Corporation.

Parallel flash device: name AM29LV320MT, id 0x2201, size 32768KB
CPU type 0x2A031: 400MHz, Bus: 160MHz, Ref: 64MHz
CPU running TP0
Total memory: 134217728 bytes (128MB)
Boot Address 0xb8000000


Board IP address                  : 192.168.1.1:ffffff00
Host IP address                   : 192.168.1.100
Gateway IP address                :
Run from flash/host (f/h)         : f
Default host run file name        : vmlinux
Default host flash file name      : bcm963xx_fs_kernel
Boot delay (0-9 seconds)          : 1
Boot image (0=latest, 1=previous) : 0
Board Id (0-4)                    : 96368VVW
Number of MAC Addresses (1-32)    : 11
Base MAC Address                  : e4:xx:xx:xx:xx:xx
PSI Size (1-64) KBytes            : 64
Main Thread Number [0|1]          : 0
Serial Number (20)                : V130B--------
Vendor Specific 01 (40)           : L66r----------
Vendor Specific 02 (40)           :
Vendor Specific 03 (40)           :

*** Press any key to stop auto run (1 seconds) ***
Auto run second count down: 1
web info: Waiting for connection on socket 0.
web info: Waiting for connection on socket 1.
web info: Waiting for connection on socket 0.
web info: Waiting for connection on socket 1.
web info: Waiting for connection on socket 0.
web info: Upload 4063236 bytes, Broadcom image format.
CFE>
Flashing root file system and kernel at 0xb8020000: ............................
....

.
*** Image flash done *** !

Resetting board...

CFE version 1.0.37-102.15 for BCM96368 (32bit,SP,BE)
Build Date: Wed Feb 10 09:57:47 CST 2010 (link@hpnb)
Copyright (C) 2000-2009 Broadcom Corporation.

Parallel flash device: name AM29LV320MT, id 0x2201, size 32768KB
CPU type 0x2A031: 400MHz, Bus: 160MHz, Ref: 64MHz
CPU running TP0
Total memory: 134217728 bytes (128MB)
Boot Address 0xb8000000


Board IP address                  : 192.168.1.1:ffffff00
Host IP address                   : 192.168.1.100
Gateway IP address                :
Run from flash/host (f/h)         : f
Default host run file name        : vmlinux
Default host flash file name      : bcm963xx_fs_kernel
Boot delay (0-9 seconds)          : 1
Boot image (0=latest, 1=previous) : 0
Board Id (0-4)                    : 96368VVW
Number of MAC Addresses (1-32)    : 11
Base MAC Address                  : e4:xx:xx:xx:xx:xx
PSI Size (1-64) KBytes            : 64
Main Thread Number [0|1]          : 0
Serial Number (20)                : V130B--------
Vendor Specific 01 (40)           : L66r----------
Vendor Specific 02 (40)           :
Vendor Specific 03 (40)           :

*** Press any key to stop auto run (1 seconds) ***
Auto run second count down: 0
Booting from latest image (0xb8020000) ...
Code Address: 0x80010000, Entry Address: 0x80010000
LZMA: Prossible old LZMA format, trying to decompress..
Decompression OK!
Entry at 0x80010000
Closing network.
Disabling Switch ports.
Flushing Receive Buffers...
48 buffers found.
Closing DMA Channels.
Starting program at 0x80010000
[    0.000000] Linux version 3.10.34 (XXXX) (gcc versi
on 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.01 r40396) ) #1 Wed Aug 6 03:29:22 CEST 20
14
[    0.000000] Detected Broadcom 0x6368 CPU revision b2
[    0.000000] CPU frequency is 400 MHz
[    0.000000] 128MB of RAM installed
[    0.000000] registering 38 GPIOs
[    0.000000] board_bcm963xx: Boot address 0xb8000000
[    0.000000] board_bcm963xx: CFE version: 1.0.37-102.15
[    0.000000] Overriding boardid with 'VH4032N'
[    0.000000] board_bcm963xx: unknown bcm963xx board: VH4032N
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0002a031 (Broadcom BMIPS4350)
[    0.000000] Kernel panic - not syncing: unable to detect bcm963xx board
Creo que el menuconfig lo he dejado bien, Target System (Broadcom BCM63xx), Subtarget (brcm6368), Target Profile (Observa Telecom VH4032N ), le he añadido el Luci y lo básico que me había funcionado en otros modelos.

Por cierto, aunque ha tenido varios Kernel panic, siempre he podido cargar el binario desde el navegador, despues de la interrupcion desde el puerto serie claro esta..

Mi router no es el de vodafone creo, no tiene el logo y el firm que tenia era el de Tecom, supongo que es el mismo.

Un saludo

Editado para quitar los datos personales.
« Última modificación: 06-08-2014, 15:07 (Miércoles) por Tki2000 »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1866
Re: [Desarrollo] OpenWrt en Observa Telecom VH4032N
« Respuesta #119 en: 06-08-2014, 15:17 (Miércoles) »
Hola, aunque ya habia compilado con éxito algun modelo, no estoy seguro que se pueda considerar mi prueba definitiva porque algunos conceptos no los domino todavia.

He compilado esta noche y el resultado al arrancar ha sido este:
Citar
CFE version 1.0.37-102.15 for BCM96368 (32bit,SP,BE)
Build Date: Wed Feb 10 09:57:47 CST 2010 (link@hpnb)
Copyright (C) 2000-2009 Broadcom Corporation.

Parallel flash device: name AM29LV320MT, id 0x2201, size 32768KB
CPU type 0x2A031: 400MHz, Bus: 160MHz, Ref: 64MHz
CPU running TP0
Total memory: 134217728 bytes (128MB)
Boot Address 0xb8000000


Board IP address                  : 192.168.1.1:ffffff00
Host IP address                   : 192.168.1.100
Gateway IP address                :
Run from flash/host (f/h)         : f
Default host run file name        : vmlinux
Default host flash file name      : bcm963xx_fs_kernel
Boot delay (0-9 seconds)          : 1
Boot image (0=latest, 1=previous) : 0
Board Id (0-4)                    : 96368VVW
Number of MAC Addresses (1-32)    : 11
Base MAC Address                  : e4:xx:xx:xx:xx:xx
PSI Size (1-64) KBytes            : 64
Main Thread Number [0|1]          : 0
Serial Number (20)                : V130B--------
Vendor Specific 01 (40)           : L66r----------
Vendor Specific 02 (40)           :
Vendor Specific 03 (40)           :

*** Press any key to stop auto run (1 seconds) ***
Auto run second count down: 1
web info: Waiting for connection on socket 0.
web info: Waiting for connection on socket 1.
web info: Waiting for connection on socket 0.
web info: Waiting for connection on socket 1.
web info: Waiting for connection on socket 0.
web info: Upload 4063236 bytes, Broadcom image format.
CFE>
Flashing root file system and kernel at 0xb8020000: ............................
....

.
*** Image flash done *** !

Resetting board...

CFE version 1.0.37-102.15 for BCM96368 (32bit,SP,BE)
Build Date: Wed Feb 10 09:57:47 CST 2010 (link@hpnb)
Copyright (C) 2000-2009 Broadcom Corporation.

Parallel flash device: name AM29LV320MT, id 0x2201, size 32768KB
CPU type 0x2A031: 400MHz, Bus: 160MHz, Ref: 64MHz
CPU running TP0
Total memory: 134217728 bytes (128MB)
Boot Address 0xb8000000


Board IP address                  : 192.168.1.1:ffffff00
Host IP address                   : 192.168.1.100
Gateway IP address                :
Run from flash/host (f/h)         : f
Default host run file name        : vmlinux
Default host flash file name      : bcm963xx_fs_kernel
Boot delay (0-9 seconds)          : 1
Boot image (0=latest, 1=previous) : 0
Board Id (0-4)                    : 96368VVW
Number of MAC Addresses (1-32)    : 11
Base MAC Address                  : e4:xx:xx:xx:xx:xx
PSI Size (1-64) KBytes            : 64
Main Thread Number [0|1]          : 0
Serial Number (20)                : V130B--------
Vendor Specific 01 (40)           : L66r----------
Vendor Specific 02 (40)           :
Vendor Specific 03 (40)           :

*** Press any key to stop auto run (1 seconds) ***
Auto run second count down: 0
Booting from latest image (0xb8020000) ...
Code Address: 0x80010000, Entry Address: 0x80010000
LZMA: Prossible old LZMA format, trying to decompress..
Decompression OK!
Entry at 0x80010000
Closing network.
Disabling Switch ports.
Flushing Receive Buffers...
48 buffers found.
Closing DMA Channels.
Starting program at 0x80010000
[    0.000000] Linux version 3.10.34 (XXXX) (gcc versi
on 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.01 r40396) ) #1 Wed Aug 6 03:29:22 CEST 20
14
[    0.000000] Detected Broadcom 0x6368 CPU revision b2
[    0.000000] CPU frequency is 400 MHz
[    0.000000] 128MB of RAM installed
[    0.000000] registering 38 GPIOs
[    0.000000] board_bcm963xx: Boot address 0xb8000000
[    0.000000] board_bcm963xx: CFE version: 1.0.37-102.15
[    0.000000] Overriding boardid with 'VH4032N'
[    0.000000] board_bcm963xx: unknown bcm963xx board: VH4032N
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0002a031 (Broadcom BMIPS4350)
[    0.000000] Kernel panic - not syncing: unable to detect bcm963xx board
Creo que el menuconfig lo he dejado bien, Target System (Broadcom BCM63xx), Subtarget (brcm6368), Target Profile (Observa Telecom VH4032N ), le he añadido el Luci y lo básico que me había funcionado en otros modelos.

Por cierto, aunque ha tenido varios Kernel panic, siempre he podido cargar el binario desde el navegador, despues de la interrupcion desde el puerto serie claro esta..

Mi router no es el de vodafone creo, no tiene el logo y el firm que tenia era el de Tecom, supongo que es el mismo.

Un saludo

Editado para quitar los datos personales.

¿De dónde te has bajado el repositorio? Tiene pinta de que te pasa lo que me pasó a mí en el primer intento al compilar: https://foro.seguridadwireless.net/openwrt/(desarrollo)-observa-telecom-vh4032n/msg310260/#msg310260
No sé si este cambio lo ha hecho Noltari en su repo. En el que me dió gmtii creo que ya está hecho.
¿Puedes probar la imagen que compilé a ver si esa te funciona? Imagen openwrt r40396 Barrier Breaker 14.04: Imagen VH4032N
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.