Autor Tema: has detectado una version nueva , ...avisanos.  (Leído 189433 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado lupox

  • Colaborador
  • *
  • Mensajes: 531
  • volver....
Re: has detectado una version nueva , ...avisanos.
« Respuesta #80 en: 28-06-2013, 12:31 (Viernes) »
cambios desde syslinux 4.05

Aunque igual genera mas problemas en general que beneficios en particular.

http://www.syslinux.org/wiki/index.php/The_Syslinux_Project

Citar
Changes in 6.00 Add support for booting from EFI.
EFI TCP/IP support. This allows the EFI backend to hook into the generic TFTP, HTTP and FTP functionality.

Syslinux 5 ChangelogFrom Syslinux Wiki

Jump to: navigation, searchChanges in 5.10 PXELINUX: An entirely new network implementation based on the lwIP embedded TCP/IP stack. As a result, plain PXELINUX can now support HTTP and FTP without gPXE/iPXE. ls/readdir functionality is supported over HTTP with an indexing webserver, or over FTP with most common FTP servers. For the new network stack use lpxelinux.0. For the legacy stack use pxelinux.0.
Rename the "ipappend" option to "sysappend" ("ipappend" is still accepted as an alias) and make it available for all derivatives. Add additional strings derived from the system DMI/SMBIOS information if available.
"sysappend" strings are also sent as http cookies, with the prefix _Syslinux_ added, on all http transfers. This can be overridden with the SENDCOOKIES configuration file command.
poweroff.c32: A new module to power off a system via APM. It replaces the poweroff COMBOOT module (Sebastian Herbszt).
PXELINUX: Fix booting with DHCP options 209 and 210 which was broken in

5.00.
Handle loading kernel images with no protected mode code. A legitimate kernel image can consist solely of real-mode code. The support for booting such images was broken in 5.00 (Josh Triplett).
Fix a regression in the .psf font file loader introduced in 5.00.
Changes in 5.01 txt/: A new AsciiDoc documentation set (work-in-progress) (Gene Cumm).
core: Fix a bug in the realloc() implementation that caused machines to appear to run out of free memory.
ldlinux: Fix multiple buffer overflows in cmdline parsing code that resulted in files failing to run and cmdlines being truncated.
core: Fix debug build by tagging __bad_SEG() with __export.
com32: Restrict library filenames to 8.3 format.
EXTLINUX: Fix installation and subdirectory patching.
ISOLINUX: Fix booting isohybrid images that are over 32K.
com32: Strip modules to reduce their size.
XFS: Implement directory block cache and fix shortform-directory lookup (Paulo Alcantara).
Changes in 5.00 com32: Switched from the COM32 object format to ELF as it is a much more powerful format that allows undefined symbols to be resolved at runtime and dynamic loading of module dependencies, which means modules now become shared object files instead of statically linked binaries - reducing both disk space and runtime memory consumption.
core: Split non-core functionality into ldlinux.c32, which is an ELF module loaded by the core that contains everything the core doesn't require to boot the system, e.g. config parser, command-line interface, etc.
Replaced __intcall() calls with direct function calls now that we can resolve undefined symbols at runtime, thanks to the ELF object support. Now that we no longer need to go through the 16-bit interrupt mechanism we can make full use of the 32-bit execution environment. This change required reimplementing lots of the 16-bit assembly code from core/ in C.
com32: __com32.cs_bounce is gone. Now we always run in a 32-bit environment once we execute ldlinux.c32.
ldlinux: A new "PATH" directive was added to the ldlinux.c32 config parser that specifies a colon-separated list of directories to search when attempting to load modules.
ALL: Delete all references to/code for 16-bit COMBOOT files. COMBOOT files (.cbt and .com) are no longer supported under Syslinux

Changes in 4.06 Support for NTFS, by Paulo Alcantara.
EXTLINUX: more robust device detection, allow user to override.
kontron_wdt.c32: Add a new module to enable the hardware watchdog of some Kontron boards. It allows enabling the watchdog and then booting a given image.
HDT updated, and now can display images regarding some detection steps. Add postexec command to run a particular entry after HDT's execution, add silent option and various fixes.
ifcpu.c32: Detect hypervisor presence.
lua.c32: Add dhcp support and support for native Syslinux functions syslinux_config(), syslinux_ipappend_strings() and syslinux_reboot().
isohybrid: Workaround for various EFI systems.
pxechn.c32, a PXE NBP chainloader. More versatile alternative to pxechain.com and resolves the PXELINUX -> WDS issue with Microsoft Windows Server 2008R2 (Gene Cumm).
btrfs: Fix booting off of a subvolume.
com32: Add device tree support.
SYSLINUX: Fix relative paths for VFAT. The CONFIG and APPEND directives now support entirely relative paths.


« Última modificación: 28-06-2013, 12:33 (Viernes) por lupox »

venturi

  • Visitante
Re: Re: has detectado una version nueva , ...avisanos.
« Respuesta #81 en: 20-07-2013, 11:18 (Sábado) »
El tvenlinux dice que se ha actualizado

Enviado desde mi GT-I9300 usando Tapatalk 2

jmgarcia

  • Visitante
Re: has detectado una version nueva , ...avisanos.
« Respuesta #82 en: 19-08-2013, 11:53 (Lunes) »
Actualizacion de wifite en

https://github.com/derv82/wifite

Gracias

Stenka

  • Visitante
Re:
« Respuesta #83 en: 16-09-2013, 00:32 (Lunes) »
Una pregunta, ya que actualizais la suite kde.. El kernel, porque no basar la distro en los paquetes de la rama current de slack en vez de en la obsoleta 14? Como xorg, mesa y sus drivers, etc...



Sent from my RM-821_eu_spain_435 using Tapatalk

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: Distro
« Respuesta #84 en: 16-09-2013, 00:34 (Lunes) »
Una pregunta, ya que actualizais la suite kde.. El kernel, porque no basar la distro en los paquetes de la rama current de slack en vez de en la obsoleta 14, Como xorg, mesa y sus drivers, etc...

No se exactamente los que me falatarn ,pero algunos ya estan actualizados.

si te refieres a los paquetes que aparecen como version de parches para reparar algun fallo , ... a dia de hoy los llevotodos,.


Si es que existe un current en el que actualizan mas cosas, pues lo mirare.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: has detectado una version nueva , ...avisanos.
« Respuesta #85 en: 16-09-2013, 02:04 (Lunes) »
acabo de añadir unas sources para slackware-current

y veo que efectivamente tengo cosas desactualizadas.


ahora a ver si soy capaz.

alist3r

  • Visitante
Re: has detectado una version nueva , ...avisanos.
« Respuesta #86 en: 16-09-2013, 12:54 (Lunes) »
olvidaros de syslinux para arrancar UEFI, de momento.
gummiboot lleva ventaja en este sentido y se parece mas al conocido grub

Desconectado lupox

  • Colaborador
  • *
  • Mensajes: 531
  • volver....
Re:
« Respuesta #87 en: 16-09-2013, 17:35 (Lunes) »
Tu sabrás, no lo conozco, pero en principio el syslinux era muy compatible con los dispositivos USB. Y a su vez con todas las diestros, no uefi.

Enviado desde Tapaltak 4

alist3r

  • Visitante
Re:
« Respuesta #88 en: 16-09-2013, 17:36 (Lunes) »
Tu sabrás, no lo conozco, pero en principio el syslinux era muy compatible con los dispositivos USB. Y a su vez con todas las diestros, no uefi.

Enviado desde Tapaltak 4

tambien lo era loadlin xD

PD: coñas aparte, tambien lo estoy explorando. pero se queda atrás, claramente!
« Última modificación: 16-09-2013, 17:38 (Lunes) por alister »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re:
« Respuesta #89 en: 19-09-2013, 05:06 (Jueves) »
Una pregunta, ya que actualizais la suite kde.. El kernel, porque no basar la distro en los paquetes de la rama current de slack en vez de en la obsoleta 14? Como xorg, mesa y sus drivers, etc...



Sent from my RM-821_eu_spain_435 using Tapatalk

peticion aceptada , la proxima iso de desarrollo , sera basad en current ... si puedo mañana mismo os la subo..,.que ya la tengo  ;D


se han actualizado cerca de 400 paquetes...  ^-^
« Última modificación: 19-09-2013, 05:06 (Jueves) por USUARIONUEVO »

Stenka

  • Visitante
Re:
« Respuesta #90 en: 19-09-2013, 11:39 (Jueves) »
Cojonudo, sobre todo para los que tienen Intel o graficas ati legacy...

Sent from my RM-821_eu_spain_435 using Tapatalk

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17429
  • Misántropo
Re:
« Respuesta #91 en: 24-09-2013, 16:45 (Martes) »
Cojonudo, sobre todo para los que tienen Intel o graficas ati legacy...

no le veo la relación ???

la rama legacy hace referencia a los productos antiguos a los que ya no se da soporte y no a los últimos modelos.

seria mas lógico que la versión mas actual del sistema que sea ya no incluya drivers de hardware obsoleto, así que creo que es mas mala que buena noticia para quien usa hardware del neolítico.


un saludo

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re:
« Respuesta #92 en: 24-09-2013, 19:15 (Martes) »
Cojonudo, sobre todo para los que tienen Intel o graficas ati legacy...

no le veo la relación ???

la rama legacy hace referencia a los productos antiguos a los que ya no se da soporte y no a los últimos modelos.

seria mas lógico que la versión mas actual del sistema que sea ya no incluya drivers de hardware obsoleto, así que creo que es mas mala que buena noticia para quien usa hardware del neolítico.


un saludo

no tiene por que ser asi , de hecho suele darse soporte a todo lo mas actual y a veces se dejan haredwrae mas viejo ...

es como lo de añadir un ID VENDOR , a un driver wifi ... o como los nv-driver y los nouveaua , los dos son para nvidia uno para viejas y otro para nuevas.

de todas formas creo que se refiere mas a algún tipo de bug o problema que hubiese en los drivers graficos , aunque no estoy al corriente ,por que no puedo leerlo todo ,  ;D

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17429
  • Misántropo
Re: has detectado una version nueva , ...avisanos.
« Respuesta #93 en: 26-09-2013, 11:22 (Jueves) »
los productos legacy son los que el fabricante ya ha dejado de desarrollar drivers para los sistemas operativos mas modernos o simplemente han dejado de producir.

mira en la web de Nvidia y en su gama legacy a ve si encuentras algo para windows 8 o 7.

o mira en Ubiquiti, o en AMD (ATI).

evidentemente cada uno es libre de meter en su distro lo que le plazca, pero si no se añade todo llegara un momento que las iso harán varios TB y lo que se va eliminado es sobre todo los drivers de los productos legacy.

windows 8 no incluye drivers de ningún producto lecacy, MacOS no incluye drivers para la mas del 70% de productos vigentes pues imagina los legay, Linux lo hace es simplemente por que no puede perderse esa cuota de mercado, los usuarios Linux que empiezan por aprovechar una maquina antigua son muchos, pero es Linux quien rompe la norma no los otros.

un saludo

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: has detectado una version nueva , ...avisanos.
« Respuesta #94 en: 26-09-2013, 11:37 (Jueves) »
Yo me he perdido algo ..

¿ quien ha dicho que se vayan a quitar drivers de nada ?

, el comentario del usuario que decia bien por intel o no se que, es por que precisamente es uno de esos drivers que siempre tiene bugs, y si se actualiza pues mejor que mejor.


y por el de ati , ( el free de linux xf86-driver-ati ) , por ese lo que ocurre, es que si no se actualiza no soporta las tarjetas nuevas, pero no por eso deja atras las que ya soportaba.


y aun a malas , siempre quedara vesa.

pero aqui nadie habla de quitar soporte de drivers..al reves.

joss

  • Visitante
Re: has detectado una version nueva , ...avisanos.
« Respuesta #95 en: 04-10-2013, 19:44 (Viernes) »
Creo que salio la versión 0.8 de ettercap:

The latest Ettercap release is: 0.8.0-Lacassagne
Release date: Sep 21, 2013

Citar
    Bug Fix
        !! Fixed some problems in fork and execve usage in case of command failure (sslstrip)
        !! Fixed dropping privileges for remote_browser plugin ran as root
        !! Fixed infinite loop when a http GET was issued on the attacker browser, while remote_browser was active
        !! Fixed some "atexit" bad references
        !! Fixed plugin load on text interface, if no number were entered
        !! Fixed problem spotted when ethtool wasn't installed on the machine
        !! Fixed old "ethereal" references
        !! Fixed missing newlines in printf
        !! Switching to ps2pdf as default (from ps2pdf13), it should point to ps2pdf14 on all distros
        !! Fix cmake file, dropped MACPORTS_BASE_DIRECTORY
        !! Fix problem in "stopping attacks" window not properly shown in gtk
        !! Fix problem in wrong pcap file saving
        !! Fix issue in send_udp function
        !! Fix problem in libnet rc detection
        !! Fix restore ip_forward by retrying up to 5 times
        !! Fix socket issues
        !! Fix for hex format display
        !! New send_tcp function, taking payload and length
        !! Fixed memory leak in remote browser plugin
        !! Fixed comparison bug in ec_decode
        !! Fixed UI input for GTK
        !! Fixed some memory leaks
        !! Fixed man pages and AUTHORS file
        !! Fixes in sslstrip plugin
        !! Many etter.dns fixes
        !! Many documentation fixes
        !! A ton of refactors/fixes in Cmake scripts
        !! Fix GTK crash when scanning hosts
        !! Fix build failure on Mac OS X 10.6
        !! Crash fix in target selection
        !! Disabled UID change for remote browser plugin
        !! Fixed remote browser plugin
        !! A ton of fixes in protocols and dissectors (dhcp, http, ppp, mpls)

    New Features
        + New ettercap logo
        + Renamed help menu to "?", to avoid double "H" shortcut
        + New WARN_MSG warning message
        + Added message in DHCP spoofing when no mitm has started
        + New horizontal scrollbar for messages in gtk view
        + Disabled offload warning messages (only in Release mode)
        + New ettercap-pkexec, policy and ettercap.desktop files for launching ettercap -G as a normal user with sudo privileges
        + Automatic host list refresh in GTK GUI after scanning
        + New fraggle plugin attack
        + New fields in etter.fields file
        + Cherry picked debian patches (svg icon)
        + Added content print on http dissector
        + Added support for negative dns replies
        + Creation of (experimental) unit tests
        + Creation of (experimental) libettercap
        + Now you can build just the ettercap library (libettercap) without any GUIs
        + Added travis-ci support
        + DNS spoofing for IPv6 addresses
        + PDF Docs generation is not optional
        + Added SRV query handling to DNS spoof
        + New mDNS spoof plugin
        + New low level decoders
        + New decoder for ip over pppoe
        + Added PPP DLT to interfaces
        + Add experimental Lua support to Ettercap
        + New Bundle libnet and curl
        + Full support for wifi decrypting (wep and wpa)

    Removed
        - Disabled update feature (not working anymore and not secure)
        - Deprecated napster dissector

Fuente:
Citar
http://ettercap.github.io/ettercap/downloads.html

Saludos

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: has detectado una version nueva , ...avisanos.
« Respuesta #96 en: 04-10-2013, 21:59 (Viernes) »
Gracias joss , en la iso del dia 2 ya esta actualizado..y   ;D

ing01

  • Visitante
Re: has detectado una version nueva , ...avisanos.
« Respuesta #97 en: 04-10-2013, 22:08 (Viernes) »
Gracias joss , en la iso del dia 2 ya esta actualizado..y   ;D

Gracias USUARIONUEVO


vk496

  • Visitante
Re:
« Respuesta #98 en: 01-11-2013, 13:27 (Viernes) »
Hola newuser, el lighttpd esta por la 1.4.33 El de la rc7 tiene bug de imagenes en base64, en la posterior supuestamente eso se arregla (no lo probe todavia)

Salu2

Enviado desde mi GT-I9505

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re:
« Respuesta #99 en: 02-11-2013, 11:24 (Sábado) »
Hola newuser, el lighttpd esta por la 1.4.33 El de la rc7 tiene bug de imagenes en base64, en la posterior supuestamente eso se arregla (no lo probe todavia)

Salu2

Enviado desde mi GT-I9505

creo que esa libreria la usaba el cazador cazado ....

actualizare a ver y si no hay problema pùes mejor.