Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
19-08-2017, 09:29 (S?bado)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.1 version final para descargar

Videos Downloader




  Mostrar Mensajes
Páginas: [1]
1  Equipos y materiales / Openwrt / Re: Migracion pepephone masmovil en openwrt (el diablo esta en los detalles) : 24-05-2017, 23:31 (Mi?rcoles)
Eso es lo que me faltaba a mí. En mi route sólo tenía la de local, no las otras. No sé qué me faltaba por configurar o qué hice mal. Lo que pasa es que ahora no puedo probarlo porque eso fue en casa de mi hermana, que la tiene alquilada y fui cuando pude a probar el router con open. En mi casa tengo otra conexión, así que no puedo volver a probarlo...

Sería de gran ayuda que pusieras los pasos a seguir para configurar la conexión desde cero (imagínate desde openwrt recién instalado), a modo de tutorial.

Y ya con eso sólo faltaría saber la forma en la que poder agradecértelo. Por cierto, qué router usaste? ¿tuviste que compiarle un archivo firmware del modem...?

Uso un TP-LINK TD-W8970 y postee la configuración inicial aqui,  hace un par de años,  uso el "imagebuilder" y actualmente es innecesario instalarle el "firmware" ya que todas las imagenes instalan debidamente el firmware, en mi caso seria dsl-vrx200-firmware-xdsl-a_05.08.01.08.01.06_05.08.00.0B.01.01_osc-1_mips_24kc.ipk  ello solito se instala sin pegas, en su dia era necesario bajarlo aparte pero ya es innecesario.

Hola!

He intentado configurar como comentas, pero no he tenido éxito. Mira, así es como lo tenía originalmente con mi intento:

Sabrías decirme qué he hecho mal? El option metric, desde LUCI no me salía. Desde que he cambiado el fichero a mano lo veo incluso en la pantalla del LUCI.

Gracias

Para empezar mis conocimientos son limitados, asi que te respondo de buena fe pero de entrada desconozco como pretendes conectarte,  asumo un adsl modo puente y router openwrt,  y de entrada hay un fallo evidente, la salida a internet eth0 esta asignada a dos vlan diferentes de diferente tipo switch_vlan y wan  tienen ambos eth0 como miembro de la red, ademas wan  tendras que permitir que sea la ruta por defecto. por probar dejaria tu archivo tal que:

Código:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth1'
option force_link '1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.0.1'

config interface 'wan'
option _orig_ifname 'eth0'
        option delegate '0'
option proto 'pppoe'
option ifname 'eth0.20'
option username 'adsl@masmovil'
option password 'masmovil'
        option metric '1488'


config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '5 6'


2  Equipos y materiales / Openwrt / Re: Migracion pepephone masmovil en openwrt (el diablo esta en los detalles) : 20-05-2017, 00:12 (S?bado)
Código:
po vale
[code]
root@TDW8970:/# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         10.1.1.2        0.0.0.0         UG    1488   0        0 pppoe-wan
10.1.1.2        *               255.255.255.255 UH    0      0        0 pppoe-wan
192.168.2.0     *               255.255.255.0   U     0      0        0 br-lan

ip externa e ip asignada a la interfaz wan

Código:
]root@TDW8970:/#  ip a ls dev pppoe-wan
12: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc hfsc state UNKNOWN qlen 3
    link/ppp
    inet 100.65.179.176 peer 10.1.1.2/32 scope global pppoe-wan
       valid_lft forever preferred_lft forever
root@TDW8970:/# wget -qO- http://ipecho.net/plain ; echo
139.47.14.xxx
[/code]
3  Equipos y materiales / Openwrt / Migracion pepephone masmovil en openwrt (el diablo esta en los detalles) : 19-05-2017, 21:12 (Viernes)
por sorprendente que parezca algo tan insultantemente facil me ha llevado un buen rato y me he atascado varias veces encima me he emperrado en chorradas como el ubr y el vlan id , por si  alguien ha tenido el mismo problema

extracto del archivo /etc/config/network correctamente configurado

Código:
config atm-bridge 'atm'
        option atmdev '0'
        option vci '32'
        option vpi '8'
        option unit '0'
        option payload 'bridged'
        option encaps 'llc'

config interface 'wan'
        option proto 'pppoe'
        option delegate '0'
        option username 'adsl@masmovil'
        option password 'masmovil'
        option ifname 'nas0.20'
        option metric '1488'

config dsl 'dsl'
        option annex 'a'
        option firmware '/lib/firmware/lantiq-vrx200-a.bin'
        option xfer_mode 'atm'

desde luci las claves son red>> interfaces>> wan>> conf avanzada>> metrica de la pasarela >>1488
y red >>interfaces>>wan >>conf fisica >> interfaz propio >> nas0.20

si usas openwrt como router neutro en lugar de nas0.20 usas el interfaz de salida +20 por ejemplo si wan usa eth3 entonces configuras como interfaz propio eth3.20

Lo que a mi me ha matado es la metrica de la pasarela, venga a cambiar la mtu de todo y no conseguia nada



4  Equipos y materiales / Openwrt / Re: [Duda] Prescindir de uci para configurarlo todo. : 16-11-2015, 03:46 (Lunes)
En realidad ese tipo de firm suele "arrejuntar" varios programas en un demonio de arranque "unico"  una especie de cajon desastre de un monton de cosas, que o bien lee su configuración de una particion aparte, en xml, (cualquier mtd de entre 32 y 128 k es candidato)  o alguna rareza particular.


Al contrario que el proyecto abierto, donde todo se modulariza y se separa en componentes minimos,  estos firm tienen un monoproceso.  Gente con talento suele encontrar enseguida sus puntos flacos, si te interesa el tema http://www.devttys0.com por ejemplo.
5  Equipos y materiales / Openwrt / Re: [Duda] Prescindir de uci para configurarlo todo. : 15-11-2015, 18:55 (Domingo)
uci no es mas que un pequeño ayudante que solo lee las configuraciones en texto plano de /etc/config lo modifica y recarga ciertos demonios al  cambiar las configuraciones. Instalado ocupa unos 8 Kb y ademas necesita ciertos programas del paquete base files, que son sobre otros 10 Kb. En total tratar de retirar uci es un ahorro  de unos 20 Kb, algo realmente pequeño. Y complicado por que muchos programas llaman a uci.

Luci es innecesario.

Si quieres no usarlo, editas los archivos de configuración de /etc/config a la antigua y listo, es lo que hago yo. Por que llevo tanto tiempo editando las configuraciones en archivos de texto plano que me aturullo con otras cosas.

Ya que mencionas libubox, forma parte del conjunto RPC (remote procedure call) que es el enlace correcto para funciones de programas fronted que es lo que entiendo quieres hacer, en el caso de luci usa lua via json-rpc
6  Equipos y materiales / Openwrt / Re: Cable Alargador Usb Activo : 06-09-2015, 22:51 (Domingo)
La costumbre cuando planteas "el usb no fuciona" es leerse los mesajes del kernel, un dmesg antes, enchufar el usb y un dmesg despues, las seis o siete lineas que añade el kernel indican si lo detecta y si existe algun problema. Si usas luci creo que hay un apartado donde leerlo.
Fallo mas comun:falta firmware, lo dice al enxhufar.

Apuesto por el siguiente fallo, sin ofender:
renombrado de dispositivo, al cargar un nuevo dispositivo le asigna un nombre nuevo, o wlan0  o wifi0,  y no lo has configurado.

El alargador, copiate las lieas tras enchufarlo a ver.
7  Equipos y materiales / Openwrt / Re: Problemas estabilidad usb con ALFA AWUS036NHA (AR9271) : 29-08-2015, 04:10 (S?bado)
Hola,  yo lo que haria seria pasar los siguientes parametros al  kernel, al arranque o con modprobe
Código:
options ath9k ps_enable=0 nohwcrypt=1  blink=0

que viene a ser, deshabilitar el ahorro de energia, el descifrado via hardware y  el parpadeo del led.  tal como indican los autores https://github.com/qca/open-ath9k-htc-firmware/wiki/usb-related-issues el falllo podria ser ua mezcla entre firm defectuoso, host  usb que no le da potencia etc. Asi que lo del cable doble ese tiene bastante sentido.  Pero prueba primero a ver si deshabilitando alguna de las funciones tradicionalmente "problematicas" (hwcrypt) deja de fallar.
 
8  Equipos y materiales / Openwrt / Re: Problema de MTU en algunos routers de Movistar o es problema de OpenWRT ? : 26-08-2015, 12:55 (Mi?rcoles)
flo basico va bien,(yo no tengo ipv6 por eso falla)
Código:
ping -4 www.catgenie.es
PING www.catgenie.es (217.126.185.215): 56 data bytes
64 bytes from 217.126.185.215: seq=0 ttl=116 time=62.884 ms
64 bytes from 217.126.185.215: seq=2 ttl=116 time=82.901 ms
64 bytes from 217.126.185.215: seq=4 ttl=116 time=116.382 ms
64 bytes from 217.126.185.215: seq=5 ttl=116 time=138.075 ms

ping -6 www.catgenie.es
PING www.catgenie.es (2001:470:1f09:495::3): 56 data bytes
ping: sendto: Permission denied

resolución de nombres
Código:
dig @4.2.2.1 catgenie.es any

; <<>> DiG 9.9.5-11-Debian <<>> @4.2.2.1 catgenie.es any
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32548
;; flags: qr rd ra; QUERY: 1, ANSWER: 10, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 8192
;; QUESTION SECTION:
;catgenie.es.                   IN      ANY

;; ANSWER SECTION:
catgenie.es.            172495  IN      A       217.126.185.215
catgenie.es.            172495  IN      NS      dns1.consulintel.es.
catgenie.es.            172495  IN      NS      dns1.consulintel.com.
catgenie.es.            172495  IN      NS      dns2.consulintel.es.
catgenie.es.            172495  IN      NS      dns2.consulintel.com.
catgenie.es.            172495  IN      SOA     dns1.consulintel.es. dnsadmin.consulintel.es. 2015081500 43200 7200 2419200 10800
catgenie.es.            172495  IN      MX      30 mail.consulintel.es.
catgenie.es.            172495  IN      MX      10 mail.consulintel.com.
catgenie.es.            172495  IN      TXT     "v=spf1 mx ~all"
catgenie.es.            172495  IN      AAAA    2001:470:1f09:495::3

;; Query time: 79 msec
;; SERVER: 4.2.2.1#53(4.2.2.1)
;; WHEN: Wed Aug 26 12:51:39 CEST 2015
;; MSG SIZE  rcvd: 301

9  Equipos y materiales / Openwrt / Re: Ddns no actualiza : 30-07-2015, 01:55 (Jueves)
por comentarlo, yo me volvi medio tonto intentando configurar una actualización con name***.

Mi fallo fue permitir usar "wget" que lleva por defecto el busybox. la actualización se hace con https , que no esta soportado, y si instalas el otro falla tambien por no tener certificados validos que verificar.

En caso de ser eso, se puede solucionar instalando curl + ca-certificates, o modificando el script para darle una opcion extra al wget (--no-check-certificate)  otras soluciones son posibles, desde instalar el .pem hasta actualizarlo de otro modo.
10  Equipos y materiales / Openwrt / Re: Velocidad lenta USB, ExFat en OpenWrt : 16-06-2015, 18:20 (Martes)
primero exfat funciona perfectamente, y me gustaria matizar eso de ntfs va mal por que openwrt es linux, no, va mal por que es una puta mierda de sistema de archivos y va mal en linux por que esta pesimamente documentado.

Segundo, veo que a pesar de  marcar el punto de montaje bien en la parte superior de la captura que mandas, en la parte baja cuando señala el uuid del dispositivo marca un ?.

Diria que tienes algun error en el fstab, revisa /etc/config/fstab (te bajas una copia de la configuracion y alli lo tendras) apostaria un euro a que tienes duplicado el montaje, una vez con dispositivo (/dev/sda1) otra con uuid o algo asi (o con etiqueta, label)
11  Equipos y materiales / Openwrt / Re: [Tutorial] OpenWRT Image Builder para Archer C5 y otros con CentOS : 03-06-2015, 23:03 (Mi?rcoles)
Unas puntualizaciones:

El paquete "imagebuilder" que sugieres, la version trunk, se genera cada dia automaticamente, y el archivo comprimido bz2 pesa unos seiscientos megas por que lleva incluido los paquetes ipk ya metidos, por lo tanto al dia siguiente se contruira automaticamente uno nuevo que incluira los pequeños cambios del kernel o cosas asi, por lo tanto al tener ya los paquetes y al cambiar a diario mi personal opinión es que si se usa trunk no incluir los repositorios externos, quedando el repositories.conf
Código:
src imagebuilder file:packages
sin mas. Si no en pocos dias falla mas que una escopeta de feria. Si se usa cualquier versión mas estabilizada, un release candidate, ya el paquete de bajada es de apenas cien megas y opino que en ese caso si se debe usar los repositorios externos.

Cuando empiezas a actualizar relativamente a menudo  si guardas configuraciones te evitas volver a poner la misma puñetera clave para el wifi, via luci  vas a "grabar firmware copia de seguridad" y el archivo lo desempaquetas en files o bien bajas directamente los tres o cuatro archivos desde el router (asumiento que estas en el directorio del imagebuilder)
Código:
mkdir -p files/etc/config
scp root@192.168.1.1:/etc/config/network files/etc/config/

Y añades
Código:
make image  FILES=files/ el_resto_de_la_parrafada_muy_gorda

De forma que despues de grabar te queda configuradito que es una gozada.

Añadir que en el shell se puede añadir el chirimbolo "\" para romper lineas largas

Código:
make image PROFILE=ARCHERC5 PACKAGES="kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev \ (le doy a enter y sigo)
 kmod-ath10k kmod-fs-ext4 kmod-fs-ntfs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
kmod-usb-storage block-mount uci lua bird4 kmod-bridge kmod-ipt-nathelper-rtsp mcproxy \
kmod-tun luci luci-lib-ip luci-lib-nixio

lo que facilita poner toda la parrafada bien.

Sirvan estas puntualizaciones como el pulido final de un buen tuto, no como critica.
12  Equipos y materiales / Openwrt / Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518) : 04-03-2015, 20:29 (Mi?rcoles)
Hola, acabo de instalar el openwrt a un ARV4518 y funcionando sin problemas. Mi desilusion viene por el hecho de que me doy cuenta que despues de instalar lo básico, lo que venia de serie, es de decir ADSL, interface web y USB, no queda espacio para nada más...

En concreto ha instalado la compilación creada por medber de pero me queda muy poquito espacio y no de deja instalar samba.

- Habria alguna posibilidad de instalar ADSL, Luci, DDNS, y Samba o me olvido del tema.
- He visto compilaciones en las que se instala USB, pero no Samba, por ejemplo la que yo he instalado. Mi pregunta es y disculpad mi torpeza, ¿que utildad tiene eso? quiero decir como se accede desde cualquier dispositivo a lo que tengas pinchado sin haber un servidor de por medio.

Instalas un pincho usb, instalas otros programas en el pincho, por ejemplo samba. un extroot de los de toda la vida vamos.  no te entra usb+otras cosas y empiezas por acceder al usb. Por otro lado mucha gente no usamos samba ni que nos paguen, talibanismo radical contra protocolos ponzoñosos de la wintendo. los ficheros por sftp, ftp, usando el servidor web, etc.
13  Equipos y materiales / Openwrt / Re: Apache en Openwrt - Solucionar acceso local y remoto (httpd close_wait) : 12-02-2015, 01:30 (Jueves)
Nuevamente sin saber exactamente que puede ser, yo haria:

tras iniciar, paro y reinicio apache mediate init
Código:
/etc/init.d/apache stop
/etc/init.d/apache start

Si arranca es que inicia demasiado prontro, pasalo a START=97  por ejemplo, o añade al script algo como sleep 20
Código:
start() {
echo launch apache
# commands to launch application
                sleep 20
apachectl start
}

que no arranca, el eterno problema de permisos, apache arranca con un usuario y grupo realmente muy limitados y linux es particularmente picajoso en impedir que un programa con permisos limitados acceda a los directorios, en realidad eso es bueno pero a veces te hace la pascua,  lista el document root
Código:
ls -la /usr/share/htdocs
ls -la /usr/share
y verifica propietario y grupo y permisos del listado
Código:
drw-r--r--   1 root root      blablabla /usr/share/htdocs
eso es, dueño root, grupo root, las letras son la clave la primera d es directorio, y luego en grupos de tres usuario grupo y resto del mundo, es decir el usuario tiene permiso de lectura r escritura w pero no ejecucion - el grupo solo lectura y el restolmundo solo lectura.

Antes has usado chmod para darle permiso de ejecucion , de ser ese el problema o bien das permisos generales o cambias el grupo del directorio o  cambias el usuario y grupo en el que se inicia apache en httpd.conf Chmod y chown son tus amigos.
14  Equipos y materiales / Openwrt / Re: Apache en Openwrt - Solucionar acceso local y remoto (httpd close_wait) : 11-02-2015, 17:00 (Mi?rcoles)
Hola, no se que puede ser pero yo te digo lo que haria,

paro el apache
Código:
apachectl stop
corrigo las comillas (o las dos o ninguna) de tu httpd.conf
Código:
ServerRoot "/usr/share/htdocs

cambio el nombre de la maquina  de nuevo en httpd.conf
Código:
ServerName subdominio.no-ip.org:83
por
Código:
ServerName 192.168.1.10:83

no recuerdo si era necesario poner el puerto, por supuesto que sea la ip de tu maquina, finalmente cambiaria
Código:
LogLevel debug
por
Código:
LogLevel error

por que es mas que evidente que ni has mirado el log haciendo un
Código:
cat /var/log/error_log
que lo pondran para algo, luego inicias
Código:
apachectl start
e intentas acceder, si lo permite, tienes un error de resolucion o dns o ruta, seria configurar debidamente el hostame de tu maquina, si es que no, pues lee el log a ver, que siempresd es buena idea.


Y para la proxima puedes recortar el tochaco que has pegado faciendo
Código:
grep -v '#' /etc/apache/httpd.conf
que te deja solo las opciones activas y es mas facil de leer para ayudarte a desfacer el entuerto.
15  Equipos y materiales / Openwrt / Re: Modulos del kernel en memoria : 11-02-2015, 16:09 (Mi?rcoles)
      En mi modesta  opinion si, udev es "mas mejor" que hotplug, systemd es mejor que init, y dbus es mejor que ubus,  el tema es que openwrt esta pensada para dispositivos limitaditos, y en ese entorno de recursos limitados,  pues es una mejor eleccion esos demonios "mini" que rondan el mega de memoria entre todos en vez de los demonios maxi que rondaran entre cinco y diez entre todos.

Y por cierto diria que openwrt ha migrado de hotplug a procd, un demonio propio.
16  Equipos y materiales / Openwrt / Re: Modulos del kernel en memoria : 07-02-2015, 12:29 (S?bado)
El hecho de que lsmod informe de que un modulo  depende de 0 modulos es irrelevante sobre su uso.

En tu caso por ejemplo de b43 dependen 0 modulos pero es el controlador wifi. lsmod lee /proc/modules y lo lista, y salvo soporte para impresora usb o algo asi casi todo lo que tienes es perfectamente normal.
17  Equipos y materiales / Openwrt / Re: Mantenimiento de paquetes de OpenWrt : 31-10-2014, 03:26 (Viernes)
Veo que quizas no has entendido  como  funciona lo de de las versiones, asi que breve guia para versionado en sistemas abiertos:

El firmware que usas, nombre en codigo "barrier breaker"  esta congelado,  es estable y esta probado. Solo se actualizan los fallos de seguridad, y opcionalmente se puede  traer algun paquete mas nuevo o que incluya una funcion interesante (un backport) por lo demas funciona y no se toca.

 Mientras tanto todos los paquetes, el nucleo, la forma de configurar se actualizan repetidamente una vez al dia se realizan compilaciones automaticas con todas las actualizaciones hasta ese dia, para probarlas. Ese tipo de compilaciones son  algo inestables, o pueden incluir algun fallo evidente de seguridad. En openwrt la version en desarrollo se llama "Chaos Calmer" si lo compilas tendras un numero de revision por ejemplo r43100 se usa para poder echar hacia atras algun cambio que impida compilar o algo asi. No es aconsejable si no te manejas un poquito con el tema, pero yo mismo empece  con cosas asi  en su dia y hace dos semanas que uso openwrt y la r es la revision que uso actualmente, eso si,  si de repente me falla no me veras quejarme. Si encuentro algun fallo es de buen gusto mandar el debido bug.

De aqui a x tiempo, se estabilizara el sistema entero, una "congelación" se iran sacando releace candidates "candidatos a version estable" de todo el sistema y se puliran los pequeños fallos tras varias release candidates rc1 rc2 etc se declarara estable y es entonces, no antes cuando un usuario un poquito verde deberia cambiar su firm.

     Si vienes de windows, con eso de actualizar  segun publican  un exe en a saber que pagina o te carga las actualizaciones, puede que te confunda la forma de hacer,  pero en estas cosas si no se ha detectado un fallo de seguridad que necesite ser solucionado, o algo asi, tu paquete y tu firm esta perfectamente actualizado a la ultima version estable.
18  Equipos y materiales / Openwrt / Re: Como saber si ddns-scripts se esta ejecutando cada X horas? : 29-10-2014, 10:27 (Mi?rcoles)
Yo acabo de instalar un open wrt, asi que te digo como se hace "a la antigua" es posible que haya una forma mas correcta de hacerlo.

Te conectas por ssh al router en cuestion,  y verificas si que tienes en marcha:
Código:
:~#ps
los procesos entre corchetes son modulos del kernel, buscas si tienes algo como
Código:
/bin/sh /usr/lib/ddns/dynamic_dns_updater.sh blabla 0

que no lo tienes, pues miramos la configuracion  si esta todo debidamente configurado
Código:
:~#cat  /etc/config/ddns

tendras una seccion global
Código:
config ddns 'global'
        option date_format '%F %R'
        option log_lines '250'

y una seccion con tu servicio particular
Código:
config service 'por ejemplo duckdns'
        option service_name '
        option domain
        option username
        option password
        option use_logfile '1'
        option interface 'wan'
        option enabled '1'

le decimos que active el servicio, que escupa al syslog, y que nos de al maximo detalle que esta haciendo, y arrancamos el servicio a ver que pasa, y tras darle unos segundos nos leemos el log a ver que tripa se le ha roto

Código:
uci set ddns.duckdns.enabled=1 #el nombre que tenga tu servicio sera diferente
~#uci set ddns.duckdns.use_syslog=1 #luego lo pones a 4 para que no de tantos mensajes
~#uci set ddns.duckdns.use_logfile=1
~#uci commit
~#/etc/init.d/ddns start
~#logread
bla bla bla
2014 user.info ddns-script main loop noseque
2014 user.notice ddns-scripts otro rollo

el fallo mas habitual es que no tiene ni wget ni curl instalado, y el wget del busybox no funciona bien. se soluciona instalando wget, pero en el log te indicara bastante precisamente donde falla. Otro fallo que he tenido yo es , con curl, no tener el certificado de la web para https.

luego habilitas el servicio al arranque

Código:
#/etc/init.d/ddns enable
y pista.
19  Equipos y materiales / Openwrt / Re: tplink tdw8970 probando openwrt, comentarios sobre la eleccion de annex etc. : 26-10-2014, 02:46 (Domingo)
Por si le sirve de ayuda a alguien;

Al haber incluido tando el firmware vdsl como los modulos ptm del kernel, intenta conectarse mediante vdsl al dslam. No vale ni la contraseña ni nada, un fallo de lo mas tonto.

Código:
network.atm=atm-bridge
network.atm.encaps=llc
network.atm.payload=bridged
network.atm.vpi=0
network.atm.vci=33
network.atm.unit=0
network.wan=interface
network.wan.username=pepephone@pepephone
network.wan.password=pepephone
network.wan.proto=pppoe
network.wan.ipv6=0
network.wan.ifname=nas0
network.dsl=dsl
network.dsl.annex=a
network.dsl.firmware=/lib/firmware/vdsl.bin
network.dsl.tone=av
network.dsl.xfer_mode=atm

Cambiando el network.dsl.xfer_mode de ptm (vdsl) a atm (adsl) todo va bien.  se arranca el puente
Código:
/etc/init.d/br2684ctl start
y se configura para que inicie siempre
Código:
/etc/init.d/br2684ctl enable

y enlaza "chachi". . Por si a algien le pasa como a mi.

20  Equipos y materiales / Openwrt / tplink tdw8970 probando openwrt, comentarios sobre la eleccion de annex etc. : 21-10-2014, 13:12 (Martes)
Hola cuadrilla, quiero poner  el router a funcionar con adsl "nasional" que viene a ser annex a,  y me he encontrado con algun problemilla.

  Me bajo el "sysupgrade" oficial , me conecto por la consola de serie, paro el arranque del uboot y tftboot  
Código:
VR9 #  tftpboot 0x80800000 openwrt-lantiq-xrx200-TDW8970-sysupgrade.image
patapum y te termina diciendo cuanto ocupa en hexadecimal algo como 330f93
Código:
VR9 #sf erase 0x20000 0x7a0000
laminamos el firm actual
Código:
VR9 # sf write 0x80800000 0x20000 0x330f93
que viene a ser, escribe eso que has guardao en la memoria desde la direccion 0x80800000 empieza despues del uboot 0x20000 y termina en todo lo grande que es la imagen que es el numero que nos ha dado al subirla con su 0x de antemano
Código:
VR9 # setenv bootargs 'board=WD8970'  
y terminamos añadiendo a la linea de arranque el parametro para el kernel device tree, que no tardara en usarse.


Reinicio y el openwrt esta un ratico con sus cosas, formateando lo libre y tal, y al de un rato ya me logeo, y bien,  no adsl. Problema, falta el firmware. tiene una utilidad para bajarlo, pero es "annex b". Pues nada me bajo en https://downloads.openwrt.org/barrier_breaker/14.07/lantiq/xrx200/OpenWrt-ImageBuilder-lantiq_xrx200-for-linux-x86_64.tar.bz2 el generador de imagenes, muy apañao, me bajo algunos firm para el adsl https://github.com/danielschwierzeck/firmware-lantiq y en el directorio donde voy a crear la imagen meto todos en files/lib/firmware/ luego ya veremos cual resulta, los ire probando todos.

pues nada
Código:
joseba:~/src/opw$ make image PROFILE=TDW8970 FILES=files/
Muy bien, me hace una imagen, me mete los firms dentro y hago el sysupgrade. Mecaguen todo no he incluido web de configuracion y me pide modulos del kernel que no estan. para el annex a. Hijos de perkins, han dejado la configuracion por defecto para los annex b. pues nada,
Código:
joseba:~/src/opw$ make image PROFILE=TDW8970  PACKAGES="kmod-ltq-ptm-vr9 ppp-mod-pppoe uboot-envtools\
 swap-utils usbutils mount-utils iwinfo luci-base luci-mod* uhtpdd* " FILES=files/

y como el viaje anterior no puse web, pues el upgrade en linea de comandos, como dios manda.

volvemos a arrancar, y ala,  cambiando las variables con uci, pues sigo sin tener web. modifico vpi vci meto nombre y usuario, configuro para que carge un firmware de los que tengo en /lib/firmware y el tema queda mas o menos
Código:
network.atm=atm-bridge
network.atm.encaps=llc
network.atm.payload=bridged
network.atm.vpi=0
network.atm.vci=33
network.wan=interface
network.wan.ifname=nas0
network.wan.proto=pppoe
network.wan.ipv6=1
network.wan.username=pepephone@pepephone
network.wan.password=pepephone
network.wan6=interface
network.wan6.ifname=@wan
network.wan6.proto=dhcpv6
network.dsl=adsl
network.dsl.tone=av
network.dsl.xfer_mode=ptm
network.dsl.firmware=/lib/firmware/dsl_vr9.bin
network.dsl.annex=a2
y sincroniza perfetisimamente, con un snr bueno, pero no se asigna ip, ya no se si es que me falta algun parametro o, lo mas probable, atm o pppoe esta mal configurados. Como ya me ha entrado un perrenque lo dejo, mañana revisare todo, si alguno tiene una idea pues ala, soltarla. Yo antes no era tan inutil.

Notas: Cuando era joven y atrevido apañaba cables de nokia para conectar a placas, ahora uso modulos usb http://www.amazon.es/RHX-PL2303-convertidor-autom%C3%A1tico-adaptador/dp/B00DEWBB4K/ref=aag_m_pw_dp?ie=UTF  o http://www.amazon.es/cp2102-serial-convertidor-m%C3%B3dulo-pines/dp/B00AFRXKFU/ref=sr_1_1?ie=UTF8 que por tres euris te hacen el apaño, pero hoy me he dado cuenta que algunos tienen la señalizacion incorrecta, tx en lugar de rx. y he tardado un rato hermoso y me he cagado hasta en ... de lo torpon que ando. La ventaja de esos modulos es que reconectando pines puede alimentar los 3,3v de la placa si intentas forzar el modo uart.
Compro y sueldo pines a la placa, por un lado tx y rx, los dos juntos, y luego busco por la placa mas "tierras"  donde me resulte comodo, (bujeros que pone gnd) rasco bien con lija,  y sueldo, como tengo un pulso asi asi al no juntar muchos sueldes a la vez mejoro el resultado. un cepillo de dientes, aguita con jabon y secarlo bien, y niquelado. una tira de pines acodados me sale por menos de un euro, flux y estaño unos tres, y el soldador no se como andara ahora, pero por menos de 10 habra alguno, asi que merece la pena.

Páginas: [1]


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums