Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
22-01-2018, 20:54 (Lunes)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.1 version final para descargar

Videos Downloader




  Mostrar Mensajes
Páginas: [1] 2 3 4 5 6 ... 24
1  Equipos y materiales / Openwrt & LEDE / Re: Mesh en openwrt : Ayer a las 23:28
Hay una lista de chips compatibles con mesh aquí: https://wikidevi.com/wiki/Wireless_adapters/Chipset_table


Mis pruebas:

- HG556a tipo B (Atheros). Compatible con Mesh. Como nada más que tengo dos, no he podido montar una verdadera red. Pocas pruebas he podido hacer, pero se ve que funcionan.

- HG556a tipo C (Ralink). Monta un chip RT3062F incompatible con Mesh.

- HG553. Incompatible a pesar de tener un chip Broadcom 4318, en teoría compatible.

- AR-5387un. Con un chip BCM43225 tenía que haber funcionado con el driver b43. Pero no.

- También he probado un par de pinchos wifi con chips RT2870 y RT2571W a sabiendas que no soportaban Mesh.

Saludos.
2  Equipos y materiales / Openwrt & LEDE / Re: Mesh en openwrt : 20-01-2018, 14:21 (S?bado)
¡FUNCIONANDO!

ESQUEMA


Para configurar los routers, he adaptado la receta https://wiki.openwrt.org/doc/recipes/bridgedap. Al Mesh AP, le he añadido un pincho inalámbrico como segundo radio.

MESH PORTAL, IP 192.168.1.3 (Router HG556a B)
- Instalar LEDE.
- Eliminar paquete wpad-mini (opkg remove wpad-mini).
- Instalar paquetes wpad y authsae (opkg install wpad authsae).
- Fichero /etc/config/network (éste es el mío completo):
Citar
config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config globals 'globals'
   option ula_prefix 'fd35:6f7c:0e37::/48'

config interface 'lan'
   option type 'bridge'
   option ifname 'eth0.1'
   option proto 'static'
   option netmask '255.255.255.0'
   option ip6assign '60'
   option ipaddr '192.168.1.3'
   option gateway '192.168.1.2'
   option dns '192.168.1.2'

config switch
   option name 'switch0'
   option reset '1'
   option enable_vlan '1'

config switch_vlan
   option device 'switch0'
   option vlan '1'
   option ports '0 1 2 3 5t'

- Fichero /etc/config/wireless (éste es el mío completo):
Citar
config wifi-device 'radio0'
   option type 'mac80211'
   option channel '1'
   option hwmode '11ng'
   option path 'pci0000:00/0000:00:01.0'
   option htmode 'HT40'

config wifi-iface
   option device 'radio0'
   option mode 'mesh'
   option network 'lan'
   option ssid 'Nodo 1'
   option mesh_id 'mi-red-mesh'
   option encryption 'authsae'
   option key 'MiClaveSuperSecreta'

- Deshabilitar dnsmasq
Código:
root@LEDE:~# /etc/init.d/dnsmasq disable

- Y aplicar los cambios.
Código:
root@LEDE:~#  wifi

MESH AP, IP 192.168.1.4 (Router HG556a B con pincho USB DWL-G122)
- Instalar LEDE.
- Eliminar paquete wpad-mini (opkg remove wpad-mini).
- Instalar paquetes wpad y authsae (opkg install wpad authsae).
- Fichero /etc/config/network, sección "config interface lan":
Citar
config interface 'lan'
   option type 'bridge'
   option ifname 'eth0.1'
   option proto 'static'
   option ipaddr '192.168.1.4'
   option gateway '192.168.1.2'
   option dns '192.168.1.2'
   option netmask '255.255.255.0'
   option ip6assign '60'

- Fichero /etc/config/wireless, (el mío completo es así):
Citar
config wifi-device 'radio0'
   option type 'mac80211'
   option channel '1'
   option path 'pci0000:00/0000:00:01.0'
   option htmode 'HT20'
   option country '00'
   option hwmode '11g'

config wifi-iface
   option device 'radio0'
   option mode 'mesh'
   option network 'lan'
   option ssid 'MESHPOINT'
   option mesh_id 'mi-red-mesh'
   option encryption 'authsae'
   option key 'MiClaveSuperSecreta'

config wifi-device 'radio1'
   option type 'mac80211'
   option channel '11'
   option hwmode '11g'
   option path 'platform/ehci-platform/usb1/1-2/1-2:1.0'

config wifi-iface
   option device 'radio1'
   option mode 'ap'
   option network 'lan'
   option ssid 'MESHAP'
   option encryption 'psk2'
   option key 'ClaveWifi'

- Deshabilitar dnsmasq
Código:
root@LEDE:~# /etc/init.d/dnsmasq disable

- Y aplicar los cambios.
Código:
root@LEDE:~# wifi
3  Equipos y materiales / Openwrt & LEDE / Re: Mesh en openwrt : 20-01-2018, 11:50 (S?bado)
@Fitch. Estás preguntando justo por el siguiente reto pendiente, que son los nodos Mesh Portal.
Supongo que habrá que establecer un puente entre la interfaz cableada y la inalámbrica y configurar el enrutado y el cortafuegos. Es cuestión de ponerse, a ver si lo logramos.


Otra cosa. Sólo tengo dos HG556a con atheros, asi que no he podido averiguar cómo se comportan los Mesh Points cuando hay más de dos . ¿Se establecerá múltiples conexiones entre ellos?


Otra cosa más que ma gustaría comprobar. Supongamos dos Mesh Points tan distantes (Nodo 1 y Nodo 3) que no hay conectividad entre ellos. ¿Un nodo intermedio (Nodo 2) los conectaría sin que haya que configurar nada más?
4  Equipos y materiales / Openwrt & LEDE / Re: Mesh en openwrt : 19-01-2018, 21:08 (Viernes)
Después de algunas pruebas fallidas con HG553, he conseguido conectar dos nodos tipo Mesh Point montados sobre dos routers HG556a tipo B (Atheros) con LEDE 17.01.4.
FUENTE: https://wwwvs.cs.hs-rm.de/vs-wiki/images/9/9a/11sMesh_SoHoRoutern_OpenWRT.pdf

Partimos de un router router principal con conexión a Internet e IP estática 192.168.1.2. Este router no forma parte de la red Mesh.

Instalación del primer nodo Mesh Point:
- Conectar el router por cable al router principal.
- Instalar LEDE.
- Ponerle IP estática 192.168.1.3, puerta de enlace 192.168.1.2 y DNS 192.168.1.2.
- Eliminar el paquete wpad-mini e instalar los paquetes wpad y authsae.
- Crear una interfaz inalámbrica en modo mesh sobre el radio0 (editar fichero /etc/config/wireless).
Citar
config wifi-iface
   option device 'radio0'
   option mode 'mesh'
   option network 'interfaz_mesh'
   option ssid 'Nodo 1'
   option mesh_id 'mi-red-mesh'
   option encryption 'authsae'
   option key 'MiClaveSuperSecreta'

- Configurar la interfaz inalámbrica recién creada (editar fichero /etc/config/network).
Citar
config interface 'interfaz_mesh'
   option proto 'static'
   option netmask '255.255.255.0'
   option ipaddr '192.168.88.3'

Instalación del segundo nodo Mesh Point:
- Conectar el router por cable al router principal.
- Instalar LEDE.
- Ponerle IP estática 192.168.1.4, puerta de enlace 192.168.1.2 y DNS 192.168.1.2.
- Eliminar el paquete wpad-mini e instalar los paquetes wpad y authsae.
- Crear una interfaz inalámbrica en modo mesh sobre el radio0 (editar fichero /etc/config/wireless).
Citar
config wifi-iface
   option device 'radio0'
   option mode 'mesh'
   option network 'interfaz_mesh'
   option ssid 'Nodo 2'
   option mesh_id 'mi-red-mesh'
   option encryption 'authsae'
   option key 'MiClaveSuperSecreta'

- Configurar la interfaz inalámbrica recién creada (editar fichero /etc/config/network).
Citar
config interface 'interfaz_mesh'
   option proto 'static'
   option netmask '255.255.255.0'
   option ipaddr '192.168.88.4'

No olvidar levantar la wifi cada vez que se cambia el fichero /etc/config/wireless.

Las interfaces de ambos routers quedan conectadas inalámbricamente, respondiendo al ping de la otra.

Código:
root@LEDE:~# ping -I 192.168.88.3 192.168.88.4
PING 192.168.88.4 (192.168.88.4) from 192.168.88.3: 56 data bytes
64 bytes from 192.168.88.4: seq=0 ttl=64 time=5.308 ms
64 bytes from 192.168.88.4: seq=1 ttl=64 time=2.116 ms
64 bytes from 192.168.88.4: seq=2 ttl=64 time=5.304 ms



Queda pendiente:
- Nodo tipo Mesh Portal (bridge LAN-MESH).
- Nodo tipo Mesh AP (bridge MESH-AP).

Saludos.
5  Equipos y materiales / Openwrt & LEDE / Re: Mesh en openwrt : 18-01-2018, 20:13 (Jueves)
Comando para determinar si nuestro router soporta el modo Mesh (802.11s):
FUENTE: https://wiki.openwrt.org/doc/howto/mesh.80211s
Código:
iw list
Hay que mirar que en la sección "Supported interface modes:" aparezca la línea "* mesh point"

HG556a (version B)
Citar
Supported interface modes:
         * IBSS
         * managed
         * AP
         * AP/VLAN
         * WDS
         * monitor
         * mesh point
         * P2P-client
         * P2P-GO

HG553:
Citar
Supported interface modes:
         * IBSS
         * managed
         * AP
         * AP/VLAN
         * monitor
         * mesh point


6  Equipos y materiales / Openwrt & LEDE / Re: Mesh en openwrt : 18-01-2018, 18:42 (Jueves)
@eduperez. Efectivamente, el problema se puede resolver cableando varios APs, todos con el mismo SSID, misma encriptación, misma contraseña, distintas IPs dentro de la misma subred, y distintos canales no solapables. Muy importante no solapar canales: El mito de los once canales. Pero de esto ya se ha hablado en en algún qué otro post.

O también se podría utilizar el tema de la ampliación de la cobertura y de la itinerancia como simple pretexto para aprender y compartir conocimientos sobre tecnología Mesh en LEDE, de la que tan poca información hay en Internet.
7  Equipos y materiales / Openwrt & LEDE / Re: Mesh en openwrt : 16-01-2018, 23:47 (Martes)
Sin tener un objetivo claro, estuve siguiendo sin éxito este post https://www.gl-inet.com/forums/topic/simple-802-11s-meshing/.

Ahora me he centrado en montar un nodo tipo Mesh Portal en un router HG553 con LEDE. Por un lado irá cableado al router principal (ISP) y por otro irá conectado inalámbricamente a futuros nodos Mesh (ya veremos si Mesh Point o Mesh AP).
8  Equipos y materiales / Openwrt & LEDE / Re: Mesh en openwrt : 16-01-2018, 23:40 (Martes)
He  estado enredando con tres HG553 y LEDE, pero tampoco he conseguido nada.

Para facilitar las cosas a futuros participantes en el post, creo que es interesante dejar claro qué se quiere consequir. Básicamente, se trata de utilizar más de un AP para dar cobertura de calidad a una zona wifi utilizando topología Mesh (en la que los nodos de infraestructura se interconectan directa, dinámica y no jerárquicamente a tantos nodos como sea posible y cooperan entre sí para enrutar datos de manera eficiente desde / hasta los dispositivos cliente). https://en.wikipedia.org/wiki/Mesh_networking

Una red wifi tradicional está formada por varios APs conectados por cable a la red principal. La cobertura inalámbrica se expande añadiendo nuevos APs que habrá que cablear hasta la red principal.

Imágen tomada de http://www.ieee802.org/802_tutorials/06-November/802.11s_Tutorial_r5.pdf, diapositiva 7.

Una red Mesh también está formada por uno o más APs conectados por cable a red principal. A difertencia de la red wifi tradicional, la cobertura inalámbrica se expande añadiendo nuevos APs conectados inalámbricamente a los nodos ya existentes. La red Mesh se autogestiona buscando la ruta más eficiente en cada momento.

Imágen tomada de http://www.ieee802.org/802_tutorials/06-November/802.11s_Tutorial_r5.pdf, diapositiva 19.

En una red Mesh coexisten nodos de tres tipos: Mesh Portal, Mesh Point y Mesh AP.
9  Equipos y materiales / Openwrt & LEDE / Re: Mesh en openwrt : 14-01-2018, 18:10 (Domingo)
La configuración de Fitch es parecida a la que se explica en este post: Ampliar la cobertura Wi-Fi con dos routers conectados por cable. Es una configuración que yo personalmente he probado y puedo decir que funciona.

No obstante, me apunto a explorar las posibilidades de una red mesh. A bote pronto, que yo sepa están las opciones 802.11s y B.A.T.M.A.N.

En OpenWrt, el estándar IEEE 802.11s se puede manejar desde LuCI: Menú - Wifi - Botón Edit. En la ventana Wireless Network, Sección Interface Configuration, Pestaña General Setup, seleccionar Mode 802.11s.


Aunque pudiera parecerlo, actualmente no es posible configurar el modo 802.11s (mesh) desde LuCI.
10  Equipos y materiales / Openwrt & LEDE / Re: Rpi con "15.05 Chaos Calmer" como AP : 14-01-2018, 15:58 (Domingo)
@machiminax el que se ha liado he sido yo; efectivamente, es para Raspbian.
Lips Sealed
11  Equipos y materiales / Openwrt & LEDE / Re: Rpi con "15.05 Chaos Calmer" como AP : 11-01-2018, 17:28 (Jueves)
Un tal MrEngman ha publicado unas instrucciones para instalar el driver de la TL-WN725N en la RPi aquí: https://www.raspberrypi.org/forums/viewtopic.php?t=62371

Según su autor, el driver da soporte al adaptador ID 0BDA:8179.


Para facilitar la instalación, el autor se ha currado un script.


En fin, puede que te funcione. Es cuestión de que te lo leas tranquilamente y si lo ves claro, lo apliques.

¡Suerte!
12  Equipos y materiales / Openwrt & LEDE / Re: Rpi con "15.05 Chaos Calmer" como AP : 09-01-2018, 19:54 (Martes)
Conecta el adaptador wifi y mira qué te devuelve el comando lsusb
Se debería ver una línea mostrando el ID del adaptador:

Código:
root@OpenWrt:~# lsusb
Bus 001 Device 001: ID 07d1:3c03 D-Link System AirPlus G DWL-G122 Wireless Adapter(rev.C1) [Ralink RT2571W]
El mío es un D-Link DWL-G122. Para que funcione hay que instalar el paquete kmod-rt73-usb.

Primero tienes que saber qué adaptador tienes y luego instalar el paquete adecuado.
13  Equipos y materiales / Openwrt & LEDE / Re: wget no me baja nada, aunque internet va. : 08-01-2018, 20:47 (Lunes)
Así es el opkg.config de mi router (Huawei EchoLife HG556a ver.B con la Chaos Calmer 15.05.1):
Código:
root@OpenWrt:~# cat /etc/opkg.conf
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay
option check_signature 1

Los "feeds" están aparte, en el fichero distfeeds.conf
Código:
root@OpenWrt:~# cat /etc/opkg/distfeeds.conf
src/gz chaos_calmer_base http://downloads.openwrt.org/chaos_calmer/15.05.1/brcm63xx/generic/packages/base
src/gz chaos_calmer_luci http://downloads.openwrt.org/chaos_calmer/15.05.1/brcm63xx/generic/packages/luci
src/gz chaos_calmer_packages http://downloads.openwrt.org/chaos_calmer/15.05.1/brcm63xx/generic/packages/packages
src/gz chaos_calmer_routing http://downloads.openwrt.org/chaos_calmer/15.05.1/brcm63xx/generic/packages/routing
src/gz chaos_calmer_telephony http://downloads.openwrt.org/chaos_calmer/15.05.1/brcm63xx/generic/packages/telephony
src/gz chaos_calmer_management http://downloads.openwrt.org/chaos_calmer/15.05.1/brcm63xx/generic/packages/management

Saludos.
14  Equipos y materiales / Openwrt & LEDE / Re: Rpi con "15.05 Chaos Calmer" como AP : 08-01-2018, 20:30 (Lunes)
¿Qué es exactamente lo que aparece listado desde  PuTTY?
15  Equipos y materiales / Openwrt & LEDE / Re: Proyecto GPIO: Manejo de una pantalla LCD vía bus I²C. : 04-01-2018, 20:52 (Jueves)
@Fitch
El truco para escribir el carácter º consiste en pasarle al script su valor octal (que es \337).

Código:
./lcd 0 0 "Temperatura 19\337C"



Solución encontrada en http://todomarino.com/forum/temas/como-poner-el-s%C3%ADmbolo-de-%C2%BA-grados-en-la-temperatura.88667/

Saludos.
16  Equipos y materiales / Openwrt & LEDE / Re: Módem usb 3g en router hg556a con firm Openwrt : 04-01-2018, 13:25 (Jueves)
Hay un tutorial sobre el tema en "hilos relevantes".
https://foro.seguridadwireless.net/openwrt/(tutorial)-openwrt-y-usb-3g/

Saludos.
17  Equipos y materiales / Openwrt & LEDE / Re: Compartir internet mediante ethernet : 31-12-2017, 09:49 (Domingo)
El Zidoo X9S viene con Android. OpenWRT lo lleva como complemento para implementar el NAS. Desde LuCI sólo se puede gestionar el NAS. Todo lo demás se hace desde Android.



Saludos.
18  Equipos y materiales / Openwrt & LEDE / Re: Proyecto GPIO: Manejo de una pantalla LCD vía bus I²C. : 23-12-2017, 13:30 (S?bado)
El mapa de caracteres de estos LCDs es:


El carácter que más se aproxima a º es el bx1101111 (223 en decimal y 0xDF en hexadecimal). Actualmente no tengo ninguna pantalla conectada al router y no puedo hacer pruebas, pero si te apetece podrías probar tú mismo si este código:
Código:
./lcd 0 0 "▀C"
Sólo hay que copiar y pegar.

Saludos.
19  Equipos y materiales / Openwrt & LEDE / Re: ayuda por favor crear red con router xiaomi oem y router nexx wt3020f openwrt : 04-11-2017, 10:58 (S?bado)
Según parece, tu configuración es esta:


Dices que los PCs conectados al ISP no encuentran los recursos compartidos en la red OpenWRT. Probablemente tengas que instalar "relayd".

Primero lee esto https://wiki.openwrt.org/doc/recipes/relayclient

Y después sigue esta guía https://foro.seguridadwireless.net/openwrt/instalacion-(facil)-de-openwrt-en-huawei-553/msg279562/#msg279562

Saludos.

20  Equipos y materiales / Openwrt & LEDE / Re: Proyecto GPIO: Manejo de una pantalla LCD vía bus I²C. : 31-10-2017, 19:10 (Martes)
Ok, ya lo he visto. Hay que poner sólo el "código" del vídeo youtube. Es decir, si la url del vídeo es https://www.youtube.com/watch?v=EYPsCChMwfk, hay que poner únicamente lo que va detrás del signo igual:
Código:
[youtube]EYPsCChMwfk[/youtube]

<a href="http://www.youtube.com/watch?v=EYPsCChMwfk" target="_blank">http://www.youtube.com/watch?v=EYPsCChMwfk</a>
Páginas: [1] 2 3 4 5 6 ... 24


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums