Autor Tema: d'link usb dwa 110 - wifislax-3.1 - VMware Workstation 6.0.4  (Leído 10505 veces)

0 Usuarios y 1 Visitante están viendo este tema.

baco

  • Visitante
d'link usb dwa 110 - wifislax-3.1 - VMware Workstation 6.0.4
« en: 06-09-2008, 05:38 (Sábado) »
Hola este tema es para ver si me pueden colaborar con dos cosas si estoy mal les ruego me muevan a donde corresponde o coloquen donde ya resolvieron esto uso win xp sp2 ue v.7.0
descargue e instálale el VMware Workstation 6.0.4 y me acomodo a él,  instale wifislax-3.1 la versión larga  o completa seguí el manual de dr.valium y todo perfecto hasta la parte donde modificamos  la línea que dice kernel/boot/vmlinuz root=/dev/sda1 ro vga=791 splash=silent showopts y añadimos un espacio y acpi=off y yo muy brillante lo deje solo of y si lo dejo arrancar solo no me funciona por lo cual tengo que darle otras opciones y completar la f faltante he tratado de reeditar pero no encuentro el fichero.

El siguiente inconveniente es que no logro hacer trabajar mi  tarjeta USB d'link  dwa 110 que asigno al VMware como dice en el manual  y seguir el paso  iwconfig sale lo siguiente:


wifislax ~ # iwconfig
lo        no wireless extensions.

wifislax ~ #

 
y al entrar al centro de información en los dispositivos USB me aparece:
EHCI Host Controller (1)
802.11bg wlan


Class
0
((Defined at Interface level))
Subclass
0
Protocol
0
USB Version
2.00

Vendor ID
0x7d1
(D-Link System)
Product ID
0x3c07
Revision
0.01

Speed
480 Mbit/s
Channels
0
Max. Packet Size
0
y al correr lsusb aparece lo siguiente

wifislax ~ # lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 002: ID 07d1:3c07 D-Link System
Bus 001 Device 001: ID 0000:0000


Algo estoy haciendo mal no soy muy versado en Linux pero me defiendo un poco con los Pc`s
Veo que el puerto USB detecta el dispositivo  y supongo que lo que me hace falta es instalar el driver para hacerlo subir. Pero nunca he montado un driver en Linux aparte de las graficas de nvidia y atreves de gestor de paquetes que trae Ubuntu (además ay que ver como casi me he liado la explicación sobre la instalación del VmWare tools  que casi no lo logro compilar)

Gracias de ante mano por la colaboración y espero no preguntar algo que ya otros respondieron de ser así mil disculpas y hasta ahora no habia usado otra distro diferente a Ubuntu que ha sido muy amigable desde el liveCd así que si me pueden explicar a prueba de tontos se los agradecería por su paciencia


« Última modificación: 06-09-2008, 05:55 (Sábado) por baco »

baco

  • Visitante
Re: d'link usb dwa 110 - wifislax-3.1 - VMware Workstation 6.0.4
« Respuesta #1 en: 06-09-2008, 07:01 (Sábado) »
me puse a buscar drivers y encontre:

Esto lo encontre aca
http://www.tinchio.com/2008/03/06/how-to-instalar-d-link-dwa-110-en-gnulinux/


Necesitan bajar el driver, desde este link: http://rt2x00.serialmonkey.com/rt73-cvs-daily.tar.gz
Copiar el archivo a /usr/src
cp rt73-cvs-daily.tar.gz /usr/src

Extraer el archivo
tar -xvzf rt73-cvs-daily.tar.gz

Instalar los headers del kernel acutal y el paquete build essential, aunque puede ser que ya los tengan instalados
apt-get install build-essential linux-headers-`uname -r`

Dirigirse a la carpeta extraida
cd /usr/src/rt73-cvs-2008030518/Module/

make
make install
Ahora tienen que desactivar algunos modulos, aunque puede ser que no los tengan
modprobe -r rt73usb
modprobe -r rt2570
modprobe -r rt2500usb
modprobe -r rt2×00lib

Dar de baja la interfaz por si estuviera ya pre-configurada
ifconfig wlan0 down

Ahora editar este archivo para agregar algunos modulos a la lista negra
nano /etc/modprobe.d/blacklist

Y agregar lo siguiente:
# Blacklist rt73usb, as it is a non-functional beta module which conflicts with the working rt73 module.
blacklist rt73usb
# Blacklist rt2570, as it causes conflicts with rt73
blacklist rt2570
# Other modules that break rt73
blacklist rt2500usb
blacklist rt2×00lib

Cargar el modulo
modprobe -v rt73

Ahora se deberia haber prendido el led del dispositivo, ya se pueden ir poniendo contentos, falta poco. Ahora solo deberian dar de alta la interfaz de red:
ifconfig wlan0 up


despues de esto




wifislax ~ # iwconfig
lo        no wireless extensions.

wlan0     RT73 WLAN  ESSID:""
          Mode:Managed  Frequency=2.412 GHz  Bit Rate=54 Mb/s
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality=0/100  Signal level:-121 dBm  Noise level:-111 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
No se si me sirva pero creo que meti la pata pues en el manual aparece rausb0 i a mi wlan0 no le cacharreo mas hasta mañana
en la noche asi que agradecere su colaboracion

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17387
  • Misántropo
Re: d'link usb dwa 110 - wifislax-3.1 - VMware Workstation 6.0.4
« Respuesta #2 en: 06-09-2008, 15:43 (Sábado) »
buenas

pues te has pegado el curro para nada, wifislax ya lleva drivers para ese chip, lo único que tenias que hacer era forzar el driver desde el asistente de chipset.

Citar
he tratado de reeditar pero no encuentro el fichero.

¿donde lo buscas? la ruta correcta es /boot/grub


saludos

baco

  • Visitante
Re: d'link usb dwa 110 - wifislax-3.1 - VMware Workstation 6.0.4
« Respuesta #3 en: 07-09-2008, 04:45 (Domingo) »
buenas

pues te has pegado el curro para nada, wifislax ya lleva drivers para ese chip, lo único que tenias que hacer era forzar el driver desde el asistente de chipset.

Disculpa la ignorancia pero como le hago llevo todo el dia probando si me puedes explicar a prueva de tontos te lo agradesceria

fitoz

  • Visitante
Re: d'link usb dwa 110 - wifislax-3.1 - VMware Workstation 6.0.4
« Respuesta #4 en: 06-03-2009, 03:55 (Viernes) »
la verdad es que yo he tenido problemas con esta tarjeta
al conectarla no hace nada
al usar el asistente par el chipset me sale esto

rausb0: ERROR while getting interface flags: No such device
ERROR: Module rt2570 does not exist in /proc/modules
rausb0: ERROR while getting interface flags: No such device
lo        no wireless extensions.

eth0      no wireless extensions.


y la verdad no entiendo que hice mal

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17387
  • Misántropo
Re: d'link usb dwa 110 - wifislax-3.1 - VMware Workstation 6.0.4
« Respuesta #5 en: 08-03-2009, 16:24 (Domingo) »
por favor no reabras temas que llevan casi un año parados.



saludos

RicardoTR

  • Visitante
Re: d'link usb dwa 110 - wifislax-3.1 - VMware Workstation 6.0.4
« Respuesta #6 en: 21-01-2010, 18:05 (Jueves) »
buenas

pues te has pegado el curro para nada, wifislax ya lleva drivers para ese chip, lo único que tenias que hacer era forzar el driver desde el asistente de chipset.

Citar
he tratado de reeditar pero no encuentro el fichero.

¿donde lo buscas? la ruta correcta es /boot/grub


saludos

hola drvalium...podes por favor explicar como forzar el driver desde el assitende de chipset,  com debo buscar en esta ruta??

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17387
  • Misántropo
Re: d'link usb dwa 110 - wifislax-3.1 - VMware Workstation 6.0.4
« Respuesta #7 en: 21-01-2010, 23:05 (Jueves) »
por favor no reabras temas que llevan casi un año parados.



saludos

//FINAL Y MÁS DOS RESPUESTAS