Autor Tema: wifislax64-2.1-rc1 para testeo  (Leído 53620 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #20 en: 09-01-2020, 23:59 (Jueves) »
recuerdo ahora que al usuario sol666 , le pasaba hace tiempo algo raro ... cuando arrancaba el live , ... con el pincho usb , los discos, tenian una numeracion , pero si despinchaba el usb , los numeros cambiaban , y el grub le fallaba ....

pueden ser tantas cosas ...

vaya , en el proximo merge de slackbuilds, por fin van a dat opcion de compilar vlc , permitiendo ejecutarlo como root ...  que es la razon de que yo tengo un updater ,puesto que si no habilitas eso al compilarlo , no te deja ejecutarlo despues ...

https://git.slackbuilds.org/slackbuilds/commit/?h=user/chris.willing/updates

se exporta la variable -- >  RUNASROOT=yes

y sera transparente haciendo solo slapt-src -i vlc ....  aunque muchas otras opciones interesantes las siguen dejando opcionales ...


« Última modificación: 10-01-2020, 00:04 (Viernes) por USUARIONUEVO »

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #21 en: 10-01-2020, 00:19 (Viernes) »
a lo que me refiero con lo de modo efi ..o normal  ... es cuando elegimos como arrancamos en el menu de boot del portatil ..en el cuadro rojo podeis ver el mismo dispositivo , se puede arrancar normal, o con efi ... si elgies efi , el instalador lo sabe ,y forzara instalarlo asi ...


Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #22 en: 10-01-2020, 01:13 (Viernes) »
el disco duro esta vacio ?

lo digo ,por que creo que debes antes, crear tabla de particion msdos  ....  a ti te pone en todos LINUX  , .... ¿puede ser que instalaras en algun momento un liveslak de alien?

una vez instale uno ... y me lio la de dios ...tube que formatear todo el disco para recuperarlo ...

si el hdd esta vacio y no te importa formatearlo ...  en gparted antes , en dispositivo ..crear tabla ...  eliges msdos  ...  y luego crear las particiones que quieras del tipo que quieras ... el instalador de wifislax , es un poco limitado en algunas cosas..mas bien para no modificarlas sin que el usuario lo sepa.

voy a probar en la maquina virtual ..si cambio la tabla de particion a linux , y creo la particion ext4 ..a ver si me falla.

vlc ...  estaba ahora mismo probando , y me falla compilarlo ,desde slackbuilds, y desde el script ...me va a tocar mirar el script de alienbob , seguramente necesito un parche ,por que el error dice que algo no esta bien en libaom , pero la he recompilado ..y ffmpeg ..y igue igual.

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #23 en: 10-01-2020, 22:38 (Viernes) »
el grub.cfg , no se te genera la entrada de menu  ... por eso no hay gub  ... que raro.

ahora que lo tienes asi ,y que yo creo que la parte que falla es solo la del grub , iniciando en live , hay una entrada donde el instalador que pone reinstalar grub , o instalar grub ..

ejecutalo desde consola, para intentar instalarlo ... el ya detecta donde esta wifislax, no tienes que hacer nada,solo desde consola y mirar que error sale.

Código: [Seleccionar]
/opt/install/Grub2InstallerGUI
lo de la TV , ni idea, puede que el driver generico ni siquiera soporte esa salida externa ...de todas formas , en el area de notificacion tienes la app de kde ,para configurar e identificar pantallas.... aunque lo normal seria que se detectara solo ...


Desconectado vapo

  • **
  • Mensajes: 8
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #24 en: 12-01-2020, 16:48 (Domingo) »
hola USUARIONUEVO  se que me vas a tomar por pesao pero puedes echarme una mano o aconsejarme creo que lo que tengo que hacer ahora es descargarme este driver de esta pagina https://translate.google.es/translate?hl=es&sl=en&u=https://packages.debian.org/sid/nvidia-legacy-304xx-driver&prev=search y por lo que he visto luego tengo que ir a la pagina que colgaste https://slackbuilds.org/result/?search=nvidia&sv=14.2 que ahy esta el driver

bueno para que me aclare y lo aga bien y haber si lo voy entendiendo desgargo el driver de la primera pagina y luego busco en la pagina que me enviaste que descargo el de el el nvidia linux run 65 o el tar bz  luego lo meto en modules y deberia funcionar bueno ya me diras si lo ago bien oh no un saludo y gracias por todo

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #25 en: 12-01-2020, 20:07 (Domingo) »
hola USUARIONUEVO  se que me vas a tomar por pesao pero puedes echarme una mano o aconsejarme creo que lo que tengo que hacer ahora es descargarme este driver de esta pagina https://translate.google.es/translate?hl=es&sl=en&u=https://packages.debian.org/sid/nvidia-legacy-304xx-driver&prev=search y por lo que he visto luego tengo que ir a la pagina que colgaste https://slackbuilds.org/result/?search=nvidia&sv=14.2 que ahy esta el driver

bueno para que me aclare y lo aga bien y haber si lo voy entendiendo desgargo el driver de la primera pagina y luego busco en la pagina que me enviaste que descargo el de el el nvidia linux run 65 o el tar bz  luego lo meto en modules y deberia funcionar bueno ya me diras si lo ago bien oh no un saludo y gracias por todo

https://foro.seguridadwireless.net/colaboracion-y-desarrollo-de-nuestras-lives/que-es-un-slackbuild-y-como-se-usa/

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #26 en: 17-01-2020, 22:15 (Viernes) »
wifislax 2.0 and wifislax 2.1 are missing hostapd
/etc/hostapd not in file wifislax64/base/Sbo/NNN-SBo_Network.xzm
add it
Please
thanks


https://www.kaldata.com/forums/uploads/monthly_2020_01/snapshot2.jpg.918099dd36c4e7f0959c5f0154c26f3d.jpg

hostap  + hostapd-wpe

nothing misiing ... your missing.

Código: [Seleccionar]
wifislax64 ~ # ls /var/log/packages|grep hostapd
hostapd-2.7-x86_64-1wifislax
hostapd-wpe-2.7_20181210-x86_64-1wifislax

NO SBO packages ...  WIFISLAX PACKAGES ....

« Última modificación: 17-01-2020, 22:16 (Viernes) por USUARIONUEVO »

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #27 en: 17-01-2020, 22:18 (Viernes) »
lo de la TV , ni idea, puede que el driver generico ni siquiera soporte esa salida externa
respecto a esto hay alguna manera de sustituir ese driver generico por otro??
deberia compilar un kernel nuevo o me vale pillarlo de otras distros??
necesitaria el noveau creo,
o compilar un legacy de eso que nuca me sale bien,
gracias

el nouveau es el free , es el que lleva ya ... de kernel . .. no creo que te sirvan de otras distros ... y lo de compilar un legacy  ..no hay ningun misterio ..lees las info , y es muy facil.

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #28 en: 18-01-2020, 20:19 (Sábado) »
el driver 440.xx , es para tarjetas mas o menos nuevas  (3 o 4 generaciones atras) , tu necesitas el 340.xx-legacy ...

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #29 en: 18-01-2020, 23:01 (Sábado) »
lo estuve buscando todo hace tiempo esta tarjeta siempre a sido cabrona

nvidia-legacy340-driver-340.107-x86-1_SBo.xzm

nvidia-legacy340-kernel-340.107_4.9.91-x86-1_SBo.xzm

esos probe en otra de 32 bits no en esta de 64 pero nada no arranca,
orobare lo mismo en esta a ver lo mismo es solo configuracion,
y cuda ni de coña.

pero has leido las instrucciones en slackbuilds ??

no basta con eso solo ...tienes que blacklistear el nouveau  .... 

y tampoco hara mucho que lo probaste ,por que el 107 , lo pusieron en septiembre 2019
https://git.slackbuilds.org/slackbuilds/log/system/nvidia-legacy340-kernel?h=14.2

ahora ya esta en el ultimo , el 108 , lo pusearon hace 2 dias.


The xf86-video-nouveau-blacklist package from /extra is required.
« Última modificación: 18-01-2020, 23:06 (Sábado) por USUARIONUEVO »

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #30 en: 19-01-2020, 01:30 (Domingo) »
si claro blacklistear starx xorf conf y toda la vaina

NO

cuando tu quieras blacklistear , el driver nouveau ya se ha cargado ... debes tenerlo backlisteado antes ...por algo dice la nota que necesitas el paquete de blacklistear nouveau.

ademas, segudo que tampoco haces ...
Código: [Seleccionar]
nvidia-switch --install
« Última modificación: 19-01-2020, 01:33 (Domingo) por USUARIONUEVO »

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #31 en: 20-01-2020, 22:15 (Lunes) »
Hashcat para funcionar siempre a requerido una version minima de driver ... asi van como "descatalogando" ... no me parece bien, pero la culpa es de NVIDIA , por empezar a poner ramas diferentes a segun que drivers , deberia ser el mismo para todas , y no pasaria esto.

tambien puede ser un problema con el slackbuild ... si que da guerra esa tarjeta.

tambein he visto en el git de slackbuilds, que retiran unos parches para la siguiente release semanal de slackbuilds.

https://git.slackbuilds.org/slackbuilds/commit/?h=willysr&id=7467e0f3d4ecc6866d171a9fc043ccc2d72ce6be
« Última modificación: 20-01-2020, 22:17 (Lunes) por USUARIONUEVO »

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #32 en: 22-01-2020, 02:34 (Miércoles) »
que tengo cuda pero hashcat no la reconoce?
vaya que mal
no hay manera?



buff, pero si los cuda cores son HARDWARE , todas las nvidia llevan ...  la limitacion de hashcat va por DRIVER  "SOFTWARE" ... es como si que dijeras..huy, tengo 8 gigas de ram..y hashcat no va ... o ..  tengo un monito 1080p ..y hashcat no me va.

ademas cuda..es un hardware que se usa para acelerar tareas, el cual tambien requiere de un software ...
https://slackbuilds.org/repository/14.2/development/cudatoolkit/

y al que hashcat tambien le va a dar igual si llevas cuda o no  ;D

a hashcat solo le importa OPENCL .... con soporte via sofware del driver NVIDIA, y en la version que a hashcat le parezca ..si pide driver 360 minimo y tu llevas 340 ..le va a dar igual todo ... es NVIDIA , la que va capando tarjetas segun le va pareciendo , dejandole una rama de driver fija, y solo parchenado lo justito.

que tengas un coche rapido no significa que te vayan a dejar correr en la F1 ... ;D

no se ni por que pierdo el tiempo con esto ...  si no os documentais , no es culpa de los demas ..en la pagina de hashcat viene muy clarito lo que se neceista..si no lo cumples, no es culpa de hashcat.

https://hashcat.net/hashcat/

GPU Driver requirements:
AMD GPUs on Linux require "RadeonOpenCompute (ROCm)" Software Platform (1.6.180 or later)
AMD GPUs on Windows require "AMD Radeon Software Crimson Edition" (15.12 or later)
Intel CPUs require "OpenCL Runtime for Intel Core and Intel Xeon Processors" (16.1.1 or later)
Intel GPUs on Linux require "OpenCL 2.0 GPU Driver Package for Linux" (2.0 or later)
Intel GPUs on Windows require "OpenCL Driver for Intel Iris and Intel HD Graphics"
NVIDIA GPUs require "NVIDIA Driver" (367.x or later)

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #33 en: 22-01-2020, 02:41 (Miércoles) »
no creo que vayas a poder usar esa quadro , con ningun hashcat ...he estado bajando versiones viejas , e incluso la 3.6.0 de 2017 , ya pide un driver minimo 367

hashcat v3.6.0
==============

AMD GPUs on Windows require "AMD Radeon Software Crimson Edition" (15.12 or later)
AMD GPUs on Linux require "AMDGPU-PRO Driver" (16.40 or later)
Intel CPUs require "OpenCL Runtime for Intel Core and Intel Xeon Processors" (16.1.1 or later)
Intel GPUs on Windows require "OpenCL Driver for Intel Iris and Intel HD Graphics"
Intel GPUs on Linux require "OpenCL 2.0 GPU Driver Package for Linux" (2.0 or later)
NVIDIA GPUs require "NVIDIA Driver" (367.x or later)



ninguna version de hashcat ... confirmado ..ni hashcat 2.0

oclHashcat v2.00
================

NV users require ForceWare 346.59 or later
AMD users require Catalyst 14.9 or later
« Última modificación: 22-01-2020, 02:43 (Miércoles) por USUARIONUEVO »

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #34 en: 23-01-2020, 15:43 (Jueves) »
En un principio era solo por la resolucion que ya esta mas o menos resuelto si no funciona cuda pues mala suerte,
ya me extrañaba que funcionara de repente pero habia que probarlo,

lo raro es que el error dice que la cpu tiene poca memoria,
para hashcat  el Device #1 es la CPU y el Device #2 es la GPU,
por lo menos podia dar bien los errores

gracias por la info

Es la forma que tiene nvidia , de forzar a comprar tarjetas nuevas … aunque yo ahora mismo tanga la 1070 ..iran saliendo , y la mia llegara al mismo punto que todas..que le fijen una rama de driver y no den mas soporte que ese.

para saber las plataformas que tienes habilitadas con opencl ..también puedes usar clinfo.

hashcat antes también usaba las cpus , pero ahora hay que andar también instalando cosas raras como el Intel compiler  Intel gmmlib …

Me imagino que tu el driver cogeras el tgz , y lo pasaras directamente a xzm … antes yo lo hacia asi , y no andaban casi nunca o andaban mal.

La mejor forma es … crear una carpeta ..

Código: [Seleccionar]
ROOT=carpeta installpkg PAQUETE.TGZ
Y ya entonces la carpeta a xzm …

Otros paquetes da igual ,pero este en concreto la mejor forma es esa ...por que renombra y toquetea las librerias del paquete mesa ...que es la librería de aceleración grafica y es un tema complicado.

« Última modificación: 23-01-2020, 15:45 (Jueves) por USUARIONUEVO »

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15744
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #35 en: 23-01-2020, 22:06 (Jueves) »
Código: [Seleccionar]
grep -r libGL.so /var/log/packages
con tgzmanager , tambien puedes buscar de que paquete salio un fichero.

Desconectado chirol05

  • **
  • Mensajes: 12
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #36 en: 10-02-2020, 04:27 (Lunes) »
si alguien quiere monitorear el proceso de instalacion desde la konsola para ver si se muestran errores ...

Código: [Seleccionar]
/opt/install/WifislaxInstallerGUI

Lo estoy instalando desde konsole y todo  muy bien sin error...

Desconectado radoman29

  • **
  • Mensajes: 41
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #37 en: 08-03-2020, 17:09 (Domingo) »
Hola buenas

Para cuando la final de wifislax 2.1

Saludos chicos de wifislax

Desconectado mofugga

  • **
  • Mensajes: 8
Re:wifislax64-2.1-rc1 para testeo
« Respuesta #38 en: 18-03-2020, 17:15 (Miércoles) »
Al instalarlo en el HDD y bootear,me da este error:


Sin embargo,si booteo desde el hdd,pero con el USB live puesto, bootea bien.
¿Como arreglarlo?