Autor Tema: Ayuda error de grub  (Leído 950 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14417
Re:Ayuda error de grub
« Respuesta #20 en: 06-01-2019, 21:25 (Domingo) »
he seguido investigando , a raiz de otro problema en una version distinta que tengo en otro usb.

mirando el script de instalacion de grub ....

Código: [Seleccionar]
if echo $DEV | grep -q '/dev/mmc'; then #Tablets fix
DEVICE=$(echo $DEV |grep -E 'mmcblk[0-9]+' -o)
else
DEVICE=${DEV//[0-9]}
fi

claro , tiene en cuenta las mmc , pero no las de tipo M.2

prueba añadiendo debajo de ese codigo esto
Código: [Seleccionar]
if echo $DEV | grep -q '/dev/nvme0n1p'; then #M.2 SSD fix
DEVICE=$(echo $DEV |grep -E 'nvme0n1p[0-9]+' -o)
fi



Desconectado diablosoy

  • **
  • Mensajes: 20
Re:Ayuda error de grub
« Respuesta #21 en: 08-01-2019, 16:39 (Martes) »
he seguido investigando , a raiz de otro problema en una version distinta que tengo en otro usb.

mirando el script de instalacion de grub ....

Código: [Seleccionar]
if echo $DEV | grep -q '/dev/mmc'; then #Tablets fix
DEVICE=$(echo $DEV |grep -E 'mmcblk[0-9]+' -o)
else
DEVICE=${DEV//[0-9]}
fi

claro , tiene en cuenta las mmc , pero no las de tipo M.2

prueba añadiendo debajo de ese codigo esto
Código: [Seleccionar]
if echo $DEV | grep -q '/dev/nvme0n1p'; then #M.2 SSD fix
DEVICE=$(echo $DEV |grep -E 'nvme0n1p[0-9]+' -o)
fi

Perdon por no responder antes pero he estado fuera.
He insertado el codigo que me has posteado y sigue saliendo el error y no instala grub.