Autor Tema: wifislax x64-2  (Leído 23744 veces)

0 Usuarios y 1 Visitante están viendo este tema.

juvalgot86

  • Visitante
Re: wifislax x64-2
« Respuesta #20 en: 20-07-2012, 04:02 (Viernes) »
Aqui algunos modulos para wifislax x64-2

jre-7u5-wifislax-x64
http://www.mediafire.com/?887b9uoq4s89035

NVIDIA-x86_64-304.22-wifislax-x64 BETA
http://www.mediafire.com/?5r3gi7w6vvfkzly
Nvidia 304.22 beta

pidgin-2.10.6-x64
http://www.mediafire.com/?zmilphbocbhtjbp

VirtualBox 4.1.18-r78361 kernel-3.4.4 + Extension Pack
http://www.mediafire.com/?y7i2el584bu86s7



Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
Re: wifislax x64-2
« Respuesta #21 en: 20-07-2012, 05:32 (Viernes) »
el driver Nvidia esta genial con solo 22 megas, en cuanto al pango el gimp me pide la versión 1.29.4 o superior ademas de (aalib, babl, gdk-pixbuf, gegl, glib, gtk+-2, jasper, jpeg-8d, libexif, libffi, libtiff)

ya avia compilado estas librerias antes pero lo hice conforme me lo pedía la compilación del gimp y estoy usando los mismos parámetros de compilación, si alguen los quiere ver para echarme una mano Gimp 2.8, ademas quiero compilar qalculate, MyPaint, que tambien requieren librerias actualizadas.


utiliza el gestor de paquetes  , que por ejemplo pango 1.29.4 esta hecha.

http://www.mmnt.net/db/0/5/ftp.slackware.org.uk/gsb/gsb64-3.2_slackware64-13.37/gsb64/l/

ftp://ftp.slackware.org.uk/gsb/gsb64-3.2_slackware64-13.37/gsb64/l/pango-1.29.4-x86_64-1gsb.txz

la bajas y conviertes a xzm.


juvalgot86

  • Visitante
Re: wifislax x64-2
« Respuesta #22 en: 24-07-2012, 18:22 (Martes) »
Hola probe con el pango que me diste y no me funciono bien, bueno, lo seguire estudiando, ahora queria actualizar el kernel a la version 3.4.6
con este scrip y usando el kernel-3.4.4-config
http://pastebin.com/GfVUkL26
y no tengo idea de que se hace con el aufs3.patch creado.

pero algo me falla, crei que eran los drivers nvidia, intente instalarlo nuvamente pero me sale error
==>  nvidia.log
Using the kernel source path '/usr/src/linux-3.4.6/' as specified by the '--kernel-source-path' commandline option.
. . .
ERROR: Kernel configuration is invalid.
       include/generated/autoconf.h or include/config/auto.conf are missing.
==>

entonces use el 002-xorg.xzm de la rc2 llega al escritorio y todo se congela

quisiera saber que es lo que me falta.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
Re: wifislax x64-2
« Respuesta #23 en: 24-07-2012, 18:40 (Martes) »
Hola probe con el pango que me diste y no me funciono bien, bueno, lo seguire estudiando, ahora queria actualizar el kernel a la version 3.4.6
con este scrip y usando el kernel-3.4.4-config
http://pastebin.com/GfVUkL26
y no tengo idea de que se hace con el aufs3.patch creado.

pero algo me falla, crei que eran los drivers nvidia, intente instalarlo nuvamente pero me sale error
==>  nvidia.log
Using the kernel source path '/usr/src/linux-3.4.6/' as specified by the '--kernel-source-path' commandline option.
. . .
ERROR: Kernel configuration is invalid.
       include/generated/autoconf.h or include/config/auto.conf are missing.
==>

entonces use el 002-xorg.xzm de la rc2 llega al escritorio y todo se congela

quisiera saber que es lo que me falta.

mira , el script para generar el aufs..has de abrirlo ...y buscar una parte en la que pone el numero de kernel.

no se si estara en 3.3  ..pues como tu vas por un kernel 3.4  deberias cambiar esa parte ...3.3 por 3.4 indiferentemente del numero final de kernel..solo importa la rama

3.3
3.4

etc etc

me pillas hipermegaliado ...pero te digo....los drivers graficos SIEMPRE VAN POR DETRAS EN COMPATIBILIDAD KERNEL, ...por ejemplo ati , aun no ha sacado siquiera para kerneles 3.4 ...el catalyst 12.6 funciona hasta la rama 3.3.

me alegra ver que te metes en cosas realmente dificiles.

ademas otra cosa..el config ....de las versiones de x64 no valen para 32 y viceversa.

el parche de kolivas brfs ..ese igual..debes mirar en el ftp ...y bajarte el ultimo para segun que kernel vayas a crear.

http://ck.kolivas.org/patches/bfs/

respecto a gtk3  , ...yo tengo 3 o 4 modulos con los que se actualiza lo necesario para gtk3 en x64 ..probe a compilar wireshark con gtk3 y funcionaba perfectamente.

a vers i te los pudiera subir..pero esque me he metido en muchas  cosas a la vez.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
Re: wifislax x64-2
« Respuesta #24 en: 24-07-2012, 18:57 (Martes) »
ese script es obra tuya ??

por que yo queria hacerme algo parecido.


reviste esta line

git checkout origin/aufs3.3

deberia preguntarte que linea de kernel es...

es decir, que te pregunte la linea de kernel ...la pongas en shell..y se configure para que descargue de donde le digas.

si fuese kernel 3.4 deberia quedar

git checkout origin/aufs3.4


que pregunte y que sea para el valor aufs

aufs-version=

i despues

git checkout origin/aufs$aufs-version

eso colocaria detras de aufs nuestra respuesta numerica.

--------------------------------------------------
luego...si te basas en una .config  ...lo mejor en vez de make xconfig   es directamente

make oldconfig

eso ajustara el kernel a la config ya establecida y en caso de nuevas opciones te preguntara para configurarlas..si no hay nuevas opciones de kernel..directamente configurara igual , y compilara.


despues esta la opcion de cuando quedan partes huerfanas en la config..que eso pasa bastante ...y no recuerdo la orden...lo digo  por que seria mas practivo


make oldconfig
make orden-de-huerfanos-todos=y
make modules
make modules_install

juvalgot86

  • Visitante
Re: wifislax x64-2
« Respuesta #25 en: 24-07-2012, 21:00 (Martes) »
el scrip lo hice yo excepto claro aufs-generator y crippled-sources-generator
hice algunas molificaciones
http://pastebin.com/cvU0yixr

aqui el archivo de ayuda del kernel
http://pastebin.com/T5xvSpBQ

_______________
modificacion:

el parche http://ck.kolivas.org/patches/bfs/3.4.0/3.4-sched-bfs-424.patch
no me funciona

y otra cosa no entiendo lo del gtk3, que tiene que ver con el kernel.
« Última modificación: 24-07-2012, 21:43 (Martes) por juvalgot86 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
Re: wifislax x64-2
« Respuesta #26 en: 24-07-2012, 22:47 (Martes) »
el scrip lo hice yo excepto claro aufs-generator y crippled-sources-generator
hice algunas molificaciones
http://pastebin.com/cvU0yixr

aqui el archivo de ayuda del kernel
http://pastebin.com/T5xvSpBQ

_______________
modificacion:

el parche http://ck.kolivas.org/patches/bfs/3.4.0/3.4-sched-bfs-424.patch
no me funciona

y otra cosa no entiendo lo del gtk3, que tiene que ver con el kernel.

lo de gtk3 venia por que me pusiste que no te sirvio pango ...y esque pango, gtk ..gdkpixbuf , glib  ..van todos a una, no puedes actualizar por ejemplo solo pango , sin tocar las demas.


Citar
el parche http://ck.kolivas.org/patches/bfs/3.4.0/3.4-sched-bfs-424.patch
no me funciona

pues usa el 423 ...creo que yo el kernel 3.4.4 lo hice con el 423 por que el 424 daba problemas.

juvalgot86

  • Visitante
Re: wifislax x64-2
« Respuesta #27 en: 24-07-2012, 23:17 (Martes) »
compile el kernel sin el parche y leendo las configuraciones del archivo kernel-3.4.4-config
usando:

make xconfig

make modules
make modules_install
-----------------------------------------
git checkout origin/aufs3.4

y persiste el problema,

pienzo que talvez es porque el codigo fuente lo compilo en: /mnt/sda2/kernel/linux-3.4.6/
y no en /usr/src/linux-3.4.6/

y lo ago desde el sda2 por que lo ago desde la live, no tengo suficiente espacio en disco para instalarlo en mi disco y solo tengo 2gb de ram para hacerlo en una maquina virtual

ademas al iniciar hay un mensaje de error q pasa muy rapido que dice algo de error server "numero algo"
no se si sera pero me da a pensar que es problema con el video

y cuando quiero instalar el driver nvidia de da error como si no econtrara  /usr/src/linux-3.4.6/ esto.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
Re: wifislax x64-2
« Respuesta #28 en: 24-07-2012, 23:23 (Martes) »
compile el kernel sin el parche y leendo las configuraciones del archivo kernel-3.4.4-config
usando:

make xconfig

make modules
make modules_install
-----------------------------------------
git checkout origin/aufs3.4

y persiste el problema,

pienzo que talvez es porque el codigo fuente lo compilo en: /mnt/sda2/kernel/linux-3.4.6/
y no en /usr/src/linux-3.4.6/

y lo ago desde el sda2 por que lo ago desde la live, no tengo suficiente espacio en disco para instalarlo en mi disco y solo tengo 2gb de ram para hacerlo en una maquina virtual

ademas al iniciar hay un mensaje de error q pasa muy rapido que dice algo de error server "numero algo"
no se si sera pero me da a pensar que es problema con el video

y cuando quiero instalar el driver nvidia de da error como si no econtrara  /usr/src/linux-3.4.6/ esto.

1- desde la live no se pueden hacer a de ser en una instalada en hd
2-correcto , usr/src/  si no na de na
3- ¿ movemos el fichero de x86 llamado bzimage a la carpeta boot renombrandolo como vmlinuz ?

el paso 3 es VITAL

TheDarkRaider

  • Visitante
Re: wifislax x64-2
« Respuesta #29 en: 10-08-2012, 19:39 (Viernes) »
Hola a todos, aunque llevo mucho tiempo siguiendo vuestro trabajo, aún soy bastante novato en esto... tengo una duda pero tpco se si este es el lugar adecuado para postearla, en el caso de no serla pido perdón y ruego al moderador la mueva al lugar indicado... :P

He probado todas o casi todas las versiones de wifislax... y me gustaría me aconsejarais si es posible...

Siempre booteo el wifislax desde un usb en modo live... y mi portatil es de 64bits supongo que el wifislax x64 sería el mejor aprovechado...

Pero es q de todas las versiones q he probado (las ultimas q habeis hecho...) wifislax 32bits incluso... y la wifislax x64 rc1.. rc2.. rc3... no doy conectado a ninguna red... y lo he intentado de varias formas diferentes antes de preguntar... pq no me gusta hacerle perder el tiempo a nadie... no sé si me hace falta algún modulo para corregir eso... o si es culpa mía pq me paso algo x alto...

Me pareció ver q le pasaba a alguien más esto... y uno de los usuarios de ésta página... Bernard... creo... subió un módulo que corregía eso... pero ese enlace está caído... si alguien pudiese resubírlo o me dijese alguna solución... se lo agradecería mucho...

Muchas gracias a todos por vuestro tiempo y vuestro trabajo...


Un saludo

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8420
Re: Re: wifislax x64-2
« Respuesta #30 en: 10-08-2012, 19:44 (Viernes) »
Hola

Pero ¿cual es la consulta exacatamente?

Saludos

si sale este mensaje, es que estoy en el movil

TheDarkRaider

  • Visitante
Re: wifislax x64-2
« Respuesta #31 en: 10-08-2012, 20:05 (Viernes) »
Hola Sanson, mi pregunta sería a q se puede deber que no se me conecte a ninguna red en la versión wifislax x64-2... pq se supone q es la última... ahora estoy probando a descargar y probar la anterior... la wifislax-x64 final... es q siempre q pruebo a conectarla a la red me pone bad password...

Muchas gracias por contestar

Un saludo

warcry

  • Visitante
Re: wifislax x64-2
« Respuesta #32 en: 10-08-2012, 20:16 (Viernes) »
dejate de rc, y descargate la final, las rc son para testear y sacar fallos.

y si no te conectas igual es porque no sabes utilizar el wicd ^-^

TheDarkRaider

  • Visitante
Re: wifislax x64-2
« Respuesta #33 en: 10-08-2012, 20:31 (Viernes) »
Ahora conseguí conectarme a la Wpa sin problemas pero la de mi amigo era una Wep y no había forma... quizás sea eso... xDDD

Ahora tengo la wifislax x64 final... entonces la wifislax x64-2... tb es para testear fallos...?

Perdonad mi ignorancia... jeje :P

Desconectado sanson

  • Moderador Global
  • *
  • Mensajes: 8420
Re: Re: wifislax x64-2
« Respuesta #34 en: 10-08-2012, 21:20 (Viernes) »
Hola

En las propiedades de wicd , donde metesvla clave, tienes que seleccionar el tipo de cifrado que lleva la red a la que te quieres conectar, por defecto esta en wpa, por eso si has podido.
cuando sea wep selecciona ese tipo y se conectara igual .

Saludos

si sale este mensaje, es que estoy en el movil

TheDarkRaider

  • Visitante
Re: wifislax x64-2
« Respuesta #35 en: 10-08-2012, 21:54 (Viernes) »
Ok... gracias... :) Hace un momento conseguí conectar a wep usando passphrase...

Muchas gracias :)