Autor Tema: wifislax-updaters HILO 2  (Leído 193058 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15402
Re: wifislax-updaters HILO 2
« Respuesta #220 en: 17-10-2015, 00:42 (Sábado) »
Voy a suprimir algunos updaters de los que slackware ya cuenta con paqute oficial.


libpcap
tcpdump
iw

en su dia hubo un problema con las libpcap de slackware , que provocaban que reaver dejara de funcionar .. desde entonces se han hido actualizado a las mas nuevas , pero slackware ya tiene un paquete nuevo de libpcap y ademas es la mas actual ahora mismo.

por ende tcpdump , ... y de paso iw.


la unica que seguira teniendo el updater sera crda ,por el tema de los canales 12-13 ,



trax69

  • Visitante
Re: wifislax-updaters HILO 2
« Respuesta #221 en: 18-10-2015, 01:11 (Domingo) »
Estaba revisando los scripts de updaters para ponerme a hacer alguno y me di cuenta que hay un pequeño fallo en uno, concretamente en aircrack-ng (es una tonteria pero bueno ..)

Eliminada foto por que descuadra el foro

Revisaré si ocurre nada mas arrancar el PC no sea que sin darme cuenta haya trasteado yo algo que haya ocasionado ese pequeño error en el script
« Última modificación: 18-10-2015, 01:33 (Domingo) por trax69 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15402
Re: wifislax-updaters HILO 2
« Respuesta #222 en: 18-10-2015, 01:16 (Domingo) »
no es una tonteria ... te explico.


se modifico la funcion de encontrar la version de paquete en sistema ...


y el paquete aircrack , no respetaba el estandard , donde define la version debe ser algo asi


1.2_rc2_revision

1.2_rc2_svn

y no como estaba

1.2-rc-2-revision

modifica el log de aicrack , cambiando a guion bajo las partes que pongo ..

1.2_rc2_revision

veras como ya te dice que hay una nueva y el paquete nuevo ya sera generado con guiones bajos.


hice lo mismo en otro paquete , "pitivi"   , pero ese como de serie no viene ,pues "aqui no ha pasao nada"

pitivi , version actual pone

94-beta no se que ...que no respeta el estandard de referencia a version.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15402
Re: wifislax-updaters HILO 2
« Respuesta #223 en: 18-10-2015, 01:18 (Domingo) »
aaa , veo que lo tienes en un xzm , como update..


entonces facil.


ejecuta el updater desde el menu ... y que te genere uno nuevo ... r2700 es la actual ..

y asi eliminas ya ese, y cero problems.

trax69

  • Visitante
Re: wifislax-updaters HILO 2
« Respuesta #224 en: 18-10-2015, 01:30 (Domingo) »
Estoy "agili****o" ahora que lo has dicho me suena que hablasteis algo de esto en un hilo (sobre los guiones y guiones bajos) haha y di por hecho que era el error del script pero tienes razón fue un cambio en la nomenclatura a la hora de nombrarlo por eso hasta que no actualice como dices no cogerá que está instalado pese a estarlo >.<. Como dices no es un error pero no me di cuenta.

Perdón y fallo mio. Sigo intentando hacer scripts de cosas que no haya entonces ,que el insomnio... haha
« Última modificación: 18-10-2015, 01:33 (Domingo) por trax69 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15402
Re: wifislax-updaters HILO 2
« Respuesta #225 en: 18-10-2015, 01:35 (Domingo) »
el unico pero , es que la gui , no afrecera actualizaciones de aircrack-ng hasta que el usuario tenga ese paquete corregido con la nomenglatura  correcta.



como la mayoria seguiran usando wifislax 4.11.1 con los scripts viejos que apuntan al ftp y donde no hay soporte/mantenimiento , pues no creo que se den ni cuenta.


ahora mismo , no recibir updates de aircrack enu n tiempo  (hasta la nueva version de wifislax9 , no supone drama alguno....sobretodo desde la aparician de wps y las tools al respecto , aircrack esta un poco "en segundo plano".

trax69

  • Visitante
Re: wifislax-updaters HILO 2
« Respuesta #226 en: 18-10-2015, 01:39 (Domingo) »
Por cambiar de tema ,me las estoy viendo ****s para encontrar sources de algunas herramientas... por que como no es algo centralizado... Pero las pocas que encuentre intentaré hacer los updaters >.<

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15402
Re: wifislax-updaters HILO 2
« Respuesta #227 en: 18-10-2015, 01:49 (Domingo) »
Por cambiar de tema ,me las estoy viendo ****s para encontrar sources de algunas herramientas... por que como no es algo centralizado... Pero las pocas que encuentre intentaré hacer los updaters >.<

si de alguna no encuentras avisa ..  ;)

fedora y debian , suelen guardarse .tar.gz  ;D

trax69

  • Visitante
Re: wifislax-updaters HILO 2
« Respuesta #228 en: 18-10-2015, 02:15 (Domingo) »
Voy a pasear un rato con los perros a despejarme por que me estoy volviendo loco por ejemplo.

de pixiewps hay script obteniendo los source de aquí:

https://github.com/wiire/pixiewps/releases

Pero es que ahora sigo buscando y tachan... -.-

https://github.com/jgilhutton/pyxiewps

Otro usuario y nueva versión 1.2... ahora eso lo extrapolo al que estoy intentando hacer yo...

GOYscript
https://github.com/0x90/wps-scripts/tree/master/goyscript

que encima no tiene subrepo de esa herramienta... me hace bajarme todo aunque bueno... no es mucho (1Mb) >.<
Y a lo poco que me doy cuenta ocurre igual... ahora mi pregunta... de donde leñes uso yo para bajar los sources ? XDDD si ni siquiera sé si es un fork el usuario que creó la herramienta o que se yo >.<
« Última modificación: 18-10-2015, 02:19 (Domingo) por trax69 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15402
Re: wifislax-updaters HILO 2
« Respuesta #229 en: 18-10-2015, 02:43 (Domingo) »
De goy script olvidate , era usuario del foro , desaparecio hace un tiempo.

no va a haber nada nuevo ..y si lo hubiera pasaria antes por aqui a presentarlo.



pixiewps, originalmente de  "wiree"   ....  asi que.  


men , si esta claro ,clarinete

el segundo es un fork en python , que me da la sensacion que es tipo "gui"
https://github.com/jgilhutton/pyxiewps



el bueno es el de wiree...y que una vez hecho todo , dudo que vayamos a ver mas versiones..
« Última modificación: 18-10-2015, 02:45 (Domingo) por USUARIONUEVO »

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: wifislax-updaters HILO 2
« Respuesta #230 en: 18-10-2015, 02:46 (Domingo) »
De las herramientas creadas en el foro no es necesario que hagas updaters, ya que la mayoría están descontinuadas y no van a salir nuevas versiones. Y las que se siguen desarrollando ya publicamos las nuevas versiones aquí en el foro para que la gente actualice.

Lo mas importante son las librerías, por ejemplo hay un monton de librerías de perl de las cuales no existen updaters.

Es importante tener las librerías actualizadas porque suelen corregir fallos de seguridad y de estabilidad.
« Última modificación: 18-10-2015, 02:50 (Domingo) por geminis_demon »

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

trax69

  • Visitante
Re: wifislax-updaters HILO 2
« Respuesta #231 en: 18-10-2015, 02:54 (Domingo) »
Entonces me pondré con las librerías hahah gracias por la aclaración por que me estaba volviendo loco. Thx !

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15402
Re: wifislax-updaters HILO 2
« Respuesta #232 en: 18-10-2015, 02:57 (Domingo) »
mmm , precisamente las de perl no  ...   :(

esas no.


hay tools , que solo funcionan con "tal o cual", version EXACTA , y si actualizas no van.

las de perl ni mirarlas  ;D


dnsenum  o killapache , solo funcionan con versiones exactas de las librerias perl que piden.
« Última modificación: 18-10-2015, 02:59 (Domingo) por USUARIONUEVO »

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: wifislax-updaters HILO 2
« Respuesta #233 en: 18-10-2015, 02:58 (Domingo) »
Al final lo vamos a volver loco  ;D

Se podría abrir un post con un listado de los updaters que hacen falta, y el que quiera colaborar que haga algún updater de ese listado, y conforme se vayan haciendo se van tachando del listado.
« Última modificación: 18-10-2015, 03:00 (Domingo) por geminis_demon »

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15402
Re: wifislax-updaters HILO 2
« Respuesta #234 en: 18-10-2015, 02:59 (Domingo) »
Al final lo vamos a volver loco  ;D


los NO LOCOS , no son bien recibidos a esta seccion del foro  ;D ;D ;D ;D

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15402
Re: wifislax-updaters HILO 2
« Respuesta #235 en: 18-10-2015, 03:02 (Domingo) »
puede mirar cosas en slackbuilds org , y crear updaters de lo que le resulte interesante.


por lo de la seguridad ni me preocuparia, de eso se encarga slackware ...seria muy muy raro una vulnerabilidad en una libreria extra de las que añadimos nosotros, aunque todo puede ser.


siempre son bugs en librerias estandard de sistema

gnutools , kernel , o librerias de video  (xorg) , audio  (alsa) , imagen  (libpng imagemagick)
openssl , glibc ...

y esas vienen de slack.  ;)

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: wifislax-updaters HILO 2
« Respuesta #237 en: 18-10-2015, 03:09 (Domingo) »
Hablando de dnsenum, no hay updater y lo tenemos desactualizado  ^-^

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15402
Re: wifislax-updaters HILO 2
« Respuesta #238 en: 18-10-2015, 03:09 (Domingo) »
 ;D


la cuestion es saber cuales se pueden actualizar de forma inofensiva ...

por ejemplo si rompes un programa , solo rompes ese ,pero una libreria puede romper varios  ;)

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15402
Re: wifislax-updaters HILO 2
« Respuesta #239 en: 18-10-2015, 03:10 (Domingo) »
Hablando de dnsenum, no hay updater y lo tenemos desactualizado  ^-^


 8) 8) 8)


juas , pues lo miro en el acto ... y sobretodo el changelog.