Autor Tema: wifislax-4.1-beta [pruebas broadcom y testing]  (Leído 35189 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14463
Re: wifislax-4.1-beta [pruebas broadcom y testing]
« Respuesta #40 en: 14-04-2012, 00:22 (Sábado) »
ir probando ...de mientras voy compilando el kernel 3.3.2

con una configuracion distinta en los driver broadcom.  >:D



inguaite

  • Visitante
Re: wifislax-4.1-beta [pruebas broadcom y testing]
« Respuesta #41 en: 14-04-2012, 04:39 (Sábado) »
vamos , que no se puede ni conectar con ella.... :'(

en wifislax veo que te marca 200 dbm ...

si pùsiste el modulo de mas dbm , prueba sin el..aunque no se..no espero milagros.



Lo quite, es mas, quite todos los modulos e inicie sin changes.dat...

Mas de lo mismo, sin novedad...

Ademas sigue marcando los 200dbm

inguaite

  • Visitante
Re: wifislax-4.1-beta [pruebas broadcom y testing]
« Respuesta #42 en: 14-04-2012, 04:53 (Sábado) »
bueno , que no se diga que no es por intentos.


prueba diferente.


iso wifislax , 4.1-beta

añadirle SOLO este modulo

http://downloadwireless.net/modulos-fase-testing/wifislax-4.1/brcm-b43xx-unblacklisted.xzm

Descargue la 4.1-beta..., meti el módulo "unblacklisted"..., inicié...

Fuimos para atrás..., no la reconoce...  ;D

Luego quite el módulo "unblacklisted", meti el "devel", meti el crippled-sources-3.2.12.xzm (el kernel es el 3.3.0, pero no tenía otro) y el Broadcom-driver-installer-v2.xzm, reinicie...

Corrí el Broadcom Installer y da errores:

Código: [Seleccionar]
patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 245 (offset 5 lines).
patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 386 (offset 1 line).
patching file Makefile
patching file src/wl/sys/wl_iw.h
Compilando el driver....
KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make: *** /lib/modules/3.3.0-wifislax/build: No existe el fichero o el directorio.  Stop.
make: *** [all] Error 2

Instalando paquete....
install -D -m 755 wl.ko /lib/modules/`uname -r`/kernel/drivers/net/wireless/wl.ko
install: cannot stat `wl.ko': No existe el fichero o el directorio
make: *** [install] Error 1
Actualizando lista de drivers del sistema....

Blacklisteando drivers conflictivos....
Blacklisteando b43....
Blacklisteando bcma....
Blacklisteando ssb....
Blacklisteando b43legacy....

Desmontamos drivers conflictivos....
Si ves mensajes de ERROR , es por que ese driver no estaba usandose....
Montamos el driver wl....
FATAL: Module wl not found.

                        *******************************
                        | La instalacion a finalizado |
                        *******************************

Comprobamos interfaces...
lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on

eth0      no wireless extensions.

Generando modulo xzm....
cp: cannot stat `/lib/modules/3.3.0-wifislax/kernel/drivers/net/wireless/wl.ko': No existe el fichero o el directorio

[+]Creando log var/log/packages/Driver-broadcom-3.3.0-wifislax
Parallel mksquashfs: Using 2 processors
Creating 4.0 filesystem on /root/Desktop/Driver-broadcom-3.3.0-wifislax.xzm, block size 1048576.
[=================================================================|] 21/21 100%
Exportable Squashfs 4.0 filesystem, xz compressed, data block size 1048576
        compressed data, compressed metadata, compressed fragments, compressed xattrs
        duplicates are removed
Filesystem size 334.36 Kbytes (0.33 Mbytes)
        9.27% of uncompressed filesystem size (3606.84 Kbytes)
Inode table size 358 bytes (0.35 Kbytes)
        32.84% of uncompressed inode table size (1090 bytes)
Directory table size 446 bytes (0.44 Kbytes)
        54.52% of uncompressed directory table size (818 bytes)
Number of duplicate files found 0
Number of inodes 34
Number of files 21
Number of fragments 5
Number of symbolic links  0
Number of device nodes 0
Number of fifo nodes 0
Number of socket nodes 0
Number of directories 13
Number of ids (unique uids + gids) 1
Number of uids 1
        root (0)
Number of gids 1
        root (0)

Limpiando temporales...

                        *******************************
                        | Modulo Creado Correctamente |
                        *******************************

Si utilizas wifislax en modo live , copia el fichero .xzm en la carpeta base
Si utilizas wifislax instalado en hd puedes borrar el fichero .xzm
Este paso solo lo has de hacer una vez, despues ya no sera necesario


                        ************************
                        | Disfruta de Wifislax |
                        ************************

wifislax Broadcom #

Seguimos cuando tengas la nueva ISO con kernel actualizado...  ;)

Salu2

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14463
Re: wifislax-4.1-beta [pruebas broadcom y testing]
« Respuesta #43 en: 14-04-2012, 04:54 (Sábado) »
vamos , que no se puede ni conectar con ella.... :'(

en wifislax veo que te marca 200 dbm ...

si pùsiste el modulo de mas dbm , prueba sin el..aunque no se..no espero milagros.



Lo quite, es mas, quite todos los modulos e inicie sin changes.dat...

Mas de lo mismo, sin novedad...

Ademas sigue marcando los 200dbm

era de esperar , en la configuracion del kernel hoy vi...

broadcom n driver .... DESHABILITADO.

osea el driver para tarjetas "n" , asi que acabo de compilar el 3.3.2 con ese driver añadido...por que ademas nos interesa ir en esa linea ya que el driver oficial , no soporta la inyeccion , o eso comentan ...ademas puede que te la detecte solo como b/g   , precisamente por eso.


montare una iso con el 3.3.2  , posiblemente por la mañana la suba....

cuando la suba, lo unico que habra que hacer es ,,

1-arrancar y comprobar si aparece....
en caso negativo , deberemos ir probando a montar y desmontar drivers ...hasta que aparezca.


desmiontar =  rmmod
montar = modprobe

nombre de los drivers a probar

b43
brcmsmac


posiblemente el sistema intente usar primero el b43 ... y ojala al estar el otro ( brcmsmac que antes no estaba ) , ya si funcione todo bien, por que ese, es el que da soporte a los chips n.

de no ser asi..

rmmod b43
modprobe brcmsmac


al final saldra ,y lo bueno es que son los que van en monitor inyeccion etc.

cerrare este hilo y abrire otro ...

inguaite

  • Visitante
Re: wifislax-4.1-beta [pruebas broadcom y testing]
« Respuesta #44 en: 14-04-2012, 05:02 (Sábado) »
OK, seguimos en el otro...

Pero ya que estamos...  ;D

Otro tema.

Cada vez que inicio, con cualquiera de las v4.x, me sale esta ventana de error:



Salu2
« Última modificación: 14-04-2012, 05:03 (Sábado) por inguaite »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14463
Re: wifislax-4.1-beta [pruebas broadcom y testing]
« Respuesta #45 en: 14-04-2012, 05:08 (Sábado) »
a mi a veces me sale ,

¿ a que tienes mas de una tarjeta de sonido en el sistema ?

a mi me pasa cuando me reconoce el audio hdmi de la ati , en vez de la tarjeta de sonido creative.

inguaite

  • Visitante
Re: wifislax-4.1-beta [pruebas broadcom y testing]
« Respuesta #46 en: 14-04-2012, 05:14 (Sábado) »
a mi a veces me sale ,

¿ a que tienes mas de una tarjeta de sonido en el sistema ?

a mi me pasa cuando me reconoce el audio hdmi de la ati , en vez de la tarjeta de sonido creative.

No, es un Netbook de 12" Asus EEEPC 1215B, con AMD/ATI...

Tiene salida HDMI, pero no la tengo conectada...

Bueno, para el caso es lo mismo que tu, el HDMI es del GPU ATI y el chip de sonido es Realtek
« Última modificación: 14-04-2012, 05:18 (Sábado) por inguaite »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14463
Re: wifislax-4.1-beta [pruebas broadcom y testing]
« Respuesta #47 en: 14-04-2012, 05:18 (Sábado) »
a mi a veces me sale ,

¿ a que tienes mas de una tarjeta de sonido en el sistema ?

a mi me pasa cuando me reconoce el audio hdmi de la ati , en vez de la tarjeta de sonido creative.

No, es un Netbook de 12" Asus EEEPC 1215B, con AMD/ATI...

Tiene salida HDMI, pero no la tengo conectada...

yo tampoco , sin embargo muchas veces carga antes el driver hdmi , ....

¿¿aun y con ese error tienes sonido en el sistema ??..por que yo si.

inguaite

  • Visitante
Re: wifislax-4.1-beta [pruebas broadcom y testing]
« Respuesta #48 en: 14-04-2012, 05:20 (Sábado) »
Si, tengo sonido por los altavoces y la salida auxiliar.

Lo que no he probado es si hay sonido por el HDMI

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14463
Re: wifislax-4.1-beta [pruebas broadcom y testing]
« Respuesta #49 en: 14-04-2012, 05:50 (Sábado) »
la verdad que es un mensaje un poco molesto.

a ver si consigo que me salga , le marco lo de no mostrar mas....y guardo ese cambio grabado en la iso.  ;)