Autor Tema: Un Aporte para la Distro (Clonextion)  (Leído 6545 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Yulexis

  • **
  • Mensajes: 26
Re:Un Aporte para la Distro (Clonextion)
« Respuesta #60 en: 20-09-2019, 14:27 (Viernes) »
Las tarjetas que he comentado anteriormente son todas 2.4 y el error que da es el siguiente:

Escaneando redes cercanas.                               CTRL+C para detener
----------------------------------------------------------------------------
BSSID              CHANNEL      ESSID
Traceback (most recent call last):
  File "clonextion.py", line 462, in <module>
    Menu_Inicio ()
  File "clonextion.py", line 248, in Menu_Inicio
    sniff(iface='clnxion1', store=0, prn=busca_ap)
  File "/usr/lib64/python2.7/site-packages/scapy/sendrecv.py", line 886, in sniff
    r = prn(p)
  File "clonextion.py", line 118, in busca_ap
    datos_de_red = (p[Dot11].addr3 + "  " + '-' + "\t\t" + p[Dot11].info)
  File "/usr/lib64/python2.7/site-packages/scapy/packet.py", line 1079, in __getitem__
    raise IndexError("Layer [%s] not found" % lname)
IndexError: Layer [Dot11] not found

Claramente se ve que tienes problemas con Scapy. Recuerda que debes de tener todas las dependencias instaladas y actualizadas.
También debes de fijarte que tus adaptadores soporten el modo monitor.

Hola @Yelexis, no creo que el problema sea Scapy o alguna dependencia, a mi me da el mismo error, te comento que tengo 3 PCs con Wifislax64 2.0 instalado del mismo modo y con los mismos módulos todos en las mismas versiones. Al probar el script en las 3 PCs me da error o no en dependencia del adaptador de red que esté usando, no importa en qué equipo lo utilice, siempre el problema es con las mismas tarjetas de red. También quiero aclarar que todos los adaptadores de red que usé para probar el script soportan el modo monitor. Salu2.

Saludos.
Sí, es problema de scapy. Parece que en la última versión han cambiado algunas cosas.
Has una búsqueda en google: "indexerror layer dot11 not found". Te arrojará unos cuantos resultados que pueden servir.
https://stackoverflow.com/questions/56154506/scapy-dot11-not-found
En las línas donde se importan las dependencias es dónde está el problema. Al no poder importarse la capa dot11 genera el error que comentas.
Debes de meterte en el código y cacharrear. Yo no puedo hacer nada ahora mismo porque como ya comenté en un post anterior, no puedo instalar la última versión de wifislax en mi laptop.

Alguien que por favor investigue un poco y nos de una mano (O que me done unos $$$$ para comprarme una laptop nueva y poder hacer algo ;D ;D ;D )
Les pido disculpas a todos, pero se me ha complicado la cosa para adaptar el proyecto a las nuevas versiones.



Desconectado VER

  • **
  • Mensajes: 19
Re:Un Aporte para la Distro (Clonextion)
« Respuesta #61 en: 05-11-2019, 00:44 (Martes) »