Autor Tema: Pruebas sound server TEST 2  (Leído 12117 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Pruebas sound server TEST 2
« en: 16-04-2012, 17:07 (Lunes) »
Bien , con este modulo pretendo acabar con el famoso fallo que muestra arts , cuando el sistema coge una tarjeta de sonido como predeterminada , y esta no puede reproducir sonido ... ( sonido hdmi de las ati ..por ejemplo )

Podeis colaborar todo , ya que ademas de buscar resolver el problema, necesito saber que no os estropea el sonido, a los que os funciona todo ok ... pensad que mañana podeis veros en las mismas , si os comprais un portatil etc , asi que no penseis "eso no va conmigo".

Añadir este modulo , a wifiway , wifislax 4.0 , wifislax 4.1 beta1 , o wifislax 4.1 beta2  .....y decidme
[ sobra con probar en uno ]

1-los que teniais el fallido de sound server si se resuelve
2-los que no teniais fallos con el sonido , si todo sigue correcto

modulo: http://www.downloadwireless.net/modulos-fase-testing/wifislax-4.1/blacklist-hdmi.xzm


gracias a los que colaborais en las pruebas.  ;)


« Última modificación: 16-04-2012, 17:09 (Lunes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re: Pruebas sound server TEST 2
« Respuesta #1 en: 16-04-2012, 23:37 (Lunes) »
por favor necesito feedbacks ...

hoy probe en el ordenador que tenia problemas con la ati hdmi ,, et voila ...


2 pruebas en dos equipos y todo ok.


PERO , me preocupa en portatiles con grafica ati y hdmi ...

si alguien tiene un portatil con grafica ati y hdmi ...con solo ese me valdria.

es decir , que pruebe el modulo y me diga si tiene sonido , por que ese es el escenario mas peligroso de todos los posibles en esta config...ya que estoy blacklistando precisamente el hdmi de ati.

ChimoC

  • Visitante
Re: Pruebas sound server TEST 2
« Respuesta #2 en: 17-04-2012, 00:17 (Martes) »
Buenas:

En el portatil de la mujer AIRIS PRAGMA N930R no he notado ninguna diferencia...se escucha todo ok

Saludos y cuidado que creo que hay alguien detrás del mostrador  ;D ;D ;D ;D  (sonidos de psicosis)

ChimoC

inguaite

  • Visitante
Re: Pruebas sound server TEST 2
« Respuesta #3 en: 21-04-2012, 21:54 (Sábado) »
Audio en reproductores multimedias, sin audio en navegadores con Youtube...

Wifislax 4.1.b3 con el módulo blacklist-hdmi.xzm

lsmod:

Código: [Seleccionar]
Module                  Size  Used by
ipv6                  176621  12
snd_seq_dummy            971  0
snd_seq_oss            20693  0
snd_seq_midi_event      3580  1 snd_seq_oss
snd_seq                34379  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          3617  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            25552  0
snd_mixer_oss          10257  2 snd_pcm_oss
snd_hda_codec_realtek    79625  1
cryptomgr               1795  0
aead                    4104  1 cryptomgr
snd_hda_intel          17608  1
arc4                     950  4
radeon                600443  2
rt2800usb              10173  0
crypto_algapi           8256  3 cryptomgr,aead,arc4
ttm                    37330  1 radeon
rt2800lib              31521  1 rt2800usb
snd_hda_codec          57917  2 snd_hda_codec_realtek,snd_hda_intel
uvcvideo               51369  0
videobuf2_core         13830  1 uvcvideo
crc_ccitt                999  1 rt2800lib
drm_kms_helper         18830  1 radeon
brcmsmac              443867  0
eeepc_wmi               1720  0
asus_wmi               11112  1 eeepc_wmi
sparse_keymap           1916  1 asus_wmi
brcmutil                1864  1 brcmsmac
rt2x00usb               6348  1 rt2800usb
videodev               58994  1 uvcvideo
drm                   140995  4 radeon,ttm,drm_kms_helper
crc8                     700  1 brcmsmac
snd_hwdep               3963  1 snd_hda_codec
media                   6692  2 uvcvideo,videodev
rt2x00lib              24848  3 rt2800usb,rt2800lib,rt2x00usb
pci_hotplug            17573  1 asus_wmi
snd_pcm                42869  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
agpgart                18017  2 ttm,drm
cordic                   657  1 brcmsmac
btusb                   7933  0
video                   9657  0
processor              22689  2
thermal                 6291  0
battery                 8581  0
videobuf2_vmalloc       1432  1 uvcvideo
snd_timer              12345  2 snd_seq,snd_pcm
wmi                     6279  1 asus_wmi
i2c_algo_bit            3653  1 radeon
i2c_piix4               6680  0
thermal_sys             9868  3 video,processor,thermal
videobuf2_memops        1194  1 videobuf2_vmalloc
button                  3393  0
ac                      2337  0
mac80211              152082  4 rt2800lib,brcmsmac,rt2x00usb,rt2x00lib
snd                    35007  11 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
atl1c                  22931  0
bluetooth             108195  1 btusb
power_supply            5915  3 radeon,battery,ac
soundcore               3537  2 snd
bcma                   14402  1 brcmsmac
i2c_core               13465  6 radeon,drm_kms_helper,videodev,drm,i2c_algo_bit,i2c_piix4
cfg80211              118349  3 brcmsmac,rt2x00lib,mac80211
k10temp                 1939  0
psmouse                52466  0
evdev                   6234  18
mousedev                7180  0
serio_raw               3042  0
rfkill                 10044  3 asus_wmi,bluetooth,cfg80211
snd_page_alloc          4763  2 snd_hda_intel,snd_pcm
hwmon                    889  4 radeon,asus_wmi,thermal_sys,k10temp
crypto                  4446  4 aead,crypto_algapi,mac80211,bluetooth
sg                     17200  0
wifislax ~ #
« Última modificación: 21-04-2012, 21:56 (Sábado) por inguaite »

inguaite

  • Visitante
Re: Pruebas sound server TEST 2
« Respuesta #4 en: 21-04-2012, 22:18 (Sábado) »
Y el cartelito del inicio sigue saliendo...

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re: Pruebas sound server TEST 2
« Respuesta #5 en: 22-04-2012, 00:31 (Domingo) »
Citar
snd_hda_codec_realtek
snd_hda_intel

intenta esto

descomprime el xzm , de blacklist hdmi ,

navega hasta llegar a /etc/modprobe.d/alsasound.conf  (creo que lo llame asi)

abre ese fichero con kwrite

y añade

blacklist snd_hda_intel

crea de nuevo el xzm , y prueba con el nuevo ..obviamente metelo en modules, y saca el anterior xzm.

aunque funcione , esa config ,solo sirve para ti , puesto que no puedo blacklistar el hda intel ni de coña.

empiezo a darme cuenta de que estas cosas, solo sirven para cada caso particular. (sonido)


inguaite

  • Visitante
Re: Pruebas sound server TEST 2
« Respuesta #6 en: 22-04-2012, 01:27 (Domingo) »
Lo hice...

El cartelito sigue saliendo...

Y me quedé totalmente sin sonido, el icono del volumen en la barra tiene una cruz, al poner el puntero del ratón sobre él sale un cartel: "No se pudo encontrar el mezclador"...

lsmod: (creo que no sale nada del sonido...)
Código: [Seleccionar]
Module                  Size  Used by
ipv6                  176621  12
cryptomgr               1795  0
aead                    4104  1 cryptomgr
arc4                     950  4
crypto_algapi           8256  3 cryptomgr,aead,arc4
eeepc_wmi               1720  0
uvcvideo               51369  0
videobuf2_core         13830  1 uvcvideo
asus_wmi               11112  1 eeepc_wmi
radeon                600443  2
rt2800usb              10173  0
sparse_keymap           1916  1 asus_wmi
brcmsmac              443867  0
brcmutil                1864  1 brcmsmac
ttm                    37330  1 radeon
rt2800lib              31521  1 rt2800usb
videodev               58994  1 uvcvideo
crc8                     700  1 brcmsmac
crc_ccitt                999  1 rt2800lib
drm_kms_helper         18830  1 radeon
rt2x00usb               6348  1 rt2800usb
drm                   140995  4 radeon,ttm,drm_kms_helper
rt2x00lib              24848  3 rt2800usb,rt2800lib,rt2x00usb
pci_hotplug            17573  1 asus_wmi
cordic                   657  1 brcmsmac
media                   6692  2 uvcvideo,videodev
processor              22689  2
agpgart                18017  2 ttm,drm
video                   9657  0
thermal                 6291  0
wmi                     6279  1 asus_wmi
battery                 8581  0
thermal_sys             9868  3 processor,video,thermal
mac80211              152082  4 brcmsmac,rt2800lib,rt2x00usb,rt2x00lib
mousedev                7180  0
psmouse                52466  0
i2c_algo_bit            3653  1 radeon
atl1c                  22931  0
i2c_piix4               6680  0
bcma                   14402  1 brcmsmac
ac                      2337  0
btusb                   7933  0
button                  3393  0
videobuf2_vmalloc       1432  1 uvcvideo
serio_raw               3042  0
evdev                   6234  17
cfg80211              118349  3 brcmsmac,rt2x00lib,mac80211
power_supply            5915  3 radeon,battery,ac
k10temp                 1939  0
videobuf2_memops        1194  1 videobuf2_vmalloc
bluetooth             108195  1 btusb
sg                     17200  0
i2c_core               13465  6 radeon,videodev,drm_kms_helper,drm,i2c_algo_bit,i2c_piix4
hwmon                    889  4 asus_wmi,radeon,thermal_sys,k10temp
rfkill                 10044  3 asus_wmi,cfg80211,bluetooth
crypto                  4446  4 aead,crypto_algapi,mac80211,bluetooth
wifislax ~ #

Salu2

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re: Pruebas sound server TEST 2
« Respuesta #7 en: 22-04-2012, 01:36 (Domingo) »
entonces blacklistea el otro

snd_hda_codec_realtek

inguaite

  • Visitante
Re: Pruebas sound server TEST 2
« Respuesta #8 en: 22-04-2012, 01:53 (Domingo) »
entonces blacklistea el otro

snd_hda_codec_realtek

OK, ahora lo hago.

Reinicié sin el módulo y hace lo mismo que con el módulo "original", esperemos que ahora funcione.

[OffTopicON]: Después de mas de una hora acomodando Opera a mi gusto, reinicié con el modulo modificado y me olvidé que había arrancado sin changes... la p#t@ m... [/OffTopicOFF]

Salu2

inguaite

  • Visitante
Re: Pruebas sound server TEST 2
« Respuesta #9 en: 22-04-2012, 02:48 (Domingo) »
Lo mismo que antes, tengo sonido por los programas multimedia, pero no por los navegadores.

Esto es muy raro, ¿como puede ser que se tenga audio por un soft y por otro no?, incluso el soft mutimedia reproduce radios online...

Lo he probado por un lado con Kplayer y UMPlayer, y por el otro con Firefox y Opera...  :(

Al iniciar me dí cuenta que el cartelito que salio al blacklistear intel decía otra cosa (sale tantas veces que ya no le presto atención) pero resumiendo era lo mismo, no encontraba algo..., si es importante vuelvo a reproducir el fallo..., que no sea por no reiniciar... :-)

lsmod:

Código: [Seleccionar]
Module                  Size  Used by
cryptd                  5394  0
crypto_hash             8057  1 cryptd
crypto_wq                483  1 cryptd
crypto_blkcipher        9208  1 cryptd
aes_i586                6824  1
aes_generic            25474  1 aes_i586
ipv6                  176621  12
snd_seq_dummy            971  0
snd_seq_oss            20693  0
snd_seq_midi_event      3580  1 snd_seq_oss
snd_seq                34379  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          3617  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            25552  0
snd_mixer_oss          10257  2 snd_pcm_oss
radeon                600443  2
ttm                    37330  1 radeon
cryptomgr               1795  0
aead                    4104  2 cryptd,cryptomgr
drm_kms_helper         18830  1 radeon
uvcvideo               51369  0
eeepc_wmi               1720  0
arc4                     950  4
rt2800usb              10173  0
videobuf2_core         13830  1 uvcvideo
drm                   140995  4 radeon,ttm,drm_kms_helper
crypto_algapi           8256  8 cryptd,crypto_hash,crypto_blkcipher,aes_i586,aes_generic,cryptomgr,aead,arc4
videodev               58994  1 uvcvideo
asus_wmi               11112  1 eeepc_wmi
rt2800lib              31521  1 rt2800usb
crc_ccitt                999  1 rt2800lib
media                   6692  2 uvcvideo,videodev
snd_hda_intel          17608  1
snd_hda_codec          57917  1 snd_hda_intel
rt2x00usb               6348  1 rt2800usb
sparse_keymap           1916  1 asus_wmi
psmouse                52466  0
brcmsmac              443867  0
videobuf2_vmalloc       1432  1 uvcvideo
agpgart                18017  2 ttm,drm
rt2x00lib              24848  3 rt2800usb,rt2800lib,rt2x00usb
snd_hwdep               3963  1 snd_hda_codec
mac80211              152082  4 rt2800lib,rt2x00usb,brcmsmac,rt2x00lib
brcmutil                1864  1 brcmsmac
snd_pcm                42869  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
pci_hotplug            17573  1 asus_wmi
btusb                   7933  0
thermal                 6291  0
processor              22689  2
video                   9657  0
k10temp                 1939  0
thermal_sys             9868  3 thermal,processor,video
serio_raw               3042  0
cfg80211              118349  3 brcmsmac,rt2x00lib,mac80211
snd_timer              12345  2 snd_seq,snd_pcm
videobuf2_memops        1194  1 videobuf2_vmalloc
i2c_algo_bit            3653  1 radeon
i2c_piix4               6680  0
button                  3393  0
ac                      2337  0
battery                 8581  0
crc8                     700  1 brcmsmac
bluetooth             108195  1 btusb
cordic                   657  1 brcmsmac
snd                    35007  10 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
mousedev                7180  0
wmi                     6279  1 asus_wmi
atl1c                  22931  0
i2c_core               13465  6 radeon,drm_kms_helper,drm,videodev,i2c_algo_bit,i2c_piix4
evdev                   6234  17
hwmon                    889  4 radeon,asus_wmi,k10temp,thermal_sys
soundcore               3537  2 snd
bcma                   14402  1 brcmsmac
power_supply            5915  3 radeon,ac,battery
sg                     17200  0
crypto                  4446  7 cryptd,crypto_hash,crypto_blkcipher,aead,crypto_algapi,mac80211,bluetooth
rfkill                 10044  3 asus_wmi,cfg80211,bluetooth
snd_page_alloc          4763  2 snd_hda_intel,snd_pcm
wifislax ~ #

Salu2
« Última modificación: 22-04-2012, 02:49 (Domingo) por inguaite »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re: Pruebas sound server TEST 2
« Respuesta #10 en: 22-04-2012, 02:55 (Domingo) »
plan b


una vez arrancado , ves a proc , ...alli busca alguna carpeta llamda sound o alsa..o algo referente a sonido

y encuentra un fichero llamado

cards

copiatelo al escritorio y veras que se convierte en un txt...

pasanos el contenido

si no encuentras el fichero usa el buscador de ficheros.

inguaite

  • Visitante
Re: Pruebas sound server TEST 2
« Respuesta #11 en: 22-04-2012, 03:35 (Domingo) »
La carpeta se llama asound.

El contenido de cards:

Código: [Seleccionar]
0 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfeb44000 irq 43
 1 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfeb40000 irq 16

Cuando está iniciando salen varias lineas de error con "algo" de alsa, pero pasa muy rápido, no alcanzo a leer...

¿se crea algún log con el inicio?

En Porteus, (KDE4), no me sale ningún cartel de error al principio, pero tampoco funciona el audio con los navegadores.

lsmod de porteus:

Código: [Seleccionar]
root@porteus:~# lsmod
Module                  Size  Used by
ipv6                  191330  12
snd_seq_oss            22547  0
snd_seq_midi_event      3975  1 snd_seq_oss
snd_seq                38235  4 snd_seq_oss,snd_seq_midi_event
snd_seq_device          3941  2 snd_seq_oss,snd_seq
snd_pcm_oss            26785  0
snd_mixer_oss          11001  1 snd_pcm_oss
rfcomm                 23496  8
bnep                    8133  2
cryptomgr               1961  0
aead                    4341  1 cryptomgr
arc4                    1144  2
crypto_algapi           9684  3 cryptomgr,aead,arc4
radeon                638999  2
rt2800usb              11168  0
rt2800lib              32871  1 rt2800usb
uvcvideo               53799  0
ttm                    47513  1 radeon
crc_ccitt               1235  1 rt2800lib
snd_hda_codec_realtek    94440  1
videobuf2_core         14608  1 uvcvideo
drm_kms_helper         20375  1 radeon
rt2x00usb               7022  1 rt2800usb
snd_hda_codec_hdmi     19629  1
drm                   166067  4 radeon,ttm,drm_kms_helper
videodev               65190  1 uvcvideo
eeepc_wmi               1952  0
rt2x00lib              27405  3 rt2800usb,rt2800lib,rt2x00usb
snd_hda_intel          19096  4
media                   7722  2 uvcvideo,videodev
asus_wmi               10772  1 eeepc_wmi
v4l2_compat_ioctl32     6813  1 videodev
mac80211              159602  3 rt2800lib,rt2x00usb,rt2x00lib
agpgart                21888  2 ttm,drm
snd_hda_codec          61376  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep               4438  1 snd_hda_codec
lib80211_crypt_tkip     6216  0
wl                   2509342  0
snd_pcm                49298  4 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
sparse_keymap           2225  1 asus_wmi
videobuf2_vmalloc       1505  1 uvcvideo
cfg80211              127685  2 rt2x00lib,mac80211
snd_timer              14318  2 snd_seq,snd_pcm
i2c_algo_bit            3826  1 radeon
btusb                   8464  2
k10temp                 2336  0
ac                      1880  0
battery                 5373  0
video                   9638  0
processor              22660  2
thermal                 6576  0
wmi                     6719  1 asus_wmi
snd                    43460  20 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
button                  3742  0
thermal_sys            11284  3 video,processor,thermal
lib80211                2903  2 lib80211_crypt_tkip,wl
atl1c                  23509  0
mousedev                8016  0
psmouse                52568  0
bluetooth             115136  23 rfcomm,bnep,btusb
videobuf2_memops        1567  1 videobuf2_vmalloc
i2c_piix4               7528  0
crypto                  5203  5 aead,crypto_algapi,mac80211,lib80211_crypt_tkip,bluetooth
rfkill                 11122  4 asus_wmi,cfg80211,bluetooth
soundcore               4196  1 snd
evdev                   7016  17
i2c_core               14617  6 radeon,drm_kms_helper,drm,videodev,i2c_algo_bit,i2c_piix4
serio_raw               3328  0
snd_page_alloc          5613  2 snd_hda_intel,snd_pcm
hwmon                   1158  4 radeon,asus_wmi,k10temp,thermal_sys
sg                     19288  0
power_supply            7515  3 radeon,ac,battery
root@porteus:~#




Chumpy

  • Visitante
Re: Pruebas sound server TEST 2
« Respuesta #12 en: 22-04-2012, 14:35 (Domingo) »
La carpeta se llama asound.

El contenido de cards:

Código: [Seleccionar]
0 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfeb44000 irq 43
 1 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfeb40000 irq 16



Volvemos un poco a lo mismo, nuestro linux asigna las diferentes opciones de sonido a diferentes tarjetas de sonido de forma indiscriminada, creo que desde interfaz con ALSA se podía cambiar eso, tambien, cuando estube buscando la otra vez encontré algunos comandos para cambiar la asignación, pero todo esto se escapa bastante a mis pobres conocimientos.

Aún no he terminado de entender que hacen exactamente aRts y ALSA y como trabajan entre ellos.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re: Pruebas sound server TEST 2
« Respuesta #13 en: 22-04-2012, 15:38 (Domingo) »
en kde4 , prueba en kmix ...a la derecha abajo al lado del reloj , una opcion que pone settings ...

aparceran los dispositivos de audio y cual quieres usar.

Chumpy

  • Visitante
Re: Pruebas sound server TEST 2
« Respuesta #14 en: 22-04-2012, 15:44 (Domingo) »
en kde4 , prueba en kmix ...a la derecha abajo al lado del reloj , una opcion que pone settings ...

aparceran los dispositivos de audio y cual quieres usar.

KDE4?? Tenía entendido que wifislax4.x utiliza KDE3  ???

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re: Pruebas sound server TEST 2
« Respuesta #15 en: 22-04-2012, 16:22 (Domingo) »
SI , pero dice que probo kde4 y salia mal tambien.

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2382
  • Prácticas precisas precisan práctica
Re: Pruebas sound server TEST 2
« Respuesta #16 en: 22-04-2012, 17:06 (Domingo) »
en kde4 , prueba en kmix ...a la derecha abajo al lado del reloj , una opcion que pone settings ...

aparceran los dispositivos de audio y cual quieres usar.

Exacto, en kubuntu que lleva kde4, pude solucionarlo directamente desde la configuración del kmix, sin blacklistear nada ni hacer cosas raras.

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Chumpy

  • Visitante
Re: Pruebas sound server TEST 2
« Respuesta #17 en: 22-04-2012, 17:10 (Domingo) »
Perdón, no me había dado cuenta de lo de Porteus (KDE4)  :-[

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re: Pruebas sound server TEST 2
« Respuesta #18 en: 22-04-2012, 17:20 (Domingo) »
pues estoy trasteando el porteus con kde4 , pero

buffffff

que diferente es del kde3 y que complicado diosss miooo

Chumpy

  • Visitante
Re: Pruebas sound server TEST 2
« Respuesta #19 en: 22-04-2012, 17:30 (Domingo) »
Viendo estas cosas... ¿Alguien me recuerda por que utilizamos kde3? (La pregunta es en serio, se que se ha hablado en algún hilo, pero no lo encuentro)

//FINAL Y MÁS DOS RESPUESTAS