Autor Tema: Problema teclado LED  (Leído 6297 veces)

0 Usuarios y 1 Visitante están viendo este tema.

vk496

  • Visitante
Problema teclado LED
« en: 30-05-2015, 21:45 (Sábado) »
Hola. Tengo un teclado Cooler Master CM Storm Devastator (http://gaming.coolermaster.com/en/products/keyboards/devastator/) con LEDS.

Si pulso la tecla de los leds, no se encienden.

Haciendo pruebas (comando showkey) sé que la tecla para encender los leds del taclado tiene el código 70

Por internet, el comando setleds no funciona

Citar
wifislax ~ # setleds
KDGKBLED: Función ioctl no apropiada para el dispositivo
Error al leer el estado actual de los indicadores. ¿Quizás no se esté en una consola?

El que SI que funciona, es el xset

Para encdender:
Código: [Seleccionar]
xset led
Para apagar
Código: [Seleccionar]
xset -led
El motivo de este hilo es arreglar este problema de la distro

Salu2



Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14892
Re: Problema teclado LED
« Respuesta #1 en: 30-05-2015, 21:57 (Sábado) »
no entiendo ...

¿que es loq ue crees que se deberia rreglar?

¿que funcione setleds?

¿el kernel deberia encender los leds?


¿en otros linux el led se enciende solo o tienes simpre que usar algun comando de shell?

vk496

  • Visitante
Re: Problema teclado LED
« Respuesta #2 en: 30-05-2015, 22:00 (Sábado) »
En Linux es la primera vez que lo pruebo.

En Windows, con pulsar la tecla mencionada, se encienden los leds y se apagan.

No sé que hay que tocar del linux para "automatizar" el encendido y apagado de los leds con los comandos que puse antes.

Salu2

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14892
Re: Problema teclado LED
« Respuesta #3 en: 30-05-2015, 22:05 (Sábado) »
aqui dicen de usar el xset ...

http://forums.fedoraforum.org/showthread.php?t=296728


....deberias probar antes algun ubuntu u otra si tienes y contarme.


hablan de pulsar scroll lock , para encender los leds.


pueden ser 2 cosas

1 - que necesite reconfigurar algo en kernel
2 - que tengas que usar xset siempre...en cuyo caso , lo mejor seria hacerte un script  y ponerlo en autostart para que se ejecute al inicio.


no se si el scroll lock  ese del que ha blan   esta en la zona numerica...recuerda que puede estar apagada la zona numerica.


« Última modificación: 30-05-2015, 22:09 (Sábado) por USUARIONUEVO »

vk496

  • Visitante
Re: Problema teclado LED
« Respuesta #4 en: 30-05-2015, 22:08 (Sábado) »
Esa es la tecla que pulso, y no funciona.

Y, esa tecla, corresponde con el id 70 (esto es un dato, por si sirve de algo)

No tengo ninguna distro a mano para probar.


EDITO: La zoan numerica no afecta. No funciona xD

Salu2
« Última modificación: 30-05-2015, 22:10 (Sábado) por vk496 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14892
Re: Problema teclado LED
« Respuesta #5 en: 30-05-2015, 22:09 (Sábado) »
Esa es la tecla que pulso, y no funciona.

Y, esa tecla, corresponde con el id 70 (esto es un dato, por si sirve de algo)

No tengo ninguna distro a mano para probar.

Salu2

pues es trabajar a ciegas.

puesto que asi , no se si es culpa de wifislax, o es que ese teclado trabaja asi en linux   (xset)


yo he probado 2 teclados con led y funcionaban , el que tengo ahora es el logitech g105
« Última modificación: 30-05-2015, 22:10 (Sábado) por USUARIONUEVO »

vk496

  • Visitante
Re: Problema teclado LED
« Respuesta #6 en: 30-05-2015, 22:12 (Sábado) »
Esa es la tecla que pulso, y no funciona.

Y, esa tecla, corresponde con el id 70 (esto es un dato, por si sirve de algo)

No tengo ninguna distro a mano para probar.

Salu2

pues es trabajar a ciegas.

puesto que asi , no se si es culpa de wifislax, o es que ese teclado trabaja asi en linux   (xset)


yo he probado 2 teclados con led y funcionaban , el que tengo ahora es el logitech g105

Voy a probar cosas por Internet hasta encontrar algo

Salu2


vk496

  • Visitante
Re: Problema teclado LED
« Respuesta #8 en: 30-05-2015, 22:15 (Sábado) »
http://unix.stackexchange.com/questions/164245/why-is-the-scroll-lock-key-disabled-in-cinnamon-linux-xorg

Creo que esto me ha funcionado.

Voy a reiniciar y probar en limpio


EDITO: @USUARIONUEVO Confirmado. Con este comando, se me activa

Código: [Seleccionar]
xmodmap -e "add mod3 = Scroll_Lock"
Creo que con añadirlo al arranque del sistema seria suficiente

Salu2
« Última modificación: 30-05-2015, 22:21 (Sábado) por vk496 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14892
Re: Problema teclado LED
« Respuesta #9 en: 02-06-2015, 01:02 (Martes) »
pero no puedo añadir esa orden , asi ..  a todo quisqui ...


añadire la orden al final del rc.local  y aver que pasa.


si quieres hacertelo permanente , solo añade esa linea , al final del fichero

/etc/rc.d/rc.local

__________________________

parece que hay mas opciones ... prueba este modulo en modo livecd VIRGEN , osea sin añadidos ...para estar seguros si va o no va.

http://www.mediafire.com/download/fdlcl39qc3ssl05/xmod-test.xzm
« Última modificación: 02-06-2015, 01:22 (Martes) por USUARIONUEVO »

vk496

  • Visitante
Re: Problema teclado LED
« Respuesta #10 en: 16-06-2015, 23:19 (Martes) »
pero no puedo añadir esa orden , asi ..  a todo quisqui ...


añadire la orden al final del rc.local  y aver que pasa.


si quieres hacertelo permanente , solo añade esa linea , al final del fichero

/etc/rc.d/rc.local

__________________________

parece que hay mas opciones ... prueba este modulo en modo livecd VIRGEN , osea sin añadidos ...para estar seguros si va o no va.

http://www.mediafire.com/download/fdlcl39qc3ssl05/xmod-test.xzm

Con el modulo que me has pasado no funciona.

Salu2